Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Nickey Chicago
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 02-28-2013, 09:09 PM   #1
Caswell239

 
Caswell239's Avatar
 
Drives: 2011 2ss/rs
Join Date: Nov 2011
Location: Canada
Posts: 1,089
Installing injectors, need help

Got myself a whipple, installing my Id 850s an having some issues. The bores in the blower plenum I swear are too tight. I lubed the bores in the plenum, all bores are smooth, lubed the orings, and CAN NOT push them in. I actually bruised my hand from pushing on the end so hard. I've done injectors numerous times and never had such a hard time. I've split 7 orings so far pushing them in. Some thing is wrong. I will be contacting whipple in the morning but just figured I'd ask here if anyone else has had the issue I'm having. I'm thinking the orings have to be too thick for the plenum. They go in the stock mani no problem. Thanks in advanced!
Caswell239 is offline   Reply With Quote
Old 02-28-2013, 09:19 PM   #2
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,347
Post up some pics bud, you might have the fatter orings in there.
__________________
01 Ws6, m6, ASC#618 of 1583,40k Miles,shortblock built by AES the rest built by me,Ls3 416,FAST 102, NW102,LPE Ls3 heads

Join us:
https://www.facebook.com/groups/5138...3848358733509/
litle88 is offline   Reply With Quote
Old 02-28-2013, 09:55 PM   #3
Caswell239

 
Caswell239's Avatar
 
Drives: 2011 2ss/rs
Join Date: Nov 2011
Location: Canada
Posts: 1,089

My next idea is wrap them in paper towel, bag them and stick em on the freezer a few hours while keeping mani on the floor vent. Should be this complicated
Caswell239 is offline   Reply With Quote
Old 02-28-2013, 10:27 PM   #4
Caswell239

 
Caswell239's Avatar
 
Drives: 2011 2ss/rs
Join Date: Nov 2011
Location: Canada
Posts: 1,089
They are 15mm od orings. I think I remember seeing 14mm orings on ID's web store... Maybe those are the ticket!
Caswell239 is offline   Reply With Quote
Old 03-02-2013, 06:32 PM   #5
Caswell239

 
Caswell239's Avatar
 
Drives: 2011 2ss/rs
Join Date: Nov 2011
Location: Canada
Posts: 1,089
Talked to Ted in another thread and he said you have to use smaller orings. He suggested the blue top oring off the old injectors. Well I put them on and work like a charm!

Ready for fuel rails and to reinstalled
Caswell239 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.