Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Nickey Chicago
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Marketplace > Vendor and Seller review / feedback / experiences

Vendor and Seller review / feedback / experiences Share review & feedback on vendors and sellers

Reply
 
Thread Tools
Old 03-15-2013, 09:46 PM   #1
nighttowl
 
nighttowl's Avatar
 
Drives: 2010 Camaro 2SS / RS
Join Date: Dec 2011
Location: So-Cal
Posts: 489
Dear Vararam

-------------------------------censored--------------------------------.

Please spend time looking into design changes to further ease routine maintenance.


that is all.


Jeff Goff
Vararam customer.
__________________
VVT L99 w/ TR6060 swap, 489 rwhp, 444 rwtq

Last edited by nighttowl; 03-15-2013 at 09:56 PM. Reason: Ill be nice.
nighttowl is offline   Reply With Quote
Old 03-16-2013, 02:20 AM   #2
1sikRS

 
Drives: chevy
Join Date: Jan 2011
Location: cleveland ohio
Posts: 860
Agreed that's one reason I switched to cai . That and its a mother putting it back on especially on a 102 tb.
1sikRS is offline   Reply With Quote
Old 03-16-2013, 06:51 AM   #3
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,347
I've had mine since 2010 and have has NO problems.
__________________
01 Ws6, m6, ASC#618 of 1583,40k Miles,shortblock built by AES the rest built by me,Ls3 416,FAST 102, NW102,LPE Ls3 heads

Join us:
https://www.facebook.com/groups/5138...3848358733509/
litle88 is offline   Reply With Quote
Old 03-16-2013, 06:59 AM   #4
dcoates18481
WWW.TEXASMILE.NET
 
dcoates18481's Avatar
 
Drives: 2010 CAMARO RALLY YELLOW SS/RS/M6
Join Date: Aug 2012
Location: Aransas Pass Texas area
Posts: 577
Agreed,
No problems servicing the element.
__________________
I LIKE TO GO FAST!

Lethal Racing Night Fury Cam Kit, Melling oil pump, C5R Timing Chain, Dyno Tuned by Shawn@Lethal Racing, Vararam Tuned intake, Vararam Power Wedge, LSR Tri Ax Short throw Shifter, VMAX Ported T/B, TSP 2" L/T Headers, TSP Cat delete, Borla axle back exhaust, Innovate A/F monitor, 471.7 HP/438.8 TQ
dcoates18481 is offline   Reply With Quote
Old 03-16-2013, 07:40 AM   #5
ssmike
Missing Big Red
 
ssmike's Avatar
 
Drives: 2013 Equinox CRT
Join Date: Jul 2009
Location: Buffalo, NY
Posts: 6,241
No problems here either! I will admit that it is a PITA to service the filter but well worth the effort for the performance I get over any of the conventional cai's!
ssmike is offline   Reply With Quote
Old 03-16-2013, 07:58 AM   #6
nighttowl
 
nighttowl's Avatar
 
Drives: 2010 Camaro 2SS / RS
Join Date: Dec 2011
Location: So-Cal
Posts: 489
every time I clean the filter I have such a hard time getting it to go back together that I want to stop it into the ground an throw it into the street. there has to be a better way.
__________________
VVT L99 w/ TR6060 swap, 489 rwhp, 444 rwtq
nighttowl is offline   Reply With Quote
Old 03-16-2013, 08:34 AM   #7
ssmike
Missing Big Red
 
ssmike's Avatar
 
Drives: 2013 Equinox CRT
Join Date: Jul 2009
Location: Buffalo, NY
Posts: 6,241
Quote:
Originally Posted by nighttowl View Post
every time I clean the filter I have such a hard time getting it to go back together that I want to stop it into the ground an throw it into the street. there has to be a better way.
Temper temper! Haha!
ssmike is offline   Reply With Quote
Old 03-16-2013, 08:40 AM   #8
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,347
Your already pissed N/O We understand.

Breathe bud lol.
__________________
01 Ws6, m6, ASC#618 of 1583,40k Miles,shortblock built by AES the rest built by me,Ls3 416,FAST 102, NW102,LPE Ls3 heads

Join us:
https://www.facebook.com/groups/5138...3848358733509/
litle88 is offline   Reply With Quote
Old 03-16-2013, 09:01 AM   #9
SSDan

 
SSDan's Avatar
 
Drives: 2010 SS LS3 VR
Join Date: Feb 2010
Location: Leesville, SC
Posts: 874
Quote:
Originally Posted by nighttowl View Post
every time I clean the filter I have such a hard time getting it to go back together that I want to stop it into the ground an throw it into the street. there has to be a better way.
This frustration wouldn't have anything to do with the pic you posted in your fouled plug thread would it?

I have only needed to pull my Vararam once to clean the filter and I must admit it was a wrestling match to get it back on. Thought it was just me in an "all thumbs" moment. I'll tolerate the situation as I like it other than that. I'm hoping practice makes perfect for the next time.
__________________
Vengeance cam, Vararam, ARH-full system, DMH cutouts, Pfadt Stage II springs/sway bars, MGW shifter, Axis "Allies" w/ 275/315 Nitto Invos, 1LE 3.91 gears
SSDan is offline   Reply With Quote
Old 03-16-2013, 10:17 AM   #10
dcoates18481
WWW.TEXASMILE.NET
 
dcoates18481's Avatar
 
Drives: 2010 CAMARO RALLY YELLOW SS/RS/M6
Join Date: Aug 2012
Location: Aransas Pass Texas area
Posts: 577
for me , it's no worse than when i first installed it.
it's a labor of love.....
__________________
I LIKE TO GO FAST!

Lethal Racing Night Fury Cam Kit, Melling oil pump, C5R Timing Chain, Dyno Tuned by Shawn@Lethal Racing, Vararam Tuned intake, Vararam Power Wedge, LSR Tri Ax Short throw Shifter, VMAX Ported T/B, TSP 2" L/T Headers, TSP Cat delete, Borla axle back exhaust, Innovate A/F monitor, 471.7 HP/438.8 TQ
dcoates18481 is offline   Reply With Quote
Old 03-16-2013, 10:32 AM   #11
PIPE
Hating prius's since 1997
 
PIPE's Avatar
 
Drives: 2010 Camaro 2SS/RS (JENNA)
Join Date: Apr 2011
Location: Maryland
Posts: 1,042
Its like a fine woman, ya just gotta take youre time with her.
__________________
PIPE
PIPE is offline   Reply With Quote
Old 03-16-2013, 11:40 AM   #12
SSGUNNER
Chu no guat a hasa is?
 
SSGUNNER's Avatar
 
Drives: 14 Jeep G Cherokee Overland HEMI
Join Date: Jun 2011
Location: Some where in So Cal
Posts: 4,216
Wow. Didnt knkw the servicing of the vararam is a pita. I went c.a.i. and like it. It much easier to get into my cc also.
__________________
11 2SS/RSL99No Longer Stock (Sold) 6/19/14:AAC Plasma DRL's | Plug n play harness | Elite CC | Tint: 35% & 5% | LED Dome light | Show-N-Go Plate Holder | Flowmaster AT | C.A.I. Intake | VMAX CNC Spiral Ported TB | Husky Splash Guards
SSGUNNER is offline   Reply With Quote
Old 03-16-2013, 11:41 AM   #13
SSGUNNER
Chu no guat a hasa is?
 
SSGUNNER's Avatar
 
Drives: 14 Jeep G Cherokee Overland HEMI
Join Date: Jun 2011
Location: Some where in So Cal
Posts: 4,216
Quote:
Originally Posted by PIPE View Post
Its like a fine woman, ya just gotta take youre time with her.
__________________
11 2SS/RSL99No Longer Stock (Sold) 6/19/14:AAC Plasma DRL's | Plug n play harness | Elite CC | Tint: 35% & 5% | LED Dome light | Show-N-Go Plate Holder | Flowmaster AT | C.A.I. Intake | VMAX CNC Spiral Ported TB | Husky Splash Guards
SSGUNNER is offline   Reply With Quote
Old 03-16-2013, 11:52 AM   #14
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,347
Id rather struggle a bit during maintenance than have high IAT's with a metal intake behind a radiator. just saying
__________________
01 Ws6, m6, ASC#618 of 1583,40k Miles,shortblock built by AES the rest built by me,Ls3 416,FAST 102, NW102,LPE Ls3 heads

Join us:
https://www.facebook.com/groups/5138...3848358733509/
litle88 is offline   Reply With Quote
Old 03-16-2013, 02:17 PM   #15
VADER SS L99


 
VADER SS L99's Avatar
 
Drives: 2010 Camaro SS L99
Join Date: Nov 2009
Location: Edmond, OK
Posts: 2,449
How often are you guys having to service the filter? Is it a oiled unit? With my 4th gen, which was kinda the same as a Vararam and a oiled KN, I just serviced it every 30K. Granted I dont live in the country but I would think any sooner than that would be a waste of time.
__________________
BLK/BLK 1SS/RS Ordered 11-01-2009 Took delivery 12-22-2009.
VADER SS L99 is offline   Reply With Quote
Old 03-16-2013, 02:35 PM   #16
SGOS252382


 
SGOS252382's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2008
Location: S.W. Florida
Posts: 6,280
Quote:
Originally Posted by SSDan View Post
This frustration wouldn't have anything to do with the pic you posted in your fouled plug thread would it?

I have only needed to pull my Vararam once to clean the filter and I must admit it was a wrestling match to get it back on. Thought it was just me in an "all thumbs" moment. I'll tolerate the situation as I like it other than that. I'm hoping practice makes perfect for the next time.

It does take some practice to do it quickly. The next time I put mine back on I should make a video. I'm pretty good at it and can do it pretty fast.
__________________
SGOS252382 is offline   Reply With Quote
Old 03-16-2013, 07:58 PM   #17
POS Dakota
 
POS Dakota's Avatar
 
Drives: GMs and Chryslers
Join Date: Nov 2012
Location: Detroit
Posts: 371
Quote:
Originally Posted by nighttowl View Post
every time I clean the filter I have such a hard time getting it to go back together that I want to stop it into the ground an throw it into the street. there has to be a better way.
POS Dakota is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.