Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
horizon670
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Marketplace > Sponsors Classifieds Marketplace > V8 Bolt-Ons & Tunes

V8 Bolt-Ons & Tunes Intake, exhaust, tunes, other bolt-ons.

View our official forum sponsors list.

Reply
 
Thread Tools
Old 10-24-2013, 06:01 PM   #1026
Algeron
 
Algeron's Avatar
 
Drives: 2011 2SS/RS vert, 1998 Z28, 1991 RS
Join Date: Jan 2013
Location: Charleston, SC
Posts: 456
Quote:
Originally Posted by San2cci View Post
Weird after reading that statement sometimes when I accelerate while mid-turn or after turning, or from a stop or rolling stop, I feel hesitation like it almost will stall out. I don't recall this happening before the RANGE device. I will however like to add that the RANGE customer service is wonderful and other than minor issues, the positive experiences with it definitely outweighs the negatives.

Just to let you know, I have never had a Range Device, and I have the same issue. Almost caused a wreck the other day when this happened.
__________________

http://imgur.com/a/kurVF Born 30 May 2011
Algeron is online now   Reply With Quote
Old 10-24-2013, 08:34 PM   #1027
SROD
THE ROD MAN
 
SROD's Avatar
 
Drives: 2010 ABM 2SS/RS #631
Join Date: May 2010
Location: TENNESSEE
Posts: 535
Quote:
Originally Posted by Algeron View Post
Just to let you know, I have never had a Range Device, and I have the same issue. Almost caused a wreck the other day when this happened.
x2 on the stall issue before the range
__________________
SROD is offline   Reply With Quote
Old 10-25-2013, 06:39 PM   #1028
Arbgast
 
Drives: DRIVES 2014 2SS RS convertible
Join Date: May 2012
Location: Eugene
Posts: 135
Quote:
Originally Posted by CAM74 View Post
Has anyone tried Ranger on a 2014 L99 yet. Any info. Thanks CAM74 .

Drives 1974 Camaro and our new 2014 2SS RS L99 Thanks
Installed on my 2014 2ss vert. No problems at all so far. Runs so much smother in traffic. On freeway lose about 2 mpg. I love it.
Arbgast is offline   Reply With Quote
Old 10-26-2013, 01:22 PM   #1029
Mr pogo
 
Drives: 96 Imp SS, 13 Camaro 2SS AGM
Join Date: Dec 2012
Location: SoCal
Posts: 321
Quote:
Originally Posted by Algeron View Post
Just to let you know, I have never had a Range Device, and I have the same issue. Almost caused a wreck the other day when this happened.
Ive noticed it during sharp turns and fuel gauge below a quarter, no problems if the gas tank is kept above that.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=71668&dateline=136924  9466
Mr pogo is offline   Reply With Quote
Old 10-27-2013, 12:41 PM   #1030
jammer174
 
jammer174's Avatar
 
Drives: 2010 Camaro SS
Join Date: Jan 2010
Location: Charleston, WV
Posts: 95
Send a message via ICQ to jammer174
My AFM Disable Device from Apex Motorsports has arrived. Super quick shipping and very reliable company to deal with. They answered my email quickly with questions I had before purchasing the device. I wish all companies delivered customer service like Apex Motorsports does! Anyhow, I have a 2013 L99 and once I put new exhaust on it the car sounded liked a 6-cylinder when the factory AFM would kick in and out. Wasn't very noticeable until I installed after market exhaust. I couldn't wait to get the AFM Disable Device and once it arrived I installed it almost immediately. All I can say is WOW! My car now has instant throttle response due to it running on all eight cylinders at all times. I have no connection or association with Apex Motorsports but let me tell you...I recommend purchasing this device from them. A little pricey...yes, but absolutely well worth the money once you plug it in and take your car down the road for the first time! However, it's going to cost me several hundred dollars to go and see a doctor about getting my perma-grin removed!
__________________
DRIVE IT LIKE YOU STOLE IT!
jammer174 is offline   Reply With Quote
Old 10-27-2013, 03:06 PM   #1031
San2cci
 
San2cci's Avatar
 
Drives: 2010 L99 2SS (20k miles)
Join Date: Jan 2013
Location: Camden County, NJ
Posts: 652
Quote:
Originally Posted by Mr pogo View Post
Ive noticed it during sharp turns and fuel gauge below a quarter, no problems if the gas tank is kept above that.
My gas never goes below 1/2 tank and this still persists in my car
San2cci is offline   Reply With Quote
Old 10-27-2013, 09:59 PM   #1032
Arbgast
 
Drives: DRIVES 2014 2SS RS convertible
Join Date: May 2012
Location: Eugene
Posts: 135
Just now noticed if I go wot it hesitates. Can this be fixed? 2014 2ss vert
Arbgast is offline   Reply With Quote
Old 10-27-2013, 10:28 PM   #1033
MrPace
 
Drives: 2013 AGM Camaro 2SS/RS L99
Join Date: Sep 2013
Location: NY
Posts: 142
Quote:
Originally Posted by Arbgast View Post
Just now noticed if I go wot it hesitates. Can this be fixed? 2014 2ss vert
Are you saying this is due to the Range device? When you take the Range out, the hesitation goes away?
MrPace is offline   Reply With Quote
Old 10-28-2013, 03:26 PM   #1034
Ohten
Hot Sauce
 
Ohten's Avatar
 
Drives: 2013 Crystal Red Tincoat SS/RS
Join Date: Jan 2010
Location: West Palm Beach,FL by way of Akron,OH
Posts: 1,218
I need an address to return my module for an updated version per Ken M.
__________________
Ohten is offline   Reply With Quote
Old 10-28-2013, 04:16 PM   #1035
SROD
THE ROD MAN
 
SROD's Avatar
 
Drives: 2010 ABM 2SS/RS #631
Join Date: May 2010
Location: TENNESSEE
Posts: 535
selling my range. just got my tune today
__________________
SROD is offline   Reply With Quote
Old 10-28-2013, 09:43 PM   #1036
Arbgast
 
Drives: DRIVES 2014 2SS RS convertible
Join Date: May 2012
Location: Eugene
Posts: 135
Quote:
Originally Posted by MrPace View Post
Are you saying this is due to the Range device? When you take the Range out, the hesitation goes away?
yes, no hesitation when range device out. Put it back in and hesitation at wot.
Arbgast is offline   Reply With Quote
Old 10-29-2013, 09:50 AM   #1037
San2cci
 
San2cci's Avatar
 
Drives: 2010 L99 2SS (20k miles)
Join Date: Jan 2013
Location: Camden County, NJ
Posts: 652
Quote:
Originally Posted by Arbgast View Post
yes, no hesitation when range device out. Put it back in and hesitation at wot.
I agree with this. Happens to me too, as stated previously.
San2cci is offline   Reply With Quote
Old 10-29-2013, 01:47 PM   #1038
SROD
THE ROD MAN
 
SROD's Avatar
 
Drives: 2010 ABM 2SS/RS #631
Join Date: May 2010
Location: TENNESSEE
Posts: 535
update: my range is version 4
__________________
SROD is offline   Reply With Quote
Old 10-29-2013, 04:41 PM   #1039
Gent
 
Drives: 2010 Rally Yellow 2SS/RS L99
Join Date: Oct 2013
Location: Texas
Posts: 5
Range V8 AFM/Disable

I gotta tell everyone> got my Range V8 on Monday 28th '13. Plugged it in as instructed and went on a 35 mile excursion. Immediately knew I didn't have that annoying AFM (problem) anymore> In town driving I'm actually gettin (better) gas mileage because afm is not kickin in and out! Out of town on the road I'm gettin slightly less mileage, so the whole thing is a wash. In other words I'm still @ the same in gas usage and no afm bullshit. These guys at Range are great and sell a product that does exactly as advertized. If you've got a SS Camaro with the L99 Automatic and don't like the afm. you gotta get this device. I highly recommend it!!! Gent
Gent is offline   Reply With Quote
Old 10-29-2013, 05:24 PM   #1040
SROD
THE ROD MAN
 
SROD's Avatar
 
Drives: 2010 ABM 2SS/RS #631
Join Date: May 2010
Location: TENNESSEE
Posts: 535
selling mine today for $150 shipped. anyone in the fence about this should get it!
__________________
SROD is offline   Reply With Quote
Old 11-04-2013, 04:14 PM   #1041
Adam @ Range

 
Drives: 2011 Tahoe, 1971 Corvette
Join Date: Mar 2013
Location: United States
Posts: 157
Hey all:
We are doing a limited time promotion on CAMARO5 and bringing back our discount code. It is just for a short time. $20 off effective immediately.

Code: NOVEMBER20

Adam
Adam @ Range is offline   Reply With Quote
Old 11-11-2013, 10:01 AM   #1042
jammer174
 
jammer174's Avatar
 
Drives: 2010 Camaro SS
Join Date: Jan 2010
Location: Charleston, WV
Posts: 95
Send a message via ICQ to jammer174
Installed my AFM disable device from Apex Motorsports on my 2013 Camaro SS and it was the best investment and plug-n-play mod I've performed to date. Didn't notice the 4 cylinder drop out with my stock exhaust but after I installed cat back "pypes" brand exhaust with resonators it was definitely noticeable. Now, with the device installed I love my Camaro all over again! Works perfectly and with instant throttle response with no hesitation.
__________________
DRIVE IT LIKE YOU STOLE IT!
jammer174 is offline   Reply With Quote
Old 11-15-2013, 02:54 PM   #1043
SSGUNNER
Chu no guat a hasa is?
 
SSGUNNER's Avatar
 
Drives: 11 2SS/RSL99No Longer Stock
Join Date: Jun 2011
Location: Some where in So Cal
Posts: 3,928
Interesting how adam doesnt respond to my PM or to this thread!!!
__________________
AAC Plasma DRL's,Plug n play harness,Elite CC,Tint: 35% & 5%, LED Dome light, Show-N-Go Plate Holder, Flowmaster AT, C.A.I. Intake, VMAX CNC Spiral Ported TB
SSGUNNER is offline   Reply With Quote
Old 11-15-2013, 08:14 PM   #1044
MrPace
 
Drives: 2013 AGM Camaro 2SS/RS L99
Join Date: Sep 2013
Location: NY
Posts: 142
Ever since my last problem on 10/17, I've been only starting the car via remote start. Haven't had another problem, and it's been almost a month. All three of my prior episodes have been two or three weeks apart (and never with remote start), so I take this as a good sign I've gone a month without another problem.

Anyone having problems might want to experiment with remote-start only and see how that goes...
MrPace is offline   Reply With Quote
Old 11-16-2013, 11:45 PM   #1045
Arbgast
 
Drives: DRIVES 2014 2SS RS convertible
Join Date: May 2012
Location: Eugene
Posts: 135
Tested range AFM disable on my 2014 2ss rs vert.(cai BORLA Axel back exhaust) 200 mile round trip. 25 to 60 mph speed limit with a average speed of 57 mph. On trip to ave 23 mpg with range on way back 26 mpg without. AFM noise OK without range at highway speeds but very irritating at the 25-40 mph. So to me giving up 3 mpg is will worth keeping in 8 at all times and no codes either and the BORLA sound is great (s-type).
Arbgast is offline   Reply With Quote
Old 11-18-2013, 08:04 PM   #1046
Adam @ Range

 
Drives: 2011 Tahoe, 1971 Corvette
Join Date: Mar 2013
Location: United States
Posts: 157
Quote:
Originally Posted by SSGUNNER View Post
Interesting how adam doesnt respond to my PM or to this thread!!!
I have disabled my PM. Trying to make sure support requests go through Zendesk so they can get logged and we can follow up appropriately. No disrespect.

What's up?
Adam @ Range is offline   Reply With Quote
Old 11-19-2013, 04:53 PM   #1047
Ohten
Hot Sauce
 
Ohten's Avatar
 
Drives: 2013 Crystal Red Tincoat SS/RS
Join Date: Jan 2010
Location: West Palm Beach,FL by way of Akron,OH
Posts: 1,218
I shipped my module back to you last week priority mail which arrived Thursday(11/14) for an updated version per email sent from Range Technology.In the box was my module a copy of the email and a priority mail return postage label.I sent an email yesterday enquiring when will I receive my new module with no response.I have request #316 and 340,can you tell me what is going on?
__________________
Ohten is offline   Reply With Quote
Old 11-21-2013, 09:45 AM   #1048
Adam @ Range

 
Drives: 2011 Tahoe, 1971 Corvette
Join Date: Mar 2013
Location: United States
Posts: 157
Quote:
Originally Posted by Ohten View Post
I shipped my module back to you last week priority mail which arrived Thursday(11/14) for an updated version per email sent from Range Technology.In the box was my module a copy of the email and a priority mail return postage label.I sent an email yesterday enquiring when will I receive my new module with no response.I have request #316 and 340,can you tell me what is going on?
Did Ken call you?
Adam @ Range is offline   Reply With Quote
Old 11-21-2013, 03:01 PM   #1049
Ohten
Hot Sauce
 
Ohten's Avatar
 
Drives: 2013 Crystal Red Tincoat SS/RS
Join Date: Jan 2010
Location: West Palm Beach,FL by way of Akron,OH
Posts: 1,218
Quote:
Originally Posted by Adam @ Range View Post
Did Ken call you?
Yes we got it straightened out finally.
__________________
Ohten is offline   Reply With Quote
Old 11-22-2013, 07:48 AM   #1050
RED2011_SS
 
Drives: 2011 SS
Join Date: Nov 2013
Location: Dallas TX
Posts: 26
Send a message via Yahoo to RED2011_SS
Hey adam, how long is that discount code good for?
RED2011_SS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.