Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Flowmaster Exhaust
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8

Forced Induction - V8 V8 Supercharger, turbo, nitrous discussions

Reply
 
Thread Tools
Old 03-23-2013, 08:22 PM   #26
fldrummer
"Black Ace"
 
fldrummer's Avatar
 
Drives: 2SS/RS black/black
Join Date: Aug 2008
Location: Ft. Lauderdale, FL
Posts: 1,731
Quote:
Originally Posted by Ron_Robinson1 View Post
Congrats my man, I bet when you pulley down it will easily be over 600. It's like driving a whole new car again. I remember the first time I pulley downed and had my 04 Cobra tuned, It was a night a day difference.
Thanks. I don't doubt it either. I don't know whether to be happy or disappointed that 1st gear is still as useable as it is. It's not as torquey off the line as I expected (especially considering the very flat torque curve on my dyno sheet); it feels more like I'm running a centrifugal than a PD blower. They tell me it's due to my cam, but I dunno. Hopefully pulleying down will fix that, but either way, the current difference puts a smile on my face.
__________________
2010 2SS/RS M6 "Black Ace" - Delivered 6/4/2009
Mods: Forged LS3 (9.8:1 CR), Maggie TVS 2300 SC with OD rear pulley, Custom Comp cam (223/244, .610/.596, 114 LSA), Monster LT1-SC twin-disk clutch, Dynotech 1-piece driveshaft, CAI Inc. intake w/ ADM scoop, XS Power full exhaust (1 7/8" LT headers with 3" off-road pipes), VMAX CNC-ported TB, LSR adjustable sway bars, LPE rear end-links, BMR 1" drop, BMR polyurethane bushings; UMI trailing arms & toe rods. 572 rwhp/548 rwtq (Mustang Dyno, maxed-out injectors).
fldrummer is offline   Reply With Quote
Old 03-25-2013, 08:52 PM   #27
fldrummer
"Black Ace"
 
fldrummer's Avatar
 
Drives: 2SS/RS black/black
Join Date: Aug 2008
Location: Ft. Lauderdale, FL
Posts: 1,731
Quote:
Originally Posted by fldrummer View Post
Thanks. I don't doubt it either. I don't know whether to be happy or disappointed that 1st gear is still as useable as it is. It's not as torquey off the line as I expected (especially considering the very flat torque curve on my dyno sheet); it feels more like I'm running a centrifugal than a PD blower. They tell me it's due to my cam, but I dunno. Hopefully pulleying down will fix that, but either way, the current difference puts a smile on my face.
Well, after more seat time and some explanation from Josh@Lashway, I see why 1st gear is still useable. Apparently, the bypass valve on the Maggie doesn't shut to allow boost to build until the throttle is open a certain amount (or something like that). I had been taking it easy off the line, so it still drives with good "civility" just like before. However, if I mash the throttle (not even half way, mind you) just after letting out the clutch to get moving, the instant torque is there and the tires just basically laugh at me! LOL 'Learn something new every day... Now if I can just get this annoying "Service Stabilitrak" warning to stop rearing its ugly head, constantly, I'll feel even better.
__________________
2010 2SS/RS M6 "Black Ace" - Delivered 6/4/2009
Mods: Forged LS3 (9.8:1 CR), Maggie TVS 2300 SC with OD rear pulley, Custom Comp cam (223/244, .610/.596, 114 LSA), Monster LT1-SC twin-disk clutch, Dynotech 1-piece driveshaft, CAI Inc. intake w/ ADM scoop, XS Power full exhaust (1 7/8" LT headers with 3" off-road pipes), VMAX CNC-ported TB, LSR adjustable sway bars, LPE rear end-links, BMR 1" drop, BMR polyurethane bushings; UMI trailing arms & toe rods. 572 rwhp/548 rwtq (Mustang Dyno, maxed-out injectors).

Last edited by fldrummer; 03-30-2013 at 07:36 PM.
fldrummer is offline   Reply With Quote
Old 03-30-2013, 07:33 PM   #28
fldrummer
"Black Ace"
 
fldrummer's Avatar
 
Drives: 2SS/RS black/black
Join Date: Aug 2008
Location: Ft. Lauderdale, FL
Posts: 1,731
Well, a day after getting the car back with the Maggie, I started noticing some unusual noises under the hood (sounded like wind howling between tall buildings in a city) after long drives. 'Took it back to the shop and everything was checked and looked normal, except for the supercharger coolant being a bit low. 'Had it topped off and checked for leaks (none were found) and I went on my way. For nearly a week, the car drove beautifully and the noise never reared its ugly head...until Thursday night, when it suddenly came back louder than before when I reached my destination for the evening. In the morning, I checked the coolant reservoir and, sure enough, it looked bone-dry!? I drove it back to the shop, keeping it out of boost. We topped it off again and checked for leaks--still could not find any, so we assumed it was an internal leak, which apparently it was. We removed the plugs and found coolant coming out so, apparently, there must be a leak in the Maggie's intercooler. This was a slightly used kit that had been sitting around for a while (how long, we don't know) and the leak is probably so small, one would not see it with the naked eye...

So, the Maggie is now off the car. The intercooler will be removed and tested to find the leak and hopefully sealed to fix it. Worst case, we'll have a brand new one overnighted from Magnuson. Kudos to the Lashway team for going the extra mile and allowing me to borrow some of their rides for the weekend, as this is my only car (yeah, I need to get a beater for a DD--in due time, I suppose)... I'm lucky my engine didn't sustain any major damage from this and we caught it early; hopefully this will just be a minor, temporary glitch...

On another note, they finished another Maggie build on a 2012 SS this week, that has a similar setup to mine (slightly different cam). They used a smaller pulley (which I might go to in the future)--made 605 rwhp/560 (if I recall) rwtq... The grin on the owner's face after his first drive looked pretty familiar; LOL!
__________________
2010 2SS/RS M6 "Black Ace" - Delivered 6/4/2009
Mods: Forged LS3 (9.8:1 CR), Maggie TVS 2300 SC with OD rear pulley, Custom Comp cam (223/244, .610/.596, 114 LSA), Monster LT1-SC twin-disk clutch, Dynotech 1-piece driveshaft, CAI Inc. intake w/ ADM scoop, XS Power full exhaust (1 7/8" LT headers with 3" off-road pipes), VMAX CNC-ported TB, LSR adjustable sway bars, LPE rear end-links, BMR 1" drop, BMR polyurethane bushings; UMI trailing arms & toe rods. 572 rwhp/548 rwtq (Mustang Dyno, maxed-out injectors).
fldrummer is offline   Reply With Quote
Old 03-30-2013, 07:35 PM   #29
UF4LIFE102SS
Treasure Coast Camaro 5
 
UF4LIFE102SS's Avatar
 
Drives: 2010 2 SS
Join Date: Nov 2010
Location: Vero Beach, FL.
Posts: 3,522
Glad u found it.
__________________
UF4LIFE102SS is offline   Reply With Quote
Old 04-12-2013, 12:15 PM   #30
fldrummer
"Black Ace"
 
fldrummer's Avatar
 
Drives: 2SS/RS black/black
Join Date: Aug 2008
Location: Ft. Lauderdale, FL
Posts: 1,731
Finally, after an extra week of down time, I have my beast back and running great. Once the Lashway crew got the blower back off the car and apart, they checked around to see if the intercooler could get repaired with no luck, so we had to order a new one from Magnuson. Overnight shipping was ridiculously expensive ($200-yikes!), so we decided to wait a little longer. They showed me where the leak was coming from, but it was too small and/or hidden to see. After testing the new intercooler for leaks (none found) and putting everything back together, the car's driving great (checked the coolant reservoir after 3 days --still full) and no more funny noises...

After all was said and done, I think I just about spent as much as I would have for a new kit, but it was still worth it. Pics of the intercooler repair can be found here:

https://www.facebook.com/media/set/?...0303405&type=1
__________________
2010 2SS/RS M6 "Black Ace" - Delivered 6/4/2009
Mods: Forged LS3 (9.8:1 CR), Maggie TVS 2300 SC with OD rear pulley, Custom Comp cam (223/244, .610/.596, 114 LSA), Monster LT1-SC twin-disk clutch, Dynotech 1-piece driveshaft, CAI Inc. intake w/ ADM scoop, XS Power full exhaust (1 7/8" LT headers with 3" off-road pipes), VMAX CNC-ported TB, LSR adjustable sway bars, LPE rear end-links, BMR 1" drop, BMR polyurethane bushings; UMI trailing arms & toe rods. 572 rwhp/548 rwtq (Mustang Dyno, maxed-out injectors).

Last edited by fldrummer; 12-30-2013 at 11:34 PM.
fldrummer is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.