Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum

Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum All audio, video, bluetooth, nav, radar, and electronics discussions.

Reply
 
Thread Tools
Old 06-05-2013, 06:25 AM   #26
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Quote:
Originally Posted by Glen e View Post
not on a mylink issue...."just sayin"....LOL
I'm sure you're right. Just venting. But I would think they'd at least have to trade out the Mylink unit since everything else has failed.
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-05-2013, 06:31 AM   #27
Glen e

 
Drives: Cyber/Red C7
Join Date: May 2013
Location: Fort Lauderdale
Posts: 1,972
Quote:
Originally Posted by benji1997 View Post
I'm sure you're right. Just venting. But I would think they'd at least have to trade out the Mylink unit since everything else has failed.
yes, they will do that....

Lemon law these days is pretty specific (I was the rep for 25 years that approved things like this for 3 diff car mfrs) the "radio" is not considered use, value, or safety impairment so they can keep throwing parts at it until it's fixed. A refurb unit is their option, and you can try and demand a new unit but refurbs are certified, and almost always just as good when it's a behind the dash item.

Good luck...seek the field service engineer thru your GM regional office and deal directly with him. You have that right...
__________________
Glen
2LT C7 Cyber/Red
Glen e is offline   Reply With Quote
Old 06-05-2013, 06:49 AM   #28
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Since Mylink is brand new, there can't be very many refurbished units. But as long as it works the way it's supposed to, a refurb wouldn't bother me,.
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-05-2013, 06:52 AM   #29
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,690
Quote:
Originally Posted by Glen e View Post
not on a mylink issue...."just sayin"....LOL
You can file lemon law for any issue. You just have to meet your state's requirements. Like VA for example, you have to give the dealer 3 tries or your car has to be out of service for 30 days.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 06-05-2013, 07:11 AM   #30
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Quote:
Originally Posted by The Stig View Post
You can file lemon law for any issue. You just have to meet your state's requirements. Like VA for example, you have to give the dealer 3 tries or your car has to be out of service for 30 days.
I actually love my car. But the Mylink problem is very annoying. So I will give the dealership at least one more chance before looking into the Mass. lemon law. Most likely that will turn out to be a non-option but if they can't fix the problem and won't replace the unit, that maybe my option.
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-05-2013, 07:21 AM   #31
Glen e

 
Drives: Cyber/Red C7
Join Date: May 2013
Location: Fort Lauderdale
Posts: 1,972
Quote:
Originally Posted by The Stig View Post
You can file lemon law for any issue. You just have to meet your state's requirements. Like VA for example, you have to give the dealer 3 tries or your car has to be out of service for 30 days.
True!...you can "file" for anything .....
__________________
Glen
2LT C7 Cyber/Red
Glen e is offline   Reply With Quote
Old 06-05-2013, 07:37 AM   #32
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Just got off the phone with the local SM. He will be in contact with GM today about the next step. He informed me that GM has told him there is no fix for the "radio info to HUD" problem. GM says it happens occasionally in all Mylink/HUD setups. I don't know if I should accept that explanation. It seems to me, if it is meant to work a certain way, it should work that way at the least most of the time. More often than not, my HUD is not getting the radio information. I asked him about doing a refresh and he said Chevy will not do a refresh if you have the most up to date program already. I'm not getting the answers I want.
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-05-2013, 07:42 AM   #33
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Quote:
Originally Posted by The Stig View Post
I got a new Camaro under lemon law. Just saying.
What was the problem with your previous Camaro?
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-05-2013, 07:47 AM   #34
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,690
Quote:
Originally Posted by benji1997 View Post
What was the problem with your previous Camaro?
Car ate through brake pads in about 5,000 miles - went through 3 sets OEM pads, 2 OEM rotors, and they even replaced the ABS. Didnt fix it, so they bought the car back and I bought a 2011.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 06-05-2013, 07:55 AM   #35
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 9,601
I am having MyLink issues as well.

http://www.camaro5.com/forums/showthread.php?t=299986
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 06-05-2013, 08:11 AM   #36
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Quote:
Originally Posted by nyrfan View Post
May I ask what your Mylink issues are?
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-05-2013, 08:23 AM   #37
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 9,601
Quote:
Originally Posted by benji1997 View Post
May I ask what your Mylink issues are?
Pretty much the same as others, radio not displaying on HUD, conectivity issues, AC fan not showing properly.

See post 3750 of the below post, that is the latest FW version with pics. I brought this to my dealer and he said I have the most recent FW which I don't as I do not have the warning signals.

http://www.camaro5.com/forums/showth...65844&page=150
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 06-05-2013, 09:00 AM   #38
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
If what my SM told me is correct, Chevy has no fix for these Mylink issues. WTF!!!!!!! How can you sell anything let alone an expensive commodity like a high-priced (or any-priced) automobile and not have fixes for all problems??? Sounds like it's time to have Elizabeth Warren look into GM a little closer. If these issues are not fixed, we're stuck with a $35,000+ commodity that doesn't function correctly. Am I being too melodramatic? I don't think so. I'm getting more and more upset, the more I post here.
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-05-2013, 12:39 PM   #39
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,617
Quote:
Originally Posted by benji1997 View Post
Just got off the phone with the local SM. He will be in contact with GM today about the next step. He informed me that GM has told him there is no fix for the "radio info to HUD" problem. GM says it happens occasionally in all Mylink/HUD setups. I don't know if I should accept that explanation. It seems to me, if it is meant to work a certain way, it should work that way at the least most of the time. More often than not, my HUD is not getting the radio information. I asked him about doing a refresh and he said Chevy will not do a refresh if you have the most up to date program already. I'm not getting the answers I want.
Hello benji1997,

I see you mentioned you are already in contact with GM. Have you been issued a case number? If so, please private message me that information. I would like to look into your situation further to see if there is any assistance I may be able to lend.

Reggie B.
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
Old 06-05-2013, 11:27 PM   #40
TomF1
 
TomF1's Avatar
 
Drives: 2013 CRT ZL1
Join Date: Jul 2012
Location: Ajax, Ontario
Posts: 182
Getting a dealer to fix a radio doesn't sound like a big issue to me. (nor a need to replace a car.)
I take my car to the dealer, they give me a ride home, call me when its ready.
Usually takes a 2nd trip when the part comes in.
then a 3rd trip when they have the parts for whatever they missed. :(
That's about normal.
When they have to keep it overnight, they get me a rental.
They warranty on my MonteCarloSS is done, on my wife's Grand Prix we're down to just the powertrain, and I hate to say it, but I haven't found anything to take the ZL1 in for, yet.
I'm not a big fan of doing any work at the Stealership, but it's a necessary evil for warranty work.
TomF1 is offline   Reply With Quote
Old 06-06-2013, 05:10 AM   #41
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Quote:
Originally Posted by TomF1 View Post
Getting a dealer to fix a radio doesn't sound like a big issue to me. (nor a need to replace a car.)
It's a big issue when they're clueless about how to fix it.
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-06-2013, 05:51 AM   #42
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 9,601
Quote:
Originally Posted by TomF1 View Post
Getting a dealer to fix a radio doesn't sound like a big issue to me. (nor a need to replace a car.)
I take my car to the dealer, they give me a ride home, call me when its ready.
Usually takes a 2nd trip when the part comes in.
then a 3rd trip when they have the parts for whatever they missed. :(
That's about normal.
When they have to keep it overnight, they get me a rental.
They warranty on my MonteCarloSS is done, on my wife's Grand Prix we're down to just the powertrain, and I hate to say it, but I haven't found anything to take the ZL1 in for, yet.
I'm not a big fan of doing any work at the Stealership, but it's a necessary evil for warranty work.
Wether it's a big issue or not is irrelevant. A car should not be sold with a component that does not work properly or cannot be fixed.


Sent from my 2SS/RS
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 06-06-2013, 07:33 AM   #43
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Quote:
Originally Posted by nyrfan View Post
Wether it's a big issue or not is irrelevant. A car should not be sold with a component that does not work properly or cannot be fixed.


Sent from my 2SS/RS
+1....couldn't have said it better myself.
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-15-2013, 06:13 PM   #44
benji1997
 
benji1997's Avatar
 
Drives: 2013 IOM 2LT/RS M6
Join Date: Mar 2013
Location: Dartmouth, Ma.
Posts: 447
Send a message via Skype™ to benji1997
Well, I had my Camaro in for service Thursday for the MyLink fan speed indicator problem, among other problems. I thought it was fixed but this afternoon, it froze again. Getting closer to Lemon Law. I'm not sure GM has a clue how to fix this.
__________________
2013 2LT/RS IOM M6 w/DUAL-MODE EXHAUST, BLADE WING SPOILER AND ZL/1 PERFORMANCE PEDALS
benji1997 is offline   Reply With Quote
Old 06-15-2013, 06:18 PM   #45
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 9,601
Quote:
Originally Posted by benji1997 View Post
Well, I had my Camaro in for service Thursday for the MyLink fan speed indicator problem, among other problems. I thought it was fixed but this afternoon, it froze again. Getting closer to Lemon Law. I'm not sure GM has a clue how to fix this.
Would you really consider a lemon law because of the MyLink issues, especially the fan not displaying? The older years don't show the fan, plus the fan still works properly.


Sent from my 2SS/RS
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 06-15-2013, 06:25 PM   #46
Glen e

 
Drives: Cyber/Red C7
Join Date: May 2013
Location: Fort Lauderdale
Posts: 1,972
Quote:
Originally Posted by nyrfan View Post
Would you really consider a lemon law because of the MyLink issues, especially the fan not displaying? The older years don't show the fan, plus the fan still works properly.


Sent from my 2SS/RS

10 4....if a defect does not impair use, value, or safety, the lemon law hill is a whole lot harder to climb......does my link fall under those?

Really not sure........
__________________
Glen
2LT C7 Cyber/Red
Glen e is offline   Reply With Quote
Old 06-15-2013, 06:34 PM   #47
Angrybird 12
Retired, Cancer Survivor
 
Angrybird 12's Avatar
 
Drives: 12 CAMARO 1LT, 08 Vue, 14 Spark
Join Date: Dec 2007
Location: J. C. Tennessee
Posts: 17,670
Sounds like my link is more trouble than its worth. I wonder if they could swap it out for a non my link radio and give you credit for it.
__________________
Cancer's a bitch! Enjoy life while you can! LIVE, LOVE, DRIVE...CAMARO!

Previous Camaros: 1974, 1979 and 2010.
Angrybird 12 is offline   Reply With Quote
Old 06-15-2013, 06:38 PM   #48
Glen e

 
Drives: Cyber/Red C7
Join Date: May 2013
Location: Fort Lauderdale
Posts: 1,972
Overall, it's working as well as many other interface systems out there, it just has its quirks, and glitches for some....IMO
__________________
Glen
2LT C7 Cyber/Red
Glen e is offline   Reply With Quote
Old 06-15-2013, 06:44 PM   #49
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 9,601
Quote:
Originally Posted by Angrybird 12 View Post
Sounds like my link is more trouble than its worth. I wonder if they could swap it out for a non my link radio and give you credit for it.
It's really not. There are a couple of bugs, but still works well and is much better then the old setup.


Sent from my 2SS/RS
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 06-15-2013, 06:44 PM   #50
impaidbyu
 
Drives: 2013 rs/ss Convertible
Join Date: May 2013
Location: North Eastern CT
Posts: 83
Mylink

Has anyone changed there mylink to a better after market unit?

I dont like having to call onstar to use my NAV its such a pain in the butt. I use my NAV all day and would like another option. I would really like it if GM would offer a software upgrade to keep the mylink in the car but am looking for options ASAP.
impaidbyu is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.