Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Gen5DIY
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 04-17-2013, 11:19 PM   #1
Zackety93
 
Zackety93's Avatar
 
Drives: 2010 Camaro SS, 6-speed manual
Join Date: Nov 2012
Location: Tennessee
Posts: 137
She's not pullin' like she used to...

So on my way home from work tonight, I found myself right next to a lowered 350z. I figured we could have a little fun. I had beaten a few stock Zs before, no sweat. This one didn't have factory exhaust, and it didn't look or sound like he was running boost, however I don't know much further. In short, he walked my ass pretty hard...

WHICH brings me to my topic...

I drive a '10 SS. Only mod so far has been a 3' Retro Chambered Catback from Stainless works. I don't know if I'm having any mechanical issues, nothing feels out of place... It just doesn't feel like it pulls as hard as it used to. This could be a mental thing, but I'm just a little curious for some feedback on this.

Zackety93 is offline   Reply With Quote
Old 04-17-2013, 11:21 PM   #2
Berje
 
Berje's Avatar
 
Drives: 1994 z28, 2010 ss, 2010 titan
Join Date: Jul 2012
Location: Warner Robins, Georgia
Posts: 147
You could try a fuse pull? maybe fuel table got used to low octane fuel.
Or maybe you just got used to the power and its time to mod!
__________________
Berje is offline   Reply With Quote
Old 04-17-2013, 11:22 PM   #3
Sevn86


 
Sevn86's Avatar
 
Drives: 2010 Camaro 2LT/RS ABM
Join Date: Sep 2009
Location: Sugar Land, TX
Posts: 13,085
Quote:
Originally Posted by Berje View Post
You could try a fuse pull? maybe fuel table got used to low octane fuel.
Or maybe you just got used to the power and its time to mod!
__________________
2LT, RS, AT6 ABM, Gray Leather
Quote:
Originally Posted by baclarsen View Post
Dude, you go through cars faster than I go through underware!!
1000 Initial Order 9/14/2009 - Classic Chevy Sugar Land
1100 Order accepted at dealer: 9/15/2009 - NPGV41.
2000 Order accepted by GM: 9/29/2009
3000 Accepted By Production Control: 9/30/2009 - TPW 10/26/09
3100 Sequenced:10/12/09
3300 Scheduled For Production:10/13/09
3400 Broadcast:10/22/09
3800 Produced:10/27/09
4000 Available To Ship:10/28/09
4200 Shipped:10/29/09
5000 Delivered To The Dealer:11/09/09
6000 Delivered To Customer:11/12/09
Sevn86 is offline   Reply With Quote
Old 04-17-2013, 11:24 PM   #4
Zackety93
 
Zackety93's Avatar
 
Drives: 2010 Camaro SS, 6-speed manual
Join Date: Nov 2012
Location: Tennessee
Posts: 137
That's kinda what I'm feeling... I run 93 all the time, so idk... Just a bruised ego :P
Was just kinda curious if any mechanical problem would cause that issue.
Zackety93 is offline   Reply With Quote
Old 04-17-2013, 11:24 PM   #5
Jeff_SS
"Cam Only"
 
Jeff_SS's Avatar
 
Drives: 2013 Camaro SS
Join Date: Nov 2011
Location: Thousand Oaks, CA
Posts: 1,549
I'm sure on the way home you stopped at a private track and did this in a safe, legal setting; therefore, making this thread totally acceptable on this forum.
__________________
2013 AGM Camaro 2SS/RS M6 | LSA Blower, 2.5" pulley, ID1000's, Fore Innovations Twin Pump fuel system w/ Flex Fuel, CMS Custom Grind Cam, Kooks 1 7/8" headers w/ catless off-road pipes, NPP Exhaust, 3.91's, JLT ZL1 Intake | Pfadt Suspension | DSS 1000hp axles | MT 305/35/20 DRs |
Tuned by Ryne @ CMS E85: 669rwhp/590rwtq (mustang dyno)

Jeff_SS is offline   Reply With Quote
Old 04-17-2013, 11:27 PM   #6
Fiveg56

 
Drives: -
Join Date: Oct 2011
Location: MN
Posts: 1,654
There is always a faster car then yours....who cares????
Fiveg56 is offline   Reply With Quote
Old 04-17-2013, 11:34 PM   #7
MrSEO
 
Drives: Hyundai Genesis Coupe 3.8
Join Date: Dec 2010
Location: Fremont, CA
Posts: 30
Without boost of some sort, be it supercharger, turbocharger, or nitrous, there's no way that he beat you unless you can't hook up...
MrSEO is offline   Reply With Quote
Old 04-17-2013, 11:37 PM   #8
yellowrs
Account Suspended
 
Drives: 2010 SS 426 V8 M/T
Join Date: Aug 2012
Location: Scottsdale AZ
Posts: 1,376
Quote:
Originally Posted by Fiveg56 View Post
There is always a faster car then yours....who cares????
Exactly, always somebody faster and better than you car!
Who cares??
You can't smoke everybody.
Plus perhaps he had a better driving ability than you do?
I would not use any sleep.
If you do buy a 370 and problem solved
yellowrs is offline   Reply With Quote
Old 04-17-2013, 11:38 PM   #9
SSGUNNER
Chu no guat a hasa is?
 
SSGUNNER's Avatar
 
Drives: 14 Jeep G Cherokee Overland HEMI
Join Date: Jun 2011
Location: Some where in So Cal
Posts: 4,282
Maybe granny shifting played a part? Just saying
__________________
11 2SS/RSL99No Longer Stock (Sold) 6/19/14:AAC Plasma DRL's | Plug n play harness | Elite CC | Tint: 35% & 5% | LED Dome light | Show-N-Go Plate Holder | Flowmaster AT | C.A.I. Intake | VMAX CNC Spiral Ported TB | Husky Splash Guards
SSGUNNER is offline   Reply With Quote
Old 04-17-2013, 11:41 PM   #10
Fiveg56

 
Drives: -
Join Date: Oct 2011
Location: MN
Posts: 1,654
Quote:
Originally Posted by SSGUNNER View Post
Maybe granny shifting played a part? Just saying
Like in the Fast and Furious??
Fiveg56 is offline   Reply With Quote
Old 04-17-2013, 11:42 PM   #11
slomaro3.4
 
slomaro3.4's Avatar
 
Drives: SS/RS L99 Crew
Join Date: Feb 2013
Location: Florida/Pittsburgh/San Diego
Posts: 439
Probably blew the welds on your intake manifold. Did your passenger side floorpan fall out? We need more details.
slomaro3.4 is offline   Reply With Quote
Old 04-18-2013, 12:00 AM   #12
Zackety93
 
Zackety93's Avatar
 
Drives: 2010 Camaro SS, 6-speed manual
Join Date: Nov 2012
Location: Tennessee
Posts: 137
Nah I was double-clutching like I should. And yes, We stopped at a private track.
Zackety93 is offline   Reply With Quote
Old 04-18-2013, 12:03 AM   #13
Zackety93
 
Zackety93's Avatar
 
Drives: 2010 Camaro SS, 6-speed manual
Join Date: Nov 2012
Location: Tennessee
Posts: 137
In all seriousness.. My main question was if there would be any mechanical issue causing this problem, or if it was all in my head. 350z aside.
Zackety93 is offline   Reply With Quote
Old 04-18-2013, 12:18 AM   #14
Jason P
 
Jason P's Avatar
 
Drives: 2011 2ss
Join Date: Oct 2012
Location: United States
Posts: 273
I think you got used to the car. Time to throw some money at it.
__________________
2011 2ss Ram twin plate ceramic clutch, Texas speed 418 LS3 235 /243 .621 / .624 cam, ported and polished heads with dual springs,magnum push rods, Hotchkis race pack, Stainless Power long tube headers with no cats, Magna Flo competition exhaust, lpe fuel pump, magnuson supercharger with overdrive and port matched blower plate, IW 8 rib pullies, AEM meth kit, id 850 injectors, 3 bar map, halltech cai, zl1 rear diff
Jason P is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:29 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.