Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cam Motion
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 05-10-2013, 02:00 PM   #18
usranger80
 
usranger80's Avatar
 
Drives: 2011 1LT "Bumblebee"
Join Date: Jun 2011
Location: San Angelo, TX
Posts: 699
Mine does it too, has been that way from day 1
__________________
usranger80 is offline   Reply With Quote
Old 05-10-2013, 03:12 PM   #19
429
Account Suspended
 
Drives: 2010 camaro ss
Join Date: Nov 2012
Location: Richmond Hill, GA
Posts: 807
The tab in the bezel is not in its receiver slot. It's a poor design, and I have seen several this way. Often the receiver slot bends permanently and is no longer functional
429 is offline   Reply With Quote
Old 05-10-2013, 06:09 PM   #20
93B4C
 
93B4C's Avatar
 
Drives: 2013 1SS Panther 1993 B4C
Join Date: Jul 2012
Location: Methuen, MA
Posts: 214
Quote:
Originally Posted by 429 View Post
The tab in the bezel is not in its receiver slot. It's a poor design, and I have seen several this way. Often the receiver slot bends permanently and is no longer functional
So, should I even bother having the dealer fix it and risk having the same thing happen?
__________________
2013 1SS M6 Panther
1993 B4C M6
1993 B4C A4
93B4C is offline   Reply With Quote
Old 05-28-2013, 09:45 AM   #21
CamaroGuyDave
 
CamaroGuyDave's Avatar
 
Drives: 2013 1LT A6
Join Date: Mar 2013
Location: Lewisville, TX
Posts: 108
I have the same problem in my car. Its a 2013 LS
CamaroGuyDave is offline   Reply With Quote
Old 05-28-2013, 10:43 AM   #22
Jalberdi99

 
Jalberdi99's Avatar
 
Drives: 2014 Summit White 2SS/RS M6
Join Date: Aug 2012
Location: @ ur moms house in VA
Posts: 1,338
same problem here, it freaking sucks. took the bezel to paint it, put it back on and got that stupid gap.
__________________
Jalberdi99 is offline   Reply With Quote
Old 05-28-2013, 11:12 AM   #23
45thAnniversary2SS


 
45thAnniversary2SS's Avatar
 
Drives: 2012 45th Anniversary 2SS LS3
Join Date: Feb 2012
Location: Charlotte, NC
Posts: 2,802
Same here..
__________________
45thAnniversary2SS is offline   Reply With Quote
Old 05-28-2013, 11:49 AM   #24
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,280
Has anyone had any luck getting this fixed under warranty?
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 05-28-2013, 03:07 PM   #25
CamaroGuyDave
 
CamaroGuyDave's Avatar
 
Drives: 2013 1LT A6
Join Date: Mar 2013
Location: Lewisville, TX
Posts: 108
I am going to take mine to the dealership today and see what they say. I'll post an update.
CamaroGuyDave is offline   Reply With Quote
Old 05-28-2013, 05:19 PM   #26
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,971
Quote:
Originally Posted by CamaroGuyDave View Post
I am going to take mine to the dealership today and see what they say. I'll post an update.
Indeed,

I would also like to hear about your dealership visit and repair turn out.

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
Old 05-28-2013, 06:37 PM   #27
skuttduck


 
skuttduck's Avatar
 
Drives: 2010 RJT 2LT Camaro
Join Date: May 2009
Location: East Lansing, MI
Posts: 2,530
Send a message via ICQ to skuttduck Send a message via AIM to skuttduck Send a message via Yahoo to skuttduck
Mine is doing it after I switched to the 2012 dash. I've reseated my bezels several times no broken tabs and can't get it to fit as tight as it did when I had the 2010 dash.
__________________
skuttduck is offline   Reply With Quote
Old 05-05-2014, 07:58 AM   #28
masonacdc
 
masonacdc's Avatar
 
Drives: 2LS Inferno Orange "PHOENIX"
Join Date: May 2012
Location: WV
Posts: 634
like to know what ended up happening
__________________


PHOENIX 323HP "LEGENDS NEVER DIE"
masonacdc is offline   Reply With Quote
Old 05-05-2014, 10:57 AM   #29
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 10,685
Quote:
Originally Posted by masonacdc View Post
like to know what ended up happening
Unfortunately this is quite normal; this only fix is to replace the whole dash. I am living with it as I rather not have my dash ripped out for something so minor.
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 05-14-2014, 12:33 AM   #30
captaincog
 
captaincog's Avatar
 
Drives: 2013 1LS V6/6 spd;1971 350RS/SS 4sp
Join Date: Feb 2013
Location: Rialto
Posts: 112
I thought I was the only one with this issue. It does bother me but so far my dealership cannot even do a normal oil change and tire rotation correct. I have 34.5K miles on my 2013 and during every service they have broken something or not serviced my ride correctly. Engine cover repeatedly not reinstalled correctly, tires rotated but not correct air pressure, tire sensors not readjusted to correct rotated tire position, and now as of this week broken air filter box tab. I pay the dealer for their expertise and so far they are only an expert at breaking my ride. The techs informally admitted that they have the attitude that since mine is a v6 it is a POS Camaro. Oh, and another dealer that fixed a nail in my tire scratched my rim several months back.

I would not trust anyone right now to touch my Camaro but I am stuck since I do not own the scan tool the reset the TPMS sensors after a tire rotation. I guess this might be the last GM product for a while and what a shame since I really like my Camaro....being a "POS v6 with a manual" and all.......
__________________
Camaros currently owned: 2
2013 1LS 6speed.... Blue Ray Metallic
and my first Camaro made 42 years before:
1971 RS/SS 350 4 speed Teal Green
captaincog is offline   Reply With Quote
Old 05-14-2014, 12:48 AM   #31
Q'smuscle
Account Suspended
 
Drives: 2011 Camaro VR 2SS/RS & Impala
Join Date: Apr 2013
Location: Riverside,ca
Posts: 5,344
Quote:
Originally Posted by captaincog View Post
I thought I was the only one with this issue. It does bother me but so far my dealership cannot even do a normal oil change and tire rotation correct. I have 34.5K miles on my 2013 and during every service they have broken something or not serviced my ride correctly. Engine cover repeatedly not reinstalled correctly, tires rotated but not correct air pressure, tire sensors not readjusted to correct rotated tire position, and now as of this week broken air filter box tab. I pay the dealer for their expertise and so far they are only an expert at breaking my ride. The techs informally admitted that they have the attitude that since mine is a v6 it is a POS Camaro. Oh, and another dealer that fixed a nail in my tire scratched my rim several months back.

I would not trust anyone right now to touch my Camaro but I am stuck since I do not own the scan tool the reset the TPMS sensors after a tire rotation. I guess this might be the last GM product for a while and what a shame since I really like my Camaro....being a "POS v6 with a manual" and all.......
Wowwwwwwwwwwww! The dealer that said that needs to get their business license taken away! Unprofessional of them , to say that! I bet the techs don't even own a camaro! What's the dealer name?????
Q'smuscle is offline   Reply With Quote
Old 05-14-2014, 02:22 AM   #32
top_of_the_pile
 
Drives: Piercer
Join Date: Mar 2014
Location: Shitcago
Posts: 66
Quote:
Originally Posted by captaincog View Post
I thought I was the only one with this issue. It does bother me but so far my dealership cannot even do a normal oil change and tire rotation correct. I have 34.5K miles on my 2013 and during every service they have broken something or not serviced my ride correctly. Engine cover repeatedly not reinstalled correctly, tires rotated but not correct air pressure, tire sensors not readjusted to correct rotated tire position, and now as of this week broken air filter box tab. I pay the dealer for their expertise and so far they are only an expert at breaking my ride. The techs informally admitted that they have the attitude that since mine is a v6 it is a POS Camaro. Oh, and another dealer that fixed a nail in my tire scratched my rim several months back.

I would not trust anyone right now to touch my Camaro but I am stuck since I do not own the scan tool the reset the TPMS sensors after a tire rotation. I guess this might be the last GM product for a while and what a shame since I really like my Camaro....being a "POS v6 with a manual" and all.......
Such behavior is too common unfortunately. I don't think the value of the car matters really. You could have brought in a brand new C7 and still gotten same treatment: "Screw that rich guy and his corvette!" vs. "Screw that dumb idiot and his cheapo-mobile!".

If mentality of assholishness exsists at the dealership, there is not much you can do. They are most like this from my experience. Irregardless of brand. Some are worse than others. I wish that all the warranty repair and maintenance could be done by a third separate party, semi-independently of GM and totally detached from the current sales dealership franchise model. I think it is the sleazy salesman culture that pollutes the dealership atmosphere down to the lowest guy changing your oil (and it is always some 19 year old kid without too many options, kid who is told and shown to do it quickly, sloppy, and that forgetting to put the oil cap back on is just fine as long as nobody notices), culture that promotes "doing minimum of work possible, at all times, and getting away with as much as you can".

Long story short: avoid dealerships at all costs!

Problem... we need cars
top_of_the_pile is offline   Reply With Quote
Old 05-14-2014, 05:25 AM   #33
ssrs2lt


 
ssrs2lt's Avatar
 
Drives: too many
Join Date: Jul 2013
Location: oh va pa ma
Posts: 2,359
mines has it also, but I've done zip about it..
ssrs2lt is offline   Reply With Quote
Old 05-14-2014, 07:47 AM   #34
davidcroft
Sellin Chevy's since '06
 
davidcroft's Avatar
 
Drives: 2014 SS sedan
Join Date: Apr 2008
Location: Houston, TX
Posts: 1,419
These are the problems we worry about on the forum? Not that we're broken down on the side of the road, not that our trans is slipping, not that we have window motor issues, A/C issues, Electrical issues (which Chevrolet doesn't have huge problems with in the Camaro at all) We are worried about a boar's hair gap in one side vs the other? I have seen this exact same thing on my 2 5th gens and tried pushing the bezel back farther....it wouldn't sit flush so I chalked it up as normal. It doesn't rattle or squeak and my car runs fine....so this is a NON issue.

end rant.


flamesuit on.
__________________
2014 SS Sedan-"houston stock" granny sedan
SOLD! 2013 Blue Ray1SS/1LE 1of20.
TRADED! 2012 White 1SS/RS
davidcroft is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:49 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.