Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Redline Goods
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-28-2013, 04:19 PM   #26
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,625
Quote:
Originally Posted by CamaroGuyDave View Post
I am going to take mine to the dealership today and see what they say. I'll post an update.
Indeed,

I would also like to hear about your dealership visit and repair turn out.

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is offline   Reply With Quote
Old 05-28-2013, 05:37 PM   #27
skuttduck


 
skuttduck's Avatar
 
Drives: 2010 RJT 2LT Camaro
Join Date: May 2009
Location: East Lansing, MI
Posts: 2,528
Send a message via ICQ to skuttduck Send a message via AIM to skuttduck Send a message via Yahoo to skuttduck
Mine is doing it after I switched to the 2012 dash. I've reseated my bezels several times no broken tabs and can't get it to fit as tight as it did when I had the 2010 dash.
__________________
skuttduck is online now   Reply With Quote
Old 05-05-2014, 06:58 AM   #28
masonacdc
 
masonacdc's Avatar
 
Drives: 2LS Inferno Orange "PHOENIX"
Join Date: May 2012
Location: WV
Posts: 535
like to know what ended up happening
__________________


PHOENIX 323HP "LEGENDS NEVER DIE"
masonacdc is offline   Reply With Quote
Old 05-05-2014, 09:57 AM   #29
nyrfan
Let's go Rangers!
 
nyrfan's Avatar
 
Drives: 13' AGM 2SS/RS L99
Join Date: Jun 2011
Location: Orlando, FL
Posts: 9,611
Quote:
Originally Posted by masonacdc View Post
like to know what ended up happening
Unfortunately this is quite normal; this only fix is to replace the whole dash. I am living with it as I rather not have my dash ripped out for something so minor.
__________________
Soprano 4/1/00-6/14/11, Gone but NEVER forgotten!
FSP tuned: 377/389
nyrfan is offline   Reply With Quote
Old 05-13-2014, 11:33 PM   #30
captaincog
 
captaincog's Avatar
 
Drives: 2013 1LS V6/6 spd;1971 350RS/SS 4sp
Join Date: Feb 2013
Location: Rialto
Posts: 101
I thought I was the only one with this issue. It does bother me but so far my dealership cannot even do a normal oil change and tire rotation correct. I have 34.5K miles on my 2013 and during every service they have broken something or not serviced my ride correctly. Engine cover repeatedly not reinstalled correctly, tires rotated but not correct air pressure, tire sensors not readjusted to correct rotated tire position, and now as of this week broken air filter box tab. I pay the dealer for their expertise and so far they are only an expert at breaking my ride. The techs informally admitted that they have the attitude that since mine is a v6 it is a POS Camaro. Oh, and another dealer that fixed a nail in my tire scratched my rim several months back.

I would not trust anyone right now to touch my Camaro but I am stuck since I do not own the scan tool the reset the TPMS sensors after a tire rotation. I guess this might be the last GM product for a while and what a shame since I really like my Camaro....being a "POS v6 with a manual" and all.......
__________________
Camaros currently owned: 2
2013 1LS 6speed.... Blue Ray Metallic
and my first Camaro made 42 years before:
1971 RS/SS 350 4 speed Teal Green
captaincog is offline   Reply With Quote
Old 05-13-2014, 11:48 PM   #31
Q'smuscle
life with muscle
 
Q'smuscle's Avatar
 
Drives: 2011 Camaro VR 2SS/RS & Impala
Join Date: Apr 2013
Location: Riverside,ca
Posts: 3,417
Quote:
Originally Posted by captaincog View Post
I thought I was the only one with this issue. It does bother me but so far my dealership cannot even do a normal oil change and tire rotation correct. I have 34.5K miles on my 2013 and during every service they have broken something or not serviced my ride correctly. Engine cover repeatedly not reinstalled correctly, tires rotated but not correct air pressure, tire sensors not readjusted to correct rotated tire position, and now as of this week broken air filter box tab. I pay the dealer for their expertise and so far they are only an expert at breaking my ride. The techs informally admitted that they have the attitude that since mine is a v6 it is a POS Camaro. Oh, and another dealer that fixed a nail in my tire scratched my rim several months back.

I would not trust anyone right now to touch my Camaro but I am stuck since I do not own the scan tool the reset the TPMS sensors after a tire rotation. I guess this might be the last GM product for a while and what a shame since I really like my Camaro....being a "POS v6 with a manual" and all.......
Wowwwwwwwwwwww! The dealer that said that needs to get their business license taken away! Unprofessional of them , to say that! I bet the techs don't even own a camaro! What's the dealer name?????
__________________
Chevy's nothing Else matters
Q'smuscle is offline   Reply With Quote
Old 05-14-2014, 01:22 AM   #32
top_of_the_pile
 
Drives: Piercer
Join Date: Mar 2014
Location: Shitcago
Posts: 62
Quote:
Originally Posted by captaincog View Post
I thought I was the only one with this issue. It does bother me but so far my dealership cannot even do a normal oil change and tire rotation correct. I have 34.5K miles on my 2013 and during every service they have broken something or not serviced my ride correctly. Engine cover repeatedly not reinstalled correctly, tires rotated but not correct air pressure, tire sensors not readjusted to correct rotated tire position, and now as of this week broken air filter box tab. I pay the dealer for their expertise and so far they are only an expert at breaking my ride. The techs informally admitted that they have the attitude that since mine is a v6 it is a POS Camaro. Oh, and another dealer that fixed a nail in my tire scratched my rim several months back.

I would not trust anyone right now to touch my Camaro but I am stuck since I do not own the scan tool the reset the TPMS sensors after a tire rotation. I guess this might be the last GM product for a while and what a shame since I really like my Camaro....being a "POS v6 with a manual" and all.......
Such behavior is too common unfortunately. I don't think the value of the car matters really. You could have brought in a brand new C7 and still gotten same treatment: "Screw that rich guy and his corvette!" vs. "Screw that dumb idiot and his cheapo-mobile!".

If mentality of assholishness exsists at the dealership, there is not much you can do. They are most like this from my experience. Irregardless of brand. Some are worse than others. I wish that all the warranty repair and maintenance could be done by a third separate party, semi-independently of GM and totally detached from the current sales dealership franchise model. I think it is the sleazy salesman culture that pollutes the dealership atmosphere down to the lowest guy changing your oil (and it is always some 19 year old kid without too many options, kid who is told and shown to do it quickly, sloppy, and that forgetting to put the oil cap back on is just fine as long as nobody notices), culture that promotes "doing minimum of work possible, at all times, and getting away with as much as you can".

Long story short: avoid dealerships at all costs!

Problem... we need cars
top_of_the_pile is offline   Reply With Quote
Old 05-14-2014, 04:25 AM   #33
ssrs2lt

 
Drives: too many
Join Date: Jul 2013
Location: oh va pa
Posts: 1,295
mines has it also, but I've done zip about it..
ssrs2lt is online now   Reply With Quote
Old 05-14-2014, 06:47 AM   #34
davidcroft
Sellin Chevy's since '06
 
davidcroft's Avatar
 
Drives: 2014 SS sedan
Join Date: Apr 2008
Location: Houston, TX
Posts: 1,306
These are the problems we worry about on the forum? Not that we're broken down on the side of the road, not that our trans is slipping, not that we have window motor issues, A/C issues, Electrical issues (which Chevrolet doesn't have huge problems with in the Camaro at all) We are worried about a boar's hair gap in one side vs the other? I have seen this exact same thing on my 2 5th gens and tried pushing the bezel back farther....it wouldn't sit flush so I chalked it up as normal. It doesn't rattle or squeak and my car runs fine....so this is a NON issue.

end rant.


flamesuit on.
__________________
2014 SS Sedan-showroom stock
SOLD! 2013 Blue Ray1SS/1LE 1of20.
TRADED! 2012 White 1SS/RS
davidcroft is offline   Reply With Quote
Old 05-14-2014, 08:13 AM   #35
Hannibal
 
Hannibal's Avatar
 
Drives: Camaro SS & ZL1
Join Date: Sep 2011
Location: Southeast USA
Posts: 526
Mine looks this way on the SS. I never gave it much thought. Most of the GM cars I've had over the last 50 years have had fit and finish issues. You can thank over restoring cars today for those imperfections vanishing.

If it's not making noise, I would apply the golden rule. If it's not broken, don't fix it.
Hannibal is offline   Reply With Quote
Old 05-15-2014, 03:31 PM   #36
RunRS9114
 
RunRS9114's Avatar
 
Drives: 2014 Camaro 2LT/RS BRM
Join Date: Dec 2013
Location: Ottawa, IL
Posts: 20
I have the exact same issue on my 2014. I noticed it the other week while detailing my interior. It looks like the tab isn't in the right place, but it won't snap back in or anything. I thought about having it looked at, but after reading this thread I may just attempt to forget about it for now.

Glad I'm not the only one with this issue, I suppose.
__________________
Robbie

"Would you not like to be, sitting on top of the world with your legs hanging free?"
RunRS9114 is offline   Reply With Quote
Old 05-16-2014, 05:58 PM   #37
IcedBee
 
Drives: 2013 Europe Summit White
Join Date: Apr 2014
Location: Switzerland
Posts: 6
I have the same issue (two weeks old car).

I removed the bezel and know now what's the reason.
The retainer which is part of the dash on the left side is smaller and more flexible as the one on the right side. due to that, the bezel is pulling it outside as the whole bezel is quite under pressure when installed. When I only pusch the upper left clips in, the gap is perfect. It just popps out when i push in the lower clip on the left side directly under the left gauge.

This also explains why all the issue are on the left side, nobody has it on the right side so far.

So what we could do is to somehow reinforce this retainer with some material.. but the question is what material? Maybe some hot glue?

I tried to illustrate it. the red part is the part which is "missing" on the left side and would need to be bult somehow to reinforce the retainer.
IcedBee is offline   Reply With Quote
Old 05-17-2014, 07:11 PM   #38
07-SRT
 
07-SRT's Avatar
 
Drives: 2014 Camaro SS-2007 Charger SRT8
Join Date: Sep 2011
Location: Jacksonville, Fl
Posts: 316
Same issue here with 400 miles on it...
__________________
2014 Camaro SS M6
2007 Charger SRT8
2013 Mustang 5.0 M6- SOLD
2007 Super Bee #0667-SOLD
07-SRT is online now   Reply With Quote
Old 05-19-2014, 03:12 PM   #39
BUTT72
 
BUTT72's Avatar
 
Drives: 2013 1LT/RS/Auto/ IOM
Join Date: Feb 2014
Location: Las Vegas
Posts: 28
Have same issue, dealer couldn't fix it. The driver's side of my dash is even off. The passenger side is flush to the door, but on d/s the dash sticks out. Dealer didn't even want to try & fix it because the dash had to be removed.
BUTT72 is offline   Reply With Quote
Old 05-22-2014, 07:17 PM   #40
suzook
 
Drives: camaro
Join Date: May 2013
Location: Stony Brook,NY
Posts: 562
I have it....doesnt bother me enough to have my dash replaced.
__________________
2013 2SS A6 Dusk Edition 1 of 307!
suzook is offline   Reply With Quote
Old 06-15-2014, 01:39 PM   #41
Darwood
 
Drives: 2014 2SS 1LE
Join Date: Mar 2014
Location: Tejas
Posts: 185
Quote:
Originally Posted by IcedBee View Post
I have the same issue (two weeks old car).

I removed the bezel and know now what's the reason.
The retainer which is part of the dash on the left side is smaller and more flexible as the one on the right side. due to that, the bezel is pulling it outside as the whole bezel is quite under pressure when installed. When I only pusch the upper left clips in, the gap is perfect. It just popps out when i push in the lower clip on the left side directly under the left gauge.

This also explains why all the issue are on the left side, nobody has it on the right side so far.

So what we could do is to somehow reinforce this retainer with some material.. but the question is what material? Maybe some hot glue?

I tried to illustrate it. the red part is the part which is "missing" on the left side and would need to be bult somehow to reinforce the retainer.
Could try a plastic welder. I repaired the door panel in my STi with one when the arm rest caved in. The 1LE the dealer won't let me have due to the recall has the gap as well.
Darwood is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.