Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
RDP Motorsport
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics > Engine | Exhaust | Bolt-On | Drivetrain Modifications

Reply
 
Thread Tools
Old 08-07-2014, 08:15 AM   #1
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Exclamation car is throwing multiple codes after exhaust and header instal

I had the local exhaust shop instal my stainless works headers, an x pipe, flowmaster super 44, and custom quad tips.

The car sounds great and I can feel a power difference even without a tune. The problem: my car keep throwing multiple codes. The CEL light is constant (which I expected). I will be driving and there wont be any codes on, and then BAM! Service transmission, service anti theft system, service power steering the ABS light comes on. It also won't let me cycle through the different driving modes (wet mode through race mode). And sometimes it takes the car multiple ignition turns before it turns on. Then the codes will clear sometimes for a short while and then they will come back.

I posted about this a couple days ago without much luck. Has anyone seen this or had it happen to them?

Will disconnecting and reconnecting the battery do anything?

I get the tune next week after I upgrade the super charger pulleys, t stat, belt, and put in id850s. Should most of these codes get cleared with the tune?

Thanks in advance.
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-07-2014, 08:23 AM   #2
jon6.0
Going for Plaid
 
jon6.0's Avatar
 
Drives: 2011 C6
Join Date: Jan 2010
Location: Phoenix
Posts: 633
Did you check to see if there are wires that got burned laying on the headers yet? You should only have a cat efficiency code. Something that shop did messed your car up. Take it back and figure it out. I wouldn't even be driving it.
__________________
2014 ZL1, manual trans, carbon hood insert, Rotofab, 1" BMR springs, JBA mid-pipes.

Serviced and modded by Cordes Performance.

2011 C6, 750rwhp, forged LS3, ported LSA heads, Vortech Ti-trim, 227/243 115+4 Lunati cam, ported LS3 intake, Alky Control methanol, Pfadt sways/shocks/trans mounts, Pfadt tri-y headers(Sold 6/28/14)
jon6.0 is offline   Reply With Quote
Old 08-07-2014, 08:48 AM   #3
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Yeah Jon I looked to see if anything was melted and the wires are fine. I have driven it twice just to see if the codes cleared and they haven't. I called the exhaust shop and they said I can bring it back. I guess when I get the tune, if it's still throwing the codes I'll take it back. I'm just trying to figure out what could cause the codes to begin with.
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-07-2014, 08:57 AM   #4
bwk1971
 
bwk1971's Avatar
 
Drives: 2013 Camaro 2SS/RS Supercharged
Join Date: Sep 2012
Location: Southern Maryland
Posts: 504
Just a thought, did you check the plugs for cracks? When I installed my headers I didn't remove the spark plugs first (I thought I was skilled enough to skip that step). When I started the car I had an entire dashboard full of lights. It turns out that I had small hairline cracks in 2 or 3 plugs. I swapped them out and the car was fine.
__________________
"STREET LEGAL" 2013 Camaro 2SS/RS LS3 Convertible -- 2.9l Whipple Supercharger, CDC SportBar, Cordon CR-1 wheels, Hex Vents, RPI ZL1 Splitter, CAI, Pfadt Tri-Y Headers, high-flow cats, ZR1 3 bar map sensor, ZL1 fuel pump, 3.875" pulley, ADM FPCM, 1LE PCV Oil Separator Kit, Elite Catch Can, APEX scoop and washer bottle relocation kit, Hotchkis lowering springs, BMR sways, BMR toe rods, BMR trailing arms, 620 rwhp, 564 rwtq, and tuned by Andrew Zurick of Complete Street Performance by way of Maryland Speed.
bwk1971 is offline   Reply With Quote
Old 08-07-2014, 10:30 AM   #5
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
That's a good thought. I had a shop do the instal so I wouldn't mess it up. I see where that got me. I spoke with dan maslic and he said it may be a common denominator.
The suspension and power steering that keeps going off. He said it may be a suspension position sensor or possible fuse...
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-07-2014, 10:51 AM   #6
ZL1-V

 
ZL1-V's Avatar
 
Drives: 2013 Camaro ZL1
Join Date: Dec 2012
Location: Southern California
Posts: 1,475
Sounds as if he's guessing? I'm with Jon on this one. The car has to physically be there. Why not take it back now and clear that problem up? That is if you trust them to do any more work on your car. It may save time and money when you do your "tune" and your parts addition as that will be one less problem to sort through first to correct? Considering the headache, I bet it sounds like a real muscle car now?
ZL1-V is offline   Reply With Quote
Old 08-07-2014, 11:46 AM   #7
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Lmao it does sound awesome. And u plan on taking it back to the shop today to fix the problem. Hopefully it's something minor.
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-07-2014, 12:18 PM   #8
jon6.0
Going for Plaid
 
jon6.0's Avatar
 
Drives: 2011 C6
Join Date: Jan 2010
Location: Phoenix
Posts: 633
Check the little positioner deals for the mag ride and the wires going to them. Get it on a lift and look around every area they had to work around.
__________________
2014 ZL1, manual trans, carbon hood insert, Rotofab, 1" BMR springs, JBA mid-pipes.

Serviced and modded by Cordes Performance.

2011 C6, 750rwhp, forged LS3, ported LSA heads, Vortech Ti-trim, 227/243 115+4 Lunati cam, ported LS3 intake, Alky Control methanol, Pfadt sways/shocks/trans mounts, Pfadt tri-y headers(Sold 6/28/14)
jon6.0 is offline   Reply With Quote
Old 08-07-2014, 01:55 PM   #9
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Thanks Guys. I'm taking it to the shop now. Let's see what happens
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-07-2014, 01:56 PM   #10
jon6.0
Going for Plaid
 
jon6.0's Avatar
 
Drives: 2011 C6
Join Date: Jan 2010
Location: Phoenix
Posts: 633
If they disconnected your steering for the header install you may need to reset the steering wheel to zero using a Tech 2. I had that happen on my C6.
__________________
2014 ZL1, manual trans, carbon hood insert, Rotofab, 1" BMR springs, JBA mid-pipes.

Serviced and modded by Cordes Performance.

2011 C6, 750rwhp, forged LS3, ported LSA heads, Vortech Ti-trim, 227/243 115+4 Lunati cam, ported LS3 intake, Alky Control methanol, Pfadt sways/shocks/trans mounts, Pfadt tri-y headers(Sold 6/28/14)
jon6.0 is offline   Reply With Quote
Old 08-07-2014, 02:52 PM   #11
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Ok they did say they had to remove soark plugs. Can I disconnect the battery to remove the codes?
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-07-2014, 03:59 PM   #12
SSSylentZL1
Aggressive ZL1 Driver
 
SSSylentZL1's Avatar
 
Drives: 2012 AGM ZL1
Join Date: Oct 2011
Location: TN
Posts: 1,222
How does the Stainless works sound? You like them?
__________________
2012 ZL1 #984
Current Mods: Roto-Fab Cold Air Intake, 20%tint all around, 35% windshield, Tinted side markers, Dipped Taillight bezels,emblems, Red interior light

----------------------------------------------------
Future mods:
ARH, Kooks, or SW Headers w/o cats, 3" connection pipes, VMAXX Ported TB, Apex Catch Can
Technostaglia Taillights, Night Owl/ Oracle Halo headlights, Fog light Halos
SSSylentZL1 is offline   Reply With Quote
Old 08-07-2014, 08:44 PM   #13
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
The headers sound awesome (I got exhaust work done too) and I def fel a power increase.

https://www.facebook.com/photo.php?v...22881828159711 is the idling video

So aside from the hud showing me all these weird issues, we hooked the car up to a CPU and I got an error code of U0109 "Lost communication with fuel pump control module"...???
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-07-2014, 10:59 PM   #14
ZO6 Bryan
 
ZO6 Bryan's Avatar
 
Drives: 02 Z06, 95 Trans Am, 2012 ZL1
Join Date: Mar 2012
Location: Southeast
Posts: 642
They screwed up somewhere. Disconnecting the battery won't help. And a tune won't help. As a matter of fact, you won't be able to tune until you fix it. With multiple systems triggering codes my bet is on a ground wire wasn't tightened up. A loose ground wire on these newer cars will cause all kind of crazy shit.
__________________
Bryan 2012 ZL1 9.55 pulley and Kooks headers, 2002 Z06 447 RWHP, 2006 Trailblazer SS, 1995 S/C Vortech Trans Am 570 RWHP(for sale)
ZO6 Bryan is offline   Reply With Quote
Old 08-08-2014, 06:05 AM   #15
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
I dropped it off at a shop last night. Hopefully they can have it fixed today
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-08-2014, 08:42 AM   #16
bwk1971
 
bwk1971's Avatar
 
Drives: 2013 Camaro 2SS/RS Supercharged
Join Date: Sep 2012
Location: Southern Maryland
Posts: 504
Quote:
Originally Posted by Rhaar001 View Post
The headers sound awesome (I got exhaust work done too) and I def fel a power increase.

https://www.facebook.com/photo.php?v...22881828159711 is the idling video

So aside from the hud showing me all these weird issues, we hooked the car up to a CPU and I got an error code of U0109 "Lost communication with fuel pump control module"...???
I had this code once, while hooking up my NightOwl LED system. It was a blown fuse. Hopefully it is as simple as that. Good luck.
__________________
"STREET LEGAL" 2013 Camaro 2SS/RS LS3 Convertible -- 2.9l Whipple Supercharger, CDC SportBar, Cordon CR-1 wheels, Hex Vents, RPI ZL1 Splitter, CAI, Pfadt Tri-Y Headers, high-flow cats, ZR1 3 bar map sensor, ZL1 fuel pump, 3.875" pulley, ADM FPCM, 1LE PCV Oil Separator Kit, Elite Catch Can, APEX scoop and washer bottle relocation kit, Hotchkis lowering springs, BMR sways, BMR toe rods, BMR trailing arms, 620 rwhp, 564 rwtq, and tuned by Andrew Zurick of Complete Street Performance by way of Maryland Speed.
bwk1971 is offline   Reply With Quote
Old 08-08-2014, 09:31 AM   #17
jon6.0
Going for Plaid
 
jon6.0's Avatar
 
Drives: 2011 C6
Join Date: Jan 2010
Location: Phoenix
Posts: 633
Other than the fuses under the hood and in the trunk are there any other fuses?
__________________
2014 ZL1, manual trans, carbon hood insert, Rotofab, 1" BMR springs, JBA mid-pipes.

Serviced and modded by Cordes Performance.

2011 C6, 750rwhp, forged LS3, ported LSA heads, Vortech Ti-trim, 227/243 115+4 Lunati cam, ported LS3 intake, Alky Control methanol, Pfadt sways/shocks/trans mounts, Pfadt tri-y headers(Sold 6/28/14)
jon6.0 is offline   Reply With Quote
Old 08-08-2014, 10:10 AM   #18
SSteven
 
SSteven's Avatar
 
Drives: 2012 2SS/RS - L99
Join Date: Aug 2013
Location: Dallas
Posts: 196
In dash on driver's side. Accessible when you open the driver's side door
__________________
2012 2SS - Auto/RS/Black/Sunroof/MyLink Nav/SW Retro Catback/SP 1 7/8" LT Headers w/HF Cats/Range V8 AFM/C.A.I. CAI/Vmax Spiral Ported Throttle Body/APEX Catch Can/275x4 Squared Wheel Setup/Custom Fit Full Size Spare/Ceramic Tint
SSteven is offline   Reply With Quote
Old 08-08-2014, 07:18 PM   #19
jon6.0
Going for Plaid
 
jon6.0's Avatar
 
Drives: 2011 C6
Join Date: Jan 2010
Location: Phoenix
Posts: 633
Quote:
Originally Posted by SSteven View Post
In dash on driver's side. Accessible when you open the driver's side door
Thanks!
__________________
2014 ZL1, manual trans, carbon hood insert, Rotofab, 1" BMR springs, JBA mid-pipes.

Serviced and modded by Cordes Performance.

2011 C6, 750rwhp, forged LS3, ported LSA heads, Vortech Ti-trim, 227/243 115+4 Lunati cam, ported LS3 intake, Alky Control methanol, Pfadt sways/shocks/trans mounts, Pfadt tri-y headers(Sold 6/28/14)
jon6.0 is offline   Reply With Quote
Old 08-08-2014, 07:52 PM   #20
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Quote:
Originally Posted by bwk1971 View Post
I had this code once, while hooking up my NightOwl LED system. It was a blown fuse. Hopefully it is as simple as that. Good luck.
Thanks. When you had that code was your HUD saying a bunch of crazy stuff like service suspension and stabilitrak?
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-11-2014, 10:11 AM   #21
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Whatever these are, they just fell out when I dropped the lower cover to see the exhaust
Attached Images
 
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-11-2014, 10:25 AM   #22
SSteven
 
SSteven's Avatar
 
Drives: 2012 2SS/RS - L99
Join Date: Aug 2013
Location: Dallas
Posts: 196
Are you talking about the tunnel brace? If so, maybe they are using those as spacers to keep the pipes from contacting the brace.
__________________
2012 2SS - Auto/RS/Black/Sunroof/MyLink Nav/SW Retro Catback/SP 1 7/8" LT Headers w/HF Cats/Range V8 AFM/C.A.I. CAI/Vmax Spiral Ported Throttle Body/APEX Catch Can/275x4 Squared Wheel Setup/Custom Fit Full Size Spare/Ceramic Tint
SSteven is offline   Reply With Quote
Old 08-11-2014, 10:40 AM   #23
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Quote:
Originally Posted by SSteven View Post
Are you talking about the tunnel brace? If so, maybe they are using those as spacers to keep the pipes from contacting the brace.
That could possibly be it. Seems legitimate.

UPDATE: The ground wire was loose therefore causing all those damn codes. Seems to be fixed. Time to change out the supercharger pulleys, t stat, belt, and put in ID850s...Tune later this week!!!
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
Old 08-11-2014, 10:48 AM   #24
bwk1971
 
bwk1971's Avatar
 
Drives: 2013 Camaro 2SS/RS Supercharged
Join Date: Sep 2012
Location: Southern Maryland
Posts: 504
Quote:
Originally Posted by Rhaar001 View Post
Thanks. When you had that code was your HUD saying a bunch of crazy stuff like service suspension and stabilitrak?
Yes. I thought I had destroyed the car, but it was simply a couple of spark plugs.
__________________
"STREET LEGAL" 2013 Camaro 2SS/RS LS3 Convertible -- 2.9l Whipple Supercharger, CDC SportBar, Cordon CR-1 wheels, Hex Vents, RPI ZL1 Splitter, CAI, Pfadt Tri-Y Headers, high-flow cats, ZR1 3 bar map sensor, ZL1 fuel pump, 3.875" pulley, ADM FPCM, 1LE PCV Oil Separator Kit, Elite Catch Can, APEX scoop and washer bottle relocation kit, Hotchkis lowering springs, BMR sways, BMR toe rods, BMR trailing arms, 620 rwhp, 564 rwtq, and tuned by Andrew Zurick of Complete Street Performance by way of Maryland Speed.
bwk1971 is offline   Reply With Quote
Old 08-11-2014, 04:21 PM   #25
Rhaar001
 
Rhaar001's Avatar
 
Drives: 2013 camaro zl1
Join Date: Jun 2014
Location: Miami
Posts: 60
Quote:
Originally Posted by bwk1971 View Post
Yes. I thought I had destroyed the car, but it was simply a couple of spark plugs.
Yeah after doing research, it seems like if the car is goin haywire then it should be a simple fix. Mine thankfully was a loose ground wire.
__________________
2013 Camaro ZL1 Blue Ray Metallic with Rotofab CAI, Stainless Works Long tube headers, custom flowmaster super 44 exhaust with x pipe and custom
quad tips
[/FONT] [FONT="Arial Black"]
Rhaar001 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.