Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD @ James Martin Chevy
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics


Reply
 
Thread Tools
Old 05-01-2013, 07:29 PM   #1
charlietuna

 
charlietuna's Avatar
 
Drives: 2013 ZL1
Join Date: Jul 2012
Location: Chicago, IL
Posts: 1,342
yet another Catch Can Question-pics

Searched and couldn't find install info for the "dual valve" ZL1 rev extreme can.

I checked their site, called them, you guys are my only hope.

what hose goes where? I have 3 one does not have a check valve where does it go?

Attached Images
  
__________________
Laus Deo
charlietuna is offline   Reply With Quote
Old 05-01-2013, 09:14 PM   #2
Silverguardrail

 
Silverguardrail's Avatar
 
Drives: 2012 ZL1 #1448
Join Date: May 2009
Location: WNY
Posts: 892
Check this out http://www.camaro5.com/forums/showpo...94&postcount=7, hope it helps
__________________
2012 ZL1 SIM, MN6, B92, RTQ


ZL1 - the true definition of joy ride
Silverguardrail is offline   Reply With Quote
Old 05-01-2013, 09:21 PM   #3
Al C.
 
Al C.'s Avatar
 
Drives: ZL1 #529 "El-Jefe"
Join Date: Mar 2012
Location: Las Vegas, NV
Posts: 672
I think he's talking bout the check valves on the hoses.. Link above doesn't show the hoses the op is using.. I have a guess on were they go but doubt you want to guess and want a correct answer.
Al C. is offline   Reply With Quote
Old 05-01-2013, 09:35 PM   #4
13 ZL1
 
13 ZL1's Avatar
 
Drives: 2013 IOM ZL1
Join Date: Nov 2009
Location: Manteca CA
Posts: 658
Go here

http://www.revxtreme.com/instructions/cc_zl1.pdf
13 ZL1 is offline   Reply With Quote
Old 05-01-2013, 11:29 PM   #5
charlietuna

 
charlietuna's Avatar
 
Drives: 2013 ZL1
Join Date: Jul 2012
Location: Chicago, IL
Posts: 1,342
I think I have it installed correctly. My only question and I have read all the install info on revextrem's site, is where the hoses connect to the can. One of my outside fittings goes to the cai the other to the intake manifold I think I have it right I just don't feel 100%

I left a MSG at revextrem and I hope they call me back tomorrow early.

Thanks for the help and support as always.
__________________
Laus Deo
charlietuna is offline   Reply With Quote
Old 05-01-2013, 11:38 PM   #6
Skylane765

 
Skylane765's Avatar
 
Drives: ZL1-1LE, Z/28
Join Date: May 2012
Location: San Diego
Posts: 3,250
You only need a in and out on the CC for a ZL1, the other line is not needed.

Putting the 3rd line to the bottom elbow will only let oil bypass to be going in front of the TB. Better not to let any air oiled go in front of the TB.

You just need one line that goes to the Valley pan, that is dirty air oil and it goes to CC then out to the blower snout PCV valve.

There is a clean air make up that goes from bottom of elbow to both valve covers and that is to let clean air IN to the engine, that is all you need. 3rd line is for set ups that add a blower, the ZL1 comes OEM with the blower.
Skylane765 is offline   Reply With Quote
Old 05-01-2013, 11:51 PM   #7
charlietuna

 
charlietuna's Avatar
 
Drives: 2013 ZL1
Join Date: Jul 2012
Location: Chicago, IL
Posts: 1,342
Quote:
Originally Posted by Skylane765 View Post
You only need a in and out on the CC for a ZL1, the other line is not needed.

Putting the 3rd line to the bottom elbow will only let oil bypass to be going in front of the TB. Better not to let any air oiled go in front of the TB.

You just need one line that goes to the Valley pan, that is dirty air oil and it goes to CC then out to the blower snout PCV valve.

There is a clean air make up that goes from bottom of elbow to both valve covers and that is to let clean air IN to the engine, that is all you need. 3rd line is for set ups that add a blower, the ZL1 comes OEM with the blower.


Ok now I'm confused. When I called revex they were informed about my year make and model. How can I have this wrong. I am installing the no tune cai in a week after a base dyno pull and intend on joining the cai with the catch can. The folks at rx were apprised of my intentions prior to purchase.
__________________
Laus Deo
charlietuna is offline   Reply With Quote
Old 05-02-2013, 12:02 AM   #8
Skylane765

 
Skylane765's Avatar
 
Drives: ZL1-1LE, Z/28
Join Date: May 2012
Location: San Diego
Posts: 3,250
Quote:
Originally Posted by charlietuna View Post
Ok now I'm confused. When I called revex they were informed about my year make and model. How can I have this wrong. I am installing the no tune cai in a week after a base dyno pull and intend on joining the cai with the catch can. The folks at rx were apprised of my intentions prior to purchase.
The 3rd line is not need on a ZL1, you only have a In and out to a CC. Even with CAI you only need a in and out, that is what you have on the car. The line to the CAI is to the engine for clean air to get in. Just block the 3rd line on CC.

I have a smog lic and the ZL1 with Roto fab CAI. I installed a CC with only two lines.

For what reason do you want air oil in front of the TB. You do not need the CAI connected to the CC only to the valve covers.
Skylane765 is offline   Reply With Quote
Old 05-02-2013, 12:09 AM   #9
Skylane765

 
Skylane765's Avatar
 
Drives: ZL1-1LE, Z/28
Join Date: May 2012
Location: San Diego
Posts: 3,250
Do you know how the PCV system works on the ZL1? What are the check valves for? The car does not have them with or with out a CAI. I have the service manual to the ZL1 and the PCV system is simple when it is connected to the blower snout, because it is under vacuum even with boost, so no 3rd line needed.

If you have a SC added to a engine, then in some cases the 3rd line is need under boost, that is not the case with our ZL1.
Skylane765 is offline   Reply With Quote
Old 05-02-2013, 07:27 AM   #10
jbotta

 
jbotta's Avatar
 
Drives: Camaro ZL1
Join Date: Jan 2012
Location: Dyer, IN
Posts: 1,131
Quote:
Originally Posted by Skylane765 View Post
Do you know how the PCV system works on the ZL1? What are the check valves for? The car does not have them with or with out a CAI. I have the service manual to the ZL1 and the PCV system is simple when it is connected to the blower snout, because it is under vacuum even with boost, so no 3rd line needed.

If you have a SC added to a engine, then in some cases the 3rd line is need under boost, that is not the case with our ZL1.
Thays good to know im about to order mine.
jbotta is offline   Reply With Quote
Old 05-02-2013, 07:34 AM   #11
Stephen12ZL1


 
Stephen12ZL1's Avatar
 
Drives: '17 ZL1 A10
Join Date: May 2012
Location: Mechanicsville VA
Posts: 4,951
read the first paragraph of the install page....disregard all of the other trash talk on this thread. With the ZL1 we use the dual valve can system with the center fitting on the can connecting to the valley cover vent tube and one outer valve to the vacuum barb that did run to the valley cover tube, and the other outer valve to the main air intake tube.
__________________
'17 ZL1 A10 Mosaic Black PDR/Nav 2:08.35 VIR Full
'15 Z/28 #325 black a/c & stereo. 2:10.1 VIR Full 1:44.74 Summit Point Shenandoah Circuit (sold)
'12 ZL1 10.52@131 1.55 60' 2:13 VIR Full (sold)
Stephen12ZL1 is online now   Reply With Quote
Old 05-02-2013, 07:35 AM   #12
Jeff65SS
 
Jeff65SS's Avatar
 
Drives: 1965 Chevelle Malibu SS
Join Date: Sep 2012
Location: Georgia
Posts: 179
Revextreme recommends the 3 hose model over the 2.
Jeff65SS is offline   Reply With Quote
Old 05-02-2013, 07:51 AM   #13
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,426
Quote:
Originally Posted by Skylane765 View Post
You only need a in and out on the CC for a ZL1, the other line is not needed.

Putting the 3rd line to the bottom elbow will only let oil bypass to be going in front of the TB. Better not to let any air oiled go in front of the TB.

You just need one line that goes to the Valley pan, that is dirty air oil and it goes to CC then out to the blower snout PCV valve.

There is a clean air make up that goes from bottom of elbow to both valve covers and that is to let clean air IN to the engine, that is all you need. 3rd line is for set ups that add a blower, the ZL1 comes OEM with the blower.
i have the 3 hose catch can, one of the first ones in fact. the can is very efficient and after 7 months i have had no oil suck back through the throttle body. of course i broke my car in like john force would and i get less oil going into my can than the people who are following the g.m break in period to a t. tracey at rev ex even commented how well my rings seated compared to some other Z owners who babied through the break in. i empty my can every other oil change and get maybe an ounce or 2 of oil out of it at that frequency. even rotofab now includes a tee for the people using the 3 hose can. i got to see first hand how clean the plenum was as i had a bad blower snout at 8k miles and dealer took off and replaced the whole supercharger. at that point even the tech said he never saw one so clean inside ever.
joes407 is offline   Reply With Quote
Old 05-02-2013, 07:58 AM   #14
jbotta

 
jbotta's Avatar
 
Drives: Camaro ZL1
Join Date: Jan 2012
Location: Dyer, IN
Posts: 1,131
Quote:
Originally Posted by joes407 View Post
i have the 3 hose catch can, one of the first ones in fact. the can is very efficient and after 7 months i have had no oil suck back through the throttle body. of course i broke my car in like john force would and i get less oil going into my can than the people who are following the g.m break in period to a t. tracey at rev ex even commented how well my rings seated compared to some other Z owners who babied through the break in. i empty my can every other oil change and get maybe an ounce or 2 of oil out of it at that frequency. even rotofab now includes a tee for the people using the 3 hose can. i got to see first hand how clean the plenum was as i had a bad blower snout at 8k miles and dealer took off and replaced the whole supercharger. at that point even the tech said he never saw one so clean inside ever.
Ok, I have the tee from rotofab, so dual can cant hurt. Do you have pics, did you mount it at thr radiator, sorry my typing sucks
jbotta is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:45 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.