Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-26-2009, 03:31 PM   #1
buddylok
 
buddylok's Avatar
 
Drives: 2010 Camaro 1LT (IOM)
Join Date: Jun 2009
Location: Coquitlam, BC Canada
Posts: 455
Send a message via AIM to buddylok Send a message via Skype™ to buddylok
Clutch pedal squeaky noise

Anyone notice squeaky noise when releasing the clutch pedal?
buddylok is offline   Reply With Quote
Old 06-26-2009, 03:34 PM   #2
CamaroHutch
 
CamaroHutch's Avatar
 
Drives: 2010 Camaro 2SS RJT
Join Date: Feb 2009
Location: Southern Indiana (Louisville Area)
Posts: 357
No, but at low speeds, when I push the clutch while in 1st or second, it does make a loud THUD...
__________________
Ordered Jan 09

2SS RS RJT

Delivery?? 5/27/09 #10630

AFTERMARKET:
Hurst STS
Borla ATAK Catback
CamaroHutch is offline   Reply With Quote
Old 01-29-2010, 05:48 PM   #3
CamaroHutch
 
CamaroHutch's Avatar
 
Drives: 2010 Camaro 2SS RJT
Join Date: Feb 2009
Location: Southern Indiana (Louisville Area)
Posts: 357
Now whenever it is cold, my clutch pedal squeaks something fierce. It is extremely annoying... Need to take it to the dealer for the heater coil tsb, and some other things.... Anyone else notice this with the cold weather?
__________________
Ordered Jan 09

2SS RS RJT

Delivery?? 5/27/09 #10630

AFTERMARKET:
Hurst STS
Borla ATAK Catback
CamaroHutch is offline   Reply With Quote
Old 01-29-2010, 05:56 PM   #4
MrGazinya

 
MrGazinya's Avatar
 
Drives: Aggressive
Join Date: Jul 2008
Location: Southampton, PA.
Posts: 1,067
I just heard mine do it the first time today, Gotta be the cold... It went away after the car warmed up.. It's like 20*F here
__________________
Black 2SS RS LS3 Inferno Int. Powdercoated 20's {MODS} KOOKS LT: Borla S-Type: Roto-Fab CAI: Hurst ST.: Diabloed by Jannetty Racing: PFADT Stage 2, Trailing arms, Tie Rods:

MrGazinya is offline   Reply With Quote
Old 01-29-2010, 06:30 PM   #5
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,101
got the answer for ya! this is for the intermittent squeak sound when pressing/releasing the clutch pedal.

http://www.camaro5.com/forums/showth...t=pedal+spring

see the two white bushings? Check them, I bet at least 1 of them came off the hole.


ffrcobra_65 is offline   Reply With Quote
Old 01-30-2010, 10:58 AM   #6
CamaroHutch
 
CamaroHutch's Avatar
 
Drives: 2010 Camaro 2SS RJT
Join Date: Feb 2009
Location: Southern Indiana (Louisville Area)
Posts: 357
Quote:
Originally Posted by ffrcobra_65 View Post
got the answer for ya! this is for the intermittent squeak sound when pressing/releasing the clutch pedal.

http://www.camaro5.com/forums/showth...t=pedal+spring

see the two white bushings? Check them, I bet at least 1 of them came off the hole.




Cool thanks for this... I'll take a look at it next chance I get!
__________________
Ordered Jan 09

2SS RS RJT

Delivery?? 5/27/09 #10630

AFTERMARKET:
Hurst STS
Borla ATAK Catback
CamaroHutch is offline   Reply With Quote
Old 01-03-2012, 06:30 PM   #7
bmorecam
Account Suspended
 
Drives: jealous vendors mad!! HAHA!!
Join Date: Jan 2011
Location: CYBERGMONSTER@GMAIL.COM
Posts: 3,660
I know this is old but I been having issues with my clutch squeaking for at least 2 months.. it comes and go but since the temp drop it's been doing alot more so while searching I found this thread. Well... problem solved!!
bmorecam is offline   Reply With Quote
Old 01-03-2012, 06:34 PM   #8
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,101
Quote:
Originally Posted by bmorecam View Post
I know this is old but I been having issues with my clutch squeaking for at least 2 months.. it comes and go but since the temp drop it's been doing alot more so while searching I found this thread. Well... problem solved!!
ffrcobra_65 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Best way to learn how to drive a stick? Beitzel15 Off-topic Discussions 21 06-24-2009 12:31 PM
New to the Stick...Advice? NightmareSS 5th Gen Camaro SS LS LT General Discussions 101 06-19-2009 10:24 AM
Clutch Noise? GLBL WMR V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 5 05-24-2009 01:04 AM
Burned my clutch a bit with Launch Control.... Caution you guys... Embalmer 5th Gen Camaro SS LS LT General Discussions 49 04-23-2009 09:49 PM
Review gripe prediction: light clutch UCF w00t Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 17 01-25-2009 02:03 AM


All times are GMT -5. The time now is 07:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.