Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
PFYC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 05-20-2013, 07:00 PM   #1
CamaroDreams07


 
CamaroDreams07's Avatar
 
Drives: Slow V6
Join Date: Jun 2009
Location: East Lansing, MI
Posts: 9,273
Suggestions on suspension noise

I'm not a mechanically-gifted person, so I'll try my best to describe what's happening and hopefully somebody can give me some ideas on something to look for.

First off, the car has Eibach drop springs and sway bars, all other suspension is stock.

What I'm noticing is a weird feeling and noise at low speeds when turning. It seems to me that it's coming from the area of the driver's side front wheel. It's most noticeable when the car is on unlevel ground, such as pulling into or out of a driveway. It's not the brakes because it happens regardless of whether they are depressed or not.

It's not grinding, and it's not like a "clunk" but it's just...something? and I can feel it through the steering wheel slightly. The car doesn't look to be riding any lower on that side or any lower than before, and I haven't hit anything or any major potholes. I'm just not really sure where to begin.

I don't want to take it to the dealer because I know they'll say it's modified suspension and charge me who knows how much. I'm wondering if anybody can give me an idea of something I can visually inspect

Thanks in advance suspension gurus
__________________
[B]
CamaroDreams07 is offline   Reply With Quote
Old 05-20-2013, 07:08 PM   #2
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,675
Have you measured the ride height?
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 05-20-2013, 07:11 PM   #3
CamaroDreams07


 
CamaroDreams07's Avatar
 
Drives: Slow V6
Join Date: Jun 2009
Location: East Lansing, MI
Posts: 9,273
Quote:
Originally Posted by The Stig View Post
Have you measured the ride height?
I havent measured it no. I think I still have my measurements from right after I installed the springs, so I can check it against that.

Sent from my Galaxy Nexus using Tapatalk 2
__________________
[B]
CamaroDreams07 is offline   Reply With Quote
Old 05-20-2013, 07:12 PM   #4
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,675
Wouldn't hurt. Could the spring been have installed incorrectly?
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 05-20-2013, 07:14 PM   #5
jeremywes
 
jeremywes's Avatar
 
Drives: 2012 Camaro SS
Join Date: Aug 2012
Location: Houston, TX
Posts: 506
I would nut and bolt everything. 99% of the time something has come loose.
jeremywes is offline   Reply With Quote
Old 05-20-2013, 07:20 PM   #6
CamaroDreams07


 
CamaroDreams07's Avatar
 
Drives: Slow V6
Join Date: Jun 2009
Location: East Lansing, MI
Posts: 9,273
Quote:
Originally Posted by The Stig View Post
Wouldn't hurt. Could the spring been have installed incorrectly?
It's possible, but it was three years ago and never given me problems until the last week or so.

Sent from my Galaxy Nexus using Tapatalk 2
__________________
[B]
CamaroDreams07 is offline   Reply With Quote
Old 05-20-2013, 07:21 PM   #7
CamaroDreams07


 
CamaroDreams07's Avatar
 
Drives: Slow V6
Join Date: Jun 2009
Location: East Lansing, MI
Posts: 9,273
Quote:
Originally Posted by jeremywes View Post
I would nut and bolt everything. 99% of the time something has come loose.
Will do. I'm gonna see if I can get in there and get a wrench on everything. Just a general lack of tools/workspace/knowledge.

Sent from my Galaxy Nexus using Tapatalk 2
__________________
[B]
CamaroDreams07 is offline   Reply With Quote
Old 05-20-2013, 07:24 PM   #8
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,675
Quote:
Originally Posted by CamaroDreams07 View Post
It's possible, but it was three years ago and never given me problems until the last week or so.

Sent from my Galaxy Nexus using Tapatalk 2
Ah ok. Then yea, previous poster is probably right about something coming loose.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 05-20-2013, 10:13 PM   #9
NC-V
 
NC-V's Avatar
 
Drives: cts-v
Join Date: Dec 2011
Location: Mooresville, NC
Posts: 508
Check sway bar end links
NC-V is offline   Reply With Quote
Old 05-21-2013, 12:49 AM   #10
SPCBA
Blake
 
SPCBA's Avatar
 
Drives: pleather and Chiclets
Join Date: Mar 2012
Location: a VA line somwhere
Posts: 3,724
have you replaced any bushings? check those for some lube...mine are creaky
__________________
SPCBA is offline   Reply With Quote
Old 05-21-2013, 01:49 AM   #11
jameslk55

 
jameslk55's Avatar
 
Drives: 2012 2LT/RS, 2005 SLK55 AMG
Join Date: Jul 2012
Location: Falls Church, VA
Posts: 1,168
Hmmm, when was the last time alignment was done? Just an idea.
jameslk55 is offline   Reply With Quote
Old 05-24-2013, 11:46 AM   #12
PfadtRacing
 
PfadtRacing's Avatar
 
Drives: 2010 Camaro, 2006 Z06
Join Date: Feb 2009
Location: SLC, UT
Posts: 3,375
Look for rubbing or wear on the tires?
PfadtRacing is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.