Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
HeadlightArmor
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)

V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) Driveshafts | Differentials | Gears | Rearends | Clutch | Shifters

Reply
 
Thread Tools
Old 05-15-2013, 11:42 PM   #1
Bonemaro

 
Bonemaro's Avatar
 
Drives: 2010 RJT 1SS M6
Join Date: Jul 2009
Location: Canton, Mi.
Posts: 1,695
Send a message via AIM to Bonemaro
Something had to give- hurst shifter

Took my '10 SS in for a trans leak now the next day the shifter (hurst billet plus 2 aftermarket) shakes from side to side and make a grinding noise somewhere down below it. It seems to come and go as I drive but doesn't sound safe to me. Any idea's what went wrong? Yes I am taking it back first thing in the morn.
Bonemaro is offline   Reply With Quote
Old 05-17-2013, 03:26 PM   #2
MikeOD

 
Drives: 2010 M6 2SS
Join Date: Mar 2011
Location: Manchester, CT
Posts: 1,170
If they had the transmission down/out of the car then they disconnected the shifter, and maybe they didn't re-connect it right.
__________________

2010 Camaro SS M6. Heads/Cam/Intake/Headers/Exhaust/Suspension
MikeOD is offline   Reply With Quote
Old 05-18-2013, 12:50 AM   #3
Bonemaro

 
Bonemaro's Avatar
 
Drives: 2010 RJT 1SS M6
Join Date: Jul 2009
Location: Canton, Mi.
Posts: 1,695
Send a message via AIM to Bonemaro
The lower boot was catching and making the noise. All fixed and a new one on the way.
Bonemaro is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.