Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 05-19-2013, 03:02 PM   #1
IC1Patton
 
IC1Patton's Avatar
 
Drives: 2017 Camaro 2SS
Join Date: Apr 2011
Location: chesapeake va
Posts: 74
OVERHEATING AFTER CAM INSTALL

I installed a new cam and and now its overheating. Am i missing a step that i dont know about. i changed the thermostat after it started overheating. i dont believe it to be the pump cause it worked just fine before. is there a way to prime the pump or test operation?
__________________
"It is foolish and wrong to mourn the men who died. Rather we should thank God that such men lived." - General George S. Patton
IC1Patton is offline   Reply With Quote
Old 05-19-2013, 03:03 PM   #2
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,275
Tune?
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 05-19-2013, 03:05 PM   #3
IC1Patton
 
IC1Patton's Avatar
 
Drives: 2017 Camaro 2SS
Join Date: Apr 2011
Location: chesapeake va
Posts: 74
i loaded a new tune from jre
__________________
"It is foolish and wrong to mourn the men who died. Rather we should thank God that such men lived." - General George S. Patton
IC1Patton is offline   Reply With Quote
Old 05-19-2013, 03:08 PM   #4
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,275
When you say changed the thermostat after overheating. Was that back to a stock 180?
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 05-19-2013, 03:11 PM   #5
IC1Patton
 
IC1Patton's Avatar
 
Drives: 2017 Camaro 2SS
Join Date: Apr 2011
Location: chesapeake va
Posts: 74
yep 180 from
napa
__________________
"It is foolish and wrong to mourn the men who died. Rather we should thank God that such men lived." - General George S. Patton
IC1Patton is offline   Reply With Quote
Old 05-19-2013, 03:12 PM   #6
Demon Z/28
Scarecrow
 
Demon Z/28's Avatar
 
Drives: like a granny
Join Date: Apr 2013
Location: Anahizzle, CA
Posts: 1,527
fans plugged in ? are they coming on ?
__________________
The Rooster - 2015 Z/28
The Scarecrow -2014 1LE SOLD -
Demon Z/28 is offline   Reply With Quote
Old 05-19-2013, 03:13 PM   #7
IC1Patton
 
IC1Patton's Avatar
 
Drives: 2017 Camaro 2SS
Join Date: Apr 2011
Location: chesapeake va
Posts: 74
yep fans are working
__________________
"It is foolish and wrong to mourn the men who died. Rather we should thank God that such men lived." - General George S. Patton
IC1Patton is offline   Reply With Quote
Old 05-19-2013, 03:14 PM   #8
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,275
What's your coolant temp at?
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 05-19-2013, 03:15 PM   #9
IC1Patton
 
IC1Patton's Avatar
 
Drives: 2017 Camaro 2SS
Join Date: Apr 2011
Location: chesapeake va
Posts: 74
it hit 230 and still climbing before i shut it down
__________________
"It is foolish and wrong to mourn the men who died. Rather we should thank God that such men lived." - General George S. Patton
IC1Patton is offline   Reply With Quote
Old 05-19-2013, 03:19 PM   #10
Deftones

 
Deftones's Avatar
 
Drives: 2012 RS/SS LS3
Join Date: Jun 2012
Location: Bakersfield, CA
Posts: 801
Try a oem tstat. After market tstats fail more often then not.
Deftones is offline   Reply With Quote
Old 05-19-2013, 03:30 PM   #11
Demon Z/28
Scarecrow
 
Demon Z/28's Avatar
 
Drives: like a granny
Join Date: Apr 2013
Location: Anahizzle, CA
Posts: 1,527
head gaskets for sure on correctly? they CAN go either way. may just have big air in the system still. to bleed the system i like to give it some revs, helps the flow change and in turn helps with the air. also sometimes it's better to have the cap on it, let it get above 200, then shut her down. squeeze the hose at the thermostat to radiator. which reminds me, is that hose getting hot ? compare your top hose tot he lower hose, feel the same ?
__________________
The Rooster - 2015 Z/28
The Scarecrow -2014 1LE SOLD -
Demon Z/28 is offline   Reply With Quote
Old 05-19-2013, 03:30 PM   #12
sycraft
COTW 5/06/2013
 
sycraft's Avatar
 
Drives: 2015 Corvette Stingray Z51-Ho-Vette
Join Date: May 2012
Location: Katy, Texas
Posts: 3,162
Is there a air pocket in the system, leave the cap off and run let the coolant flow, you should see it move, it may burp several times too.
__________________

2015 Corvette Stingray Z51, 7 Speed, Competition Seats, Red Calipers, Carbon Flash Badges and Trim, Adrenaline Red Interior, Custom Stripes, Tint, Lowered on stock bolts, Z06 Grill, Z06 Splitter, Borla Exhaust (soon)
sycraft is offline   Reply With Quote
Old 05-19-2013, 03:37 PM   #13
stikSS
9691 & 97586
 
stikSS's Avatar
 
Drives: '10 Camaro SS and 2LT
Join Date: Mar 2009
Location: Cameron, NC
Posts: 2,814
Quote:
Originally Posted by sycraft View Post
Is there a air pocket in the system, leave the cap off and run let the coolant flow, you should see it move, it may burp several times too.
This.... u have to let it run with the cap off and slowly add water and anti freeze till you get it full again.

Sent from my Apple sued Galaxy Note 2
stikSS is offline   Reply With Quote
Old 05-19-2013, 03:46 PM   #14
IC1Patton
 
IC1Patton's Avatar
 
Drives: 2017 Camaro 2SS
Join Date: Apr 2011
Location: chesapeake va
Posts: 74
Quote:
Originally Posted by CoolStoryBro View Post
head gaskets for sure on correctly? they CAN go either way. may just have big air in the system still. to bleed the system i like to give it some revs, helps the flow change and in turn helps with the air. also sometimes it's better to have the cap on it, let it get above 200, then shut her down. squeeze the hose at the thermostat to radiator. which reminds me, is that hose getting hot ? compare your top hose tot he lower hose, feel the same ?
i didnt remove the heads i will try that with the revs at 200* and see if that helps and the hoses are not the same temp
__________________
"It is foolish and wrong to mourn the men who died. Rather we should thank God that such men lived." - General George S. Patton
IC1Patton is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:03 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.