Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
PFYC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Specific Models / Packages > Camaro 1LE Forum

Camaro 1LE Forum Camaro 1LE Package releated discussions

Reply
 
Thread Tools
Old 05-29-2013, 06:24 PM   #1
LMC2013
 
LMC2013's Avatar
 
Drives: 2013 Chevrolet Camaro 2SS/RS 1LE
Join Date: Mar 2013
Location: United States
Posts: 73
Car has 800 miles on it...just started having a squeaky clutch

I ordered my 1le a couple months ago and just hit the 800 mile mark with no issues except...

The clutch started squeaking when I engage and disengage it...anyone have similar experiences or solutions? I'm not going to the dealer with it.. I'll probably find a way to lubricate it
LMC2013 is offline   Reply With Quote
Old 05-29-2013, 06:53 PM   #2
cornerspeed92


 
cornerspeed92's Avatar
 
Drives: 2013 1SS 1LE
Join Date: Jul 2012
Location: SoCal
Posts: 2,931
Bummer,5000 miles no issues with mine.
cornerspeed92 is offline   Reply With Quote
Old 05-29-2013, 06:56 PM   #3
chevy 3
NEcamaro5
 
chevy 3's Avatar
 
Drives: Black 2ss rs 1LE
Join Date: Apr 2009
Location: mass
Posts: 3,851
I just hit 1000 miles and alls good
__________________
chevy 3 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.