Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-28-2009, 11:28 PM   #1
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Quality Issues?

First, let me pre-face this by stating that i am a GM loyalist to the point of apologist... however... here are the problems I have so far...

Door to Dash trim do not line up... pretty off, but I will live with it...

Upon turning on the car, you would swear the battery has a low charge... its almost embarrasing to turn on in front of an audience... (my 99 fires right up!)

Developed a Rattle (cat area?), which is really noticeable upon turning car on

The infamous Passenger Side A-Pillar trim...

Spoiler Nuts (read story about lose nuts in another thread), I havent checked, but since I ordered Stripes (have yet to get them installed), I should look into...

Inspite, the car is AWESOME!
67camaro99 is offline   Reply With Quote
Old 06-28-2009, 11:39 PM   #2
Rockytophummer
 
Rockytophummer's Avatar
 
Drives: 2006 Hummer H2 2010 2SS Camaro
Join Date: Jun 2009
Location: Maryville tn.
Posts: 587
Exactly what do you mean by seems battery low when turning car on?
Rockytophummer is offline   Reply With Quote
Old 06-28-2009, 11:39 PM   #3
Vash


 
Drives: 00 Blazer
Join Date: Aug 2008
Location: Texas
Posts: 5,128
The battery and start might just be a design issue. You did have the battery TSB done? Check the connector on the back, I think it's a solenoid control connector. They are getting knocked loose when the main cable TSB is done (my theory).

If that's ok then inspect your battery for swelling and the main cable connections on batt and starter.
Vash is offline   Reply With Quote
Old 06-28-2009, 11:40 PM   #4
UCI CamaroFan
Zot!
 
UCI CamaroFan's Avatar
 
Drives: Toyota 4Runner
Join Date: Feb 2009
Location: Orange County, California
Posts: 1,332
Quote:
Originally Posted by Vash View Post
The battery and start might just be a design issue. You did have the battery TSB done? Check the connector on the back, I think it's a solenoid control connector. They are getting knocked loose when the main cable TSB is done (my theory).

If that's ok then inspect your battery for swelling and the main cable connections on batt and starter.
wasn't there a recall for this issue already?
__________________
UCI CamaroFan is offline   Reply With Quote
Old 06-28-2009, 11:42 PM   #5
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Quote:
Originally Posted by Rockytophummer View Post
Exactly what do you mean by seems battery low when turning car on?
My car is a late build VIN: 10847

Kinda like it drains before start up... if it's normal, it sucks! I'll live with it, but it does not fire right up. I am trying to think of the best way to describe it.
Like as you crank it, it almost does a hesitation... Shoot, I bet my ex-wife could describe it. She always assumed I could diagnose her car problems based on her vocal immitations... LOL

Maybe do a video tomorrow... maybe its normal...?
67camaro99 is offline   Reply With Quote
Old 06-28-2009, 11:44 PM   #6
UCI CamaroFan
Zot!
 
UCI CamaroFan's Avatar
 
Drives: Toyota 4Runner
Join Date: Feb 2009
Location: Orange County, California
Posts: 1,332
Quote:
Originally Posted by 67camaro99 View Post
My car is a late build VIN: 10847

Kinda like it drains before start up... if it's normal, it sucks! I'll live with it, but it does not fire right up. I am trying to think of the best way to describe it.

Maybe do a video tomorrow... maybe its normal...?
It kind of just sounds like the maybe you need a new battery, and preferably one that is bigger.
__________________
UCI CamaroFan is offline   Reply With Quote
Old 06-28-2009, 11:47 PM   #7
mbavenger
 
mbavenger's Avatar
 
Drives: 2010 2LT 00845
Join Date: May 2009
Location: Texas
Posts: 56
I dont have any complaints yet! knock on wood
mbavenger is offline   Reply With Quote
Old 06-28-2009, 11:50 PM   #8
stovt001


 
stovt001's Avatar
 
Drives: 2006 Cobalt, 2004 Taurus wagon
Join Date: Oct 2007
Location: California
Posts: 3,817
Quote:
Originally Posted by 67camaro99 View Post
Shoot, I bet my ex-wife could describe it. She always assumed I could diagnose her car problems based on her vocal immitations... LOL
Hey, Click and Clack can do it. Hearing people try to replicate the sounds their cars make is one of the main reasons I listen to the show.
__________________
"It's kind of fun to do the impossible" - Walt Disney

There's a great big beautiful tomorrow
shining at the end of every day
There's a great big beautiful tomorrow
Just a dream away
stovt001 is offline   Reply With Quote
Old 06-28-2009, 11:58 PM   #9
UCI CamaroFan
Zot!
 
UCI CamaroFan's Avatar
 
Drives: Toyota 4Runner
Join Date: Feb 2009
Location: Orange County, California
Posts: 1,332
Quote:
Originally Posted by stovt001 View Post
Hey, Click and Clack can do it. Hearing people try to replicate the sounds their cars make is one of the main reasons I listen to the show.
I LOVE Car Talk! hahaha

It's so intriguing that two Harvard professors who don't know anything about cars can still come up with some decent answers and be so entertaining!
__________________
UCI CamaroFan is offline   Reply With Quote
Old 06-29-2009, 12:01 AM   #10
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Well it does not get to CLICK...more like cli...CLACK

LOL.... I am SURE everyone knows what I mean now... LOL
67camaro99 is offline   Reply With Quote
Old 06-29-2009, 12:17 AM   #11
2SSJIM

 
2SSJIM's Avatar
 
Drives: CRT ZL1 #1400
Join Date: Apr 2009
Location: AZ.
Posts: 896
I highly suggest you take your car to the dealer and point these issues out and get them fixed. When the GFX are installed, they must remove the rear bumber and when mine was done the bumber to body line was uneven. Took it up to the dealer and showed them and it was fixed.... no problem! Don't just live with an issue, get it fixed while it's under warranty that way if there are a lot of cars out there with the same issue, GM corp. will see it and then improvments can happen on future cars.
2SSJIM is offline   Reply With Quote
Old 06-29-2009, 12:18 AM   #12
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Yea, with out a doubt...
The reason I waited on the A Pillar was exactly for that reason. Take it in, and get ALL issues resolved, I did not (do not) want to keep going back every week...
67camaro99 is offline   Reply With Quote
Old 06-29-2009, 12:28 AM   #13
2SSJIM

 
2SSJIM's Avatar
 
Drives: CRT ZL1 #1400
Join Date: Apr 2009
Location: AZ.
Posts: 896
Quote:
Originally Posted by 67camaro99 View Post
Yea, with out a doubt...
The reason I waited on the A Pillar was exactly for that reason. Take it in, and get ALL issues resolved, I did not (do not) want to keep going back every week...
Same here! I had it all taken care of when it went in for the window tint install! I haven't had any other issues so far (Knock on wood.... the QC hold did help there probably), but I'm keeping my eyes open because I'm expecting to take it in for the stipes this week! Hope all works out in the end.
2SSJIM is offline   Reply With Quote
Old 06-29-2009, 12:32 AM   #14
dragonZ28


 
Drives: 2001 T/A, 2010 2SS/RS, 2006 Z06
Join Date: Apr 2009
Location: Lexington, KY
Posts: 1,952
I have also noticed the driver's door trim not lining up with the dash trim - mild problem, but it should have never been approved to go production until they fixed it.
__________________
dragonZ28 is offline   Reply With Quote
Old 06-29-2009, 12:36 AM   #15
FenwickHockey65
General Motors Aficionado
 
FenwickHockey65's Avatar
 
Drives: 2003 GMC Envoy SLE/2007 Ford F-150
Join Date: Aug 2008
Location: Florida
Posts: 31,460
Send a message via AIM to FenwickHockey65
The driver's side door trim seems to be more of an optical illusion than anything else...someone posted pictures of their door to dash trim from different angles, and it does indeed look crooked from some, but perfect from others.
__________________
FenwickHockey65's GM Thread!

My Cars: 2003 GMC Envoy SLE, 2007 Ford F-150 XL (State-issued)
Extended Family: 2013 GMC Terrain SLE, 1998 GMC Sonoma SLS Extended Cab

FenwickHockey65 is offline   Reply With Quote
Old 06-29-2009, 05:52 AM   #16
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Ummm sorry, but I am not basing it on photos, but rather in person, as I sit in my car. Much as I love my car, I'm not going to pretend that issues dont exist. Nor are there any regrets.

Last edited by 67camaro99; 06-29-2009 at 09:42 AM.
67camaro99 is offline   Reply With Quote
Old 06-29-2009, 06:10 AM   #17
camarolt76
2SS/RS Black/CGM Stripes
 
camarolt76's Avatar
 
Drives: 88 Iroc, 76 Camaro, 2010 2SS/RS
Join Date: Nov 2008
Location: Hampton Roads Virginia
Posts: 596
Knock on wood, but so far I have no complaints on my 2SS/RS. My car fires right up when you turn the key. Haven't had any problems with the A pillar trim piece either, or noticed an alignment problem with the door and dash pieces. I agree with the other person who said you should take it back to the dealer and have them fix the issues.
__________________
2SS/RS Black with CGM Rally Stripes (#8575) Built on 8th of May, Delivered 10 June 2009.

camarolt76 is offline   Reply With Quote
Old 06-29-2009, 06:11 AM   #18
oldbowtie
 
oldbowtie's Avatar
 
Drives: 2010 RJT 2SS/RS, 2013 Regal GS
Join Date: Sep 2008
Location: Dublin, OH
Posts: 292
My RJT 2SS/RS is number 7992. I have no issues with this car. Fit and finish are great. My wife and I took it on a 1609 mile trip to New England and back. No problems. I had the oil changed at 2300 miles and now I'm sitting at 2467.

Just had to chime in...

Former Rides:
1966 Chevelle (1971 to 2007)
1970 Chevelle (1974 to 1991)

Now the proud owner of a 2010 RJT 2SS/RS L99 Camaro 20" polished wheels
oldbowtie is offline   Reply With Quote
Old 06-29-2009, 07:20 AM   #19
King Mouse
 
King Mouse's Avatar
 
Drives: EXT
Join Date: Nov 2008
Location: Western PA
Posts: 416
My car just had stripes painted on and the painter said the spoiler nuts were just finger tight. Just saying so other members can keep an eye on this.
King Mouse is offline   Reply With Quote
Old 06-29-2009, 07:35 AM   #20
Foster26
 
Drives: 2SS/RS IOM 6SP CGRS #9761
Join Date: Mar 2007
Location: Tuttle, OK
Posts: 294
What you are describing with starting really sounds like a bad battery. You would think that a brand new car couldn't already have a bad battery but sometimes batteries are bad when they're new, just like other things. Like others have said, I would seriously take that thing in immediately. You have enough issues to point out.

By the way, that tint REALLY makes your car look even better! Very nice pic.
Foster26 is offline   Reply With Quote
Old 06-29-2009, 07:45 AM   #21
Supermans
Camaro & Stang Enthusiast
 
Supermans's Avatar
 
Drives: 2011 Mustang 5.0 in Kona Blue
Join Date: Mar 2008
Location: Miami
Posts: 4,757
Quote:
Originally Posted by 67camaro99 View Post
First, let me pre-face this by stating that i am a GM loyalist to the point of apologist... however... here are the problems I have so far...

Door to Dash trim do not line up... pretty off, but I will live with it...

Upon turning on the car, you would swear the battery has a low charge... its almost embarrasing to turn on in front of an audience... (my 99 fires right up!)

Developed a Rattle (cat area?), which is really noticeable upon turning car on

The infamous Passenger Side A-Pillar trim...

Spoiler Nuts (read story about lose nuts in another thread), I havent checked, but since I ordered Stripes (have yet to get them installed), I should look into...

Inspite, the car is AWESOME!
Yeah, there seems to be a lot that Quality Control isn't checking for that they definitely should..
__________________
Bought my Camaro from Eric Hall(817) 421-7266
Supermans is offline   Reply With Quote
Old 06-29-2009, 08:45 AM   #22
jimhowie2000
 
Drives: '10 Camaro 2LT/RS & 6 older Chevy's
Join Date: Feb 2009
Location: Mount Vernon, Ohio
Posts: 75
If I get this right, the starter sounds kind of lazy when you turn the key? I find mine sounds that way as well but always starts with no problem. I found my '07 Cobalt sounded the same way. Unfortunately, new American cars no longer have a starter that sounds like an American car. They all have that timid lazy sound like Asian cars do. As for quality issues, the only one I found on my car was loose A pillar trim on the Driver's side. I gently pushed on it and it slid into place and fits great now. Everything else looks just as it should and works as it should. My dealer was fantastic through the whole process and this was probably one of my best buying experiences so far. Of course, I bought my Cobalt from the same dealership in '07 and was treated just as well then so, I knew what to expect. Take the car back to your dealer, I am sure they do not want a customer with such a high profile GM product unhappy.
jimhowie2000 is offline   Reply With Quote
Old 06-29-2009, 08:50 AM   #23
2010SLVRBULIT


 
2010SLVRBULIT's Avatar
 
Drives: G5 & C6
Join Date: Apr 2009
Location: MARS
Posts: 6,728
read around here that if you don't park it in reverse, power is not completely turned off(thus draining your battery). I take it as for only M6 vehicles..
2010SLVRBULIT is offline   Reply With Quote
Old 06-29-2009, 09:42 AM   #24
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
By the way, that tint REALLY makes your car look even better! Very nice pic.[/QUOTE]

Thanks!
67camaro99 is offline   Reply With Quote
Old 06-29-2009, 09:45 AM   #25
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Quote:
Originally Posted by jimhowie2000 View Post
If I get this right, the starter sounds kind of lazy when you turn the key? I find mine sounds that way as well but always starts with no problem. I found my '07 Cobalt sounded the same way. Unfortunately, new American cars no longer have a starter that sounds like an American car. They all have that timid lazy sound like Asian cars do. As for quality issues, the only one I found on my car was loose A pillar trim on the Driver's side. I gently pushed on it and it slid into place and fits great now. Everything else looks just as it should and works as it should. My dealer was fantastic through the whole process and this was probably one of my best buying experiences so far. Of course, I bought my Cobalt from the same dealership in '07 and was treated just as well then so, I knew what to expect. Take the car back to your dealer, I am sure they do not want a customer with such a high profile GM product unhappy.
That is correct, thats how it sounds, yea, it sounds like a weak over-seas import, before it fires up. I couldn't find a better way to describe til I read your response (I have only owned 1 import, but that was like 4 yrs ago).

Anyhow, I will take to dealer, and HOPEFULLY they find an issuse.

THANKS TO EVERYONE FOR THEIR INPUT!
67camaro99 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quality Control Issues CRPMRO Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 12 07-09-2009 07:10 AM
Anyone Having Any Quality Issues thearrow Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 28 06-24-2009 03:27 PM
quality control issues darty111 Camaro Price | Ordering | Tracking | Dealers Discussions 10 05-14-2009 10:26 AM
A Quality Car? According to who? Mr. Wyndham General Automotive + Other Cars Discussion 6 10-27-2008 07:50 PM
GM picks up MORE quality awards. Mr. Wyndham General Automotive + Other Cars Discussion 10 06-06-2008 09:43 AM


All times are GMT -5. The time now is 04:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.