Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 06-28-2009, 11:28 PM   #1
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Quality Issues?

First, let me pre-face this by stating that i am a GM loyalist to the point of apologist... however... here are the problems I have so far...

Door to Dash trim do not line up... pretty off, but I will live with it...

Upon turning on the car, you would swear the battery has a low charge... its almost embarrasing to turn on in front of an audience... (my 99 fires right up!)

Developed a Rattle (cat area?), which is really noticeable upon turning car on

The infamous Passenger Side A-Pillar trim...

Spoiler Nuts (read story about lose nuts in another thread), I havent checked, but since I ordered Stripes (have yet to get them installed), I should look into...

Inspite, the car is AWESOME!
67camaro99 is offline   Reply With Quote
Old 06-28-2009, 11:39 PM   #2
Rockytophummer
 
Rockytophummer's Avatar
 
Drives: 2006 Hummer H2 2010 2SS Camaro
Join Date: Jun 2009
Location: Maryville tn.
Posts: 586
Exactly what do you mean by seems battery low when turning car on?
Rockytophummer is offline   Reply With Quote
Old 06-28-2009, 11:39 PM   #3
Vash


 
Drives: 00 Blazer
Join Date: Aug 2008
Location: Texas
Posts: 5,104
The battery and start might just be a design issue. You did have the battery TSB done? Check the connector on the back, I think it's a solenoid control connector. They are getting knocked loose when the main cable TSB is done (my theory).

If that's ok then inspect your battery for swelling and the main cable connections on batt and starter.
Vash is offline   Reply With Quote
Old 06-28-2009, 11:40 PM   #4
UCI CamaroFan
Zot!
 
UCI CamaroFan's Avatar
 
Drives: Toyota 4Runner
Join Date: Feb 2009
Location: Orange County, California
Posts: 1,317
Quote:
Originally Posted by Vash View Post
The battery and start might just be a design issue. You did have the battery TSB done? Check the connector on the back, I think it's a solenoid control connector. They are getting knocked loose when the main cable TSB is done (my theory).

If that's ok then inspect your battery for swelling and the main cable connections on batt and starter.
wasn't there a recall for this issue already?
__________________
UCI CamaroFan is offline   Reply With Quote
Old 06-28-2009, 11:42 PM   #5
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Quote:
Originally Posted by Rockytophummer View Post
Exactly what do you mean by seems battery low when turning car on?
My car is a late build VIN: 10847

Kinda like it drains before start up... if it's normal, it sucks! I'll live with it, but it does not fire right up. I am trying to think of the best way to describe it.
Like as you crank it, it almost does a hesitation... Shoot, I bet my ex-wife could describe it. She always assumed I could diagnose her car problems based on her vocal immitations... LOL

Maybe do a video tomorrow... maybe its normal...?
67camaro99 is offline   Reply With Quote
Old 06-28-2009, 11:44 PM   #6
UCI CamaroFan
Zot!
 
UCI CamaroFan's Avatar
 
Drives: Toyota 4Runner
Join Date: Feb 2009
Location: Orange County, California
Posts: 1,317
Quote:
Originally Posted by 67camaro99 View Post
My car is a late build VIN: 10847

Kinda like it drains before start up... if it's normal, it sucks! I'll live with it, but it does not fire right up. I am trying to think of the best way to describe it.

Maybe do a video tomorrow... maybe its normal...?
It kind of just sounds like the maybe you need a new battery, and preferably one that is bigger.
__________________
UCI CamaroFan is offline   Reply With Quote
Old 06-28-2009, 11:47 PM   #7
mbavenger
 
mbavenger's Avatar
 
Drives: 2010 2LT 00845
Join Date: May 2009
Location: Texas
Posts: 56
I dont have any complaints yet! knock on wood
mbavenger is offline   Reply With Quote
Old 06-28-2009, 11:50 PM   #8
stovt001


 
stovt001's Avatar
 
Drives: 2006 Cobalt, 2004 Taurus wagon
Join Date: Oct 2007
Location: California
Posts: 3,812
Quote:
Originally Posted by 67camaro99 View Post
Shoot, I bet my ex-wife could describe it. She always assumed I could diagnose her car problems based on her vocal immitations... LOL
Hey, Click and Clack can do it. Hearing people try to replicate the sounds their cars make is one of the main reasons I listen to the show.
__________________
"It's kind of fun to do the impossible" - Walt Disney

There's a great big beautiful tomorrow
shining at the end of every day
There's a great big beautiful tomorrow
Just a dream away
stovt001 is offline   Reply With Quote
Old 06-28-2009, 11:58 PM   #9
UCI CamaroFan
Zot!
 
UCI CamaroFan's Avatar
 
Drives: Toyota 4Runner
Join Date: Feb 2009
Location: Orange County, California
Posts: 1,317
Quote:
Originally Posted by stovt001 View Post
Hey, Click and Clack can do it. Hearing people try to replicate the sounds their cars make is one of the main reasons I listen to the show.
I LOVE Car Talk! hahaha

It's so intriguing that two Harvard professors who don't know anything about cars can still come up with some decent answers and be so entertaining!
__________________
UCI CamaroFan is offline   Reply With Quote
Old 06-29-2009, 12:01 AM   #10
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Well it does not get to CLICK...more like cli...CLACK

LOL.... I am SURE everyone knows what I mean now... LOL
67camaro99 is offline   Reply With Quote
Old 06-29-2009, 12:17 AM   #11
2SSJIM

 
2SSJIM's Avatar
 
Drives: 2012 CRT ZL1 #1400
Join Date: Apr 2009
Location: AZ.
Posts: 940
I highly suggest you take your car to the dealer and point these issues out and get them fixed. When the GFX are installed, they must remove the rear bumber and when mine was done the bumber to body line was uneven. Took it up to the dealer and showed them and it was fixed.... no problem! Don't just live with an issue, get it fixed while it's under warranty that way if there are a lot of cars out there with the same issue, GM corp. will see it and then improvments can happen on future cars.
2SSJIM is offline   Reply With Quote
Old 06-29-2009, 12:18 AM   #12
67camaro99
Account Suspended
 
Drives: 67, 69, 99 +2010
Join Date: Oct 2008
Location: SoCal
Posts: 602
Yea, with out a doubt...
The reason I waited on the A Pillar was exactly for that reason. Take it in, and get ALL issues resolved, I did not (do not) want to keep going back every week...
67camaro99 is offline   Reply With Quote
Old 06-29-2009, 12:28 AM   #13
2SSJIM

 
2SSJIM's Avatar
 
Drives: 2012 CRT ZL1 #1400
Join Date: Apr 2009
Location: AZ.
Posts: 940
Quote:
Originally Posted by 67camaro99 View Post
Yea, with out a doubt...
The reason I waited on the A Pillar was exactly for that reason. Take it in, and get ALL issues resolved, I did not (do not) want to keep going back every week...
Same here! I had it all taken care of when it went in for the window tint install! I haven't had any other issues so far (Knock on wood.... the QC hold did help there probably), but I'm keeping my eyes open because I'm expecting to take it in for the stipes this week! Hope all works out in the end.
2SSJIM is offline   Reply With Quote
Old 06-29-2009, 12:32 AM   #14
dragonZ28



 
Drives: 2001 T/A, 2010 2SS/RS, 2006 Z06
Join Date: Apr 2009
Location: Lexington, KY
Posts: 2,395
I have also noticed the driver's door trim not lining up with the dash trim - mild problem, but it should have never been approved to go production until they fixed it.
__________________

JULY SALE! Enter promo code:
JULYSALE10 - 10% off orders under $100
JULYSALE15 - 15% off orders over $100
Exclusions apply
dragonZ28 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quality Control Issues CRPMRO Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 12 07-09-2009 07:10 AM
Anyone Having Any Quality Issues thearrow Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 28 06-24-2009 03:27 PM
quality control issues darty111 Camaro Price | Ordering | Tracking | Dealers Discussions 10 05-14-2009 10:26 AM
A Quality Car? According to who? Mr. Wyndham General Automotive + Other Cars Discussion 6 10-27-2008 07:50 PM
GM picks up MORE quality awards. Mr. Wyndham General Automotive + Other Cars Discussion 10 06-06-2008 09:43 AM


All times are GMT -5. The time now is 08:15 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.