Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Dyno Max
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 06-03-2013, 06:10 PM   #1
MARINE1991


 
MARINE1991's Avatar
 
Drives: COTW 8/29/11 2010 CAMARO
Join Date: Jul 2009
Location: hickville NC USA
Posts: 9,916
Need help getting an O2 code

Hello I trying to figure out an O2 code P0154 insuffient activity bank 2 sensor 1, been looking all over and cant figure it out, its going to a performance shop next week for some engine work so they are going to try and fix it before that, but I am stressed out cause I have had my set up for a while and no issues now I been getting this code and the car when this happens back fires and has no power, I have kooks long tubes and got rid of the cats and have a dyno tune. Tried changing out both O2 sensors and it still happens.
MARINE1991 is offline   Reply With Quote
Old 06-03-2013, 06:17 PM   #2
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,690
If you swap the wiring harnesses, does the code change to bank 1?
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 06-03-2013, 06:19 PM   #3
MARINE1991


 
MARINE1991's Avatar
 
Drives: COTW 8/29/11 2010 CAMARO
Join Date: Jul 2009
Location: hickville NC USA
Posts: 9,916
Quote:
Originally Posted by The Stig View Post
If you swap the wiring harnesses, does the code change to bank 1?
I did not try that....
MARINE1991 is offline   Reply With Quote
Old 06-03-2013, 06:22 PM   #4
MARINE1991


 
MARINE1991's Avatar
 
Drives: COTW 8/29/11 2010 CAMARO
Join Date: Jul 2009
Location: hickville NC USA
Posts: 9,916
I am taking it to the shop next week have an apt to get the conversion and cam done, and told them I am stressed cause I don't want to get the engine work done with this issue still happening, its crazy cause it does not happen all the time, can drive it long and drives great then drive it to work and it does not....
MARINE1991 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.