Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)

V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) Driveshafts | Differentials | Gears | Rearends | Clutch | Shifters

Reply
 
Thread Tools
Old 06-04-2013, 06:18 PM   #1
Teamradrz1
 
Teamradrz1's Avatar
 
Drives: 2012 2SS/RS
Join Date: Jan 2012
Location: Gresham, OR
Posts: 405
clutch disk question

I'm having clutch issues and trying to get the dealer to cover it. My question is on the factory clutch disk itself there are two yellow inner springs on oposite sides of each other that are loose (able to move freely inside the outer spring) is this normal? When I first went to the dealer to look at it the tech said it wasn't normal and that something was broke, I thought as both springs acted the same I feel that is normal, just curious if it is or isn't. any help is appreciated!
__________________
Mods: Synergy series edition added by dealer(GFX, striping, hertiage grill, dove tail spoiler, ambient light kit, Hurst short throw shifter)
Showstopper side markers, Phoenix Gold system, MBRP Catback exhaust, Factory Strut tower brace, CAI intake, Hydro graphics, carbon fiber door panel inserts, 20% tint, clear bra, Plasma DRL, AAC scanner bar & Grill LEDs, int-trunk-license plate swapped for LEDs.
Teamradrz1 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.