Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 06-10-2013, 04:12 AM   #1
Erad
 
Drives: Camaro SS 2010
Join Date: Jun 2013
Location: Dubai
Posts: 4
Post Engine misfire

Hey guys, I'm actually new to LS3 engine. I have recently purchased a Camaro SS 2010 and it has some work done on the engine. Unfortunately I don't know what exactly but as per my experience the below modifications:
1. Cam
2. Intake
3. Throttle body
4. High pressure piston
5. Air intake
6. Headers and one chamber cat back

I have tuned the car recently and since I'm in Dubai the temp in the summer is really hot so additionally I have kept and engine oil cooler as well. I'm using MSD wires and my tuner advices that I should go with NGK 7. However, after my research I noticed everyone is recommending to stay with the AC Delco stock plugs.

The issue what I have the car from rpm 1 to 2.5 has a misfire and after that everything goes normal and the other issue I have the all the lights on the dashboard are on! such as traction control, abs, airbag and sometimes the check engine sign. The car had no accident. However, my tuner says its because of the modification done to the car you can not get rid of these lights and since you have misfire.

Sorry for the long story, but I would appreciate if anyone can help me out here. Thanks
Erad is offline   Reply With Quote
Old 06-10-2013, 05:39 AM   #2
Da Mammer
 
Drives: 2010 camaro SS LSXFoFiddyFo
Join Date: Nov 2012
Location: Pennsyltucky
Posts: 194
Well lets see where to start. I'm guessing its a manual transmission if its an auto then it's a whole new can of poop in your wheaties. Im going to assume the cam you speak of has a stupid long duration, If it has a big cam in it and has a rough lope on idle I'm assuming that's where your misfire is coming from until 2500rpm. Your tuner should be able to lower the sensitivity of the misfire detection of he doesn't know that find yourself a different tuner. it is probably the source of your engine light being on. Secondly your 3 lights associated with abs traction control are going to light up BECAUSE of the cylinder misfire trouble code. So you have to fix the misfire code and the traction control/abs lights should go off less something else is wrong. As far as your airbag light I'm lost do you have non-stock seats in the car? Or a simple steering wheel? Somewhere someone may have disconnected an air bag on a seat to pull the seat out to shed weight for racing maybe? May have to take that one to a dealer to clear the code. And finally I'd stick with ac delco. If ac delco is good enough for a ls9 to zz572 it should do the job in your 6.2L
__________________
LSXTC
Da Mammer is offline   Reply With Quote
Old 06-10-2013, 06:13 AM   #3
Erad
 
Drives: Camaro SS 2010
Join Date: Jun 2013
Location: Dubai
Posts: 4
That's right it's stick shift and its has a big cam because on the idle its rough. I will take it to a different tuner and I hope it works out. The seats are original and has not been changed. However, all the lights which I mentioned it comes and goes! I will stick to the stock spark. Thanks a lot
Erad is offline   Reply With Quote
Old 06-10-2013, 08:15 AM   #4
christianchevell
old school chevy rodder
 
christianchevell's Avatar
 
Drives: 2013 2SS/RS Manual,DM exhaust,CRT
Join Date: Jul 2012
Location: Oregon
Posts: 1,342
I seriously doubt some one put a high pressure.....pistons on the car its probably the same normal pistons as we allready have to use high octane...sauper gas and run premium.......you see dissassembling the entire motor to change only the pistons and cam is not very money friendly......ANd yes the lope of the more radical cam may be what is saying misfire as your timing is off from firing just right or the computer can not handle it................or you have a bad spark plug that has a small crack and misfires when it wants. Changing intake is ok yet expensive with not much gain...like 1000$ expensive and 3 h.p. ........... SO who ever built the car may not well have known what money to throw where at the car to try to make it perform better..................
__________________
2013 2SS/RS LS3 M6 ,CRT, 500rwhp 460 torque mustang dyno,dual mode ,sunroof ,heritage grill clear bra, TSP cam, Stainless power headers HFC, CAI induction, Vmax PTD,Fluidampr25% udp, LPW diff cover, BMR strut brace,trailing arms, toes, bushings, Rocket racing wheels, catch can, separate clutch reservoir, under dash/body lights/scanner LED, DRL lights/halos rewire, Dash kit, Custom striping and Sparks badges and Engine badge, Corvette Stainless engine cover, mild to wild, coming soon Eaton true trac and 3.91's
christianchevell is offline   Reply With Quote
Old 06-10-2013, 12:21 PM   #5
Sword5

 
Sword5's Avatar
 
Drives: 2010 2SS
Join Date: Jun 2009
Location: Lexington, Ky
Posts: 1,091
Could have a cracked or broken plug when headers were installed.
__________________
Ordered 6/19/09 Black on Black 2 SS Delivery 10/14/09! Added CAI, Heritage Grill, DRL Plug and Play Harness
Sword5 is offline   Reply With Quote
Old 06-10-2013, 12:29 PM   #6
vroomapunk
[COTW 5/12/14]
 
vroomapunk's Avatar
 
Drives: 2012 CRT NF Cammed 2SS/RS
Join Date: Oct 2011
Location: New Orleans, Louisiana
Posts: 5,492
Im not 100% sure, but I think people have the same mods as you and do not have to live with the check engine, etc lights on.

You may need a new tuner, or get a mail order tune from Jannety Racing, that you guys can send files back and forth through email, and he may be able to fix your issues.
__________________
vroomapunk is offline   Reply With Quote
Old 06-10-2013, 10:02 PM   #7
oville-rider
 
oville-rider's Avatar
 
Drives: 2010 Camaro Summit White 2SS/RS
Join Date: Aug 2009
Location: Ortonville, MI.
Posts: 131
Quote:
Originally Posted by Erad View Post
Hey guys, I'm actually new to LS3 engine. I have recently purchased a Camaro SS 2010 and it has some work done on the engine. Unfortunately I don't know what exactly but as per my experience the below modifications:
1. Cam
2. Intake
3. Throttle body
4. High pressure piston
5. Air intake
6. Headers and one chamber cat back

I have tuned the car recently and since I'm in Dubai the temp in the summer is really hot so additionally I have kept and engine oil cooler as well. I'm using MSD wires and my tuner advices that I should go with NGK 7. However, after my research I noticed everyone is recommending to stay with the AC Delco stock plugs.

The issue what I have the car from rpm 1 to 2.5 has a misfire and after that everything goes normal and the other issue I have the all the lights on the dashboard are on! such as traction control, abs, airbag and sometimes the check engine sign. The car had no accident. However, my tuner says its because of the modification done to the car you can not get rid of these lights and since you have misfire.

Sorry for the long story, but I would appreciate if anyone can help me out here. Thanks
Well if I'm reading this right you bought the car with mods 1-6 already installed. Since then you've replaced the plugs and wires? You could have possibly damaged a plug or don't have a wire pushed on fully. Easily done ! If you have a OBD II scanner depending on it's capabilities you might be able to checks things in run mode. It may tell you what cylinder is misfiring? If not go back and check each wire first to see if they are on all the way, then plugs for damage. I would stick with the stock plugs but that's me. Good Luck
oville-rider is offline   Reply With Quote
Old 06-11-2013, 03:13 AM   #8
Erad
 
Drives: Camaro SS 2010
Join Date: Jun 2013
Location: Dubai
Posts: 4
Thanks a lot guys. I have dropped the car to a tuner and he will be doing full diagnostic on the car and fingers crossed he said it will be ready in two days with all the problems solved. Once I receive the car, I will share with you guys what the issue was. Thanks again
Erad is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.