Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Grabiak Performance Center
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Member Car Journals

Member Car Journals Want to keep a long term Camaro project journal to share with the community? Use this forum to create a single thread which you can update over time to document the progress.

Reply
 
Thread Tools
Old 12-31-2011, 03:44 PM   #1
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
Two years in the making...My L99/A6 build

In September of '06, I assigned my local Chevy dealer with the impossible task of finding me a gently used 2005 Impulse Blue Metallic GTO. I wasn't asking for much, it just had to be an M6 with black guts and the 17" wheels. I mean, come one....there were 160 of these cars built in 2005 so certainly they could find me one ASAP.
Two weeks later, they actually found me the exact car! I was driving the GTO 80 miles a day for work, so a few simple mods and I was happy.



A few months after buying the GTO, the previews for the Transformers movie started hitting the TV and I started looking up info on the car that was to become the new Camaro. While I liked what I saw, I wasn't sold on it.
I ended up selling the GTO in order to buy my first house in April of '08 and again started searching for info on the new Camaro.
In November of '08 I was asked by my employer to relocate from Illinois to the New Orleans area, so the thoughts of buying a toy were gone as I now had to sell the house I had just bought and start looking for one in New Orleans.
In the year that it took to sell one house and buy another, the Camaro had started to grow on me. Since I missed the GTO and loved the color, I told myself that I wanted an ABM SS. And I wanted an A6 that would eventually be supercharged.
In April of 2010, I closed on a house just outside of New Orleans and started to hunt for my ABM SS. I took my time in hopes that something would drop into my lap just like the GTO did.
This time it didn't and in November of 2010, I was asked to move again...this time to Texas. So here we go again with selling a home I had just bought and looking for a 3rd one in 2 years to buy.
In June of 2011 I had sold the house in Louisiana and found one that I liked in Texas. While getting the financing on the new house lined up, I started looking at the new 2011's on the local dealers lots. I still wanted an ABM, but also wanted to buy a brand new 2011.
I drove a used 2011 SIM SS with the A6 to make sure I didn't have any issues with the car or the A6, and told the salesman that once I closed on the house and had an address that I could title a vehicle to that he would see me again and we'd find my new 2011 SS.
On friday July 22nd I closed on the house in Texas, and on monday July 25th I went talked to my salesman again. At 10pm that night, I signed the papers brought home my white 2011 2SS with the RS package and the A6. I wasn't screwing around anymore.







I liked the look of the pure white car, but knew that I wanted to pull the bowtie's off the front and back and throw on some SS emblems. After doing some searching here on the forum, I bought the white SS emblems for the front and back from Sparks Restorations.
I also wanted to add a little black to the car to offset the white, but wanted to try and do something a bit more subtle than the stripes on the hood and decklid. So after doing a bit more searching here on the forum, I came across Big Worm Motorsports and ordered some hood spears and a rear blackout panel.







Close, but not quite enough. So I hit up Big Worm Motorsports again for some gill vinyl and sidemarker and tail light blackouts.







This.....I like.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 12-31-2011, 04:13 PM   #2
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
Well now that I'm happy with the first stage of appearance mods, it was time to see what the car could do at the track.
October 21st brought some decently cool weather to the DFW area, and the DA was about 1300ft at Dallas Raceway. I was hoping for something a bit better, but good enough to at least make a few passes and get used to the car. I was still hoping to see somewhere around 13.3@106mph???

I tech'd in after my 45 minute drive to the track and got in the lanes. I drove around the waterbox, turned off both TC and stabilitrak, cleaned off the stock Pirelli's, made sure the shifter was down in M....and staged.
My first pass was a 13.66@102mph. I don't think a 13.3 is in the cards in this car, at least not tonight. But at least I cut a .503 light on my first pass at a dragstrip in probably 5 years. Gotta take something positive out of it I guess.
I let the car cool down for an hour and a half, staged her again, and it went 13.43@104mph. Much better! Air temp was in the low 60's so letting the car sit with the hood up for nearly 90 minutes certainly allowed the car to cool a bit and helped get rid of a bit of heatsoak on the MAF and IAT.

By 11pm the DA was down to about 900ft, and I told myself that if I can manage to get my 2.0 60 foot times down into the 1.9's that this 400ft lower DA should be enough to get my 13.3. And I was right.
1.996 and 13.32@103mph.

Minor mission accomplished, but 103-104mph?????

Due to an issue with the battery on my spare laptop that I use to tune and scan, I was only able to get my first pass to save. The power issue was pretty easy to spot right away. The HPT scanner is picking up anywhere from 14 to 22 degrees of timing and 2 to 4 degrees of retard being pulled out of that!!! Sounds like 102mph to me.
So I again started digging on this forum trying to come up with ideas as to why I'm seeing this much retard. No exhaust rattles, no cracked plugs, and nothing mechanical that I can find. I found a few threads with some folks discussing some knock retard being caused by the stock cats. Well, if that's it....not much I can do. The car is staying stock for now so I guess I'll just have to deal with it.
I also did some logging of some normal driving and found no timing retard at part throttle anywhere, but still the same retard at WOT. Since the track is only 45 minutes from me, I figured I'd drag the laptop back to the track with me the next weekend and get more datalogs of some runs and see what I can find.


The next weekend brought 10 degree cooler temps, and lower DA's...so back to the track on October 29th.
I also let the car run nearly empty and filled up with 93 from a different gas station. I also did the #5 and #20 fuse pull to see what would happen with timing.
DA started around 0 and ended up about -500ft. Perfect.
First pass shocked me. 1.975 and 13.16@105mph!!!
I guess my brain was registering the fact that the DA was about 1300ft better.
The scan of the pass actually showed that commanded timing was between 18 and 25 degrees depending on rpm, but I was still seeing nearly identical retard as the previous week. :(
2nd and 3rd passes were within .015 of the first and saw similar retard, so it is what it is.
While I was certainly pleased with the .16, I was similarly upset about the timing retard issue. I couldn't help but wonder what the car would do in this good air if it could actually make a pass without any retard???

I guess I'll never know.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx

Last edited by white ZL1; 12-31-2011 at 04:48 PM.
white ZL1 is offline   Reply With Quote
Old 12-31-2011, 04:57 PM   #3
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
For the last month or so, I've been fiddling with the trans tune on this A6. I've found a ton of posts on the HPT board that have really helped me sort out what is what, and I've made some small changes to part throttle shift mph, shift times, and line pressure. I've also played with TCC lock and unlock just a bit. The car is completely different to drive, and again...I've only made simple changes.
I've also pulled all of the engine torque management, changed the stoich point to reflect our 10% ethanol gas, and disabled the AFM in sport mode completely and in 3rd and 4th gears in D. Worlds better.

In the next month or so, the goal is to get the maf and ve dialed in with my wideband and then work on wot timing. Also since I haven't touched trans torque management at all, I'll start pulling that depending on rpm and calculated torque.
Then it's back to the track to see what I can pull out of this car as delivered by GM, but with an optimized ECM and TCM.

My plan is to update this post with some links to the threads and posts that I've found useful for the 6L80E, and maybe some info on maf and ve tuning on the E38 as well.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 12-31-2011, 05:30 PM   #4
Red Jewel RS
 
Red Jewel RS's Avatar
 
Drives: 2013 Camaro ZL1 Blue Ray Metallic
Join Date: Apr 2010
Location: Billings, MT
Posts: 550


:Cool thread. Thanks for sharing!
I'm new to tuning, how/what are you using to tune?

I will be waiting for more post on your build. Subscribed!
Red Jewel RS is offline   Reply With Quote
Old 12-31-2011, 06:04 PM   #5
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
Thanks!
I've been using the HP Tuners package for years and really like it. I've also got an Innovate LM1 wideband that I use.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 12-31-2011, 07:13 PM   #6
AngelSpeedFreak
Most hated in NM....
 
AngelSpeedFreak's Avatar
 
Drives: Boosted, Cammed, Bagged, Dipped...
Join Date: Sep 2011
Location: New Mexico
Posts: 2,837
Very nice.... Needs more cowbell, I mean pics

Subscribed.
__________________
AngelSpeedFreak is offline   Reply With Quote
Old 12-31-2011, 07:22 PM   #7
Red Jewel RS
 
Red Jewel RS's Avatar
 
Drives: 2013 Camaro ZL1 Blue Ray Metallic
Join Date: Apr 2010
Location: Billings, MT
Posts: 550
Quote:
Originally Posted by white 2SS/RS View Post
Thanks!
I've been using the HP Tuners package for years and really like it. I've also got an Innovate LM1 wideband that I use.

Thanks!!
Red Jewel RS is offline   Reply With Quote
Old 12-31-2011, 07:57 PM   #8
RED DEMON SS
OFF THE CHAIN
 
RED DEMON SS's Avatar
 
Drives: RED DEMON!
Join Date: Sep 2011
Location: PNW MISFIT
Posts: 8,228
Hey another member of team L99! Welcome aboard!
__________________
RED DEMON SS is offline   Reply With Quote
Old 12-31-2011, 09:32 PM   #9
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
Quote:
Originally Posted by Farthestnorth View Post
Hey another member of team L99! Welcome aboard!
Thanks!
I actually read through your entire journal yesterday! You've had a trying last few weeks.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 01-08-2012, 11:01 PM   #10
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
After being away from the car for the last two weeks, I finally had a chance to get more of the tune sorted out the last few days.
I've now got the trans torque management completely disabled, and it certainly makes the car snap right into gear on shifts! Wow. It almost throws you forward a bit on an upshift! I might start putting some of that TM back in at part throttle...but not much.
And today I went ahead and dug out the wideband and tuned the MAF in open loop. I was shocked at how quick I was able to get it nailed down. 2 passes on it, and it was over. I was getting lambda at part throttle all up and down the MAF range and nailed my .85 lambda during PE. I'll drive it this week, and work on wot timing and some odds and ends and then hopefully the track will be open soon enough for me to go back and see what a stock but tuned L99 will do.
Hopefully I can convince myself not to run up to ADM to pick up their race CAI before I can make that trip to the track.

My P13W's from AAC are here too. Not sure why I didn't get them installed and get some before and after pics this weekend, but I didn't. I guess that'll give me something to do this week.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 01-09-2012, 12:20 AM   #11
RED DEMON SS
OFF THE CHAIN
 
RED DEMON SS's Avatar
 
Drives: RED DEMON!
Join Date: Sep 2011
Location: PNW MISFIT
Posts: 8,228
Looking good, post more pics when you can!
__________________
RED DEMON SS is offline   Reply With Quote
Old 01-09-2012, 12:36 AM   #12
2010 SSRS



 
2010 SSRS's Avatar
 
Drives: 3 V8 Camaros
Join Date: May 2009
Location: The Ocean State
Posts: 123,978
Looks great
__________________
Jannetty Racing JRE Street Package
2010 SSRS is offline   Reply With Quote
Old 01-09-2012, 12:40 AM   #13
blk20
 
blk20's Avatar
 
Drives: 2011 rs2ss
Join Date: Apr 2011
Location: arizona
Posts: 118
very nice
blk20 is offline   Reply With Quote
Old 01-09-2012, 12:43 AM   #14
austinjames
Account Suspend...Right
 
austinjames's Avatar
 
Drives: Synergy LS & Vulcan 1600cc
Join Date: Apr 2011
Location: Lakeland, Florida
Posts: 3,564
Damn, you GTOr transformed into a camaro. Thats awesome
__________________
austinjames is offline   Reply With Quote
Old 04-15-2012, 11:35 PM   #15
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
Huh. I forgot all about this thread. A few things new, nothing big though.

I did eventually get the P13W fogs installed and have them wired to come on and stay on with the halos. A pretty simple jumper supplied by AAC takes care of that. The fogs certainly have more of a blue-ish tint to them than the pure white look that the stock halos and headlights do, but I think I still like it. I just went outside and took some pics of them, but the coloring is difficult to see. Plus, my camera is dead so I used my droidx to take the pics...and the camera on the x sucks IMO.





I also had a chance to get back over the track back at the end of February, but didn't get the 12's that I was hoping for. Best pass was 1.983 - 13.063 - 106.35mph. The DA at the track was about 300ft, so while it wasn't the -500ft that I ran in last fall...it wasn't bad. The car was tuned to 12.5 afr and was seeing 23 degrees of timing by the time 6000rpm rolled around. So the 13.0 is all she had in her unless I had some crazy low DA again.

So since my stock 12's didn't happen, time to start with the bolt-ons. Auto Agenda was rockin' a pretty good deal on the CAI/ADM/Rotofab threesome....so it was ordered.
Super easy install by following some of the threads that others have here on the site. I then spent a few hours with the wideband getting to tune squared away....and we're good to roll again. And while Texas Motorplex was having their Fast Friday TNT this past friday night, I didn't go. I planned on it, I swear. I left work early for it, and I still forgot to go.





And into the mouth of the beast....



I also took the car to have the windows tinted. The sides are done at 30% and the quarter windows and rear are done at 20%. I have a hard time seeing at night, but have just as tough a time with glare in the rearview and side mirrors...so I went just dark enough to help with the glare while still being able to see out at night. The car needs a serious bath, and I'm out of town for at least the next week....so the bath and new pics are going to have to wait.

Ok, so back to why I didn't make it to the track this past friday. A box showed up earlier in the week and was sitting staring me in the face for a few days. So friday when I got home from work (and while I was supposed to be getting the car ready to make the 8 mile drive to Texas Motorplex) I cracked the box open and checked out what was inside. Thanks to 2SSRS, I had a rearview camera setup that I was antsy to get installed. So what did I do? Yeah, got on the site here and started checking out the install threads. By the time I'd realized it I had called Papa Johns and forgotten all about making some passes with the CAI and ADM scoop combo.
But saturday morning I spent a few hours getting the camera installed. Piece of cake, again following some of the threads here on Camaro5. It was especially easy considering that my 2011 has the little black plastic plate where you install the camera right above the license plate. Pop the plate out, route the wiring up to the front...and done.
I'll get some pics of the camera setup too, although they're all over the site here.
white ZL1 is offline   Reply With Quote
Old 05-05-2012, 10:50 AM   #16
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
It's been an intersting past week for my poor car........
Details in my sig and I'll have vids, the dyno sheet, and details up shortly....
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 05-05-2012, 11:27 AM   #17
Vette TPI
 
Vette TPI's Avatar
 
Drives: 1987 Corvette TPI
Join Date: Mar 2012
Location: Littleton
Posts: 549
Car looks great! Keep it up!
__________________
Vette TPI is offline   Reply With Quote
Old 05-05-2012, 03:24 PM   #18
Overflow
Space Shuttle Aficionado
 
Overflow's Avatar
 
Drives: 7,000,000 lbs. of thrust
Join Date: Jun 2010
Location: Florida
Posts: 29,802
Awesome SS!
__________________
Overflow is offline   Reply With Quote
Old 04-21-2013, 01:46 PM   #19
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
Almost a year since I've updated this, so I figured I'd slowly try to get caught up.

My last post mentioned some changes to the car and referenced my sig. Andy and Ben at ADM Performance hooked me up with an LS3 conversion utilizing a GT11 cam (since I'm still planning on going FI), a set of Stainless Works 1 7/8" headers, a 3" Magnaflow exhaust, and a 3.45 gear.
I dropped the car off on a saturday, the guys tore it apart monday, and had it ready for me to pickup on wednesday. The car picked up 104hp and 71tq with what really is a smaller cam that idles like butter at 650rpm.
Can't beat that.



__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx

Last edited by white ZL1; 04-21-2013 at 02:04 PM.
white ZL1 is offline   Reply With Quote
Old 07-06-2013, 05:24 PM   #20
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
The DFW area has 2 1/4 mile tracks and 4 1/8 mile tracks, and I'm 10 minutes from one of the 1/4 mile tracks and 45 minutes from the other....so to the track she goes!
Temps were in the 90's, and the DA was 2800' in the afternoon but came down to 2200' once the sun went down. Didn't matter. The best pass the car made was 12.50 at 112mph. Corrected times were in the 12.1 range and 115mph, but....wtf! This sucks.
I was on 18" NT05R drag radials but my best 60' ft time was 2.003. So....even with the 4.03 first gear in these 6L80's and the tame GT11 cam, the car needs a converter bad. Real bad.
Don't get me wrong, the car ran 100% fine on the stock converter, it just wasn't even anywhere close to capable of getting the car to 60' at all.
I had fun at the track, but left knowing what mod was next......a new converter. Time to talk to Andy again.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 07-06-2013, 08:49 PM   #21
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
After the 12.50 pass, I knew what the car needed and knew where to go to get it.
But some threads started flying around about this Power Wedge that Vararam came out with, and for $129 what the hell I'll give it a try.
Below is my post and testing data from this thing. I 100% stand by what I did in this testing, and 100% don't understand what this thing does and how it works......but all of the dyno tests that other members have posted that show both torque and horsepower increases certainly mean something.

Quote:
Originally Posted by white 2SS/RS View Post
Did some testing today. 30 minute datalog, installed the wedge, ran it through a heat cycle, tightened it back down, then another 30 minute datalog.
Wideband O2 showed virtually no change in lambda error.
Airflow data is as follows:



Left side is pre-wedge, center is wedge installed, right side is difference between.
Data from 3100-3300 was averaged into the 3200rpm row, and so on and so forth.
I suppose similar data to what Higgs posted? Maybe this does lead towards the equalization of airflow to each cylinder rather than an increase in airflow.
Lethal's dyno test certainly showed an increase in power, so somethings going on.

And I don't want to hear any crap about learning. All tests were done in open loop with a wideband.....and my tune is spot on. I'm MAF only and lambda error was pretty much -2% up to 6000hz and then +/- 0.x% at 6000hz and up.
Now....
That said....
I did end up going back to the track, and after looking at my timeslips (now that I have them all saved in an excel file), the car ran faster in slightly worse air with the Power Wedge.
Best pass before the Power Wedge:
2.00 - 8.17@89.6 - 12.50@112.3 at 2243' DA, so it corrects to a 12.18@115.4mph
With the Power Wedge:
1.97 - 8.04@90.3 - 12.35@112.8 at 2474' DA, so it corrects to a 11.99@116.2mph
So, yeah. Ummm.....
Well, the only thing that I can think of is that the IAT at the start of the 12.50 pass was 120 and at the end of the track is was 93.
The IAT at the start of the 12.35 pass was 93 and at the end of the track it was 88.
If I remember right, I was pushing the car through the lanes that night so maybe that's what the difference was. I'll assume it was.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 07-14-2013, 07:37 AM   #22
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
With a best 60 foot of 1.97 on a tire and corrected passes in the 12.1 range at 115mph, it was time for an upgrade....and badly.
I called Andy at ADM Performance and had him order me a Yank SS 3600 converter. It was installed a few weeks later, and was ready to get back to the track.

Weather this time was awesome. DA actually started the day at -46' (yes, negative at 1:30 in the afternoon) and ended up 280' by 5pm.
If I remember right, the first pass had 20-22psi in the 305/45-18 NT05R's and the car spun to a 1.79 60 and 11.93@114.3mph. So the 60 was better even though I was spinning, and ET was better than the corrected times I was seeing pre converter.

After some playing with tire pressures and launch strategy, I managed to get it down to a 1.66 60 and an 11.76@114.7mph. On that pass though, there's was definitely a tuning issue and the car seemed like it was hitting a rev-limiter around 5000rpm in 1st gear.

And my 60's were all over the place, from the 1.66 to 1.85. Not good.
But I'll still take an 11.76 at nearly 115mph for a full weight car with the little GT11 cam.

Now I just need to figure out this tuning issue and get this car to consistently hook.
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 07-14-2013, 07:58 AM   #23
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
Time for some more appearance mods....
I had Lupe, screenname overhaulengines (find him in the marketplace), paint me up a heritage grill, taillight bezels, and a new rear bowtie.
I also ordered some new sidemarkers from Ivan at Southwest speed.

Heritage Grill
Before:


After:


Much better! I love the way the heritage grill makes the front of these cars look!

Sidemarkers
Before:


After:


Again, much better! The white sidemarkers just blend right in and the white just flows.........

Back
I wanted to get some of the black off the back of this car, so I removed the black painted bezels and partial blackout kit and added white painted taillight bezels and the painted bowtie from Lupe.

Before:


After:


Same again....just love the way this looks. Love it!
__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 07-14-2013, 08:07 AM   #24
white ZL1

 
white ZL1's Avatar
 
Drives: 2013 ZL1 #7922
Join Date: Aug 2011
Location: DFW area
Posts: 1,350
Here's all the pics that I took after the last round of appearance mods...





















__________________

2013 ZL1 #7922
ADM CAI, 90mm tb, 9.55 lower, LS9 cam, FIC 95s, SW 1 7/8" headers, Ron Davis hx
white ZL1 is offline   Reply With Quote
Old 07-14-2013, 08:36 AM   #25
BluePhoenix

 
BluePhoenix's Avatar
 
Drives: 5th gen Camaro again in few months
Join Date: Jul 2013
Location: PA
Posts: 1,301
Car looks amazing! Very nice mod choices!
BluePhoenix is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
got my build sheet demomaster Camaro Price | Ordering | Tracking | Dealers Discussions 18 02-20-2011 10:40 PM
Build from Scratch The_Blur Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 18 04-23-2010 09:39 PM
Detroit News panel wants GM to build Camaro concept Tran 5th Gen Camaro SS LS LT General Discussions 12 03-15-2009 04:38 PM
Why An april build is just as good as a March build Sean_W Camaro Price | Ordering | Tracking | Dealers Discussions 10 02-07-2009 02:51 PM
100 YEARS: GOING FORWARD Mr. Wyndham General Automotive + Other Cars Discussion 0 12-30-2007 01:36 PM


All times are GMT -5. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.