Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Phastek Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions

5th Gen Camaro SS LS LT General Discussions General 5th generation Camaro topics not covered by other subforums.

Reply
 
Thread Tools
Old 06-26-2013, 04:47 AM   #1
London-SS
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Nov 2012
Location: London-Dubai
Posts: 205
Battery Save Mode???

Guys,need some urgent help please. Just got in from a short drive to the mall,on my way back the A/C fan starts to fluctuate and than I feel that the compressor has cut out as it's starting to blow warm air.

The dash than shows the 'The battery save mode activated' message. The voltage gauge is showing just under 12V's. The battery is less than 3 weeks old.
Where should I start on this? Tried doing a search on this issue but not much came up. Has this happened to anyone else?? Should I disconnect the battery to save it?
London-SS is offline   Reply With Quote
Old 06-26-2013, 04:53 AM   #2
SnowVert
 
SnowVert's Avatar
 
Drives: Inferno Orange 2013 SS/RS LS3 6M
Join Date: Oct 2011
Location: Minnesota
Posts: 685
I don't have it in front of me right now, but I'm pretty sure the owner's manual covers this and tells you what you need to do.
__________________
With this in the garage, I smile every day
6/29/2012 New 2013 ordered...
8/21/2012 New 2013 picked up!!!
SnowVert is offline   Reply With Quote
Old 06-26-2013, 04:54 AM   #3
AdamZ
Account Suspended
 
Drives: Eve - 2011 Camaro 2SS/RS
Join Date: Apr 2012
Location: Fairfield, OH
Posts: 17,952
What battery did you use to replace the original?
AdamZ is offline   Reply With Quote
Old 06-26-2013, 05:33 AM   #4
Comrando
SScalator
 
Comrando's Avatar
 
Drives: '11 CGM LS3
Join Date: Mar 2011
Location: Chicagoland
Posts: 6,350
Alternator. Do you have a dealer near?

Cars will run without a battery once you get them started. They rely on the alternator.
__________________
Give me fuel. Give me fire. Give me that which I desire.
http://img.photobucket.com/albums/v87/Slotict/Camaro/Wink-2_zpscd6910bd.jpg
Comrando is offline   Reply With Quote
Old 06-26-2013, 05:37 AM   #5
London-SS
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Nov 2012
Location: London-Dubai
Posts: 205
Quote:
Originally Posted by AdamZ View Post
What battery did you use to replace the original?
Not sure,i'll check.
London-SS is offline   Reply With Quote
Old 06-26-2013, 05:38 AM   #6
London-SS
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Nov 2012
Location: London-Dubai
Posts: 205
Quote:
Originally Posted by Comrando View Post
Alternator. Do you have a dealer near?

Cars will run without a battery once you get them started. They rely on the alternator.
Dealer here in Dubai won't service my car due it being a U.S import!!
London-SS is offline   Reply With Quote
Old 06-26-2013, 07:59 AM   #7
London-SS
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Nov 2012
Location: London-Dubai
Posts: 205
Anymore suggestions?
London-SS is offline   Reply With Quote
Old 06-26-2013, 08:13 AM   #8
Scooter11

 
Scooter11's Avatar
 
Drives: 2013 SW 2LS
Join Date: Feb 2013
Location: Northern NJ
Posts: 1,257
Quote:
Originally Posted by London-SS View Post
Dealer here in Dubai won't service my car due it being a U.S import!!
jerks!
Out of curiosity, did you buy an AGM battery? If not you would want to pick one of those up instead.

But the main reason your battery would drop below 12 V is because the alternator is no longer recharging it, therefore I agree with Comrando, your best plan of action is to replace it as far as I can see.
Scooter11 is offline   Reply With Quote
Old 06-26-2013, 08:32 AM   #9
Badbubba
GrINned & JUICEd
 
Badbubba's Avatar
 
Drives: EB Expedition, 2010 2SS/RS M6
Join Date: Nov 2009
Location: Pittsburgh, PA
Posts: 676
I'm not 100% sure, but I believe the bcm monitors the power state, charge, of the battery. And will adjust the voltage accordingly. When it is fully charged, it will lower the voltage. But it should not be under 12 volts. Mine fluctuates, measuring with a Fluke voltmeter. Check battery and alternator connections, not sure if their may be a fuse or fusable link associated with the alternator/charging circuit that would cause an issue. Guessing alternator issue.? What was the voltage after the battery replacement?
__________________
Nitrous Outlet Plate (progressive, fuel hose upgrade, remote opener, heater, filter, console switches), LNC2000, ARH 1 7/8" LTs/gutted cats/X pipe/mufflers, Jet Hot coated LTs, JRE SCT Tune, CAI, Scoop, Rx Catch Can, Gates heater hose relocation, Remote clutch & auto brake res, Metco loop, Momentum Tunnel Brace, TSW Nurb 18" 555 & 555R, Pfadt trailing arms & toe rods, Autometer wideband, Fesler Pillar Pod, LED strips (int), Lloyds floor & trunk mats, LED DRL/front turn & license plate, DRL harness, VLEDs tail lights, Plasticoat Bowties. Ord: Oct 5, 2009 Rec: Nov 19, 2009 13.17 @ 112.6 stock
Badbubba is offline   Reply With Quote
Old 06-26-2013, 08:51 AM   #10
Hercules
 
Drives: 13 ZL1 1091, 04 Ram 2500, 12 CX9
Join Date: Jul 2012
Location: Lancaster, PA
Posts: 559
+1 on the problem being the alternator. I'm actually surprised that you needed to replace the battery after three years. I don't know what, if any extras you are running could be possibly draining it.
Hercules is offline   Reply With Quote
Old 06-27-2013, 04:39 PM   #11
London-SS
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Nov 2012
Location: London-Dubai
Posts: 205
Thanks for the input guys,just started the car to check if battery was being drained. Voltage is still just below 12V's so all good there. However,the message on the dash has changed to 'service battery charger' I can't remember exactly but something along those lines.
Does this confirm that the alternator is shot 100%
London-SS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.