Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Grabiak Performance Center
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics > Engine | Exhaust | Bolt-On | Drivetrain Modifications

Reply
 
Thread Tools
Old 06-19-2013, 09:17 PM   #1
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
ZL1 AFCO HEAT EXCHANGER BEWARE

Received my heat exchanger from RDP the other day... Today I start the install.

All is going well, remove the front bumper, remove stock heat exchanger, go to install the new one and something just isn't right... Instruction say one thing, but visually looking at my heat exchanger, it doesn't look like the picture... Seem like mine is not made correctly or they sent me the wrong unit... ( first off it is the wrong unit, I ordered the black one ) so I call RDP, not really much help, as RDP hasn't installed one of these, RDP gave me the number to call AFCO... So I call them, the guy was very nice and helpful. I sent him pictures, and sure enough, the unit was incorrectly welded together. ( no wonder why I was having so much problems figuring this thing out ) AFCO told me they are going to inspect their stock for any more that might be screwed up. I was told, he will call me in the morning and will send me the correct heat exchanger ( color too, since RDP ordered the wrong unit ). Afco did tell me that I was the first to report this problem...
Attached Images
 
__________________
kevin1106 is offline   Reply With Quote
Old 06-19-2013, 09:22 PM   #2
Brad7294
 
Drives: 2010 2SS/RS LS3
Join Date: Apr 2011
Location: Greensburg,PA.
Posts: 102
I just put one in. Both tubes should be pointed down when the fans blades are in front of the condenser. directions are not to good.
Brad7294 is offline   Reply With Quote
Old 06-19-2013, 09:27 PM   #3
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
Maybe true for the SS Camaro... But for the zl1, these are the correct way, just the mounting brackets are at the bottom, not the top... Turn it upside down, then the hose fitting is smashed into the radiator... This would definitely work if the brackets were on top, not the bottom...
__________________
kevin1106 is offline   Reply With Quote
Old 06-20-2013, 06:18 AM   #4
dynosteve
www.rdpstore.com

 
dynosteve's Avatar
 
Drives: 2010 SS Camaro Turbo
Join Date: Oct 2009
Location: Painesville Ohio
Posts: 3,581
Send a message via Yahoo to dynosteve
sorry about the issues with the Afco Unit sir, Afco are a very good company and stand behind there products, i also checked our order today that we placed with Afco and it was for a Black unit as well so obviously it was just a mistake on data entry. I Must admit though we have sold many of these units and this is the first one that we have had any issues with, i will follow up with them today as well myself when they open. Thankyou
__________________
www.rdpstore.com Ph: 440 358 5500 or 440 251 8571 SLP / Kooks / SCT / Diablosport / Cold Air Inductions / Whipple / Vortech / TruTrac /Edelbrock / Fore Innovations / DSS / Hayes / Turbonetics / Vredestein / Borla / Maganflow / Corsa / Stainless Works / Hotchkis / EBC / Magnuson / Airaid / Whiteline /Fore Innovations / Snow /Trickflow / Moroso / Hp Tuners / Brembo / Rotofab and much much more
dynosteve is offline   Reply With Quote
Old 06-20-2013, 07:33 AM   #5
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
Quote:
Originally Posted by dynosteve View Post
sorry about the issues with the Afco Unit sir, Afco are a very good company and stand behind there products, i also checked our order today that we placed with Afco and it was for a Black unit as well so obviously it was just a mistake on data entry. I Must admit though we have sold many of these units and this is the first one that we have had any issues with, i will follow up with them today as well myself when they open. Thankyou
Thank you very much!
__________________
kevin1106 is offline   Reply With Quote
Old 06-20-2013, 07:58 AM   #6
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
so where are all the flamers for afco products? this is a perfect example of another company with some QC issues that have slipped through the cracks. welded wrong and wrong color but no torture thread like the one on the badly painted catch can the other day.
joes407 is offline   Reply With Quote
Old 06-20-2013, 08:08 AM   #7
cvp33
America FVCK Yeah!
 
cvp33's Avatar
 
Drives: 2012 CTS-V coupe
Join Date: Mar 2013
Location: Oak Ridge, NC
Posts: 947
Sounds like everyone involved is stepping up to correct the issue....can't really see where any flaming is required.
cvp33 is offline   Reply With Quote
Old 06-20-2013, 08:18 AM   #8
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
Quote:
Originally Posted by cvp33 View Post
Sounds like everyone involved is stepping up to correct the issue....can't really see where any flaming is required.
parties involved the other day did the same as far as correction too yet there was 4 or more pages of b.s flaming in less than an hour before the parties involved could defend themselves or address the issue. to me a wrongly welded part is far worse than a badly painted product, just saying
joes407 is offline   Reply With Quote
Old 06-20-2013, 09:24 AM   #9
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
Quote:
Originally Posted by bumblebeecamaro View Post
There aren't any flamers because this is and probably will be a one time issue. Unlike other forum vendors (which you obviously know who I'm referring to) keep upsetting customers more often than not.

You can color that any way you want Joe, but in the end the truth comes out. Then there's no running from the truth at that point.

But to stay on topic. I'm sure they will get this fixed. I'm actually about to upgrade my heat exchanger and I'm going with the same unit.
that's good ozz, you go with the heat exchanger with possible qc issues and ill stick with my chiller unit from that other vendor you don't seem to like with no qc issues whatsoever for over a year its been on my car. my point is same as before, that all companies no matter how big or small have qc issues and given the chance they will remedy the problem so its not good to single out specific vendors and flame them for issues especially when you haven't even used the product you bash. to sum it up youd still buy product A with known possible QC issues because only 1 bad item surfaced to date but product B you wouldn't buy because of known QC issues as well, even knowing that whether its product A or B the issue would be fixed should you be the unlucky recipient to get the sub-standard piece. a bit of a double standard if you ask me. people here need to realize that no company has singled you out to get the one bad item that slipped through QC so members need not make this a personal ax to grind against any vendors here. yes we want to know what you got, who you got it from and how you like it but if youre not or never have been one of their customers or used their product then keep the bashing to a minimum because you really have no valuable input on that particular topic. im not paid by party B but ive had the opportunity to use and thoroughly enjoy their products, info and services given to me and all of us on these forums.
joes407 is offline   Reply With Quote
Old 06-20-2013, 10:12 AM   #10
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
Quote:
Originally Posted by joes407 View Post
parties involved the other day did the same as far as correction too yet there was 4 or more pages of b.s flaming in less than an hour before the parties involved could defend themselves or address the issue. to me a wrongly welded part is far worse than a badly painted product, just saying
I agree, but shit does happen, and it was just my luck....Just as long as I have my new heat exchanger by tomorrow, I'll be happy....
__________________
kevin1106 is offline   Reply With Quote
Old 06-20-2013, 10:30 AM   #11
Al C.
 
Al C.'s Avatar
 
Drives: ZL1 #529 "El-Jefe"
Join Date: Mar 2012
Location: Las Vegas, NV
Posts: 671
Quote:
Originally Posted by joes407 View Post
that's good ozz, you go with the heat exchanger with possible qc issues and ill stick with my chiller unit from that other vendor you don't seem to like with no qc issues whatsoever for over a year its been on my car. my point is same as before, that all companies no matter how big or small have qc issues and given the chance they will remedy the problem so its not good to single out specific vendors and flame them for issues especially when you haven't even used the product you bash. to sum it up youd still buy product A with known possible QC issues because only 1 bad item surfaced to date but product B you wouldn't buy because of known QC issues as well, even knowing that whether its product A or B the issue would be fixed should you be the unlucky recipient to get the sub-standard piece. a bit of a double standard if you ask me. people here need to realize that no company has singled you out to get the one bad item that slipped through QC so members need not make this a personal ax to grind against any vendors here. yes we want to know what you got, who you got it from and how you like it but if youre not or never have been one of their customers or used their product then keep the bashing to a minimum because you really have no valuable input on that particular topic. im not paid by party B but ive had the opportunity to use and thoroughly enjoy their products, info and services given to me and all of us on these forums.

Didn't you get a free can and chiller from party B? You sir have a bias opinion..
Al C. is offline   Reply With Quote
Old 06-20-2013, 10:42 AM   #12
dynosteve
www.rdpstore.com

 
dynosteve's Avatar
 
Drives: 2010 SS Camaro Turbo
Join Date: Oct 2009
Location: Painesville Ohio
Posts: 3,581
Send a message via Yahoo to dynosteve
Quote:
Originally Posted by kevin1106 View Post
Thank you very much!
not a problem at all Kevin Afco rang me first thing today to follow up on your phone call and they are even checking with other customers to make suit their units are correct as well, its great to see a Manufacturer step up so quickly.
If theres anything i can do sir please just ask.
__________________
www.rdpstore.com Ph: 440 358 5500 or 440 251 8571 SLP / Kooks / SCT / Diablosport / Cold Air Inductions / Whipple / Vortech / TruTrac /Edelbrock / Fore Innovations / DSS / Hayes / Turbonetics / Vredestein / Borla / Maganflow / Corsa / Stainless Works / Hotchkis / EBC / Magnuson / Airaid / Whiteline /Fore Innovations / Snow /Trickflow / Moroso / Hp Tuners / Brembo / Rotofab and much much more
dynosteve is offline   Reply With Quote
Old 06-20-2013, 11:14 AM   #13
urr2slo

 
urr2slo's Avatar
 
Drives: 2010 2ss ss/rs abm
Join Date: Feb 2009
Location: N. Phx, Az
Posts: 1,115
I've installed several of these at work with no issues, we have only sold the black ones so far. I think this is probably a one off issue. AFCO is a stand up company.
__________________
URR2SLO - If you're not going fast enough, get out the way......
urr2slo is offline   Reply With Quote
Old 06-20-2013, 12:14 PM   #14
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
Quote:
Originally Posted by Al C. View Post
Didn't you get a free can and chiller from party B? You sir have a bias opinion..
yes I took a gamble on company B offering me to test some brand new parts on the market before they hit the market and before I even knew these people personally. some I bought and got installed for free and others were free to test period. if those parts were not up to quality I would've said so. many members here have had this same privilege with other companies to try parts before the masses. I think you have missed my point altogether. my posts were and are directed to the people who are bashing companies and products they have never used, that's all. just because I tested some products, still use them to this day and am very happy with them does not mean im sworn to them for life and if I had or have any issue I would bring it up. being an owner and user of such items gives me a right to give input positive or negative but if I was not using said items my commentary would and should be limited to a simple it looks nice or not. certainly I wouldn't go to "oh my god that guy doesn't know how to run a business" because of a bad paint job or slow delivery or 2.
joes407 is offline   Reply With Quote
Old 06-20-2013, 12:32 PM   #15
bumblebeecamaro
Car Lover By Nature
 
Drives: Mini Cooper S
Join Date: Dec 2009
Location: Central FL
Posts: 2,310
Quote:
Originally Posted by joes407 View Post
certainly I wouldn't go to "oh my god that guy doesn't know how to run a business" because of a bad paint job or slow delivery or 2.
you make it sound like party B (as you keep referring him to) has only had one or two instances.

yeah right, one or two instances....... lol
__________________
bumblebeecamaro is offline   Reply With Quote
Old 06-20-2013, 04:50 PM   #16
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
Quote:
Originally Posted by bumblebeecamaro View Post
you make it sound like party B (as you keep referring him to) has only had one or two instances.

yeah right, one or two instances....... lol
whatever ozzman, why don't you buy something before you bash where it came from? as far as im concerned you have no valuable input on either of these threads until you actually have the parts in question and can give input on fit, finish & quality. until then kindly ride your basher bandwagon in another thread. company B has many,many satisfied customers in addition to some that weren't as with all big business.
joes407 is offline   Reply With Quote
Old 06-20-2013, 05:19 PM   #17
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
Quote:
Originally Posted by urr2slo View Post
I've installed several of these at work with no issues, we have only sold the black ones so far. I think this is probably a one off issue. AFCO is a stand up company.
Yeah, sucks it was me to find out. I did order the black heat exchanger, but... Somewhere along the ordering process from A to B, I got the wrong one... Which I would have been ok with, if it fit correctly....

Afco called me this morning and they are sending out another unit ( black this time) also they are overnighting it to me... I couldn't ask for anything else...

I had a problem, between RDP and afco, they took care of it right away...

To all vendors and members, this is all we ask for... Problem? Fixed! ASAP... No BS, no drama, no bashing....
__________________
kevin1106 is offline   Reply With Quote
Old 06-20-2013, 05:32 PM   #18
SinisterEcho


 
SinisterEcho's Avatar
 
Drives: 2010 2SS/RS M6/LS3
Join Date: Oct 2011
Location: Arvada, Co
Posts: 9,986
Glad to see this got resolved so quickly for you!
__________________
My Mod Journal <-- Its updated... again!
SinisterEcho is offline   Reply With Quote
Old 06-20-2013, 08:39 PM   #19
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
Quote:
Originally Posted by SinisterEcho View Post
Glad to see this got resolved so quickly for you!
Me too. It's nice to see a vendor fix a problem ASAP
__________________
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 12:02 AM   #20
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
UPDATE-------- Received my new heat exchanger today, everything turned out great. Black definitely looks better then the standard finish.
Attached Images
 
__________________
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 08:05 AM   #21
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
i was just noticing in this pic that your bumper support is red. did the factory paint it like that? mine is not painted from the factory on my black car
joes407 is offline   Reply With Quote
Old 06-22-2013, 08:18 AM   #22
Hercules
 
Drives: 13 ZL1 1091, 04 Ram 2500, 12 CX9
Join Date: Jul 2012
Location: Lancaster, PA
Posts: 559
Looks good, glad to see everything was taken care of so quickly. It's great to see excellent customer service. It says a lot for the companies that we deal with.
Hercules is offline   Reply With Quote
Old 06-22-2013, 09:10 AM   #23
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
Quote:
Originally Posted by joes407 View Post
i was just noticing in this pic that your bumper support is red. did the factory paint it like that? mine is not painted from the factory on my black car
Mine came like that. It looked the same way on my SS.. Idk, maybe yours had been replaced before you bought the car...




Quote:
Originally Posted by Hercules View Post
Looks good, glad to see everything was taken care of so quickly. It's great to see excellent customer service. It says a lot for the companies that we deal with.
Yes it is, really makes it an easy decision to buy from them again.
__________________
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 09:12 AM   #24
kevin1106


 
kevin1106's Avatar
 
Drives: 2014 3LT-Z51 Vert
Join Date: Nov 2010
Location: La plata MD
Posts: 2,312
Quote:
Originally Posted by joes407 View Post
i was just noticing in this pic that your bumper support is red. did the factory paint it like that? mine is not painted from the factory on my black car
My SS
Attached Images
 
__________________
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 09:17 AM   #25
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,355
[QUOTE=kevin1106;6701058]Mine came like that. It looked the same way on my SS.. Idk, maybe yours had been replaced before you bought the car...





um no i bought the car the car brand new
joes407 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.