Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vitesse Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics > Engine | Exhaust | Bolt-On | Drivetrain Modifications


Reply
 
Thread Tools
Old 06-20-2013, 06:32 PM   #18
SinisterEcho


 
SinisterEcho's Avatar
 
Drives: 2010 2SS/RS M6/LS3
Join Date: Oct 2011
Location: Arvada, Co
Posts: 9,888
Glad to see this got resolved so quickly for you!
__________________
My Mod Journal <-- Its updated... again!
SinisterEcho is offline   Reply With Quote
Old 06-20-2013, 09:39 PM   #19
kevin1106


 
kevin1106's Avatar
 
Drives: 2015 ZO6 3LZ Stage 2 A8
Join Date: Nov 2010
Location: La plata MD
Posts: 2,298
Quote:
Originally Posted by SinisterEcho View Post
Glad to see this got resolved so quickly for you!
Me too. It's nice to see a vendor fix a problem ASAP
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 01:02 AM   #20
kevin1106


 
kevin1106's Avatar
 
Drives: 2015 ZO6 3LZ Stage 2 A8
Join Date: Nov 2010
Location: La plata MD
Posts: 2,298
UPDATE-------- Received my new heat exchanger today, everything turned out great. Black definitely looks better then the standard finish.
Attached Images
 
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 09:05 AM   #21
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,422
i was just noticing in this pic that your bumper support is red. did the factory paint it like that? mine is not painted from the factory on my black car
joes407 is offline   Reply With Quote
Old 06-22-2013, 09:18 AM   #22
Hercules
 
Drives: 13 ZL1 1091, 04 Ram 2500, 12 CX9
Join Date: Jul 2012
Location: Lancaster, PA
Posts: 559
Looks good, glad to see everything was taken care of so quickly. It's great to see excellent customer service. It says a lot for the companies that we deal with.
Hercules is offline   Reply With Quote
Old 06-22-2013, 10:10 AM   #23
kevin1106


 
kevin1106's Avatar
 
Drives: 2015 ZO6 3LZ Stage 2 A8
Join Date: Nov 2010
Location: La plata MD
Posts: 2,298
Quote:
Originally Posted by joes407 View Post
i was just noticing in this pic that your bumper support is red. did the factory paint it like that? mine is not painted from the factory on my black car
Mine came like that. It looked the same way on my SS.. Idk, maybe yours had been replaced before you bought the car...




Quote:
Originally Posted by Hercules View Post
Looks good, glad to see everything was taken care of so quickly. It's great to see excellent customer service. It says a lot for the companies that we deal with.
Yes it is, really makes it an easy decision to buy from them again.
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 10:12 AM   #24
kevin1106


 
kevin1106's Avatar
 
Drives: 2015 ZO6 3LZ Stage 2 A8
Join Date: Nov 2010
Location: La plata MD
Posts: 2,298
Quote:
Originally Posted by joes407 View Post
i was just noticing in this pic that your bumper support is red. did the factory paint it like that? mine is not painted from the factory on my black car
My SS
Attached Images
 
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 10:17 AM   #25
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,422
[QUOTE=kevin1106;6701058]Mine came like that. It looked the same way on my SS.. Idk, maybe yours had been replaced before you bought the car...





um no i bought the car the car brand new
joes407 is offline   Reply With Quote
Old 06-22-2013, 10:24 AM   #26
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,422
pic with bumper off for chiller install, guess they put more paint on the red ones.
Attached Images
 
joes407 is offline   Reply With Quote
Old 06-22-2013, 10:40 AM   #27
kevin1106


 
kevin1106's Avatar
 
Drives: 2015 ZO6 3LZ Stage 2 A8
Join Date: Nov 2010
Location: La plata MD
Posts: 2,298
Quote:
pic with bumper off for chiller install, guess they put more paint on the red ones.
Sure looks that way. At least you can see some black paint. I'd be worried if there was none. lol
kevin1106 is offline   Reply With Quote
Old 06-22-2013, 10:47 AM   #28
SinisterEcho


 
SinisterEcho's Avatar
 
Drives: 2010 2SS/RS M6/LS3
Join Date: Oct 2011
Location: Arvada, Co
Posts: 9,888
That looks really good!
__________________
My Mod Journal <-- Its updated... again!
SinisterEcho is offline   Reply With Quote
Old 06-22-2013, 04:51 PM   #29
kevin1106


 
kevin1106's Avatar
 
Drives: 2015 ZO6 3LZ Stage 2 A8
Join Date: Nov 2010
Location: La plata MD
Posts: 2,298
Quote:
Originally Posted by SinisterEcho View Post
That looks really good!
Thanks, AFCO definitely makes a nice piece. Customer service was very impressive.
kevin1106 is offline   Reply With Quote
Old 06-25-2013, 08:42 AM   #30
PRZL1
 
Drives: ZL1
Join Date: Apr 2013
Location: Puerto Rico
Posts: 19
Well, here is another customer with a bad HX. Just sent a message to RDP so that theu can get back to me on what to do.
PRZL1 is offline   Reply With Quote
Old 06-25-2013, 09:09 AM   #31
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,422
uh oh that's 2 in 1 week.
joes407 is offline   Reply With Quote
Old 06-25-2013, 09:52 AM   #32
jtulery
 
Drives: 2012 CAMARO ZL1, 2012 CTS-V,
Join Date: May 2012
Location: Delaware ohio
Posts: 119
Sounds like everyone involved is stepping up to correct the issue....can't really see where any flaming is required.
jtulery is offline   Reply With Quote
Old 06-25-2013, 10:13 AM   #33
joes407


 
joes407's Avatar
 
Drives: 2014 ZL1m6 red hot #569
Join Date: Dec 2009
Location: florida
Posts: 2,422
Quote:
Originally Posted by kevin1106 View Post
Sure looks that way. At least you can see some black paint. I'd be worried if there was none. lol
maybe the difference is from 2012 to 2013
joes407 is offline   Reply With Quote
Old 06-25-2013, 11:54 AM   #34
PRZL1
 
Drives: ZL1
Join Date: Apr 2013
Location: Puerto Rico
Posts: 19
No flaming, just letting people know that there are issues with these HX. Aparently this is with recent orders.
PRZL1 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:34 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.