Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
SDPC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum


Reply
 
Thread Tools
Old 07-20-2013, 08:10 AM   #1
suzook

 
Drives: camaro
Join Date: May 2013
Location: Stony Brook,NY
Posts: 1,578
replacing stock amp on BA

I will be replacing the stock BA amp with my trusty old kenwood KAC-X4R. This amp has a built in Full DSP with Time Alignment, and parametric EQ options. I am confident this thing will be able to properly EQ the stock BA speakers. As it stands there are too many peaks in the wrong areas making the BA system sound harsh, and canny. Once i receive my Fark harness, and do the install, I will post my results. Im not looking for ear splitting loudness...just quality sound, which i honestly believe the BA speaks can deliver with a quality amp, and some EQ'ing.
__________________
2016 2SS,A8,NAV,NPP,MAG Ride,Sunroof
Hyperblue/JetBlack
suzook is offline   Reply With Quote
Old 07-20-2013, 11:56 PM   #2
JimE


 
JimE's Avatar
 
Drives: 2013 2SS/RS/1LE
Join Date: Apr 2010
Location: St Louis, MO
Posts: 2,992
I'm sure it will. Many have reported improved sound quality with a simple amp replacement.

Good luck...............
__________________
Perm-a-grin in place.....
JimE is offline   Reply With Quote
Old 07-21-2013, 11:06 AM   #3
lfree11012
 
lfree11012's Avatar
 
Drives: Ashen gray 1ss/rs npp
Join Date: Feb 2013
Location: delaware
Posts: 315
lfree11012 is offline   Reply With Quote
Old 07-21-2013, 12:01 PM   #4
FrankT
400HP used to be enough..
 
FrankT's Avatar
 
Drives: 2010 2SS rs manual
Join Date: Aug 2009
Location: Central NC
Posts: 706
I think the stock speakers are up to the task. Good luck on the install. I gutted my entire system and replaced it. I think you'll be pleased with the results.
__________________
Currently in the fleet... 2010 ZR1 Corvette, 2014 Cadillac CTS-V, 2010 Camaro SS single turbo, 2006 Chevrolet 2500HD Duramax, 1967 Camaro SS350, 1969 Camaro SS427.

Build thread: http://www.camaro5.com/forums/showthread.php?t=47925
FrankT is offline   Reply With Quote
Old 07-22-2013, 08:01 AM   #5
suzook

 
Drives: camaro
Join Date: May 2013
Location: Stony Brook,NY
Posts: 1,578
My biggest hurdle is the amp won't fit in the stock location. I'm thinking I could mount it right behind the wheel well....or another option I'm thinking is where the "spare" tire is....I could cut out some of the foam for it to fit nicely on top of it. I will post some pics as I go along....just waiting for my fark....anyone know how long it takes to get it? I ordered Thursday... And still no shipping info.
__________________
2016 2SS,A8,NAV,NPP,MAG Ride,Sunroof
Hyperblue/JetBlack
suzook is offline   Reply With Quote
Old 07-22-2013, 08:07 AM   #6
DuskSS
Bayou City Muscle Cars
 
DuskSS's Avatar
 
Drives: 2013 2SS Dusk Edition
Join Date: Jan 2013
Location: Houston Texas
Posts: 1,442
I just think the stock everything is garbage.
they sound muddy they distort, they just have no clarity at all.

same car as the OP and this is by far the worst premium system I have ever had in any car.
I'm not sure even an amp can help this.
__________________
2013 2SS Dusk Edition
Lethal Racing Stage V
PER 418ci Forged LS3
530/520 SAE
DuskSS is offline   Reply With Quote
Old 07-22-2013, 08:22 AM   #7
suzook

 
Drives: camaro
Join Date: May 2013
Location: Stony Brook,NY
Posts: 1,578
Quote:
Originally Posted by DuskSS View Post
I just think the stock everything is garbage.
they sound muddy they distort, they just have no clarity at all.

same car as the OP and this is by far the worst premium system I have ever had in any car.
I'm not sure even an amp can help this.
They do distort at very high levels...part of the problem is the stock amp. I believe an aftermarket amp will help...as I don't need ear splitting levels....as far as the quality of sound...the amp should help also....along with the eq/DSP settings that are included in the amp I'm installing. Worst case scenario??? I could always swap out the speakers if im not happy with the end result. Btw....i agree that the boston system sucks...def the worst "premium" system in a vehicle.
__________________
2016 2SS,A8,NAV,NPP,MAG Ride,Sunroof
Hyperblue/JetBlack
suzook is offline   Reply With Quote
Old 07-22-2013, 08:35 AM   #8
DuskSS
Bayou City Muscle Cars
 
DuskSS's Avatar
 
Drives: 2013 2SS Dusk Edition
Join Date: Jan 2013
Location: Houston Texas
Posts: 1,442
Quote:
Originally Posted by suzook View Post
They do distort at very high levels...part of the problem is the stock amp. I believe an aftermarket amp will help...as I don't need ear splitting levels....as far as the quality of sound...the amp should help also....along with the eq/DSP settings that are included in the amp I'm installing. Worst case scenario??? I could always swap out the speakers if im not happy with the end result. Btw....i agree that the boston system sucks...def the worst "premium" system in a vehicle.
half on the dial even on above CD ripped music. game over.. dont even think about listening to XM at that level.
anything above elevator music with any kind of mild bass = distort.

Mine must be worse than yours because that it far from "ear splitting" levels before it just flat sucks. hell my engine is louder than the stereo by far now.
__________________
2013 2SS Dusk Edition
Lethal Racing Stage V
PER 418ci Forged LS3
530/520 SAE
DuskSS is offline   Reply With Quote
Old 07-23-2013, 08:27 PM   #9
Camaroshark

 
Drives: 2010 Camaro 2SS/RS RJT, 6speed
Join Date: May 2011
Location: South Florida
Posts: 887
Quote:
Originally Posted by DuskSS View Post
half on the dial even on above CD ripped music. game over.. dont even think about listening to XM at that level.
anything above elevator music with any kind of mild bass = distort.

Mine must be worse than yours because that it far from "ear splitting" levels before it just flat sucks. hell my engine is louder than the stereo by far now.
When I swapped the stock BA amp for a JL XD 400 /4, the muddy sound disappeared... The speakers are still not superb, but they do sound much better than with the factory amp.

C3-650 are going in the doors next weekend.... Provided my ******** package arrives...
__________________
2010 Camaro 2SS/RS, LS3 - 6 speed. Mods, Magnaflow exhaust with resonator delete. ******** 12" stealth box subwoofer kit, Kicker 400 mono amp, JL XD 400/4 amp.
Camaroshark is offline   Reply With Quote
Old 07-23-2013, 10:22 PM   #10
Glen e


 
Glen e's Avatar
 
Drives: Garnet 2LT RS, PCX 150
Join Date: May 2013
Location: Retired from Car Biz/Fort Lauderdale
Posts: 5,564
Yup...my JL's going in Thursday, and then a 10 hour trip to have steve install my hex vents at his shop. Should be a nice trip to test them out.....
Glen e is online now   Reply With Quote
Old 07-27-2013, 10:35 AM   #11
Camaroshark

 
Drives: 2010 Camaro 2SS/RS RJT, 6speed
Join Date: May 2011
Location: South Florida
Posts: 887
I was very happy when I finished mine up.
Attached Images
 
__________________
2010 Camaro 2SS/RS, LS3 - 6 speed. Mods, Magnaflow exhaust with resonator delete. ******** 12" stealth box subwoofer kit, Kicker 400 mono amp, JL XD 400/4 amp.
Camaroshark is offline   Reply With Quote
Old 07-27-2013, 10:42 AM   #12
Camaroshark

 
Drives: 2010 Camaro 2SS/RS RJT, 6speed
Join Date: May 2011
Location: South Florida
Posts: 887
Wired it up the night before...
Attached Images
 
__________________
2010 Camaro 2SS/RS, LS3 - 6 speed. Mods, Magnaflow exhaust with resonator delete. ******** 12" stealth box subwoofer kit, Kicker 400 mono amp, JL XD 400/4 amp.
Camaroshark is offline   Reply With Quote
Old 07-27-2013, 10:53 AM   #13
Glen e


 
Glen e's Avatar
 
Drives: Garnet 2LT RS, PCX 150
Join Date: May 2013
Location: Retired from Car Biz/Fort Lauderdale
Posts: 5,564
Clean looking.....
Glen e is online now   Reply With Quote
Old 07-27-2013, 04:54 PM   #14
suzook

 
Drives: camaro
Join Date: May 2013
Location: Stony Brook,NY
Posts: 1,578
So in went the amp today...fark harness is well worth the $....BA speaks still sound kinda shitty though..even with all the parametric eq settings I have available. These speakers just suck!....WTF was Chevy thinking with the BA system...while im not a big fan of BOSE....they sound way better than the BA. Oh well guess a new set of focals for the front...ill leave the BA's in the rear. I now have a lil pop when the amp turns on/off now too. Maybe Ill just throw the stock amp back...and just be done with it.
__________________
2016 2SS,A8,NAV,NPP,MAG Ride,Sunroof
Hyperblue/JetBlack
suzook is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:10 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.