Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
autoguy
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis


Reply
 
Thread Tools
Old 07-31-2013, 02:01 PM   #35
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: Rockwall, TX
Posts: 1,377
Alright guys, here is an update. I completely removed the rear struts. The driver side one had a slight rattle in it. I'm assuming it was the washer not completely seated against the mount. The outside washer was completely tight so that was a little weird. I reinstalled the newly stacked strut and I believe most if not all the noise is gone from the rear. The only issue now is I found out that one of my bolts for the drop link is completely stripped. How can I get a new nut and bolt for one drop link? there is some pretty good noise in a slow hard turn back there and I'm very certain it's because one side is barely tight since it's stripped. I think the back masked a little bit of front noise too. I need to see about tightening up the front sway bar end links now. It's not near as bad as it was before and could be attributed to not having the bushings timed yet. Thanks for every ones patience and help.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-31-2013, 07:52 PM   #36
TLSTWIN
Romans10:9-13
 
TLSTWIN's Avatar
 
Drives: /\yes, this is me/\
Join Date: Nov 2008
Location: Vermilion, Ohio
Posts: 3,934
Good to hear you found the problem.

How did it strip?
__________________
R.I.P. http://www.camaro5.com/forums/showthread.php?t=373249
Back Street Performance has done a great job with ALL my Performance & Suspension mods, highly recommend them (Rich@BSP) he's in my friends list. https://youtu.be/Lht8sKe1Maw
TLSTWIN is offline   Reply With Quote
Old 07-31-2013, 08:04 PM   #37
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: Rockwall, TX
Posts: 1,377
Quote:
Originally Posted by TLSTWIN View Post
Good to hear you found the problem.

How did it strip?
It's really trashed. The other side looks fine. I'm not sure what the heck happened.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-31-2013, 09:07 PM   #38
caverman


 
caverman's Avatar
 
Drives: '69 SS Convertible
Join Date: May 2009
Location: DFW, TX
Posts: 7,105
I would have to see what you mean by completely striped. Is it rounded off? are the threads all boogered up? What is making you say it's stripped?

I would say you need to get with Pete and possibly get another drop link. If it's stripped as in is the threads are all messed up then your going to have to get a new bolt or re-tap that one. Probably easier just to get a new one.

BTW: don't for get to use some blue locktite when putting your bolts on. I had a nut on my drop link back off. The drop link then came out of the bottom of the LCA and jammed up inside the LCA pretty good. Threw off my alignment as well.
__________________
-2010 Camaro 2SS | M6 | VR w/White Stripes | 1 3/4" KOOKS - 3" Magnaflow | LPE 3.91 gears | ADM tuned | Halltech w/ADM Scoop | Spohn/BMR Trailing Arm/Toe Rod | BC Coilovers| Pedders FE4 ZL1 swaybars | Cradle/Diff/Radius Rod bushings | VMax TB | Morimoto Projectors | MGW shifter | Red Calipers
Build Journal
caverman is offline   Reply With Quote
Old 07-31-2013, 09:20 PM   #39
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: Rockwall, TX
Posts: 1,377
Quote:
Originally Posted by caverman View Post
I would have to see what you mean by completely striped. Is it rounded off? are the threads all boogered up? What is making you say it's stripped?

I would say you need to get with Pete and possibly get another drop link. If it's stripped as in is the threads are all messed up then your going to have to get a new bolt or re-tap that one. Probably easier just to get a new one.

BTW: don't for get to use some blue locktite when putting your bolts on. I had a nut on my drop link back off. The drop link then came out of the bottom of the LCA and jammed up inside the LCA pretty good. Threw off my alignment as well.
Loctite is on everything. Bolt is on the car but just the first 1/4" is salvageable. The rest is essentially smoothed out.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 08-01-2013, 12:04 AM   #40
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Take the damaged bolt off and walk into the nearest Fastenal store. They should have a match on the shelf or you could just email AR@peddersusa.com and ask for a replacement bolt and nut. We'll be happy to ship one to you.
JusticePete is offline   Reply With Quote
Old 08-01-2013, 02:06 PM   #41
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: Rockwall, TX
Posts: 1,377
Quote:
Originally Posted by JusticePete View Post
Take the damaged bolt off and walk into the nearest Fastenal store. They should have a match on the shelf or you could just email AR@peddersusa.com and ask for a replacement bolt and nut. We'll be happy to ship one to you.
I will email since I'm out of town for awhile now. Thanks
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 08-04-2013, 05:35 PM   #42
edog


 
edog's Avatar
 
Drives: 2010 2SS/RS IOM
Join Date: Oct 2008
Location: F'BURG VA
Posts: 3,641
Mine did that. I had to tighten the rear end links making sure I used a hex wrench and a socket ensuring it was tightened properly.

Nothing else was loose in my situation.
__________________
LS3 Conversion 113/225/238 COMP CAM, 3200 Stall, Doug Thorley Tri-Y LT/HF cat, Xpipe, Ported TB, 160 therm, Tranny cooler, Halltech CAI, Pedders sways, endlinks, 1" Eibach Drop Springs, 3.45 rear gears. Tuned by Doug @ ECS. 435HP/420TQ
edog is offline   Reply With Quote
Old 08-04-2013, 10:52 PM   #43
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by ackeight View Post
I will email since I'm out of town for awhile now. Thanks
Cool.
JusticePete is offline   Reply With Quote
Old 08-06-2013, 06:37 PM   #44
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: Rockwall, TX
Posts: 1,377
Does this gap look normal on the front mounts? I'm trying to diagnose a slight noise in the front now that the back has quieted down. Name:  ImageUploadedByTapatalk1375828617.958330.jpg
Views: 108
Size:  147.8 KBName:  ImageUploadedByTapatalk1375828631.371200.jpg
Views: 119
Size:  158.3 KB
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 08-06-2013, 06:42 PM   #45
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Yep.

JusticePete is offline   Reply With Quote
Old 08-06-2013, 06:42 PM   #46
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
What is the noise?
JusticePete is offline   Reply With Quote
Old 08-06-2013, 07:46 PM   #47
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: Rockwall, TX
Posts: 1,377
Quote:
Originally Posted by JusticePete View Post
What is the noise?
A much more quiet version of what I had in the rear. I can almost feel it in the seat. I'm going to check my end link bolts again once I get my replacement rear drop link bolt in the mail. I put inserts in the front radius rod too.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 08-06-2013, 07:52 PM   #48
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
You know the drill. Lay a wrench on every nut and bolt including the tie rod ends and ball joints.
JusticePete is offline   Reply With Quote
Old 08-06-2013, 08:05 PM   #49
TLSTWIN
Romans10:9-13
 
TLSTWIN's Avatar
 
Drives: /\yes, this is me/\
Join Date: Nov 2008
Location: Vermilion, Ohio
Posts: 3,934
Quote:
Originally Posted by ackeight View Post
A much more quiet version of what I had in the rear. I can almost feel it in the seat. I'm going to check my end link bolts again once I get my replacement rear drop link bolt in the mail. I put inserts in the front radius rod too.
You would be surprised how noisy a end link can be if it is not completely tight. I know
__________________
R.I.P. http://www.camaro5.com/forums/showthread.php?t=373249
Back Street Performance has done a great job with ALL my Performance & Suspension mods, highly recommend them (Rich@BSP) he's in my friends list. https://youtu.be/Lht8sKe1Maw
TLSTWIN is offline   Reply With Quote
Old 08-07-2013, 11:15 AM   #50
GTAHVIT
Blessed
 
GTAHVIT's Avatar
 
Drives: 2013 Sonic RS MT
Join Date: Dec 2007
Location: Saint Augustine FL
Posts: 28,499
Quote:
Originally Posted by TLSTWIN View Post
You would be surprised how noisy a end link can be if it is not completely tight. I know
Me too.

lol
GTAHVIT is offline   Reply With Quote
Old 08-11-2013, 10:20 AM   #51
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: Rockwall, TX
Posts: 1,377
End links are tight. Are you supposed to be able to turn the front springs when the car is raised? The lower silver portion of the mount spins too. I know I set the preload to 4 mm. There is no lateral movement.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.