Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
PFYC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 08-25-2013, 12:31 PM   #1
DJ-Silver 2SS
Ah DJ-IOM ZL1 haha
 
DJ-Silver 2SS's Avatar
 
Drives: 13 IOM ZL1 M6 & 10 SIM 2SS M6
Join Date: Jul 2009
Location: Augusta, GA
Posts: 520
Send a message via Yahoo to DJ-Silver 2SS
What could cause an end link to snap?

As I was going through the underside of my 2SS after running through a big pile of mud..... I pulled off my wheels and inner fenders to pressure wash all of the mud. As I was inspecting my front suspension, I noticed a rod that was snapped into 2 pieces. Not sure what it was attached to, so I stuck my head farther in and realized it was the sway bar end link!!!!! It has snapped in two!!!

Now I've been in and around building cars for over 20 years and I have never seen this on a street car. This car has never been on a track and the suspension is in stock form!!!

Does anyone have an idea what could have caused this breakage?
Attached Images
 
__________________

2013 IOM ZL1 #002415 Born 09/13/12
2010 SIM 2SS/RS #005549 Born 05/02/09
DJ-Silver 2SS is offline   Reply With Quote
Old 08-25-2013, 12:33 PM   #2
tramtwo


 
Drives: 2013 1LE
Join Date: Jul 2011
Location: N'Awlinz
Posts: 6,521
So you where four wheeling in the mud with a camaro?

Sent from my DROID RAZR using Tapatalk 2
tramtwo is offline   Reply With Quote
Old 08-25-2013, 12:41 PM   #3
DJ-Silver 2SS
Ah DJ-IOM ZL1 haha
 
DJ-Silver 2SS's Avatar
 
Drives: 13 IOM ZL1 M6 & 10 SIM 2SS M6
Join Date: Jul 2009
Location: Augusta, GA
Posts: 520
Send a message via Yahoo to DJ-Silver 2SS
Hahahahaha. No.
I was driving on the local army post and on a road I drive on regularly, they had what seemed to be a mud slide over the weekend and I didn't really see it until it was too late, I thought is was just water.
__________________

2013 IOM ZL1 #002415 Born 09/13/12
2010 SIM 2SS/RS #005549 Born 05/02/09
DJ-Silver 2SS is offline   Reply With Quote
Old 08-25-2013, 12:43 PM   #4
102SS
waiting at the tree
 
102SS's Avatar
 
Drives: SIM 2010 2SS/RS A6
Join Date: Apr 2013
Location: Niagara Falls
Posts: 688
I have broken a few(stock and aftermarket) on my 4th gens with just aggressive street driving and tight off and on ramps.
__________________
2010 2SS/RS A6 DD K/N CAI
60ft 2.03 13.08 at 107.82 (4/28)
1999 TA NBM A4
12.2 at 110
102SS is offline   Reply With Quote
Old 08-25-2013, 12:48 PM   #5
danvillekidd
2013 ZL1
 
danvillekidd's Avatar
 
Drives: 2013 ZL1 m6
Join Date: Oct 2010
Location: Danville, IN & Holloman AFB, NM
Posts: 684
I had the same thing happen in my SS. Not sure if it was caused by a pot hole or bump of some kind. I don't think they are quite strong enough. I found mine getting ready to install my Pedders parts so I never put a stock one back on. No problems with the Pedders ones.
__________________
danvillekidd is offline   Reply With Quote
Old 08-25-2013, 12:56 PM   #6
Apex Motorsports

 
Apex Motorsports's Avatar
 
Drives: 2000 Camaro SS
Join Date: Feb 2010
Location: Louisville, Ky.
Posts: 23,100
The stock end links on the 2010-2011 SS are pretty pitiful to be honest. It is not uncommon for them to fail especially when the car is driven aggressively. An end link upgrade is basically required if you go to stiffer aftermarket sway bars.
__________________
Apex Motorsports is offline   Reply With Quote
Old 08-25-2013, 02:22 PM   #7
rdblan2

 
Drives: 2SS RS
Join Date: Mar 2010
Location: MD
Posts: 1,223
How big was the pothole you hit a while back?
__________________
Livernois 2C cam and tune, LS3 conversion, Roto-Fab intake, Kooks headers, DSS driveshaft and axles, BMR suspension parts, VMax ported throttle body, Whipple blower. (623hp).
rdblan2 is offline   Reply With Quote
Old 08-25-2013, 04:08 PM   #8
SPCBA
Blake
 
SPCBA's Avatar
 
Drives: pleather and Chiclets
Join Date: Mar 2012
Location: a VA line somwhere
Posts: 3,707
potholes, curbs, improper torque etc many reasons. they are a cheap upgrade and easy diy
__________________
SPCBA is offline   Reply With Quote
Old 08-25-2013, 04:15 PM   #9
Mr. iNCREDIBLE


 
Mr. iNCREDIBLE's Avatar
 
Drives: 2012 2SS/RS Convertible
Join Date: Aug 2012
Location: SoCal Baby...
Posts: 2,298
looks like the bushing are shot to hell as well.


sad if that happened in only 3 years, cheap parts.
__________________
"A world 100% full of Prius drivers is still 100% addicted to oil. " ~ E. Musk
Mr. iNCREDIBLE is offline   Reply With Quote
Old 08-25-2013, 05:23 PM   #10
PAUL SS
The Mark of Excellence
 
PAUL SS's Avatar
 
Drives: 2010 ABM 1SS RS LS3
Join Date: Jan 2009
Location: Smallest State in the Union
Posts: 8,400
Quote:
Originally Posted by Apex Chase View Post
The stock end links on the 2010-2011 SS are pretty pitiful to be honest. It is not uncommon for them to fail especially when the car is driven aggressively. An end link upgrade is basically required if you go to stiffer aftermarket sway bars.
This.

Those end links are like tooth picks especially the front ones considering their length.
__________________
BMR, CAI, DynoMax, Elite Eng., Hurst, Jannetty, Clear Image Headers & Hi Flow cats, Jet Hot, LSR, TSW, Vredestein
PAUL SS is offline   Reply With Quote
Old 08-26-2013, 10:53 AM   #11
BMR Sales



 
Drives: 2010 2SS/RS R6P
Join Date: Sep 2009
Location: Seffner, FL
Posts: 2,276
Quote:
Originally Posted by DJ-Silver 2SS View Post
As I was going through the underside of my 2SS after running through a big pile of mud..... I pulled off my wheels and inner fenders to pressure wash all of the mud. As I was inspecting my front suspension, I noticed a rod that was snapped into 2 pieces. Not sure what it was attached to, so I stuck my head farther in and realized it was the sway bar end link!!!!! It has snapped in two!!!

Now I've been in and around building cars for over 20 years and I have never seen this on a street car. This car has never been on a track and the suspension is in stock form!!!

Does anyone have an idea what could have caused this breakage?
It is pretty rare to see the end link break like your did, more times than not the ends get a lot of tolerance in them and become noisy. If I had to guess it was either a pothole, curb, or maybe even just a manufacturing flaw in the factory end link that created the failure.

Our BMR end links are much stronger than the factory units and are just as quite as the factory end links due to their design. If there is any way we can help you out let us know.

__________________
Keith Kanyuh
5th Gen Camaro Suspension Specialist
keith@bmrsuspension.com
www.bmrsuspension.com
Like us on Facebook!
BMR Sales is offline   Reply With Quote
Old 08-26-2013, 01:28 PM   #12
JDP Tyler

 
JDP Tyler's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Nov 2010
Location: SLC, UT
Posts: 6,644
Yep this is fairly common, but not so much with the stock sway bars. But if you have to replace, upgrade! Feel free to call, PM or email me anytime with questions or pricing.

Best regards,

Tyler
888-308-6007
__________________
JDP Tyler is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.