Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions

5th Gen Camaro SS LS LT General Discussions General 5th generation Camaro topics not covered by other subforums.

Closed Thread
 
Thread Tools
Old 08-30-2013, 11:24 AM   #1
sstnt
 
sstnt's Avatar
 
Drives: 2010 Camaro SS!
Join Date: May 2009
Location: Broomfield, CO
Posts: 194
Clutch & Click?

Posted this in the Transmissions forum, but no replies. Maybe someone here can help out.

Anyone know what might cause a click when I push in or let out the clutch pedal to go into 1st and sometimes 2nd? Sometimes doesn't happen, but more often than not it does. Seems to be coming from under the car...almost from the back, but that could just be the acoustics. Doesn't seem to have impacted the function, just annoying and a bit concerning. Any ideas? Should I be worried?
__________________
1SS ABM Manual, Black int., 20" PAWs, Sunroof
$$ down on dealer car #3466, pending Pw: 6-10-2009
Car Picked up by Shipper: 6-22-2009
Car has ARRIVED: 6-24-2009 (and she's a beauty!)
sstnt is offline  
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.