Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums -
Night Owl LED
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8

Thread Tools
Old 09-11-2013, 11:31 AM   #1
RichP's Avatar
Drives: 2013 Camaro SS Vert L99
Join Date: Mar 2013
Location: Austin, TX
Posts: 102
Question Anyone running JBA or Solo Cats behind a turbo or supercharger?

Wanted to put high flow cats(and maybe shorties) on now and then maybe do a Turbonetics kit later on.

Will either the JBAs or Solos live behind a turbo with a conservatve tune?

I'd be happy with 500rhwp (L99)

RichP is offline   Reply With Quote
Old 09-12-2013, 11:04 AM   #2

Drives: 2010
Join Date: Jul 2009
Location: NH
Posts: 4,697
quite a few people on here have high flow cats installed...
600hp-lpe is offline   Reply With Quote
Old 09-12-2013, 11:21 AM   #3

Drives: 2006 Z06
Join Date: Oct 2010
Location: Gilbert, AZ
Posts: 4,228
I would save your money, then just do a nice TT kit. It will be cheaper in the long run and make a lot more power.
Corvette Z06 -1200ish rwhp
Unreal is online now   Reply With Quote
Old 09-12-2013, 12:12 PM   #4
Account Suspended
Drives: SS/RS
Join Date: May 2010
Location: Transplanted from NYC..(ret. NYPD).Now in CT
Posts: 905
Send a message via AIM to epstein
I bought mine used with headers from a fellow member who was SC... and the biscuits were loose already..... I just helped them along.......
epstein is offline   Reply With Quote
Old 09-12-2013, 12:22 PM   #5

Drives: 2011 2SS
Join Date: Jun 2013
Location: Kansas City
Posts: 855
I am not sure with a Turbo how they will do but with many FI situations people have had there cats start to collapse there is sever threads about that on here, however others will argue this will not happen with the appropriate tune. I had the jba on my car with long tube on a maggie set up but got rid of them just to keep from worrying.
2011 2SS,fti th400, ECS 1500, Flex Fuel, Boost built 376, squash fuel system
pdiddy is offline   Reply With Quote
Old 09-14-2013, 12:28 PM   #6
EOD's Avatar
Drives: 1968 Camaro SS & 2015 GMC Sierra De
Join Date: Nov 2012
Location: Camp Lejeune, NC
Posts: 89
I've had JBA cats and long tubes on my car for 25,000 miles. No issues to date, took the exhaust off a couple of month ago and there werent any noticable problems
Whipple SC, Lingenfelter Heads & Cam, ACT Twin Disc Clutch, Rotofab CAI, JBA 1 7/8" Long Tube Headers & 3" Exhaust, Livernois Motorsports Fuel Pump, DSS 1400Hp Axles
RWHP 660
EOD is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 10:16 AM.

Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.