Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions

5th Gen Camaro SS LS LT General Discussions General 5th generation Camaro topics not covered by other subforums.

Reply
 
Thread Tools
Old 10-11-2013, 06:42 PM   #1
alvar350z
 
Drives: charcoal
Join Date: Oct 2013
Location: TX
Posts: 13
JET skip shift eliminator

Hi guys, it may sound silly but I need help installing my JET skip shift eliminator. The reason is because the connector has some kind of black silicone on one end. I dont know if I need to remove this or not. When I installed this on my GTO it didnt have that black thing on one end, thats what is throwing me off. Anyone have any experience on these eliminators?
Thanks for your help in advance!
alvar350z is offline   Reply With Quote
Old 10-11-2013, 10:57 PM   #2
alvar350z
 
Drives: charcoal
Join Date: Oct 2013
Location: TX
Posts: 13
Thanks for the answers that were pmd. U guys are great. Just in case someone else has this issue, the black silicone is not to be removed. The JET eliminator does not create a link between the cables. U just plug one end with the blue/white connector and connect the Jet cable to the other end. Leaving the original cable separated. I taped the silicone edge with electrical tape just to be sure no water or dirt could get in. Anyone having same question pm me and I'll gladly send u pics of the finished work
It's all about teamwork. FYI I'm glad to back to the V8 world!
alvar350z is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.