Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Member Car Journals


Reply
 
Thread Tools
Old 11-24-2013, 11:43 AM   #29
Chris-10


 
Chris-10's Avatar
 
Drives: 2ss/rs vr 6m
Join Date: Mar 2009
Location: New Port Richey,fl
Posts: 2,711
Badazz ride man!!!
__________________
My build thread.click the pic. COTW 10/24/11
Chris-10 is offline   Reply With Quote
Old 11-24-2013, 12:03 PM   #30
n2oblkz
 
Drives: 1996 Z28
Join Date: Jun 2011
Location: Versailles, IN
Posts: 12
Quote:
Originally Posted by timtoolman24 View Post
Getting a VFN hood installed today after work! Pics to soon come.
Which hood are you doing?
n2oblkz is offline   Reply With Quote
Old 11-27-2013, 06:26 PM   #31
timtoolman24
 
timtoolman24's Avatar
 
Drives: 2012 LS3 2SS/RS
Join Date: Jul 2012
Location: Baton Rouge, LA
Posts: 494
VFN Copo style hood, I have it on now and love it. I need to upload the pic and post it.
__________________
timtoolman24 is offline   Reply With Quote
Old 11-27-2013, 07:46 PM   #32
timtoolman24
 
timtoolman24's Avatar
 
Drives: 2012 LS3 2SS/RS
Join Date: Jul 2012
Location: Baton Rouge, LA
Posts: 494
Uploaded to new hood pics
__________________
timtoolman24 is offline   Reply With Quote
Old 11-30-2013, 09:25 PM   #33
TEXZL1
 
Drives: 2013 ZL1 Summit White
Join Date: Nov 2013
Location: Houston, TX
Posts: 3
Where did you get your wheels? What are the specs and offset?
TEXZL1 is offline   Reply With Quote
Old 12-02-2013, 04:21 AM   #34
timtoolman24
 
timtoolman24's Avatar
 
Drives: 2012 LS3 2SS/RS
Join Date: Jul 2012
Location: Baton Rouge, LA
Posts: 494
D2Forged wheels, dont know offset give them a call

Quote:
Originally Posted by TEXZL1 View Post
Where did you get your wheels? What are the specs and offset?
__________________
timtoolman24 is offline   Reply With Quote
Old 12-02-2013, 04:26 AM   #35
timtoolman24
 
timtoolman24's Avatar
 
Drives: 2012 LS3 2SS/RS
Join Date: Jul 2012
Location: Baton Rouge, LA
Posts: 494
Well went to the track today, and total failure. Three runs and no complete pass. First run did great burn out, launched car real good, went to shift to second gear and clutch wasnt having it haha (stock clutch) I couldnt get it in second and rev engine up pretty high so aborted run. Second pass, launched and had zero power! Looked and everything couldnt find anything wrong so I went for third pass, same thing no power. Got home and jacked car up to find a .25 cent part had ruined my day! A hose clamp on my procharger had broke causing the hose to blow off! NO BOOST NO GO! So I'm redo all my plumming and getting big T-bolt clamps to hold it together! Try again next time.
__________________
timtoolman24 is offline   Reply With Quote
Old 12-03-2013, 05:24 AM   #36
SUKXOST
Do you even lift, bro?
 
SUKXOST's Avatar
 
Drives: 2013 1LE Camaro
Join Date: Aug 2012
Location: Sumter, SC
Posts: 3,158
didnt see internals on your mod list...you on stock bottom end @ over 800whp? What kind of boost are you running?
__________________
My 1LE (645WHP/597WTQ) build/journal Thread:
1st ever 1LE COTW http://www.camaro5.com/forums/showthread.php?t=255461
SUKXOST is offline   Reply With Quote
Old 12-03-2013, 05:37 AM   #37
timtoolman24
 
timtoolman24's Avatar
 
Drives: 2012 LS3 2SS/RS
Join Date: Jul 2012
Location: Baton Rouge, LA
Posts: 494
Stock internals, If I remember right its 14psi at max boost
__________________
timtoolman24 is offline   Reply With Quote
Old 12-03-2013, 05:46 AM   #38
Stecky
 
Drives: 0000
Join Date: Sep 2013
Location: none
Posts: 265
That's Cool.
It looked like you could have blown a hole in the wall, when it was on the dyno.
Like the hood accecent .
Stecky is offline   Reply With Quote
Old 12-03-2013, 06:25 AM   #39
SUKXOST
Do you even lift, bro?
 
SUKXOST's Avatar
 
Drives: 2013 1LE Camaro
Join Date: Aug 2012
Location: Sumter, SC
Posts: 3,158
Quote:
Originally Posted by timtoolman24 View Post
Stock internals, If I remember right its 14psi at max boost
wowza....it's incredible to me that it hasn't gone boom. I'm @ 11 and 12 sometimes and I'm about to change my set up to reduce boost (and yes some power) but I cant stand the thought of blowing my motor at 11/12lbs.
__________________
My 1LE (645WHP/597WTQ) build/journal Thread:
1st ever 1LE COTW http://www.camaro5.com/forums/showthread.php?t=255461
SUKXOST is offline   Reply With Quote
Old 12-06-2013, 05:33 PM   #40
timtoolman24
 
timtoolman24's Avatar
 
Drives: 2012 LS3 2SS/RS
Join Date: Jul 2012
Location: Baton Rouge, LA
Posts: 494
??

Quote:
Originally Posted by Stecky View Post
That's Cool.
It looked like you could have blown a hole in the wall, when it was on the dyno.
Like the hood accecent .
__________________
timtoolman24 is offline   Reply With Quote
Old 12-06-2013, 05:53 PM   #41
kold

 
kold's Avatar
 
Drives: 2011 LS White Camaro
Join Date: Jul 2011
Location: Santa Maria,CA
Posts: 1,168
DAM!!!!!!!!!!! DAM!!!!!!!!!
kold is offline   Reply With Quote
Old 12-10-2013, 04:36 AM   #42
timtoolman24
 
timtoolman24's Avatar
 
Drives: 2012 LS3 2SS/RS
Join Date: Jul 2012
Location: Baton Rouge, LA
Posts: 494
ON ORDER!!!! Billet built 4l80 full manual, with rachet shifter! Being built as we speak.
__________________
timtoolman24 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:12 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.