Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Classic Design Concepts
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 07-18-2009, 11:13 AM   #1
robsmack920
 
Drives: 2010 2SS #3894
Join Date: Jan 2009
Location: houston texas
Posts: 34
Is the paint under warranty?

under my spoiler on the passenger side, under the spoiler my paint seems to be rubbing off. anyone else have this issue? and is that under warranty?
robsmack920 is offline   Reply With Quote
Old 07-18-2009, 12:46 PM   #2
thanxa
 
Drives: zr1
Join Date: Apr 2009
Location: fl
Posts: 8
Regardless of what posters with good intentions tell you , you need to approach any GM dealer with warranty issues . " They did this or they refused to honor that " means nothing . Every issue is an individual case . I've been selling GM for 45 years as well as other brands like Ferrari and they all have their factory guidance that they must follow . If they discover it to be their fault they will honor the paint warranty , however if its brake fluid , or some other chemical that caused it , even without you witnessing it then all bets are off . Trucks drive on our roads with Pest control , pool chemicals , etc that may have easily caused this . Your dealer will know immediately and if its their fault they will get paid to paint it .
thanxa is offline   Reply With Quote
Old 07-18-2009, 12:48 PM   #3
Indpowr
Account Suspended
 
Drives: Corvette C6
Join Date: May 2008
Location: Florida
Posts: 7,028
yes they should cover it.
Indpowr is offline   Reply With Quote
Old 07-18-2009, 12:51 PM   #4
fldrummer
"Black Ace"
 
fldrummer's Avatar
 
Drives: 2SS/RS black/black
Join Date: Aug 2008
Location: Ft. Lauderdale, FL
Posts: 1,731
I have the exact same issue in the same area. It's as if they painted the car with the spoiler already on and the paint didn't get in that one little crack. It should be covered as a factory defect, IMHO, because that could spread over time and then your whole trunk lid is peeling paint. It's just one of many little issues I keep finding with mine, in addition to the mis-aligned door & dash, driver seat clicking noises and the weather stripping coming loose behind both my rear windows. I'm gonna make a laundry list of these warranty issues for the first time I take the car back to the dealer for work.
fldrummer is offline   Reply With Quote
Old 07-18-2009, 01:03 PM   #5
robsmack920
 
Drives: 2010 2SS #3894
Join Date: Jan 2009
Location: houston texas
Posts: 34
well my case is, it looks like the paint wasn't dry when they put the spoiler on (i think) and the spoiler is rubbing the paint off somehow



Quote:
Originally Posted by thanxa View Post
Regardless of what posters with good intentions tell you , you need to approach any GM dealer with warranty issues . " They did this or they refused to honor that " means nothing . Every issue is an individual case . I've been selling GM for 45 years as well as other brands like Ferrari and they all have their factory guidance that they must follow . If they discover it to be their fault they will honor the paint warranty , however if its brake fluid , or some other chemical that caused it , even without you witnessing it then all bets are off . Trucks drive on our roads with Pest control , pool chemicals , etc that may have easily caused this . Your dealer will know immediately and if its their fault they will get paid to paint it .
robsmack920 is offline   Reply With Quote
Old 07-18-2009, 02:29 PM   #6
Hebe4
 
Hebe4's Avatar
 
Drives: 2010 Black 2SS/RS M6
Join Date: Oct 2008
Location: BC
Posts: 115
Quote:
Originally Posted by fldrummer View Post
I have the exact same issue in the same area. It's as if they painted the car with the spoiler already on and the paint didn't get in that one little crack. It should be covered as a factory defect, IMHO, because that could spread over time and then your whole trunk lid is peeling paint. It's just one of many little issues I keep finding with mine, in addition to the mis-aligned door & dash, driver seat clicking noises and the weather stripping coming loose behind both my rear windows. I'm gonna make a laundry list of these warranty issues for the first time I take the car back to the dealer for work.
You mean like this.
Attached Images
 
Hebe4 is offline   Reply With Quote
Old 07-18-2009, 02:33 PM   #7
robsmack920
 
Drives: 2010 2SS #3894
Join Date: Jan 2009
Location: houston texas
Posts: 34
BLAME CANADA!!!!!!!!!!!!!!!!!

Quote:
Originally Posted by Hebe4 View Post
You mean like this.
robsmack920 is offline   Reply With Quote
Old 07-18-2009, 02:34 PM   #8
bobby35ny

 
bobby35ny's Avatar
 
Drives: 2013 ZL1
Join Date: Nov 2008
Location: South East, FL
Posts: 1,617
Quote:
Originally Posted by robsmack920 View Post
under my spoiler on the passenger side, under the spoiler my paint seems to be rubbing off. anyone else have this issue? and is that under warranty?
Is the spoiler loose and maybe rubbing off the paint?

-bobby
__________________
ZL1::J-E-T-S JETS JETS JETS
bobby35ny is offline   Reply With Quote
Old 07-18-2009, 02:44 PM   #9
robsmack920
 
Drives: 2010 2SS #3894
Join Date: Jan 2009
Location: houston texas
Posts: 34
it's not loose at all, but it's taking the paint off somehow

Quote:
Originally Posted by bobby35ny View Post
Is the spoiler loose and maybe rubbing off the paint?

-bobby
robsmack920 is offline   Reply With Quote
Old 07-18-2009, 04:17 PM   #10
bobby35ny

 
bobby35ny's Avatar
 
Drives: 2013 ZL1
Join Date: Nov 2008
Location: South East, FL
Posts: 1,617
Quote:
Originally Posted by robsmack920 View Post
it's not loose at all, but it's taking the paint off somehow
Remember, there is alot of downforce there, maybe retorque the spoiler?

-bobby
__________________
ZL1::J-E-T-S JETS JETS JETS
bobby35ny is offline   Reply With Quote
Old 07-18-2009, 04:50 PM   #11
Paperer
Ragin' Cajun
 
Paperer's Avatar
 
Drives: '02 Camaro SS - '10 CGM 2SS/RS
Join Date: Jul 2008
Location: Texas/Oklahoma
Posts: 1,170
I got a huge warranty with mine, I don't plan on modding it, might put a snazzy SS/RS badge on the inside, but that's it. Anyway, with my warranty it covered everything. If the paint is scratched they'll fix it or a dent, they'll fix it. (Has to be smaller than a credit card...)

But in your case, if it's something from the factory that messed it up, I don't see any reason why they wouldn't or couldn't cover it.
__________________
http://img.photobucket.com/albums/v202/paper2302/Siggy.jpg
Paperer is offline   Reply With Quote
Old 07-18-2009, 05:23 PM   #12
Ranger 75
 
Ranger 75's Avatar
 
Drives: 2010 Camaro 2SS IBM
Join Date: Apr 2009
Location: Florida
Posts: 286
Quote:
Originally Posted by Hebe4 View Post
You mean like this.
I have the exact same problem with the weather strip on the rear window. looks just like yours. I have tried to fix it myself but have not found a compound that will work yet. It is very hot down here and does not seem to want to cure.

Last edited by Ranger 75; 07-18-2009 at 05:38 PM.
Ranger 75 is offline   Reply With Quote
Old 07-20-2009, 06:23 PM   #13
Hebe4
 
Hebe4's Avatar
 
Drives: 2010 Black 2SS/RS M6
Join Date: Oct 2008
Location: BC
Posts: 115
Quote:
Originally Posted by Ranger 75 View Post
I have the exact same problem with the weather strip on the rear window. looks just like yours. I have tried to fix it myself but have not found a compound that will work yet. It is very hot down here and does not seem to want to cure.
I repaired mine with 3M 06385 tape adhesive and 06396EA Adhesion Promoter, cost $20. Other water proof tape adhesives may work as well.

Just install the new adhesive beside the old adhesive under the glass. You may need to double up on the tape so it is equal in thickness to the old.

Clean the vinyl seal contact surface with the Ad Promoter and press into place....careful, you only get one crack at it. The alternative would be: drop off to dealer for half a day and 20 sets of fingerprints on car.
Hebe4 is offline   Reply With Quote
Old 07-22-2009, 10:33 PM   #14
Li0nel1234
What should I name my car
 
Li0nel1234's Avatar
 
Drives: 2010 Camaro 2SS RS IOM
Join Date: Jul 2009
Location: San Antonio, TX
Posts: 770
Send a message via AIM to Li0nel1234
Quote:
Originally Posted by Hebe4 View Post
You mean like this.
I had that too. I just pushed it back in place and it hasn't come loose.
Li0nel1234 is offline   Reply With Quote
Old 07-23-2009, 11:03 PM   #15
Li0nel1234
What should I name my car
 
Li0nel1234's Avatar
 
Drives: 2010 Camaro 2SS RS IOM
Join Date: Jul 2009
Location: San Antonio, TX
Posts: 770
Send a message via AIM to Li0nel1234
Quote:
Originally Posted by Li0nel1234 View Post
I had that too. I just pushed it back in place and it hasn't come loose.
Just checked today after washing again and it's loose again. I'm taking it to the dealer tomorrow for the stripes, gfx, and plates... hopefully they can fix that too.
Li0nel1234 is offline   Reply With Quote
Old 07-23-2009, 11:24 PM   #16
FNKNSTN
Banned
 
Drives: A Black Car
Join Date: Mar 2009
Location: Los Angeles, CA
Posts: 818
That's what the "bumper to bumper" warranty period is for.

So where's the picture?
FNKNSTN is offline   Reply With Quote
Old 07-26-2009, 06:34 PM   #17
2010SSRSM6
SoCal C5 Family Member
 
2010SSRSM6's Avatar
 
Drives: My wife crazy with my C5 usage.
Join Date: Apr 2009
Location: SoCal
Posts: 5,895
Depending on the color of your car, you might want to check where the front clip and rear clip meet metal. I had it pointed out to me by a fellow Camaro owner that there are wear problems with both RY and IOM in this area.
He was told that the clip's were over tightened and causing the blistering, however after the dealership repaired the problem it's back again.
I checked all the cars at the SoCal meet on Saturday and the only cars with the problem were Ry or IOM. There wasn't a RJT or VR car there to check so I'm not sure if they are victim to the problem or not.
__________________
Powered by Cunningham MotorSports
2010SSRSM6 is offline   Reply With Quote
Old 07-18-2011, 07:58 PM   #18
black2010RS
Tom
 
black2010RS's Avatar
 
Drives: 2010 Camaro RS V6
Join Date: Jul 2011
Location: Viriginia
Posts: 1
rear weatherstrip

I also have the same problem with the rear weatherstrip. I tried 3M Black Super Weatherstip Adhesive.

I wish I didn't rip it completely off before re-attaching it. I'm not completely sure I put in on the right way.

I'm not really happy with the result. Any suggestions?
Attached Images
    
black2010RS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Washing/Detailing for Newbies MRK III Z28 Cosmetic Maintenance: Washing, Waxing, Detailing, Bodywork, Protection 111 07-21-2014 08:37 PM
Your Warranty Rights The_Blur Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 75 10-19-2012 07:24 PM
Paint your own stripes? blackZbandit Cosmetics and Lighting Modification Discussions 44 09-18-2011 09:22 AM
Will the V6 have DBW or a good old fashioned cable throttle? theholycow Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 41 08-02-2009 08:25 PM


All times are GMT -5. The time now is 07:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.