Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 01-04-2014, 02:21 PM   #1
johandepuydt
 
johandepuydt's Avatar
 
Drives: Camaro 2012 45th edition-Edelbrock
Join Date: Feb 2013
Location: Belgium
Posts: 31
smell of coolant inside

I have a 2012 L99 with 25.000 kms (European model).
Now for some time I smell often, after a warm start (I mean never after the car has been standing overnight) a scent of coolant in the interior.
This is happening for a few months now but the coolant level stays at maximum. I am puzzeled.
Anybody had or has the same thing going on?
johandepuydt is offline   Reply With Quote
Old 01-04-2014, 04:19 PM   #2
LS3 SS

 
LS3 SS's Avatar
 
Drives: 2010 Cyber Grey Camaro SS (LS3)
Join Date: Mar 2010
Location: Clarksville TN
Posts: 2,195
Get to your dealership and get your heater core checked out ASAP. I have a 2010, and the first thing people riding in my car would say, is "I smell coolant dude." I didn't think nothing of it, until I started smelling it myself. Then I would smell it worse when I hit my defroster or heat buttons. Then it got to the point where the passenger side of the windshield wouldn't defrost, it would say fogged up. Turns out, my heater core was leaking, and went bad. I got it replaced UNDER WARRANTY.


Without a warranty, it's a 1800$ job, which includes removing and replacing your windshield with a new one.
__________________
PCM 545 Cam, PRC ported/milled 255 heads, Melling 10296, Brian Tooley Racing Valvetrain, Powerbond 25% UDP, C5R Timing Chain 498rwhp/ 446 ft/lbs tq Tuned by Alvin of PCM of NC
LS3 SS is offline   Reply With Quote
Old 01-04-2014, 10:28 PM   #3
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,192
Hello!

I am sorry to hear this has occurred. If you would like assistance from the customer care team in Belgium, they would be happy to help. The phone number is 32-0-2-257-29-50.

Jessica
Chevrolet Customer Care

Quote:
Originally Posted by johandepuydt View Post
I have a 2012 L99 with 25.000 kms (European model).
Now for some time I smell often, after a warm start (I mean never after the car has been standing overnight) a scent of coolant in the interior.
This is happening for a few months now but the coolant level stays at maximum. I am puzzeled.
Anybody had or has the same thing going on?
Chevrolet Customer Svc is offline   Reply With Quote
Old 01-09-2014, 11:20 AM   #4
johandepuydt
 
johandepuydt's Avatar
 
Drives: Camaro 2012 45th edition-Edelbrock
Join Date: Feb 2013
Location: Belgium
Posts: 31
Would you believe it!!!
Made an appointment with the dealer and brought te car in for inspection this morning.
Got it back this evening.
This is what they said to me....
Sir, we can not find anything but we also have no technician that can work on American cars.....
I asked...did you do a pressure test and he looked at me as if I came from Mars in a space ship.
This is what you get when you buy a nice American muscle car in a country like Belgium. You pay 3500 dollar on taxes yearly and nobody can service it!
I'm screwed
johandepuydt is offline   Reply With Quote
Old 01-10-2014, 07:04 PM   #5
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,192
Hi johandepuydt,

I am sorry to hear this resolution! Were you able to contact the customer care department in Belgium for further assistance?

Jessica
Chevrolet Customer Care

Quote:
Originally Posted by johandepuydt View Post
Would you believe it!!!
Made an appointment with the dealer and brought te car in for inspection this morning.
Got it back this evening.
This is what they said to me....
Sir, we can not find anything but we also have no technician that can work on American cars.....
I asked...did you do a pressure test and he looked at me as if I came from Mars in a space ship.
This is what you get when you buy a nice American muscle car in a country like Belgium. You pay 3500 dollar on taxes yearly and nobody can service it!
I'm screwed
Chevrolet Customer Svc is offline   Reply With Quote
Old 01-10-2014, 09:01 PM   #6
SimpleGreen

 
Drives: 2013 1SS/1LE IOM
Join Date: Apr 2012
Location: Southeast Louisiana
Posts: 1,076
It's not as though American cars are from a different planet than European cars. Sounds like poor mechanics! You may want to bypass the heater core or risk leaking coolant into the interior of the car.
__________________
'13 1SS/1LE-Inferno Orange-Borla SType-Katzins-RotoFab-Elite Engineering-Michelin AS3-IOM Interior Pack
SimpleGreen is offline   Reply With Quote
Old 01-12-2014, 10:44 AM   #7
johandepuydt
 
johandepuydt's Avatar
 
Drives: Camaro 2012 45th edition-Edelbrock
Join Date: Feb 2013
Location: Belgium
Posts: 31
Quote:
Originally Posted by Chevrolet Customer Svc View Post
Hi johandepuydt,

I am sorry to hear this resolution! Were you able to contact the customer care department in Belgium for further assistance?

Jessica
Chevrolet Customer Care
I will do this on monday if I find the time. E-mail has already been sent.
Johan
johandepuydt is offline   Reply With Quote
Old 01-14-2014, 06:38 PM   #8
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,192
Okay, keep me posted! They would be happy to assist.

Jessica
Chevrolet Customer Care

Quote:
Originally Posted by johandepuydt View Post
I will do this on monday if I find the time. E-mail has already been sent.
Johan
Chevrolet Customer Svc is offline   Reply With Quote
Old 01-14-2014, 08:36 PM   #9
Nutro


 
Nutro's Avatar
 
Drives: 2011 2SS Synergy Green
Join Date: Nov 2011
Location: Austin, Texas
Posts: 3,227
Mine did that too. It was an easy fix. Open the hood and look at the radiator. Look all the way to the left and find the overflow bottle (Black with a small lid that screws on) and look at the inlet hose to that bottle. There is a rubber grommet there. Make sure it is pushed in and sealed there.
__________________
2011 L99 W/ Kooks Long Tubes, Ported TB, Roto-Fab CAI, Apex Catch can, Stainless Works 3" ZL-1 Catback, Overdriven Maggie @10 Pounds boost putting down 501/535 on a conservative tune. Oh and Forgestar 20's
Nutro is offline   Reply With Quote
Old 01-15-2014, 05:19 AM   #10
johandepuydt
 
johandepuydt's Avatar
 
Drives: Camaro 2012 45th edition-Edelbrock
Join Date: Feb 2013
Location: Belgium
Posts: 31
Quote:
Originally Posted by Nutro View Post
Mine did that too. It was an easy fix. Open the hood and look at the radiator. Look all the way to the left and find the overflow bottle (Black with a small lid that screws on) and look at the inlet hose to that bottle. There is a rubber grommet there. Make sure it is pushed in and sealed there.
I don't think we have the same issue. I also noticed a wet and foggy front window on the inside, just above the dash, after driving.

I have an appointment next monday at another dealership. I will keep you guys posted!
johandepuydt is offline   Reply With Quote
Old 01-20-2014, 03:36 AM   #11
johandepuydt
 
johandepuydt's Avatar
 
Drives: Camaro 2012 45th edition-Edelbrock
Join Date: Feb 2013
Location: Belgium
Posts: 31
Back home from dealer.
They found the problem.
There is a motor controlled valve behind the dash to choose between in or outside air. That motor is jammed and must be replaced.
Has anybody technical drawings so I can see what part they mean?
johandepuydt is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.