Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
B&M
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 03-26-2014, 12:21 AM   #1
Wuiquen


 
Wuiquen's Avatar
 
Drives: 2011 Summit White 2LT/RS
Join Date: Nov 2010
Location: NorCal
Posts: 2,778
car pulling to the right after lowering

So I really did not marked the camber bolts or anything.. I installed everything. I am using BMR 1.2" springs. Took the car for a right and its pulling bad to the right. My steering wheel turns to the right as well. And I have to correct to the left to keep the car straight.. did I do something wrong? I redo the left side trying to set spindle bolts to the marks from stock.. have not driven yet. Will have the car aligned Thursday.. will the alignment fixed my problems.. I had perfect alignment prior to springs.
__________________
Wuiquen is offline   Reply With Quote
Old 03-26-2014, 12:24 AM   #2
Demon 1LE
Cool Story, Bro !
 
Demon 1LE's Avatar
 
Drives: The Scarecrow
Join Date: Apr 2013
Location: Buena Park, CA
Posts: 1,146
You need an alignment. Just didn't set the strut back where it needs to be. That gets sorted during the alignment...
__________________
The Scarecrow - 2014 1LE, BMR springs, Eibach Sways, TSP Longtubes, Tuned by FSP
Demon 1LE is online now   Reply With Quote
Old 03-26-2014, 01:32 AM   #3
Bo White
Account Suspended
 
Drives: 2010 Summit White 1SS
Join Date: Feb 2012
Location: Vance Alabama
Posts: 2,418
Yep. Always do an alignment when you lower.
Bo White is offline   Reply With Quote
Old 03-26-2014, 07:21 AM   #4
Dropspeed
2013 Camaro SS1LECTSVZ28
 
Dropspeed's Avatar
 
Drives: 2013 AGM 1SS/1LE
Join Date: Nov 2012
Location: Suburbs of Detroit, MI
Posts: 1,557
Quote:
Originally Posted by Wuiquen View Post
So I really did not marked the camber bolts or anything.. I installed everything. I am using BMR 1.2" springs. Took the car for a right and its pulling bad to the right. My steering wheel turns to the right as well. And I have to correct to the left to keep the car straight.. did I do something wrong? I redo the left side trying to set spindle bolts to the marks from stock.. have not driven yet. Will have the car aligned Thursday.. will the alignment fixed my problems.. I had perfect alignment prior to springs.
You had to removed and then reinstalled the two bolts that are used to hold the front strut and also adjust camber. You also lowered the car which changed the toe.

You Must get an alignment to correct it.

A for effort. C- for not researching and understanding what you were doing...

-Matt
Dropspeed is offline   Reply With Quote
Old 04-04-2014, 06:01 PM   #5
Wuiquen


 
Wuiquen's Avatar
 
Drives: 2011 Summit White 2LT/RS
Join Date: Nov 2010
Location: NorCal
Posts: 2,778
Name:  IMG_20140404_155149328.jpg
Views: 255
Size:  73.0 KB

Name:  IMG_20140404_155202496.jpg
Views: 261
Size:  73.4 KB

So alignment is done. car feels better but idk for sure yet cuz it was reaining so hard that I figured any impression could not be the best of it since the road and tires were all wet and slippery.

So what does the alignment specs mean? im suspension retarded
__________________
Wuiquen is offline   Reply With Quote
Old 04-04-2014, 09:33 PM   #6
Bo White
Account Suspended
 
Drives: 2010 Summit White 1SS
Join Date: Feb 2012
Location: Vance Alabama
Posts: 2,418
They done a good job. The main reason why it was pulling before is because the left front tire was -.85* camber and the right front had +.19* This is were both tires were leaning towards the right and can cause it to drift to the right going down the road.
Bo White is offline   Reply With Quote
Old 04-04-2014, 09:37 PM   #7
shibbs
 
shibbs's Avatar
 
Drives: IOM 2012 6-speed
Join Date: Feb 2013
Location: Twin Cities, MN
Posts: 736
Yup. Looks like you got your money's worth out of that alignment. Should handle great now!
shibbs is offline   Reply With Quote
Old 04-05-2014, 10:48 AM   #8
rockrau
 
rockrau's Avatar
 
Drives: 2010 2ss red
Join Date: Aug 2011
Location: perkasie pa
Posts: 365
When installed my coil-overs(40mm drop), I flat bedded the car to the alignment shop because I knew the alignment would be way off(big time tire wear when driven). A non factory AKA sport alignment will wake up the car!
rockrau is offline   Reply With Quote
Old 04-06-2014, 04:10 PM   #9
Wuiquen


 
Wuiquen's Avatar
 
Drives: 2011 Summit White 2LT/RS
Join Date: Nov 2010
Location: NorCal
Posts: 2,778
Thanks guys. I am glad I waited for this guy to do my alignment. He said he's worked on corvettes and hot rods. He was pretty cool too. I think the car feels better and handles better there is some pull to either side if I let go off the steering wheel for a while but I think that's cus of the roads and imperfections. Otherwise I think its great.
__________________
Wuiquen is offline   Reply With Quote
Old 04-14-2014, 09:34 PM   #10
Wuiquen


 
Wuiquen's Avatar
 
Drives: 2011 Summit White 2LT/RS
Join Date: Nov 2010
Location: NorCal
Posts: 2,778
So after driving a little I think my car still needs alignment. Idk if its me that nmore aware of the road and steering or the alignment is off or the result of lowering the car that makes the car feel the road more.. It is like I have to make smaller adjustment on the steering wheel to keep the car straight at moments. But it doesn't pull badly. It is like if the road makes the car go and because of the springs

Sent from my XT1080 using Tapatalk
__________________
Wuiquen is offline   Reply With Quote
Old 04-15-2014, 06:45 AM   #11
HerRide
 
HerRide's Avatar
 
Drives: '14 2SS/RS AGM
Join Date: Oct 2013
Location: ATL
Posts: 353
Quote:
Originally Posted by Wuiquen View Post
It is like if the road makes the car go and because of the springs

Sent from my XT1080 using Tapatalk
^Huh?

Is it pulling to one side still?

I just got mine lowered and aligned and it doesn't pull but my steering wheel is very slightly off position when I'm going straight and it's making me nuts.
__________________
HerRide is offline   Reply With Quote
Old 04-15-2014, 07:34 AM   #12
Dropspeed
2013 Camaro SS1LECTSVZ28
 
Dropspeed's Avatar
 
Drives: 2013 AGM 1SS/1LE
Join Date: Nov 2012
Location: Suburbs of Detroit, MI
Posts: 1,557
Quote:
Originally Posted by Wuiquen View Post
So after driving a little I think my car still needs alignment. Idk if its me that nmore aware of the road and steering or the alignment is off or the result of lowering the car that makes the car feel the road more.. It is like I have to make smaller adjustment on the steering wheel to keep the car straight at moments. But it doesn't pull badly. It is like if the road makes the car go and because of the springs

Sent from my XT1080 using Tapatalk

Search for Trammling online and read some of the posts...

Here is one example:

http://www.supraforums.com/forum/sho...-and-Trammling
__________________
Dropspeed is offline   Reply With Quote
Old 04-15-2014, 10:22 AM   #13
Wuiquen


 
Wuiquen's Avatar
 
Drives: 2011 Summit White 2LT/RS
Join Date: Nov 2010
Location: NorCal
Posts: 2,778
Quote:
Originally Posted by HerRide View Post
^Huh?

Is it pulling to one side still?

I just got mine lowered and aligned and it doesn't pull but my steering wheel is very slightly off position when I'm going straight and it's making me nuts.
Sorry I rushed to type that. But yeah its the same for me. Sometimes I try to level the Camaro writing on the steering wheel and it like it won't go straight and have to keep it slightly off position as u mentioned. Other times is all good. I need to go on a freeway and see what happens

Sent from my XT1080 using Tapatalk
__________________
Wuiquen is offline   Reply With Quote
Old 04-15-2014, 07:28 PM   #14
Twoblindsheep
[COTW 1/6/14]
 
Twoblindsheep's Avatar
 
Drives: 2011 2SS/RS LS3
Join Date: Mar 2012
Location: Dover AFB, DE
Posts: 1,673
haha lowered mine and it was fine but did it on the stock RS wheels.. when it was warm enough i put on the ZL1 wheels and now i also pull to the right and the steering wheels is off too.. -_-

also i hope you are doing well lol thought i post a picture of how it looks now LOL
470rwhp!!
Attached Images
 
__________________
Twoblindsheep is offline   Reply With Quote
Old 04-15-2014, 09:06 PM   #15
Wuiquen


 
Wuiquen's Avatar
 
Drives: 2011 Summit White 2LT/RS
Join Date: Nov 2010
Location: NorCal
Posts: 2,778
Dude it looks sick.. Well today in the quest to figure it out I realized the car doesn't pull at all in streets that are flat with no bumps.. Steering wheel is slightly off sometimes

Sent from my XT1080 using Tapatalk
__________________
Wuiquen is offline   Reply With Quote
Old 04-15-2014, 09:12 PM   #16
Twoblindsheep
[COTW 1/6/14]
 
Twoblindsheep's Avatar
 
Drives: 2011 2SS/RS LS3
Join Date: Mar 2012
Location: Dover AFB, DE
Posts: 1,673
thanks man! i finally got it cammed over a month ago.. and suspension is all done now too.. well i mean beside new clutch and axles. lol
__________________
Twoblindsheep is offline   Reply With Quote
Old 04-16-2014, 12:28 PM   #17
BMR Sales



 
Drives: 2010 2SS/RS R6P
Join Date: Sep 2009
Location: Seffner, FL
Posts: 2,352
If you decide to go get another alignment, here are our recommendations for a "Street Performance" alignment. They may be trying to use the factory alignment specs. With the 1.2" springs, you no longer have the same factory geometry as a factory set-up. We have found these settings to work better with the lowering springs.

Front Camber: -0.8 min to -1.1 max
Front Toe: -1/16" (.06)
Front Caster: 7 to 8.5 (OE not adjustable)

Rear Camber: -0.7 min to -1.0 max
Rear Toe: -1/16" (.06)
__________________
Keith Kanyuh
5th Gen Camaro Suspension Specialist
keith@bmrsuspension.com
www.bmrsuspension.com
Like us on Facebook!
BMR Sales is offline   Reply With Quote
Old 04-16-2014, 07:21 PM   #18
Wuiquen


 
Wuiquen's Avatar
 
Drives: 2011 Summit White 2LT/RS
Join Date: Nov 2010
Location: NorCal
Posts: 2,778
Thank you for the info. The alignment is spot on though. However the problem was the steering wheel being slightly off to the left when the car was going straight. Went to the shop today and got it fixed. He did some small adjustment to idk what. But now its straight so I can have piece of mind

Sent from my XT1080 using Tapatalk
__________________
Wuiquen is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.