Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Rick@Livernois
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LLT Engine, Exhaust, and Bolt-Ons

Camaro V6 LLT Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 01-20-2014, 03:11 PM   #1
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Check Engine Light

P0420 catalyst system low efficiency bank 1


I haven't modified anything on my Camaro in a couple years, the only bolt-on's I have installed are an Airraid CAI and replaced the mufflers. I haven't touched the cats. Over the past month or so I have gotten this CEL code randomly on some days.

Any ideas?
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-20-2014, 03:19 PM   #2
Ventmaster

 
Ventmaster's Avatar
 
Drives: 2010 Camaro RS 1LT M6
Join Date: Jan 2011
Location: Utah
Posts: 1,584
How many miles on your car? The driver's side cat could be failing just from use.

Data from the MAF can also cause this code, so I'd also give it a clean!
__________________
Airaid CAI, Rx ported TB, Mace ported IM, JBA shorty headers, Richmond 3.73, Borla touring axleback, Hurst short throw, NH-SS fix, IDEALG clutch m/c, SS struts/springs, Spohn trailing arms, Pfadt Racing sways, Pedders radius arm & rear subframe bushing inserts, 2LT gauge pkg.TSW Nurburgs. IPF S/C
Ventmaster is offline   Reply With Quote
Old 01-20-2014, 03:37 PM   #3
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Quote:
Originally Posted by Ventmaster View Post
How many miles on your car? The driver's side cat could be failing just from use.

Data from the MAF can also cause this code, so I'd also give it a clean!
It has around 53,500 miles. What would be the correct way of cleaning the MAF without damaging it?
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-20-2014, 03:51 PM   #4
Ventmaster

 
Ventmaster's Avatar
 
Drives: 2010 Camaro RS 1LT M6
Join Date: Jan 2011
Location: Utah
Posts: 1,584
Pick up a spray can of cleaner at any auto parts store and follow instructions closely (don't hold it too closely to the sensor) and allow to dry before use. Eazy-peazy!

Cat's should be good for at least 100K miles, hopefully the cleaning will do it.
__________________
Airaid CAI, Rx ported TB, Mace ported IM, JBA shorty headers, Richmond 3.73, Borla touring axleback, Hurst short throw, NH-SS fix, IDEALG clutch m/c, SS struts/springs, Spohn trailing arms, Pfadt Racing sways, Pedders radius arm & rear subframe bushing inserts, 2LT gauge pkg.TSW Nurburgs. IPF S/C
Ventmaster is offline   Reply With Quote
Old 01-20-2014, 03:57 PM   #5
Sikoriko

 
Sikoriko's Avatar
 
Drives: 2011 V6 IOM
Join Date: Jul 2012
Location: San Diego
Posts: 1,388
Do you race the car? This would cause them to foul prematurely.
Sikoriko is offline   Reply With Quote
Old 01-20-2014, 04:15 PM   #6
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Quote:
Originally Posted by Sikoriko View Post
Do you race the car? This would cause them to foul prematurely.
Nope. It's my DD.. I'll get on the throttle every once in a while since Austin drivers can be pretty retarded.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-20-2014, 04:16 PM   #7
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Quote:
Originally Posted by Ventmaster View Post
Pick up a spray can of cleaner at any auto parts store and follow instructions closely (don't hold it too closely to the sensor) and allow to dry before use. Eazy-peazy!

Cat's should be good for at least 100K miles, hopefully the cleaning will do it.
Mind giving me a link to a product you would recommend?

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-20-2014, 05:28 PM   #8
Nutbutt


 
Nutbutt's Avatar
 
Drives: 2011 RJT 2LT/RS Convertible
Join Date: Nov 2009
Location: Western Massachusetts
Posts: 3,183
Take a look for an exhaust leak. Typically you can see leaks on the camaro since the cars run rich. Look for black carbon streaks on exhaust joints up front. Seen this before on muffler jobs where moving things around resulted in leaks by the manifold and cats.
__________________
1st IPF Supercharged 2011 2LT/RS RJT Convertible
Nutbutt is offline   Reply With Quote
Old 01-20-2014, 06:00 PM   #9
Ventmaster

 
Ventmaster's Avatar
 
Drives: 2010 Camaro RS 1LT M6
Join Date: Jan 2011
Location: Utah
Posts: 1,584
This what I'm currently using- http://shop.advanceautoparts.com/web...-crc_7070079-p

And Nutbutt's right, could be an exhaust leak.
I've heard of a few Camaro owner's stock exhaust manifold gaskets have simply gone bad and starting leaking without provocation.

If this persists, there's always a trip to the dealer to fall back on!
__________________
Airaid CAI, Rx ported TB, Mace ported IM, JBA shorty headers, Richmond 3.73, Borla touring axleback, Hurst short throw, NH-SS fix, IDEALG clutch m/c, SS struts/springs, Spohn trailing arms, Pfadt Racing sways, Pedders radius arm & rear subframe bushing inserts, 2LT gauge pkg.TSW Nurburgs. IPF S/C
Ventmaster is offline   Reply With Quote
Old 01-21-2014, 07:39 AM   #10
TooCool5
Resident Gearhead
 
TooCool5's Avatar
 
Drives: 2010 Camaro 1LS 3.6 LLT V6 325 HP
Join Date: May 2009
Location: Central CT
Posts: 3,576
That is a pesky code, MAF cleaning is a good start, also torque the exhaust manifold bolts and look for leaks, also fuel injector clean sometimes helps clean the 02's.

Check your glove box manual, the cat is covered under extended warranties.
__________________
2010 Camaro Auto, Inferno Orange, Titanium Interior, Gearhead Wheels AIRAID CAI

Last edited by TooCool5; 01-21-2014 at 08:18 AM.
TooCool5 is offline   Reply With Quote
Old 01-21-2014, 01:41 PM   #11
Flashpoint135
Dogs on the run
 
Flashpoint135's Avatar
 
Drives: 2011 1LT
Join Date: Jun 2011
Location: Newark, NY
Posts: 859
I had the same issue, took it into the dealer and they replaced the cat under warranty. Mine is also a daily driver, >60,000 miles. I have a Cold Air Inductions CAI but stock exhaust.
__________________


(Click above image to learn about UpstateC5)
Flashpoint135 is offline   Reply With Quote
Old 01-21-2014, 02:37 PM   #12
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Is the cat covered under the 100,000 mile powertrain warranty? How many years does that come with?

I'm at 53,500 miles and have had the car 4.5 years.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-21-2014, 02:40 PM   #13
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,690
Check Engine Light

Quote:
Originally Posted by BigBOSS View Post
Is the cat covered under the 100,000 mile powertrain warranty? How many years does that come with?

I'm at 53,500 miles and have had the car 4.5 years.

Sent from my SAMSUNG-SGH-I337 using Tapatalk

5 year 100,000 miles I believe. But yes, the catalytic converter is covered under the powertrain warranty.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 01-21-2014, 02:43 PM   #14
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Think they would give me shit for having the AIRRAID CAI and different mufflers? I know it depends on the dealer ultimately..

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-21-2014, 04:40 PM   #15
Sikoriko

 
Sikoriko's Avatar
 
Drives: 2011 V6 IOM
Join Date: Jul 2012
Location: San Diego
Posts: 1,388
You could put the stock box back on when you drop it off at the dealer. But as for the exhaust leak. I did not troque my DT shorties, massive leak no CEL. got in a hurry. Then when it warmed up I went back to torque them down.
Sikoriko is offline   Reply With Quote
Old 01-21-2014, 05:00 PM   #16
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
I don't even know if I kept my stock intake lol, no idea where it would be haha. Anyways, I am selling my Camaro soon since I just bought a Ford Raptor, just waiting to hear back from a coworker on whether they want to buy it for their son or I will be selling it to Carmax probably.

I know Carmax typically wants the car stock as far as wheels and stuff but I wonder if they would care about me having the AIRRAID CAID, Metra Kit, and a Kenwood DNX9960. hmmmmm
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-22-2014, 08:15 AM   #17
TooCool5
Resident Gearhead
 
TooCool5's Avatar
 
Drives: 2010 Camaro 1LS 3.6 LLT V6 325 HP
Join Date: May 2009
Location: Central CT
Posts: 3,576
Cat warranty is separate from the 5/100.
__________________
2010 Camaro Auto, Inferno Orange, Titanium Interior, Gearhead Wheels AIRAID CAI
TooCool5 is offline   Reply With Quote
Old 01-22-2014, 01:23 PM   #18
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Quote:
Originally Posted by TooCool5 View Post
Cat warranty is separate from the 5/100.
What is it then?

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-26-2014, 07:10 PM   #19
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Ok now today it only showed P0430 bank 2. What the ****?

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 01-26-2014, 07:22 PM   #20
Ventmaster

 
Ventmaster's Avatar
 
Drives: 2010 Camaro RS 1LT M6
Join Date: Jan 2011
Location: Utah
Posts: 1,584
Causes for P0430:
No AIR, CKP, CMP, ECT, EVAP, IAT, MAF, MAP, HO2S (Left Bank), Misfire, Fuel Trim (Left Bank), Injector, TP, Transmission or VSS codes set, in closed loop, ECT input over 124°F, VSS from 20-75 mph, throttle angle over 2%, engine speed below 3500 rpm, MAP input 25-80 kPa, MAF input 15-100 g/sec, then the PCM determined the Bank 2 Catalyst had degraded below its threshold.

Have you cleaned the MAF yet?
__________________
Airaid CAI, Rx ported TB, Mace ported IM, JBA shorty headers, Richmond 3.73, Borla touring axleback, Hurst short throw, NH-SS fix, IDEALG clutch m/c, SS struts/springs, Spohn trailing arms, Pfadt Racing sways, Pedders radius arm & rear subframe bushing inserts, 2LT gauge pkg.TSW Nurburgs. IPF S/C
Ventmaster is offline   Reply With Quote
Old 01-26-2014, 08:34 PM   #21
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Quote:
Originally Posted by Ventmaster View Post
Causes for P0430:
No AIR, CKP, CMP, ECT, EVAP, IAT, MAF, MAP, HO2S (Left Bank), Misfire, Fuel Trim (Left Bank), Injector, TP, Transmission or VSS codes set, in closed loop, ECT input over 124°F, VSS from 20-75 mph, throttle angle over 2%, engine speed below 3500 rpm, MAP input 25-80 kPa, MAF input 15-100 g/sec, then the PCM determined the Bank 2 Catalyst had degraded below its threshold.

Have you cleaned the MAF yet?
I removed the maf from the CAI tube today to get a look at it. Not sure exactly what to clean. It's a bunch of plastic with 2 little tiny wires that looked like a bobby pin, which is what I assume I am supposed to clean but it looked fine?

I did pull off the air filter and knocked a bunch of junk off of it though thinking maybe the maf wasn't getting enough air. Turned the car on and off a couple times while clearing the fault codes. But each time I scanned for faults it came back

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
Old 02-01-2014, 03:32 AM   #22
danyell123
 
Drives: white corolla xli
Join Date: Jan 2014
Location: united kingdom
Posts: 1
if you want to get good camaro parts on any other type of car parts then you must visit this http://www.amcarparts.co.uk/engine/list.html I will must say your problem will must be solve when you may get good parts.
__________________
danyell123 is offline   Reply With Quote
Old 02-01-2014, 09:41 AM   #23
shrinkdoc

 
Drives: SRT Yugo GT Super Sport with Manual
Join Date: Mar 2012
Location: va
Posts: 1,399
Quote:
Originally Posted by Ventmaster View Post
This what I'm currently using- http://shop.advanceautoparts.com/web...-crc_7070079-p

And Nutbutt's right, could be an exhaust leak.
I've heard of a few Camaro owner's stock exhaust manifold gaskets have simply gone bad and starting leaking without provocation.

If this persists, there's always a trip to the dealer to fall back on!
I cleaned mine yesterday, exactly the one I used.
shrinkdoc is offline   Reply With Quote
Old 02-01-2014, 10:50 AM   #24
Nutbutt


 
Nutbutt's Avatar
 
Drives: 2011 RJT 2LT/RS Convertible
Join Date: Nov 2009
Location: Western Massachusetts
Posts: 3,183
Easy maintenance !
__________________
1st IPF Supercharged 2011 2LT/RS RJT Convertible
Nutbutt is offline   Reply With Quote
Old 02-16-2014, 07:59 PM   #25
BigBOSS
 
BigBOSS's Avatar
 
Drives: 2010 Camaro 1LT/RS, 6M, IBM
Join Date: Jul 2009
Location: Austin, TX
Posts: 481
Forgot to post back a couple weeks ago but the CEL is gone now. I used the MAF cleaner posted in this thread as well as dumping a can of Seafoam in my tank and driving til nearly empty. Not sure if it was one or the other that solved the problem or the combination of both but it has been gone for 2 weeks now.

Thanks for the suggestion on cleaning the MAF even though when I visually inspected it, it looked 100% clean.
__________________
2010 Camaro 1LT/RS
Mods: Staggered 20" Lexani LX15 Wheels, Airraid CAI, AAC Blue LED Dome/Trunk Lights, AAC LED License Plate Lights, AAC LED P13W Running Lights w/Harness, Metra Radio Kit, Kenwood DNX9960 DDIN Radio, JL Audio 10" W6 Sub, JL Audio 500/1 Amp, Subthump Sub Box and Amp Rack, AeroExhaust Resonators
BigBOSS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.