Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vector Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Specific Models / Packages > Camaro 1LE Forum

Camaro 1LE Forum Camaro 1LE Package releated discussions

Reply
 
Thread Tools
Old 02-21-2014, 09:56 AM   #1
Blue_11RS
 
Blue_11RS's Avatar
 
Drives: 2013 1SS RS 1LE NPP CRT 1 of 20
Join Date: Mar 2011
Location: Columbus, Ohio
Posts: 180
HELP! Cant get the MAF unplugged

Hi Everyone. Need some help. I am afraid I am going to break something trying to get the MAF unplugged for a CAI install...I have the grey clip pulled back but this damn thing wont budge..Any I doing something wrong or is there some trick to getting it off? Help as I am mid install!!!
Blue_11RS is offline   Reply With Quote
Old 02-21-2014, 10:11 AM   #2
Balue
 
Balue's Avatar
 
Drives: 2013 SW 2SS/1LE
Join Date: Jan 2014
Location: San Diego
Posts: 93
Pull grey retainer clip back as stated then push the black thumb tab down and it should slide right out.
Balue is offline   Reply With Quote
Old 02-21-2014, 10:17 AM   #3
Blue_11RS
 
Blue_11RS's Avatar
 
Drives: 2013 1SS RS 1LE NPP CRT 1 of 20
Join Date: Mar 2011
Location: Columbus, Ohio
Posts: 180
Duh!!! I found the thumb clip. You rock! Thanks!
Blue_11RS is offline   Reply With Quote
Old 02-21-2014, 11:34 AM   #4
Mannsiam
 
Mannsiam's Avatar
 
Drives: 2014 Camaro 1SS/RS 1LE
Join Date: Oct 2013
Location: Wisconsin
Posts: 425
Love it when these forums work like this. Great info.
__________________

Yeah Im a Chevy Guy. 11 Silverado, 12 Malibu, 14 Camaro 1LE
Mannsiam is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.