Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vector Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 03-20-2014, 09:29 PM   #1
TwentyTen2SSRS


 
TwentyTen2SSRS's Avatar
 
Drives: 2010 2SS/RS
Join Date: Apr 2013
Location: Seattle, WA
Posts: 2,399
Brake squeel at 9k miles?

What gives?

Hear some sqeeling from my brakes when I push down but car only has 9k miles on it.

Can that be possible? Only happens sometimes and squeal is slight but still present? Does it just need some extra lube somewhere?

I have recently painted my calipers but didn't hear anything for last three or four weeks since paint until today.

Tell me I don't need new brakes already. That's absurd.


Sent from my iPhone using Tapatalk 2
__________________
Cold Air Inductions CAI • Stainless Power LT's with HFC's • Flowmaster American Thunder Cat Back • APEX Scoop and WW Relocation Kit • VMAX Ported Throttle Body • Custom Dyno Tune • Pfadt 1.25" Lowering Springs • ZL1 Rims on 275 front 315 Rear • matte black hood, trunk and roof wrap • Lime Green Custom Vinyl • Anvil Spoiler • heritage grill • SLP front splitter • 416.5 whp 410 torque
TwentyTen2SSRS is online now   Reply With Quote
Old 03-20-2014, 09:31 PM   #2
JimE


 
JimE's Avatar
 
Drives: 2013 2SS/RS/1LE
Join Date: Apr 2010
Location: St Louis, MO
Posts: 2,286
It's a common and a known issue with the Brembos. There are numerous topics here about it, such as this one: http://www.camaro5.com/forums/showth...t=brake+squeal
__________________
Perm-a-grin in place.....
JimE is offline   Reply With Quote
Old 03-20-2014, 09:46 PM   #3
jrhagen

 
Drives: Camaro
Join Date: Mar 2013
Location: USA
Posts: 826
Did you lube the pad backs after painting?
jrhagen is offline   Reply With Quote
Old 03-20-2014, 10:22 PM   #4
BigMatt
2010 Camaro 2 SS/RS M6
 
BigMatt's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: May 2009
Location: Landenberg, Pa
Posts: 1,096
Send a message via AIM to BigMatt
mine have 32k miles and still don't squeak
__________________
LS3, JRE Smooth Idle cam, CAI Inc, ARH 1 7/8, Corsa, MSD Wires, MGW Shifter, Street slayer clutch, Tick braided clutch line & speed bleeder, DSS 1000hp ds & 1400hp axles, BMR Split drop, Sway Bars, Trailing Arms, Toe Rods, Pro bushing kit, Spohn lcas, Whipple, LPE dual fuel pumps, Rx catch can, Id850s, Powerhaus Performance tuned.
BigMatt is offline   Reply With Quote
Old 03-20-2014, 10:29 PM   #5
TwentyTen2SSRS


 
TwentyTen2SSRS's Avatar
 
Drives: 2010 2SS/RS
Join Date: Apr 2013
Location: Seattle, WA
Posts: 2,399
Thanks guys! That works. Pretty much nothing to worry about but I'll try some hard braking!


Sent from my iPhone using Tapatalk 2
__________________
Cold Air Inductions CAI • Stainless Power LT's with HFC's • Flowmaster American Thunder Cat Back • APEX Scoop and WW Relocation Kit • VMAX Ported Throttle Body • Custom Dyno Tune • Pfadt 1.25" Lowering Springs • ZL1 Rims on 275 front 315 Rear • matte black hood, trunk and roof wrap • Lime Green Custom Vinyl • Anvil Spoiler • heritage grill • SLP front splitter • 416.5 whp 410 torque
TwentyTen2SSRS is online now   Reply With Quote
Old 03-21-2014, 09:01 PM   #6
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,782
Quote:
Originally Posted by 2013BlackLS View Post
Thanks guys! That works. Pretty much nothing to worry about but I'll try some hard braking!
Sorry to hear that you experienced this, but please keep us posted on this concern. We're here if you notice anything further that might require an official diagnosis.

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.