Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Dyno Max
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 03-24-2014, 09:43 PM   #1
DragRacerX
 
DragRacerX's Avatar
 
Drives: 2012 Camaro 2SS/RS IBM / Gray
Join Date: Jul 2009
Location: Dallas, GA
Posts: 102
SLP 25005 Brake-Control Kit Warning

A few days ago I had this professionally installed by MTI Racing on my 2012 Camaro 2SS/RS. Functionally it appears to work fine. HOWEVER, be forewarned: EVERY time you use it your dashboard will be lit up like a Christmas tree with warnings & error icons. The DIC will display "Service Stabilitrak"; the ABS, TCS, & TC amber warning lights will be lit up, too. According to SLP's description of the unit it says "This kit is custom fitted for the Camaro chassis and is fully compatible with the factory anti-lock braking and traction-control systems." Lighting up my dashboard is not my definition of fully compatible! SLP Technical Support confirmed what I have stated above as normal. How do you reset it? GOOD question, they only had suggestions. A reset tool or after awhile the computer will see everything is OK and reset itself.
__________________
2012 2SS/RS IBM / Gray Leather Interior (Daily Driver) Heads Up Display, Sun Roof, Heritage Grill, GM Silver Ice Groud Effects,
Technostalgia LED taillights (RapidFire™ Brake Light, AfterBurner™ taillight, Sequential turn signals),
Magnuson TVS2300 SuperCharger, Injen PF7015WB Cold Air Intake System, BBK Long Tube Headers With Free Flow Cats,
MBRP S7022409 T409-Stainless Steel Rectangle Tipped 3" Dual Cat Back Exhaust System, Hurst Billet Plus 2 Shifter
With SideWinder Knob, SLP 25005 Brake-Control Kit
A.C.E.5

525 RWHP/511 RWTQ
DragRacerX is offline   Reply With Quote
Old 03-24-2014, 09:52 PM   #2
sycraft
COTW 5/06/2013
 
sycraft's Avatar
 
Drives: 2012 Camaro LS "Hot Blown Six"
Join Date: May 2012
Location: Katy, Texas
Posts: 2,819
Should be normal, just like you have your have your car on a dyno. If it sees the rear wheels spinning and the fronts not it will light those up. Any Line lock will do that. It will clear once you start to drive.
__________________

2012 LS M6,ZL1Brakes, OEM Foglights (BCM Flashed for Fogs),4 Pack Guages, Factory Reproduction Wheels,Nitto NT05 tires 275/315 stagger, Leather OEM Steering Wheel,Hurst Shifter, GM Hurst Leather Shifter knob,OEM Leather Console top,Carbon Fiber Stripe Package,Emblems with Carbon overlays, ZL1 Grill,LSR Stage 4 susp,1LE Strut Brace, SOLO Cats and Exhaust, 1LE Struts/shocks, IPF Supercharger-Redline Motorsports, FSP Tuning
sycraft is offline   Reply With Quote
Old 03-25-2014, 10:01 AM   #3
BMR Sales



 
Drives: 2010 2SS/RS R6P
Join Date: Sep 2009
Location: Seffner, FL
Posts: 2,356
I agree with Sycraft. It just means all those systems are functioning properly. Although, you should disable your "nannies" though when using this. It will still illuminate your lights, but at least the ABS and traction control won't be fighting to try and correct the loss of traction. Once you turn off the car and turn it back on the system will reset itself, or like mentioned after you drive it a few miles, the systems should reset.
__________________
Keith Kanyuh
5th Gen Camaro Suspension Specialist
keith@bmrsuspension.com
www.bmrsuspension.com
Like us on Facebook!
BMR Sales is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.