Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 07-30-2009, 02:52 PM   #1
fieldgoal00
Account Suspended
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Dec 2008
Location: New Orleans
Posts: 769
Analog Speedometer Not Working

I noticed this last weekend when driving the car home from Baton Rouge, the analog meter did not go around with all the other meters when I started up the car. It also did not move until I was going about 60mph, at that point it was showing I was going 12 MPH when the digital displayed 60. Then I stopped to get gas and it started to work like normal again. It did this again last night. Anyone know what is going on? Is it the computer or the servo motor could be going out? Here's a Pic
Attached Images
 
fieldgoal00 is offline   Reply With Quote
Old 07-30-2009, 02:56 PM   #2
fbodfather


 
fbodfather's Avatar
 
Drives: Camaros................
Join Date: Oct 2006
Location: Grosse Pointe Farms, MI (suburban Detroit)
Posts: 4,485
Quote:
Originally Posted by fieldgoal00 View Post
I noticed this last weekend when driving the car home from Baton Rouge, the analog meter did not go around with all the other meters when I started up the car. It also did not move until I was going about 60mph, at that point it was showing I was going 12 MPH when the digital displayed 60. Then I stopped to get gas and it started to work like normal again. It did this again last night. Anyone know what is going on? Is it the computer or the servo motor could be going out?
Most likely the vendor put the speedometer needle on and the end is just slightly bent and 'catching' on the face of the speedometer.

Stop by your dealership - they should be able to correct it for you.

I'm sorry that you had this inconvenience.
:(
fbodfather is offline   Reply With Quote
Old 07-30-2009, 03:04 PM   #3
fieldgoal00
Account Suspended
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Dec 2008
Location: New Orleans
Posts: 769
It worked perfectly the first 2000 miles, why would it hang up now? How hard is it to replace? Now they are going to just replace the needle or the whole gauge assembly? My concern is if you remove the needle to replace a new one, you have no idea where "0" is when you put the new needle on, so my MPH will be off on the analog gauge.
fieldgoal00 is offline   Reply With Quote
Old 07-30-2009, 03:07 PM   #4
Legend
Hello!
 
Legend's Avatar
 
Drives: 2008 JSB Z06!
Join Date: Oct 2008
Location: Texas
Posts: 2,624
Heat!

It's hot and the needles being pressed on too deep have caused the material to expand and hence...sticking.

Mine is the exact opposite...my speedo says I'm going 140 mph when doing 60! I've actually buried it a few times!

Mine is on order at the dealer already...and there is a service bulletin about this...jsut stop by your dealer and they'll get you another one ordered up.
Legend is offline   Reply With Quote
Old 07-30-2009, 03:08 PM   #5
fieldgoal00
Account Suspended
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Dec 2008
Location: New Orleans
Posts: 769
they are replacing only the needle or the whole gauge assembly?
fieldgoal00 is offline   Reply With Quote
Old 07-30-2009, 03:09 PM   #6
fieldgoal00
Account Suspended
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Dec 2008
Location: New Orleans
Posts: 769
Quote:
Originally Posted by Legend View Post
Heat!

It's hot and the needles being pressed on too deep have caused the material to expand and hence...sticking.

Mine is the exact opposite...my speedo says I'm going 140 mph when doing 60! I've actually buried it a few times!

Mine is on order at the dealer already...and there is a service bulletin about this...jsut stop by your dealer and they'll get you another one ordered up.
Do you understand my concern of them simply taking the old needle off and replacing it? There is no way for them to know how to set the needle back at "0"
fieldgoal00 is offline   Reply With Quote
Old 07-30-2009, 03:26 PM   #7
PolishMike
 
PolishMike's Avatar
 
Drives: 2010 2SS RS
Join Date: Jul 2009
Location: Tracy/San Diego CA
Posts: 224
Quote:
Originally Posted by fieldgoal00 View Post
Do you understand my concern of them simply taking the old needle off and replacing it? There is no way for them to know how to set the needle back at "0"
Why not? I havent taken one apart but there is definitely a way to align it.
__________________
IOM w/ White Stripes 2SS RS M6 #17772
Now - Stainless Works 2" Headers, Intake, Cam, tune, ect
And shepherds we shall be, For thee my lord for thee. Power has descended forth from thy hand, that our feet may swiftly carry out thy commands. So we shall flow a river forth to thee, and teeming with souls shall it ever be.In nomine Patri, Et Fili, Spiritus Sancti
PolishMike is offline   Reply With Quote
Old 07-30-2009, 03:29 PM   #8
fieldgoal00
Account Suspended
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Dec 2008
Location: New Orleans
Posts: 769
the other problem is we all know that once you open something up, it never seals properly again, it's going to eventually make noise or rattle sometime in the future.
fieldgoal00 is offline   Reply With Quote
Old 07-30-2009, 03:29 PM   #9
CamaroSkooter
Retarded One-Legged Owl
 
CamaroSkooter's Avatar
 
Drives: 2010 Black Camaro 2SS
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 9,658
They replace the entire gauge, not just the needle.
CamaroSkooter is offline   Reply With Quote
Old 07-30-2009, 03:30 PM   #10
fieldgoal00
Account Suspended
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Dec 2008
Location: New Orleans
Posts: 769
the mph gauge is a seprate unit than the rpm and the gas and temp gauge?
fieldgoal00 is offline   Reply With Quote
Old 07-30-2009, 03:32 PM   #11
PolishMike
 
PolishMike's Avatar
 
Drives: 2010 2SS RS
Join Date: Jul 2009
Location: Tracy/San Diego CA
Posts: 224
Quote:
Originally Posted by fieldgoal00 View Post
the mph gauge is a seprate unit than the rpm and the gas and temp gauge?
Yes.
__________________
IOM w/ White Stripes 2SS RS M6 #17772
Now - Stainless Works 2" Headers, Intake, Cam, tune, ect
And shepherds we shall be, For thee my lord for thee. Power has descended forth from thy hand, that our feet may swiftly carry out thy commands. So we shall flow a river forth to thee, and teeming with souls shall it ever be.In nomine Patri, Et Fili, Spiritus Sancti
PolishMike is offline   Reply With Quote
Old 07-30-2009, 03:34 PM   #12
fieldgoal00
Account Suspended
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Dec 2008
Location: New Orleans
Posts: 769
i thought they would all be on the same board like many other cars.
fieldgoal00 is offline   Reply With Quote
Old 07-30-2009, 03:34 PM   #13
Legend
Hello!
 
Legend's Avatar
 
Drives: 2008 JSB Z06!
Join Date: Oct 2008
Location: Texas
Posts: 2,624
Yeah they replace the entire cluster...even the bulletin says to order a new cluster...not just needles or to adjust the needles....
Legend is offline   Reply With Quote
Old 07-30-2009, 03:35 PM   #14
fieldgoal00
Account Suspended
 
Drives: 2010 Chevy Camaro 2SS/RS
Join Date: Dec 2008
Location: New Orleans
Posts: 769
Quote:
Originally Posted by Legend View Post
Heat!

It's hot and the needles being pressed on too deep have caused the material to expand and hence...sticking.

Mine is the exact opposite...my speedo says I'm going 140 mph when doing 60! I've actually buried it a few times!

Mine is on order at the dealer already...and there is a service bulletin about this...jsut stop by your dealer and they'll get you another one ordered up.
do you know if your dealer ordered another needle for you or an entire gauge?
fieldgoal00 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash gauges not working and clicking noise Tigerrag24 Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 26 02-26-2013 02:16 PM
Speedometer on LT vs SS Myssi Cosmetics and Lighting Modification Discussions 17 04-06-2011 04:48 PM
speedometer 25thanniversary 3rd Generation Camaros 12 10-03-2009 12:23 AM
KPH to MPH analog guage change out (HELP) khislop007 Cosmetics and Lighting Modification Discussions 16 07-06-2009 11:41 PM
V6 Analog Speedometer bond2 Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 9 07-01-2009 07:08 AM


All times are GMT -5. The time now is 09:18 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.