Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 08-04-2009, 11:58 AM   #1
CamaroSkooter
Retarded One-Legged Owl
 
CamaroSkooter's Avatar
 
Drives: 2010 Black Camaro 2SS
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 9,682
Seat upholstery

Has anyone had any problems with their seat's upholstery? It appears that the left front edge of the leather on my driver's side chair (I haven't checked the passenger side yet) is sliding up and over the foam backing. I'm sure it's pretty easy to fix, I just wonder if maybe it has to do with how I'm sliding in and out of the seat entering and exiting the vehicle.
CamaroSkooter is offline   Reply With Quote
Old 08-05-2009, 12:48 PM   #2
CamaroSkooter
Retarded One-Legged Owl
 
CamaroSkooter's Avatar
 
Drives: 2010 Black Camaro 2SS
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 9,682
It appears it's just an issue that the clip that secures to the seat framing has come undone.

Nothing to see here
CamaroSkooter is offline   Reply With Quote
Old 08-17-2009, 01:52 PM   #3
CamaroSkooter
Retarded One-Legged Owl
 
CamaroSkooter's Avatar
 
Drives: 2010 Black Camaro 2SS
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 9,682
So, I took my car back to the dealer, and 10 minutes later, voilá! The seats were fixed.

And now, a few weeks later, the leather upholstery has unclipped from the framing again.

Anyone else have this problem?
CamaroSkooter is offline   Reply With Quote
Old 08-17-2009, 04:55 PM   #4
LS/V6
 
LS/V6's Avatar
 
Drives: 1LT
Join Date: Apr 2009
Location: Richmond-Texas
Posts: 138
I had that problem on my 1lt that the clip came undone. Went to the dealer got it fixed it hasn't come back out yet. They told me that they had to undo the seat to get the clip back in place. But it was the right side of the seat.
__________________
LS/V6 is offline   Reply With Quote
Old 08-18-2009, 11:24 PM   #5
haulass350
 
haulass350's Avatar
 
Drives: 97 silverado
Join Date: Aug 2008
Location: Savannah, GA
Posts: 138
mines doing the same thing
haulass350 is offline   Reply With Quote
Old 09-11-2010, 08:28 PM   #6
magzx12r
 
Drives: 2014 ZL1
Join Date: May 2010
Location: Houston area
Posts: 52
I noticed the clip undone on the right side of the driver's seat today. I took it to the dealer, but they did not have time to fix it. He said they have to remove the seat to fix it and to bring it in one morning. I tried to feel where the clip should connect, but could not figure it out. Anyone know how to fix this without removing the seat?
__________________
Mark
2014 Camaro ZL1
2014 Jeep GC SRT
2014 ZX-14R
magzx12r is offline   Reply With Quote
Old 09-12-2010, 10:27 PM   #7
69er
 
Drives: 69 Z/28 , 83 Z/28 (L69), 10 2SS CGM
Join Date: Sep 2008
Location: Alamogordo, New Mexico
Posts: 281
I just noticed my driver's seat upholstery unclipping too. After a few failed attempts to get it to stay fastened, it finally stayed on. We'll see how long it lasts.
69er is offline   Reply With Quote
Old 09-14-2010, 09:23 AM   #8
reason
 
reason's Avatar
 
Drives: 2010 Camaro 2SS / RS
Join Date: Feb 2010
Location: Los Angeles, CA
Posts: 131
same problem here... keeps popping off
__________________
reason is offline   Reply With Quote
Old 09-14-2010, 02:36 PM   #9
RandomHB
 
Drives: 2013 Black & Grey 2LT/RS M6
Join Date: May 2009
Location: Tallahassee, Fl
Posts: 58
I noticed this problem a few weeks ago and took it in - had it fixed that day, no problem. I noticed it starting again on a roadtrip last weekend and by this weekend, it had fully detached again. Not cool.
RandomHB is offline   Reply With Quote
Old 09-14-2010, 05:49 PM   #10
69er
 
Drives: 69 Z/28 , 83 Z/28 (L69), 10 2SS CGM
Join Date: Sep 2008
Location: Alamogordo, New Mexico
Posts: 281
Personally, I don't thinks it's a fix by just snapping it back on.

With the complaints of wrinkled upholstery, I think it might be the cushions that are loosing their shape and are compressing. This loosens the covering to the point that when the seat is sat in, the cushion compresses easier and the clip just falls off. There's not enough tension from the cushion anymore to pull it against the lip of the seat frame.

This is what I think is also causing the wrinkles, (maybe the covering is stretching too?) I haven't read any more on this loose upholstery topic recently, so maybe this is has been determined already.

I don't know how this stuff happens after the months of on-the-road testing before production started. You think this would have occurred to the testers.
69er is offline   Reply With Quote
Old 05-10-2011, 01:44 PM   #11
silverbullet10
Ken
 
silverbullet10's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2011
Location: Arkansas
Posts: 64
I've had mine put back on three times and it just happened again. If someone figures out how to make this stay in place please let me know.
silverbullet10 is offline   Reply With Quote
Old 05-14-2011, 07:09 PM   #12
DangerZL1

 
Drives: Accord
Join Date: Oct 2009
Location: Memphis, TN Area
Posts: 1,910
If you can get to the clip without taking your car in to the dealer, I'd try some glue on the clip or run a piece of wire around the clip after reattaching it. It may involve piercing the seat cover. 69-er has probably nailed the problem. GM uses low quality foam in their seats and if it compresses, the tabs won't have any tension to hold. The last option I can think of is to take the car to an upholestry shop if you can't fix it. They'll come up with a creative solution.
DangerZL1 is offline   Reply With Quote
Old 05-19-2011, 11:36 AM   #13
silverbullet10
Ken
 
silverbullet10's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2011
Location: Arkansas
Posts: 64
I was at the dealer again today getting my bottom seat covers re-attached. There is now a bulletin to correct this problem. They cut one inch of plastic off each end of the plastic strip that holds the cover in place. Apparently the way the bottom of the seat pan is curved is causing these plastic retainers to come unclipped. I'm not feeling very confident in this fix, but I'll go with it and see how it turns out.
silverbullet10 is offline   Reply With Quote
Old 05-25-2011, 12:36 PM   #14
silverbullet10
Ken
 
silverbullet10's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2011
Location: Arkansas
Posts: 64
Seat bottom came loose again even after they performed the so-called fix. The dealer is replacing the seat upholsery on the bottom of the drivers seat today. I hope someone comes up with a better fix to this problem soon.
silverbullet10 is offline   Reply With Quote
Old 05-25-2011, 09:51 PM   #15
MARTYBMW
 
MARTYBMW's Avatar
 
Drives: 2011 2LT/RS RJT Convertible
Join Date: Mar 2011
Location: San Antonio
Posts: 58
I had the same issue on my 2010 2Lt, I had 3 new cushions and 4 new leather covers put on and it never helped. What they discovered after my tenth trip ( I am a little anal when it comes to little annoyances like this) is that the thickness of the foam at the leading edge of the seat is actually .5 inch too thick. They removed the foam and and shaved .75 inch off the leading edge feathering it back. After that I never had another issue with it.
__________________


Born On 04/01/11
MARTYBMW is offline   Reply With Quote
Old 05-31-2011, 04:31 PM   #16
CamaroSkooter
Retarded One-Legged Owl
 
CamaroSkooter's Avatar
 
Drives: 2010 Black Camaro 2SS
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 9,682
Now I'm afraid to go back to the dealer because my electric cut-out buttons are attached to the seat and if they have to remove the seat I don't want them screwing up the wiring to my cut-outs...
__________________

My VIN = 2G1FK1EJ9A9105017
Build Date: 04-23-2009 according to:
http://www.compnine.com/vid.php
CamaroSkooter is offline   Reply With Quote
Old 10-30-2012, 10:34 PM   #17
yellowrs
Saftladen
 
Drives: 2010 SS 426 V8 M/T
Join Date: Aug 2012
Location: Scottsdale AZ
Posts: 1,378
Quote:
Originally Posted by CamaroSkooter View Post
So, I took my car back to the dealer, and 10 minutes later, voilá! The seats were fixed.

And now, a few weeks later, the leather upholstery has unclipped from the framing again.

Anyone else have this problem?
I do, took it to the dealer, they fixed it and 2 minuts later it was loose again!
yellowrs is offline   Reply With Quote
Old 10-31-2012, 10:30 PM   #18
Warlace
 
Warlace's Avatar
 
Drives: 2010 Camaro SS
Join Date: Oct 2011
Location: Las Vegas
Posts: 52
Quote:
Originally Posted by yellowrs View Post
I do, took it to the dealer, they fixed it and 2 minuts later it was loose again!

Mine had the same problem, they evantually put "Hog Clips" i think is what they called it. I hate and its ugly and no matter how much I complained and called everyone but the President, Chevy will not budge saying its the "appropiate fix for the problem and they will not replace the seat or cover because the Clips work fine". I have a post if you look mine up with pics.
Warlace is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
baby/car seat question kellertxgen5 5th Gen Camaro SS LS LT General Discussions 36 06-09-2011 12:45 AM
WHAT HAPPENED TO THE 2LT & THE 2SS PASSENGER POWER SEAT ? FISHTAIL Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 33 09-16-2009 07:21 AM
Cloth Seat Back Rattle with fix shiftz33 Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 5 06-18-2009 10:20 PM
Any new cloth seat pictures? VICTORY RED 1SS Camaro Photos | Spyshots | Video | Media Gallery 47 12-03-2008 10:45 AM
Who else is a seat snob? Good seats are a MUST Gatecrasher 5th Gen Camaro SS LS LT General Discussions 40 02-22-2008 07:40 PM


All times are GMT -5. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.