Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 05-05-2014, 09:18 PM   #18
Q'smuscle
Account Suspended
 
Drives: 2011 Camaro VR 2SS/RS & Impala
Join Date: Apr 2013
Location: Riverside,ca
Posts: 5,344
Nice ! Man, that looks like fun in the sun!
Q'smuscle is offline   Reply With Quote
Old 05-05-2014, 09:24 PM   #19
Balue
 
Balue's Avatar
 
Drives: 2013 SW 2SS/1LE
Join Date: Jan 2014
Location: San Diego
Posts: 290
Me and my brother are planning to run Willow in June with speed ventures.

Here are a few of my shots from yesterday. I still need to DL the videos and get them up.



Balue is online now   Reply With Quote
Old 05-05-2014, 09:29 PM   #20
cornerspeed92


 
cornerspeed92's Avatar
 
Drives: 2013 1SS 1LE
Join Date: Jul 2012
Location: SoCal
Posts: 3,757
Quote:
Originally Posted by Balue View Post
Me and my brother are planning to run Willow in June with speed ventures.

Here are a few of my shots from yesterday. I still need to DL the videos and get them up.



Willow is a blast and you will have fun, just know Willow is brutal on tires.
__________________
cornerspeed92 is offline   Reply With Quote
Old 05-05-2014, 09:30 PM   #21
KRich2587
 
KRich2587's Avatar
 
Drives: 2014 Summit White 1LE
Join Date: Jan 2012
Location: Temple, TX
Posts: 431
Yeah I was getting super hot cause of the mods more power = more heat Ryne said he had heat issues then he changed the tstat and fixed it he also had a huge oil cooler on his 1LE so im going to wait until I do those upgrades before I track again
KRich2587 is offline   Reply With Quote
Old 05-05-2014, 09:32 PM   #22
CHMSC
ROAD COURSE JUNKIE
 
CHMSC's Avatar
 
Drives: 2012 SS/RS LS3
Join Date: Oct 2012
Location: Somewhere
Posts: 4,844
Quote:
Originally Posted by cornerspeed92 View Post
Hey Kirk, was the overheating because of the mod's you did?
I had that problem and I am stock. Last time I was there I couldn't go all out because my oil temps were too high and my oil pressure was way to low. Need an oil cooler and good oil.
__________________
CHMSC is offline   Reply With Quote
Old 05-05-2014, 09:33 PM   #23
KaBoom1701
KaBoom1701
 
KaBoom1701's Avatar
 
Drives: 13' ZL1 Red M6
Join Date: Dec 2012
Location: I.E. SoCal (Yucaipa)
Posts: 6,709
Man this was a blast!

I was the BRM 13' RS. Best time was 2:11. I think good for a first timer.

I hit 128mph on the straight away once. During the 4th session my ACS T-5 splitter came loose and I felt a crazy vibration at over 100mph. I thought I blew a tire. I was on the last lap of the session so I just drove slow and gave everyone point by's. A quick fix in the garage and I was out for the 5th session. I got stuck behind a 45th edition Camaro with no courtesy point by....

It was good to see you and your 1LE in person. I can't wait to install my "Red" 1LE Brembo brakes soon. I was going to ask if I could ride along to see how you drive and learn some tips but I caught up in the moment and forgot to ask you. lol

You missed Bryon spinning out on the last session! I think he *hit some brinks thinking he broke his car. After a quick ignition restart he was off and running again.

Oh, and welcome to the Inland Empire Camaro Club!
__________________
Mods:
Roto-Fab Intake, WW Reservoir kit & Big Gulp Air Scoop, Elite Catch Can, ATI Super Damper & 5% overdrive Pulley, Ron Davis HX, D3 Reservoir, Dash-Logic controller, 3m Clear Bra, ZL1 Mirror inserts, GM Interior Ambient lighting, ZL1 Addons Splitter guard washers, Tow Hook kit & rock guards, Hurst Shifter Billet Plus 6 Speed Short Shifter, Carbon Fiber Bow ties front & rear, ZL1 DRL lighting harness.


Last edited by KaBoom1701; 05-05-2014 at 11:10 PM.
KaBoom1701 is offline   Reply With Quote
Old 05-05-2014, 09:41 PM   #24
cornerspeed92


 
cornerspeed92's Avatar
 
Drives: 2013 1SS 1LE
Join Date: Jul 2012
Location: SoCal
Posts: 3,757
Quote:
Originally Posted by CHMSC View Post
I had that problem and I am stock. Last time I was there I couldn't go all out because my oil temps were too high and my oil pressure was way to low. Need an oil cooler and good oil.
I remember you saying something about low oil pressure.

Quote:
Originally Posted by KaBoom1701 View Post
Man this was a blast!

I was the BRM 13' RS. Best time was 2:16. I think good for a first timer.

I hit 128mph on the straight away once. During the 4th session my ACS T-5 splitter came loose and I felt a crazy vibration at over 100mph. I thought I blew a tire. I was on the last lap of the session so I just drove slow and gave everyone point by's. A quick fix in the garage and I was out for the 5th session. I got stuck behind a 45th edition Camaro with no courtesy point by....

It was good to see you and your 1LE in person. I can't wait to install my "Red" 1LE Brembo brakes soon. I was going to ask if I could ride along to see how you drive and learn some tips but I caught up in the moment and forgot to ask you. lol

You missed Bryon spinning out on the last session! I think he *hit some brinks thinking he broke his car. After a quick ignition restart he was off and running again.

Oh, and welcome to the Inland Empire Camaro Club!
You're more then welcome to ride along with me. I always wondered after we talked at Willow, how did you know this was me?
__________________
cornerspeed92 is offline   Reply With Quote
Old 05-05-2014, 09:43 PM   #25
KRich2587
 
KRich2587's Avatar
 
Drives: 2014 Summit White 1LE
Join Date: Jan 2012
Location: Temple, TX
Posts: 431
Yeah I run VR1 10w30 per CMS I didn't really have oil pressure issues as I have the melling pump. first day I had no issues at all. but after the second session day two I would start creeping up the temp scale.
KRich2587 is offline   Reply With Quote
Old 05-05-2014, 10:34 PM   #26
KaBoom1701
KaBoom1701
 
KaBoom1701's Avatar
 
Drives: 13' ZL1 Red M6
Join Date: Dec 2012
Location: I.E. SoCal (Yucaipa)
Posts: 6,709
Intuition....
__________________
Mods:
Roto-Fab Intake, WW Reservoir kit & Big Gulp Air Scoop, Elite Catch Can, ATI Super Damper & 5% overdrive Pulley, Ron Davis HX, D3 Reservoir, Dash-Logic controller, 3m Clear Bra, ZL1 Mirror inserts, GM Interior Ambient lighting, ZL1 Addons Splitter guard washers, Tow Hook kit & rock guards, Hurst Shifter Billet Plus 6 Speed Short Shifter, Carbon Fiber Bow ties front & rear, ZL1 DRL lighting harness.

KaBoom1701 is offline   Reply With Quote
Old 05-05-2014, 10:46 PM   #27
CHMSC
ROAD COURSE JUNKIE
 
CHMSC's Avatar
 
Drives: 2012 SS/RS LS3
Join Date: Oct 2012
Location: Somewhere
Posts: 4,844
I spoke with Ryne at CMS who was at the track that weekend and he said get rid of the shitty oil and your pressure issues will be gone. Oil cooler would help as well. Just an FYI Mark.
__________________
CHMSC is offline   Reply With Quote
Old 05-05-2014, 11:11 PM   #28
Aero_Sport_Concepts
aerosportconcepts@gmail

 
Aero_Sport_Concepts's Avatar
 
Drives: '15 1SS-RS/1LE (RRM)
Join Date: Dec 2011
Location: Menifee, SoCal
Posts: 1,217
First Time out but will not be my last. Had a Blast. Most fun i had in a long time. I think i found a New Hobby. I'll be running with the big boys soon. Ordering my 1LE in late July. Can't wait. Love my LT/RS but i need MORE.
__________________
Aero_Sport_Concepts is offline   Reply With Quote
Old 05-05-2014, 11:20 PM   #29
rgreene1971
 
rgreene1971's Avatar
 
Drives: 2010 Camaro SS
Join Date: Feb 2014
Location: Detroit, MI
Posts: 108
Would love to be a part of this if you guys ever decide to hold another day like this one.
__________________
My 2010 Camaro SS

COMP Cams XFI Street/Strip, Lingenfelter LS3 Heads, AHR Long tube headers + X pipe, FAST LSXR 102mm Intake manifold, LMR Cold air intake, Flowmaster 3" stainless steel exhaust, NoWeeds Exhaust cutouts, Platinum Valve spring kit, ZEX NOS system 175hp shot, Eibach Pro-Kit performance lowering springs (1" drop all around), Custom grills, bumper ports, etc....

rgreene1971 is offline   Reply With Quote
Old 05-05-2014, 11:52 PM   #30
KRich2587
 
KRich2587's Avatar
 
Drives: 2014 Summit White 1LE
Join Date: Jan 2012
Location: Temple, TX
Posts: 431
He told me straight up don't go so hard with the stock cooler lol
KRich2587 is offline   Reply With Quote
Old 05-06-2014, 12:02 AM   #31
Jenner

 
Jenner's Avatar
 
Drives: 2012 SS/RS
Join Date: Jul 2013
Location: Placentia, CA
Posts: 2,112
Quote:
Originally Posted by KaBoom1701 View Post
Man this was a blast!

I was the BRM 13' RS. Best time was 2:11. I think good for a first timer.

I hit 128mph on the straight away once. During the 4th session my ACS T-5 splitter came loose and I felt a crazy vibration at over 100mph. I thought I blew a tire. I was on the last lap of the session so I just drove slow and gave everyone point by's. A quick fix in the garage and I was out for the 5th session. I got stuck behind a 45th edition Camaro with no courtesy point by....

It was good to see you and your 1LE in person. I can't wait to install my "Red" 1LE Brembo brakes soon. I was going to ask if I could ride along to see how you drive and learn some tips but I caught up in the moment and forgot to ask you. lol

You missed Bryon spinning out on the last session! I think he *hit some brinks thinking he broke his car. After a quick ignition restart he was off and running again.

Oh, and welcome to the Inland Empire Camaro Club!
You ran with the stock brakes?
Jenner is offline   Reply With Quote
Old 05-06-2014, 12:32 AM   #32
KRich2587
 
KRich2587's Avatar
 
Drives: 2014 Summit White 1LE
Join Date: Jan 2012
Location: Temple, TX
Posts: 431
nothing wrong with taking a completely stock car out. People get caught up in making their car track ready but how do you know what improvements you've made without trying before hand? Just make sure your tires are good and have enough pad left and hit the track!!
KRich2587 is offline   Reply With Quote
Old 05-06-2014, 12:42 AM   #33
Jenner

 
Jenner's Avatar
 
Drives: 2012 SS/RS
Join Date: Jul 2013
Location: Placentia, CA
Posts: 2,112
Quote:
Originally Posted by KRich2587 View Post
nothing wrong with taking a completely stock car out. People get caught up in making their car track ready but how do you know what improvements you've made without trying before hand? Just make sure your tires are good and have enough pad left and hit the track!!
Oh ok. Brakes and tires were the only things holding me back
Jenner is offline   Reply With Quote
Old 05-06-2014, 01:55 AM   #34
Orange Crush 1LE

 
Orange Crush 1LE's Avatar
 
Drives: 2013 SS 1LE
Join Date: Jul 2013
Location: San Jose, CA
Posts: 1,088
Man, that is just awesome guys. Cornerspeed, you were cooking for a stock 1LE, I can't believe that time! I don't know the track but can tell by the cars you are mixing it up with, you were flat flying, LOL.

The yellow Z06 is driven by a friend of mine, Jesse. Good guy, I met him at Buttonwillow at his first ever tracking event, he's clearly come a long way and just barely edged you despite his HP and weight advantages. Jesse ran a 1:40 at Willow Springs when I was there, then recently a 1:34 with slicks the next time out. He's hooked like us.

And Kirk, kicking ass and taking names! Tell us the truth, this isn't really your 6th track day

Cornerspeed, don't laugh but I bought a Roval track decal that was going on my back window next to Buttonwillow, Thunderhill and Willow Springs. Mark my words, I'll get a chance to apply that decal. I'll be running NASA time trials at Sonoma and Laguna Seca this year, along with Thunderhill and maybe Buttonwillow. Hopefully we will finally meet up and track one day soon.

Must have been cool to run with 11 Camaros. Good times gentlemen.
__________________
Sold but not forgotten! Pedders Supercar Coilovers, 32mm rear sway bar,bushings; APR wing and splitter
Forged 416 road course stroker. 514 RWHP, 497 RW Ft-Lb
1 Camaro, 75 Vipers: http://www.camaro5.com/forums/showthread.php?t=393697
Buttonwillow Raceway: http://www.camaro5.com/forums/showthread.php?t=389086
Orange Crush 1LE is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:15 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.