Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
sjm autoprod
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 05-20-2014, 03:55 PM   #1
infernostripes!
 
Drives: 2010 1ssrs
Join Date: Apr 2009
Location: Edinburg Texas
Posts: 665
What bolts to tighten up?

After working in Houston for 5 months and driving through it's terrible roads my suspension has started to creek. I have 1in bmr drop springs and they were installed 2 years ago. I did not use locate, but I did use a torque wrench. Anyways, could anyone tell me which bolts i can loctite? If i loosen some bolts and loctite them will i have to get a new alignment? Are there bolts i should not loctite because they are the bolts needed to align the car?

Thanks!
__________________
infernostripes! is offline   Reply With Quote
Old 05-20-2014, 05:45 PM   #2
BMR Sales



 
Drives: 2010 2SS/RS R6P
Join Date: Sep 2009
Location: Seffner, FL
Posts: 2,493
I would think if you have suspension bolts coming loose, you would have more serious problems than just "creaking". You might try just giving your suspension joints a good shot with a grease gun wherever possible.
__________________
Keith Kanyuh
5th Gen Camaro Suspension Specialist
keith@bmrsuspension.com
www.bmrsuspension.com
Like us on Facebook!
BMR Sales is offline   Reply With Quote
Old 05-20-2014, 08:06 PM   #3
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,694
Quote:
Originally Posted by infernostripes! View Post
After working in Houston for 5 months and driving through it's terrible roads my suspension has started to creek. I have 1in bmr drop springs and they were installed 2 years ago. I did not use locate, but I did use a torque wrench. Anyways, could anyone tell me which bolts i can loctite? If i loosen some bolts and loctite them will i have to get a new alignment? Are there bolts i should not loctite because they are the bolts needed to align the car?

Thanks!
Aside from the lowering coils, is the rest of your suspension stock?
__________________
JusticePete is offline   Reply With Quote
Old 05-20-2014, 10:28 PM   #4
infernostripes!
 
Drives: 2010 1ssrs
Join Date: Apr 2009
Location: Edinburg Texas
Posts: 665
yes the rest is stock
__________________
infernostripes! is offline   Reply With Quote
Old 05-21-2014, 08:17 PM   #5
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,694
Stock rubber bushings rarely squeak. How many miles on your beast?
__________________
JusticePete is offline   Reply With Quote
Old 05-22-2014, 12:00 AM   #6
ICTsccaCamaro
ITCRNRS
 
ICTsccaCamaro's Avatar
 
Drives: 2014 Summit White 2SS/RS 1LE
Join Date: Jun 2012
Location: Wichita KS
Posts: 698
FE3 rear sway bar link bracket broken on one of your rear control arms? Just a thought
__________________
2014 Summit White 1LE 2SS/RS, Recaros, NPP, NAV, Elite Gen2 CC, ZL1 splash guards, ZL1 pedals, Exhaust Commander
Previous 2012 Black 2LT/RS, Fully 1LE swapped

Wichita Region SCCA Autocross
#23 FS
http://www.wichitascca.org/SoloII.html
ICTsccaCamaro is offline   Reply With Quote
Old 05-25-2014, 12:12 PM   #7
infernostripes!
 
Drives: 2010 1ssrs
Join Date: Apr 2009
Location: Edinburg Texas
Posts: 665
Quote:
Originally Posted by JusticePete View Post
Stock rubber bushings rarely squeak. How many miles on your beast?
It has 14,000 miles and it is about to turn 5 years old
__________________
infernostripes! is offline   Reply With Quote
Old 05-25-2014, 12:13 PM   #8
infernostripes!
 
Drives: 2010 1ssrs
Join Date: Apr 2009
Location: Edinburg Texas
Posts: 665
Quote:
Originally Posted by ICTsccaCamaro View Post
FE3 rear sway bar link bracket broken on one of your rear control arms? Just a thought
nope nothing has broken
__________________
infernostripes! is offline   Reply With Quote
Old 05-25-2014, 07:25 PM   #9
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,694
Quote:
Originally Posted by ICTsccaCamaro View Post
FE3 rear sway bar link bracket broken on one of your rear control arms? Just a thought
Broken sway bar brackets do not squeak.

Quote:
Originally Posted by infernostripes! View Post
It has 14,000 miles and it is about to turn 5 years old
You may have a bad strut.

1. Is there an oily residue on either of your rear struts?
2. Can you reproduce the noise by jouncing your car?
__________________
JusticePete is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.