Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Grabiak Performance Center
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

View Poll Results: What (if any) problems have you had?
Transmission (manual) 6 7.06%
Transmission (automatic) 1 1.18%
Active Fuel Management (cylinder deactivation) 1 1.18%
Cosmetic (Paint) 16 18.82%
Cosmetic (Other) 13 15.29%
Windows/sunroof 1 1.18%
Strange noises 20 23.53%
Lighting (interior or exterior) 4 4.71%
Climate control 2 2.35%
Oil leaks 1 1.18%
Other 23 27.06%
I haven't had any problems 33 38.82%
Multiple Choice Poll. Voters: 85. You may not vote on this poll

Reply
 
Thread Tools
Old 08-17-2009, 02:09 PM   #1
2bravo
 
Drives: Empty
Join Date: Aug 2009
Location: Ontario
Posts: 83
Poll: Have you experienced issues/problems?

Did a search and didn't see any polls like this already.

Just wondering how common these issues and problems I've been reading on the forum are.

I know this is a first year car and there are bound to be bugs to sort out.
2bravo is offline   Reply With Quote
Old 08-17-2009, 03:13 PM   #2
lakers171
SoCal MAYHEM
 
lakers171's Avatar
 
Drives: 2010 2LT/RS IBM
Join Date: Feb 2009
Location: Hawthorne, Ca
Posts: 2,834
you forgot interior door panel popping off its easily fixable with a different clip from your dealer but it was an issue.
__________________
lakers171 is offline   Reply With Quote
Old 08-17-2009, 03:47 PM   #3
Ranger 75
 
Ranger 75's Avatar
 
Drives: 2010 Camaro 2SS IBM
Join Date: Apr 2009
Location: Florida
Posts: 286
Quote:
Originally Posted by 2bravo View Post
Did a search and didn't see any polls like this already.

Just wondering how common these issues and problems I've been reading on the forum are.

I know this is a first year car and there are bound to be bugs to sort out.
I am tired of hearing this first year car s..t. GM has been building cars for 100 years.
Ranger 75 is offline   Reply With Quote
Old 08-18-2009, 07:49 AM   #4
2bravo
 
Drives: Empty
Join Date: Aug 2009
Location: Ontario
Posts: 83
Yeah I suppose, but it's a completely new model... realistically it will take time to get the bugs out.

Anyway, keep the votes coming guys!

If you vote "Other", maybe you could post what the problem was?

Thanks!
2bravo is offline   Reply With Quote
Old 08-18-2009, 04:50 PM   #5
2Fast4U2010
 
2Fast4U2010's Avatar
 
Drives: Camaro 2SS
Join Date: Jun 2009
Location: Brunswick, GA
Posts: 180
Has anyone had problems with 2SS/RS left front break popping? When slow down going into the garage, I"ll here a popping sound. Any advise what it might be? yes I will be taking it to the dealer to have checked out. No other problems the engine is strong, and gets faster every da, I break it in.
2Fast4U2010 is offline   Reply With Quote
Old 08-19-2009, 03:21 PM   #6
2bravo
 
Drives: Empty
Join Date: Aug 2009
Location: Ontario
Posts: 83
Bump...

If you vote other please post what the problem was.

Thanks!
2bravo is offline   Reply With Quote
Old 08-24-2009, 08:25 AM   #7
2bravo
 
Drives: Empty
Join Date: Aug 2009
Location: Ontario
Posts: 83
Post weekend bump
2bravo is offline   Reply With Quote
Old 08-28-2009, 04:08 PM   #8
GQ4Life


 
Drives: 2010 Camaro SS LS3
Join Date: Aug 2009
Location: Fishkill, NY
Posts: 5,237
well LS3 and tranny isnt new..
__________________
C7 Stingray ordered 6-7-13 (RCHT2P) 3300 status
GQ4Life is offline   Reply With Quote
Old 08-28-2009, 04:37 PM   #9
patriotpa
Account Suspended
 
Drives: 02 Silverado, 09 Vue, 10 1SS
Join Date: Aug 2008
Location: Tired of apologizing when we should be kickin' butt!
Posts: 1,967
What magazine are we going to see THIS unscientific poll in?

MINE is PERFECT!



Oh...wait...I HAVE experienced ONE annoying problem:

Punks dissing the Camaro!

Last edited by patriotpa; 08-28-2009 at 05:19 PM.
patriotpa is offline   Reply With Quote
Old 08-28-2009, 04:52 PM   #10
DGthe3
Moderator.ca
 
DGthe3's Avatar
 
Drives: 05 Grand Am GT
Join Date: Jul 2007
Location: Niagara, Canada
Posts: 22,043
Send a message via MSN to DGthe3
Quote:
Originally Posted by Ranger 75 View Post
I am tired of hearing this first year car s..t. GM has been building cars for 100 years.
We've also been flying planes for over 100 years, but they still crash due to mechanical problems. Ships have problems too and we've been on the water for thousands of years.

Thing is, cars are the most complicated things that are mass produced. There are thousands and thousands of parts and multiple systems need to integrate. Murphy's law states that if anything can go wrong, it will. This isn't just some funny little line that people say when they're frustrated. Its a valid engineering principle. A couple million miles worth of testing on cars before production is nothing compared to a few months worth of driving by all the new owners.

It simply isn't possible to design and build a car in less than 4 years, release it to an audience that examines everything with a fine toothed comb, and have 0 problems.
__________________
Note, if I've gotten any facts wrong in the above, just ignore any points I made with them
__________________
don't believe a thing you read about the next gen Camaro -- as history has proven time and time again:

WE DO NOT TALK ABOUT FUTURE PRODUCT PLANS PERIOD FbodFather
__________________

Camaro5 Fest sub-forum
DGthe3 is offline   Reply With Quote
Old 08-28-2009, 05:12 PM   #11
ShnOmac


 
ShnOmac's Avatar
 
Drives: 2006 Silverado SS, 2009 G8 GT
Join Date: Aug 2008
Location: PNW
Posts: 13,397
Quote:
Originally Posted by patriotpa View Post
What magazine are we going to see THIS unscientific poll in?

MINE is PERFECT!

ShnOmac is online now   Reply With Quote
Old 08-28-2009, 08:12 PM   #12
markbolt
Account Suspended
 
Drives: 2010 2SS Camaro
Join Date: Jul 2009
Location: Trenton IL
Posts: 314
Need help.

Question? WHen I turn on my air and hit the particular button as to where I want the air to come out there is a blue light that comes on. Now when I turn the Air off, turn the knob all the way to the left how do I get the blue light to go out? So far the only I can do this is to tun on the front window defrost then turn off the car. Once I turn the car back on then there are no lights lit up.

Any ideas?
markbolt is offline   Reply With Quote
Old 08-29-2009, 06:43 AM   #13
patriotpa
Account Suspended
 
Drives: 02 Silverado, 09 Vue, 10 1SS
Join Date: Aug 2008
Location: Tired of apologizing when we should be kickin' butt!
Posts: 1,967
When I start my car, if I turn the key to "start" and release it quickly, the starter keeps cranking, then I hear a soft rumbling noise. This rumbling increases with pressure to the throttle and does not stop until I turn the ignition key all the way to the left, then the car stops working.
patriotpa is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
poll: How many paid sticker,under or over sticker? 97one 5th Gen Camaro SS LS LT General Discussions 312 05-30-2012 08:51 AM
Poll - Do you wish GM to recognize early purchased Camaros? Hylton 5th Gen Camaro SS LS LT General Discussions 74 02-13-2009 07:55 PM
Stripe Poll - for Feedback themossman 5th Gen Camaro SS LS LT General Discussions 34 11-02-2008 06:52 PM


All times are GMT -5. The time now is 09:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.