Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)


Reply
 
Thread Tools
Old 09-11-2009, 09:43 AM   #43
haulass350
 
haulass350's Avatar
 
Drives: 97 silverado
Join Date: Aug 2008
Location: Savannah, GA
Posts: 138
Quote:
Originally Posted by o2camaross View Post
Is your car stock? And did the dealership fix it under warranty?
it was stock at the time of the axle breaking.
haulass350 is offline   Reply With Quote
Old 09-11-2009, 09:45 AM   #44
Camarorss350
camaro blogger
 
Camarorss350's Avatar
 
Drives: 2010 Black on Black SS/RS
Join Date: Jul 2009
Location: Central NJ + Atlanta GA
Posts: 358
Send a message via AIM to Camarorss350
well either theres more to this story or GM is being absurd, i hope a GM dude hops on here and reads this... This is something that needs to be fixed, by GM, under warranty.
Camarorss350 is offline   Reply With Quote
Old 09-11-2009, 09:57 AM   #45
2011RS/SS
 
2011RS/SS's Avatar
 
Drives: 2013 427 Convertible CE
Join Date: May 2009
Location: Raleigh, NC
Posts: 228
Quote:
Originally Posted by mtcwby View Post
Man, did they see you coming. I would fully expect these cars to handle 4k
clutch drops, since the launch control, that was designed by GM, sets the
engine rpms to 4200 to 4800 rpms. And the owners manual gives us directions on how to use it. Why wouldn't you expect the car to handle it?

Didn't mean to come off the way i did. I didn't know you were using launch control and I don't understand why GM even put launch control in the camaros and the corvettes know realizing shit is going to break sooner or later and that will lead to ton of claims.

I would think GM would learn from the fiasco that it caused Nissan on the GTR.

Good luck with your claim... Hope it works out for you
2011RS/SS is offline   Reply With Quote
Old 09-11-2009, 10:39 AM   #46
o2camaross
 
o2camaross's Avatar
 
Drives: 2010 2SS/RS & 04 silvy
Join Date: Mar 2008
Location: Driving
Posts: 362
We'll see. I pm'd fbodfather so I'll see if he gets back with me in time. I see this being a big deal with these cars
o2camaross is offline   Reply With Quote
Old 09-11-2009, 10:49 AM   #47
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,095
I would at least call another dealer and get their opinion. Seriously, tire tread and exhaust mod should not even come into play in this situation. If you put a supercharger or did anything to the engine to produce a lot more power or modded the tranny, that would definitely have a downstream effect then I can understand. If your driveline/drivetrain is stock, and you are simply using the factory installed performance controls to optimize performance/traction and something breaks, I really can't understand why the dealer would not honor the warranty. This is like using the factory installed cruise control, and the throttle gets stuck or whatever, and the dealer says it is not covered under warranty because you have a CAI installed. It is BS. But then again, we do not know the entire story on this.
ffrcobra_65 is offline   Reply With Quote
Old 09-11-2009, 11:52 AM   #48
mtcwby
High on "The Camaro Life"
 
mtcwby's Avatar
 
Drives: 2010 2SS, IOM, LS3, Vortech, LG cam
Join Date: May 2009
Location: Big Sandy, MT & Yuma, AZ
Posts: 1,028
Send a message via AIM to mtcwby
Quote:
Originally Posted by 2011RS/SS View Post
Didn't mean to come off the way i did. I didn't know you were using launch control and I don't understand why GM even put launch control in the camaros and the corvettes know realizing shit is going to break sooner or later and that will lead to ton of claims.

I would think GM would learn from the fiasco that it caused Nissan on the GTR.

Good luck with your claim... Hope it works out for you
If you read the whole thread you would know that I wasn't using launch control, I was accelerating hard up an on ramp and when I shifted into 2nd the CV broke. My dealer didn't even hesitate about covering
this break, so yes, it worked out for me!

People: Please read the whole thread before throwing in your $.02 worth.
__________________
"The democracy will cease to exist when you take away from those who are willing to work and give to those who are not."-Thomas Jefferson------Going Strong at 39,250 miles

Last edited by mtcwby; 09-11-2009 at 12:09 PM.
mtcwby is offline   Reply With Quote
Old 09-11-2009, 12:17 PM   #49
o2camaross
 
o2camaross's Avatar
 
Drives: 2010 2SS/RS & 04 silvy
Join Date: Mar 2008
Location: Driving
Posts: 362
My story is that I was using launch control and it broke. That's the whole story.
o2camaross is offline   Reply With Quote
Old 09-11-2009, 05:47 PM   #50
rayhawk

 
rayhawk's Avatar
 
Drives: Trailblazer SS
Join Date: Aug 2008
Location: Miami
Posts: 995
Don't give up, show them you are not the only one and that this part was obviously defective. LOL about the tire wear, that is a BS excuse.
__________________
Hooters, hooters, yum yum yum, hooters, hooters on a girl thats dumb.
-Al Bundy

07 2WD Trailblazer SS, LS1 E-fans, 4" FWI, pcmforless tune
rayhawk is offline   Reply With Quote
Old 09-12-2009, 06:52 PM   #51
mtcwby
High on "The Camaro Life"
 
mtcwby's Avatar
 
Drives: 2010 2SS, IOM, LS3, Vortech, LG cam
Join Date: May 2009
Location: Big Sandy, MT & Yuma, AZ
Posts: 1,028
Send a message via AIM to mtcwby
I almost forgot, cause I was busy driving my Camaro. Seemed like i was without her forever, but they only had it for 1 1/2 days. Great job replacing the half shaft, cleaned up all the grease for me. I have nothing but great
things to say about Davidson Gebhardt Chevrolet and their service dept, especially Gregg (service advisor) and Ryan (mechanic).
Thanks guys!!!
__________________
"The democracy will cease to exist when you take away from those who are willing to work and give to those who are not."-Thomas Jefferson------Going Strong at 39,250 miles
mtcwby is offline   Reply With Quote
Old 09-12-2009, 07:13 PM   #52
omegaman
 
omegaman's Avatar
 
Drives: very poorly
Join Date: May 2009
Location: Glendale, Arizona
Posts: 550
Send a message via AIM to omegaman
Quote:
Originally Posted by o2camaross View Post
My story is that I was using launch control and it broke. That's the whole story.
Launch Control is an approved feature designed and built for use with this vehicle. This is plainly stated in the owner's manual. Your argument should be that you were using the vehicle in exactly the manner outlined by GM in the owner's manual.

See my attached excerpt from the Camaro Owner's Manual.

Look, the owner's manual will put the sleeper hold on them.
Attached Images
 
__________________
2013 Camaro ZL1, Crystal Red, Auto, Exposed Carbon Fiber, Navigation.
omegaman is offline   Reply With Quote
Old 09-12-2009, 07:21 PM   #53
jayson71
 
Drives: 2010 Victory Red Camaro
Join Date: Jun 2009
Location: Sacramento California
Posts: 283
Lost a drive line this week using launch control. Covered under warranty and will be repaired in a few days. I can't believe you are having this problem.
jayson71 is offline   Reply With Quote
Old 09-12-2009, 08:11 PM   #54
PsyDoc
 
Drives: Soon-to-be 1st Gen
Join Date: Nov 2008
Location: Southeast
Posts: 249
Quote:
Originally Posted by omegaman View Post
Launch Control is an approved feature designed and built for use with this vehicle. This is plainly stated in the owner's manual. Your argument should be that you were using the vehicle in exactly the manner outlined by GM in the owner's manual.

See my attached excerpt from the Camaro Owner's Manual.

Look, the owner's manual will put the sleeper hold on them.

Yes, but if you go a few pages forward, you can see that GM gives itself an out printed in the bold "Notice" section:



PsyDoc is offline   Reply With Quote
Old 09-12-2009, 08:29 PM   #55
04ssSilverado
 
04ssSilverado's Avatar
 
Drives: above `12 zl1 #780
Join Date: May 2009
Location: holly-springs,nc
Posts: 197
i have "clicking noise, 2-3 clicks when i turn left and accelerate normally.need advice on dealer to trust, because i don't trust any of them.
04ssSilverado is offline   Reply With Quote
Old 09-12-2009, 11:34 PM   #56
omegaman
 
omegaman's Avatar
 
Drives: very poorly
Join Date: May 2009
Location: Glendale, Arizona
Posts: 550
Send a message via AIM to omegaman
Quote:
Originally Posted by PsyDoc View Post
Yes, but if you go a few pages forward, you can see that GM gives itself an out printed in the bold "Notice" section:
No out for GM. Launch Control a standard feature, and the driver using the feature as instructed.

Additionally, warning is for transmission damage due to shifting while car has no traction. In the OP's case, he has CV joint issue - not transmission issue.
__________________
2013 Camaro ZL1, Crystal Red, Auto, Exposed Carbon Fiber, Navigation.
omegaman is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Post your VIN if your transmission broke! McGruff 5th Gen Camaro SS LS LT General Discussions 37 09-03-2009 11:25 AM
2010 Camaro 2SS/RS Output Shaft broke KimPossible Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 60 08-31-2009 03:04 PM
2010 Camaro 2SS Needs Repair Bumleb 5th Gen Camaro SS LS LT General Discussions 164 04-27-2009 10:09 PM
Heart Broke at Philly today. . . franknbeans 5th Gen Camaro SS LS LT General Discussions 53 02-10-2009 09:22 AM
Love it or Hate it - this GTR is Fast...well then they say it broke! rmyers General Automotive + Other Cars Discussion 21 01-22-2009 08:44 PM


All times are GMT -5. The time now is 09:08 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.