Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Solo Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)

V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) Driveshafts | Differentials | Gears | Rearends | Clutch | Shifters

Reply
 
Thread Tools
Old 09-13-2009, 08:21 AM   #1
Dakrevar
 
Drives: VR 2010 SS/RS
Join Date: Jun 2009
Location: Apple Valley, MN
Posts: 3
Issue with Clutch

Went to have a little fun the other day and when i released the clutch hard in first the pedal did not return fully and i took a couple of thousand miles of the clutch plate. When i went to shift to 2nd it did the same thing. I pumped the clutch a few times and it returned to normal. I took the car for a short easy drive and when i returned i looked at the brake/clutch reservoir and its completely full to the cap. Anyone have any ideas what could cause this?
Dakrevar is offline   Reply With Quote
Old 09-13-2009, 09:56 AM   #2
omegaman
 
omegaman's Avatar
 
Drives: very poorly
Join Date: May 2009
Location: Glendale, Arizona
Posts: 510
Send a message via AIM to omegaman
Quote:
Originally Posted by Dakrevar View Post
Went to have a little fun the other day and when i released the clutch hard in first the pedal did not return fully and i took a couple of thousand miles of the clutch plate. When i went to shift to 2nd it did the same thing. I pumped the clutch a few times and it returned to normal. I took the car for a short easy drive and when i returned i looked at the brake/clutch reservoir and its completely full to the cap. Anyone have any ideas what could cause this?
I believe this forum member is having the same issue as you.
__________________
2013 Camaro ZL1, Crystal Red, Auto, Exposed Carbon Fiber, Navigation.
omegaman is offline   Reply With Quote
Old 09-13-2009, 01:29 PM   #3
halo8hkk

 
Drives: 2000 Z28. 2010 1SS IMB.
Join Date: Aug 2009
Location: New Mexico
Posts: 1,039
i wonder if the drill mod applies to the 2010 also. any one know?
__________________
1990 RS = First Car -SOLD
2000 Z28 = SOLD

2010 1SS/RS = Mysstique
Whipple Supercharger
Dyno= 618hp 555tq at the wheels
IMB Silver Stripes
VIN#44025
Born: 9/9/09 Delivered: 9/28/09
halo8hkk is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch fluid contamination problems on Vette fixed for Camaro??? LDGn63 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 11 05-28-2012 10:17 PM
Coming Soon! RAM Twin Disc Clutch and Flywheel! Taking Pre-Order List @BMC Peformance Kris@BMCPerformance V8 Bolt-Ons & Tunes 7 02-18-2010 08:00 PM
Clutch "Sticking" Issue - Not Clutch Dust - Not Boiling Fluid Embalmer Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 1 09-11-2009 10:52 AM
Vengeance Racing Introduces RPS Organic Street Twin Clutch for 2010 Camaro!!! Ron@Vengeance V8 Bolt-Ons & Tunes 2 08-05-2009 02:03 PM
Burned my clutch a bit with Launch Control.... Caution you guys... Embalmer 5th Gen Camaro SS LS LT General Discussions 49 04-23-2009 09:49 PM


All times are GMT -5. The time now is 05:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.