Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Wheels and Tires Talk Sponsored by The Tire Rack

Wheels and Tires Talk Sponsored by The Tire Rack Discuss issues related to wheels and tires

Reply
 
Thread Tools
Old 09-22-2009, 11:39 PM   #1
JDBeck23

 
Drives: 2010 Camaro, 2SS/RS
Join Date: May 2009
Location: King George, Va
Posts: 877
Bump steer, vague steering on center... Anyone else noticed??

So I felt after getting my car that I had a bit of a bump steer/vague on center steering.

I went on a 5 week business trip and came back, felt like I was 16, couldnt drive for $%#@! But it gave me a great opportunity to have a fresh look at what I felt was a small, but noticeable "habit" of my car's front end.

On center, especially when accelerating (not neccesarily "getting on it") the front end feels excessively light, and feels the tendency to "walk" a bit, which forces me to do a slight left right motion like in the ooolld cars from 50's... nothing excessive like ACTUALLY being in one of those old cars though, just trying to paint a picture. The steering feels vague on center is my point here.

Coupled with that, and may not be directly related, but if im on rough road that has ruts and or bumps on one side of the lane and not the other, a few times I've had the steering wheel move way more than I was comfortable with as a result of the bump. Around the corner from my work there's a road that's nothing but ruts for about a few hundred feet. When I hit that stretch of road the steering require virtually constant inputs to keep the car in the lane (mind you, these ruts are huge), but it really made me feel like the vagueness of the front end was making the problem much worse.

So it seems that I have 2 separate issues here, the general vagueness of on center steering, coupled with a tendency to bump steer. Anyone experience this too??
__________________

2010 2SS/RS CGM
American Racing Headers, Magnaflow axle back, Roto-Fab CAI, Audio Integrations Sub box, Alpine Type R 10, Alpine MRP-500 amp, Pro Clips iPhone Mount
JDBeck23 is offline   Reply With Quote
Old 09-23-2009, 12:16 AM   #2
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
the Camaro has an insignificant amount of bump steer. so your issues are not that.

What you are probably feeling is the effects of excess body role, ad undersprung coils. Also now that Pedders has caster adjustment, adding caster can help as well.

mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 09-23-2009, 01:00 AM   #3
JDBeck23

 
Drives: 2010 Camaro, 2SS/RS
Join Date: May 2009
Location: King George, Va
Posts: 877
So what you're telling me is that it's nothing "wrong" with my car... it's the camaro's suspension??
__________________

2010 2SS/RS CGM
American Racing Headers, Magnaflow axle back, Roto-Fab CAI, Audio Integrations Sub box, Alpine Type R 10, Alpine MRP-500 amp, Pro Clips iPhone Mount
JDBeck23 is offline   Reply With Quote
Old 09-23-2009, 01:33 AM   #4
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by JDBeck23 View Post
So what you're telling me is that it's nothing "wrong" with my car... it's the camaro's suspension??
Absolutely not!!. First thing, you should take it to the dealer and go on a road test so they can experience what you are feeling. But if they do not find anything, then I think it is save to assume my conclusions could be the case.

mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 09-23-2009, 01:43 AM   #5
JDBeck23

 
Drives: 2010 Camaro, 2SS/RS
Join Date: May 2009
Location: King George, Va
Posts: 877
Ok, im with ya. Im just wondering if alot of camaro owners are experiencing similar issues... I dont expect anyone to be able to "diagnose" the problem over the internet.
__________________

2010 2SS/RS CGM
American Racing Headers, Magnaflow axle back, Roto-Fab CAI, Audio Integrations Sub box, Alpine Type R 10, Alpine MRP-500 amp, Pro Clips iPhone Mount
JDBeck23 is offline   Reply With Quote
Old 09-23-2009, 01:45 AM   #6
BumbleDs
 
BumbleDs's Avatar
 
Drives: 2010 Camaro RS/SS TF Edition
Join Date: Sep 2009
Location: Des Moines
Posts: 629
mine pulls a little during braking
BumbleDs is offline   Reply With Quote
Old 09-23-2009, 02:15 AM   #7
fastscout
 
fastscout's Avatar
 
Drives: 14' sw 2ss
Join Date: Apr 2009
Location: washington state
Posts: 220
mine feels perfect...tracks well, mine has none of the problems the op is describing.
fastscout is offline   Reply With Quote
Old 09-23-2009, 04:24 AM   #8
HeatherMarie2LT
baby #10,978
 
HeatherMarie2LT's Avatar
 
Drives: 2010 2LT
Join Date: Sep 2009
Location: Cleveland, Ohio
Posts: 68
Quote:
Originally Posted by BumbleDs View Post
mine pulls a little during braking
mine did a little for a while-during the breakin. Not anymore
__________________
HeatherMarie2LT is offline   Reply With Quote
Old 09-23-2009, 10:25 AM   #9
usmcjlp

 
Drives: 2SS/RS LS3 RJT
Join Date: Jun 2009
Location: Northern Virginia
Posts: 755
I purchased a 2SS on Thursday. I immediately felt what you are talking about. I had the car at about 100-110 mph. At those speeds the body roll was excessive. Car felt very much like the front end was floating. During lane changes I had excessive body roll.

Lucky for me, I had a full Pedders coilover suspension installed by JusticePete on Friday. The difference is dramatic. I will post a thread tonight. I am way past due but I had difficulty uploading pictures.

To address the OP, many of the factory bushings are way too soft. The front radius rod bushings make a huge difference in feel. The rear subframe bushings change the feel under acceleration.

If your vehicle checks out at the dealer then I recommend you start with the street bushing kit and a more performance oriented alignment. This will tighten up the feel of the car greatly. People really underestimate the effect of a good alignment. If that isn't enough you can look at other suspension components, such as sway bars or coils. Start small first, no need to overspend. I originally planned to do more, but Pete talked me out of it. Car now has more capability than I can use on the street.
usmcjlp is offline   Reply With Quote
Old 09-24-2009, 03:31 AM   #10
JDBeck23

 
Drives: 2010 Camaro, 2SS/RS
Join Date: May 2009
Location: King George, Va
Posts: 877
Thanks, USMCJLP!

I spent the afternoon in the car, I had to go to a custom exhaust shop to get my ARH-Magnaflow system finished and get a custom bent piece put in between them. The shop was an hour each way. So as im driving the car... I really got a chance to play around and see what I could figure out... Here's the conclusion I came to.

All of the things that I noticed stem from the same problem (I believe). I noticed a good amount of play in the steering from center. Going 60 miles an hour, I can very quickly "jiggle" the steering wheel left and right about 2 or 2.5 inches in each direction and get pretty much ZERO response from the suspension or front wheels. When I move the steering wheel about 3 inches left to right very quickly, I can start feeling the suspension and steering move... body roll in each respective direction, car moving in the lane, etc etc. But not as much as my brain tells me that the car SHOULD be moving based on how much im jostling the steering wheel.

Now during normal driving, when Im just happily driving down the road, I can feel certain road conditions affect the front suspension, and when it does, it makes the car turn slightly... which is not unheard of.... but what was throwing an alarm in my head of something not being right, is that I could feel the car moving (turning slightly due to the bump), but I couldnt feel any input in the steering wheel at all.

So I think that's another aspect of the same problem. The steering wheel doesnt feel like I have "slop" at all. There's no "dead spot" where I feel I have no connection to the steering rack. The steering wheel feel is consistent throught a 360 degree turn. It's just when im at center, it seems there's a noticeable gap from where im turning the wheel and when the front tires respond.

Im definitely taking the car in to be checked out, but im just curious if that sounds more like what you guys have noticed.... And if not, what could possibly cause something like that?? I really dont think it could be steering rack, or steering knuckle related... Because like I said, there's no "slop" in the steering per-say. Can a loose ball joint or loose endlink cause this kind of problem?

Thanks in advance for the help! And thanks again USMCJLP for the response!
__________________

2010 2SS/RS CGM
American Racing Headers, Magnaflow axle back, Roto-Fab CAI, Audio Integrations Sub box, Alpine Type R 10, Alpine MRP-500 amp, Pro Clips iPhone Mount
JDBeck23 is offline   Reply With Quote
Old 09-24-2009, 03:34 AM   #11
BumbleDs
 
BumbleDs's Avatar
 
Drives: 2010 Camaro RS/SS TF Edition
Join Date: Sep 2009
Location: Des Moines
Posts: 629
well anyone who has the title USMC is a go to kinda man. Oohrah!
BumbleDs is offline   Reply With Quote
Old 09-24-2009, 07:14 AM   #12
hogandtow
 
Drives: 2010 1ss
Join Date: Jun 2009
Location: st. louis mo.
Posts: 12
me also

my stearing was very vauge on center felt very nervous unlike my 95 vette or the wifes monte ss which are very tight and go down the road with out having to play with the stearing much. i had work done on the wifes 02 monte at 90000 miles and a alignment done and the car drove like the camaro. looked at the print out of the alignment and he had it in specs but the front and rear were toed out. i told him about how it was driving and i wanted it toed back in as before, drives great again. so on the camaro i toed the front and rear 1/6" and drives much better. before the wind off of semi trucks would make it move around a little not any more turn in might be a little slower but i am much happier. tire wear yet to be seen. i used two jack stands and string method to set toe i am thinking about having it aligned to the vette specs and will most likely do so after pfat sway bars in the next month. also when getting on the throttle the front end does not feel light any more.
hogandtow is offline   Reply With Quote
Old 09-24-2009, 07:29 AM   #13
usmcjlp

 
Drives: 2SS/RS LS3 RJT
Join Date: Jun 2009
Location: Northern Virginia
Posts: 755
Are you getting any noise from the suspension? You can put the vehicle on a rack and check for any loose fittings or signs of rubbing or unusual wear around the joints. I know in my vehicle it took two techs with some very large pry bars to get the factory bushings loose. The car was extremely tight. What's the current mileage? Have you ever hit something that makes you doubt the suspension? I'm sure you've already thought of these things.

I would speak to or pm JusticePete, Mike at DMS, or Jordan at Pfadt racing. I chose Pedders because of the chance for Pete to work on my car and the multiple recommendations I received. But I spoke with Pedders, Pfadt Racing, and Detroit Speed before deciding. All of these people have many hours driving the vehicle. They had several things in common but somewhat different approaches. All agreed that the factory suspension was too soft for the power level of the vehicle.

I will tell you what they recommended to me, but please contact them directly. They are much more knowledgeable than I am. Both Pedders and Pfadt feel the subframe bushings need to be upgraded immediately. They offer the most bang for the buck. I can say that on launch the rear end tends to want to wallow a bit. The factory bushings are very soft and have a very narrow ring that actually contacts the subframe. I was able to deflect it with my thumb. The urethane bushings are not only harder they have a much larger surface area. Both agreed on the body roll issue. Pfadt recommended their sway bars first before coilovers. Pedders recommended coilovers then sway bars. So they end up in a similar setup. I do like that the coilover tension is easily adjustable so if you are not happy with the ride you can always change it without much effort or more money spent. I lowered mine about 2 1/2 inches and the ride is awesome. I also have the splash guards. I drove around Detroit looking for potholes and have never bottomed out or scraped. Alignment racks take some work though, just the curb feeler. A couple of long boards solved it though. Pete's car sits so low that I could barely fit 3 fingers underneath it and he never bottomed out either. Trust me, he drives it like he stole it. He loves to have fun with that thing. All I can say is that when he turns the dumps on watch out.
I have about 650 miles on the new suspension. I hope this helps. I will pm you when I finally get my thread up.
usmcjlp is offline   Reply With Quote
Old 09-24-2009, 12:01 PM   #14
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by JDBeck23 View Post
Thanks, USMCJLP!

I spent the afternoon in the car, I had to go to a custom exhaust shop to get my ARH-Magnaflow system finished and get a custom bent piece put in between them. The shop was an hour each way. So as im driving the car... I really got a chance to play around and see what I could figure out... Here's the conclusion I came to.

All of the things that I noticed stem from the same problem (I believe). I noticed a good amount of play in the steering from center. Going 60 miles an hour, I can very quickly "jiggle" the steering wheel left and right about 2 or 2.5 inches in each direction and get pretty much ZERO response from the suspension or front wheels. When I move the steering wheel about 3 inches left to right very quickly, I can start feeling the suspension and steering move... body roll in each respective direction, car moving in the lane, etc etc. But not as much as my brain tells me that the car SHOULD be moving based on how much im jostling the steering wheel.

Now during normal driving, when Im just happily driving down the road, I can feel certain road conditions affect the front suspension, and when it does, it makes the car turn slightly... which is not unheard of.... but what was throwing an alarm in my head of something not being right, is that I could feel the car moving (turning slightly due to the bump), but I couldnt feel any input in the steering wheel at all.

So I think that's another aspect of the same problem. The steering wheel doesnt feel like I have "slop" at all. There's no "dead spot" where I feel I have no connection to the steering rack. The steering wheel feel is consistent throught a 360 degree turn. It's just when im at center, it seems there's a noticeable gap from where im turning the wheel and when the front tires respond.

Im definitely taking the car in to be checked out, but im just curious if that sounds more like what you guys have noticed.... And if not, what could possibly cause something like that?? I really dont think it could be steering rack, or steering knuckle related... Because like I said, there's no "slop" in the steering per-say. Can a loose ball joint or loose endlink cause this kind of problem?

Thanks in advance for the help! And thanks again USMCJLP for the response!
The way that rack and pinion works, is much tighter on center than the old style worm and recirculating ball nut style. This is the reason rack and pinions are used; much more positive steering thru the entire turns.
With that said, and assuming the gear has proper preloads, then anything loose at all, from tie rods, ball joints, bolts, etc, can create a looseness. So if everything, I mean OE tight, then you need to think what could be causing excess loosen which we have documented very well. This relates to the posts that I made above.

Now in terms of drift, GM for some unknown reason, did not make the casters adjustable. We think this is a big mistake. What is odd, is the adjuster plates are there, but the hole that mounts the front radius rod bushing is not slotted. Therefore no adjustability is available. Also GM has a camber adjusting hole in the knuckle, but no bolt. This is the same configuration as GTOs and G8s. So if your car is drifting due to road crown, then your only opportunity is to mess with camber. We think this should not be done.
Pedders now has an extremely high quality front align kit. It includes lifetime warranty on the eccentrics for caster, and a special bolt that can be used for adjusting cambers easier. Now the caster adjusters will require drilling out and eventually slotting the mounting holes. this process will take about 30-45 minutes. But then you will have complete adjustability of caster for road crown compensation, plus will have the ability to increase caster, which will also help in that centerline steering feel.

But the Camaro has a serious amount of body role, that is "challenged" by its short wheel base, excess weight, excess height, under-tired, under sprung, and excess movements in nearly every bushing in the suspension that allows a lot of unwanted movement. So our feelings at Pedders is not to try and mask it first, but to fix it by coils, and critical bushings. Now we do/have the masking approach for the budget minded as well.

Pedders has looked at the Camaro and has solutions for all types of driver skills. We have on the forums, focused primarily on the max handling positions and opportunities because thru this process, that has been baby steps, testing, another step, testing, etc, etc, that gives us a serious amount of practical advantage and knowledge for the weekend warrier, canyon runner, drag racer, cruiser, auto crosser, and track guy, and just the ordinary Joe who just wants to tighten her up a little. Pedders USA has spent a massive amount of time, engineering, testing for all of these solutions. We have been a company that other companies can come to for assistance. Case in point, it is a concern for SCCA T2 with the front OE fluid filled radius rod bushings. In this class, the bushing cannot be replaced. But on the OE bushing, there are 2 rubber bushings that are like bumpers. they call them snubbers. We now have these replacement snubbers that help to strengthen the OE radius rod bushings. SCCA has been petitioned to allow these snubbers for safety sake.

thanks
mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 09-24-2009, 02:06 PM   #15
DDustiNN

 
DDustiNN's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Feb 2009
Location: MI
Posts: 1,845
Send a message via Skype™ to DDustiNN
I have both issues you're talking about (I think). When I'm driving, my car will drift slightly to the right if I let go of the steering wheel. I feel like I'm almost always having to hold the wheel slightly to the left just to go straight. But here's the thing... this was the exact same way on my previous 2 cars... (Ford Fusion and Dodge Stratus coupe, both V6). If you notice, most roads have a slight "hump" to them toward the center... This is so the water drains off to the sides when it rains. This seems to be the reason that cars will drift to the right. When I drive on a one-way street, where the left lane is the left-most part of the road, I don't seem to have the drifting problem.

Also, as far as the steering wheel when hitting bumps... I'd say this is normal. Again, I have this happen right now, as well as in my previous cars. There are 2 spots in particular where I drive that have this, and both are littered with huge ruts on the left side of the lane only. And every time I hit these sections, my car severely pulls to the left. Moreso with increased traveling speed, it seems.

So, all-in-all... through my completely non-professional diagnosis ()... Your car sounds pretty normal to me
__________________
DDustiNN is offline   Reply With Quote
Old 09-24-2009, 08:55 PM   #16
usmcjlp

 
Drives: 2SS/RS LS3 RJT
Join Date: Jun 2009
Location: Northern Virginia
Posts: 755
Thank you Mike for posting. I was doing a poor job of trying to explain Pedders' approach.

I can honestly say that after installing my Pedders Coil over suspension it feels like a different vehicle. I am much more comfortable in its handling capabilities. For me, it solved the problems that I had with the stock ride. Vehicle tracks true and is much more responsive. Handling and turn in is impressive. I'm no expert, but the car simply feels smaller. I can dart through traffic and make rapid lane changes and the vehicle feels very crisp with no delay in response. I am very happy with my decision. I would recommend any forum member do their own research. Contact Pedders directly and speak to them. I hate to hard sell anyone as that was not the intent of this thread. But if anyone has questions feel free to contact me and I will provide you with more details.
usmcjlp is offline   Reply With Quote
Old 09-25-2009, 04:58 PM   #17
JDBeck23

 
Drives: 2010 Camaro, 2SS/RS
Join Date: May 2009
Location: King George, Va
Posts: 877
Quote:
Originally Posted by hogandtow View Post
my stearing was very vauge on center felt very nervous unlike my 95 vette or the wifes monte ss which are very tight and go down the road with out having to play with the stearing much. i had work done on the wifes 02 monte at 90000 miles and a alignment done and the car drove like the camaro. looked at the print out of the alignment and he had it in specs but the front and rear were toed out. i told him about how it was driving and i wanted it toed back in as before, drives great again. so on the camaro i toed the front and rear 1/6" and drives much better. before the wind off of semi trucks would make it move around a little not any more turn in might be a little slower but i am much happier. tire wear yet to be seen. i used two jack stands and string method to set toe i am thinking about having it aligned to the vette specs and will most likely do so after pfat sway bars in the next month. also when getting on the throttle the front end does not feel light any more.
Now that I hadnt thought of. Im not a suspension expert, but Im sure the factory alignment has got to be a "quick, down and dirty" and get them out of there as fast as possible! So that'd make sense that some cars are toed out more than they're supposed to. I didnt realize being toed out will cause the car to be so jumpy... I'll definitely have the tech check the alignment.
__________________

2010 2SS/RS CGM
American Racing Headers, Magnaflow axle back, Roto-Fab CAI, Audio Integrations Sub box, Alpine Type R 10, Alpine MRP-500 amp, Pro Clips iPhone Mount
JDBeck23 is offline   Reply With Quote
Old 09-25-2009, 05:03 PM   #18
JDBeck23

 
Drives: 2010 Camaro, 2SS/RS
Join Date: May 2009
Location: King George, Va
Posts: 877
Quote:
Originally Posted by usmcjlp View Post
Are you getting any noise from the suspension? You can put the vehicle on a rack and check for any loose fittings or signs of rubbing or unusual wear around the joints. I know in my vehicle it took two techs with some very large pry bars to get the factory bushings loose. The car was extremely tight. What's the current mileage? Have you ever hit something that makes you doubt the suspension? I'm sure you've already thought of these things.
Yeah I had been racking my brain along those lines all week, but thanks for bringing them up, helps me feel sane!

I have 3k on the clock, havent hit anything, not even a pothole! (knock on wood) I dont have access to a lift, otherwise I would have checked sooner! I had thought about throwing the car up on stands, and getting the creeper out, but my neck gets sore just thinking about it!

Thanks for the info, it's good to hear that there's a solution already out there in the aftermarket. I just need to make sure with the dealer that my car doesnt have a problem... then I'll be ringing Pedders phone to see where I should start! Thanks again!
__________________

2010 2SS/RS CGM
American Racing Headers, Magnaflow axle back, Roto-Fab CAI, Audio Integrations Sub box, Alpine Type R 10, Alpine MRP-500 amp, Pro Clips iPhone Mount
JDBeck23 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Steering Wheel off center from factory...Advice Please DCJ Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 5 09-07-2009 11:52 AM


All times are GMT -5. The time now is 03:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.