Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing

Mechanical Maintenance: Break-in / Oil & Fluids / Servicing Discussions on mechanical maintenance and servicing of your Camaro

Reply
 
Thread Tools
Old 10-06-2009, 01:18 PM   #1
a_Username


 
a_Username's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Jul 2009
Location: Murfreesboro, TN
Posts: 3,893
A/C Units

I've had my in twice for A/C related problems. The first time was for a cracked compressor, in which they had to replace it (where the A/C completely went out and wouldn't blow cold air). Then a coolant line was loose and they had to redo it (hissing/air leaking noise from behind the passenger dash). This is apparently common problems with the Camaro, so just giving people a head's up if they hear or see anything related to the problems mentioned above.
a_Username is offline   Reply With Quote
Old 10-06-2009, 01:32 PM   #2
Michael_Js
SoCal C5 Family Member
 
Michael_Js's Avatar
 
Drives: 2010 Camaro SS/RS - Black w/IOM; 6M
Join Date: Jul 2009
Location: San Diego, CA, USA
Posts: 5,317
Send a message via AIM to Michael_Js Send a message via MSN to Michael_Js
What are the symptoms to look for? SOunds?
__________________
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~
2010 Black 2SS/RS; 6M; IOM, GFX, sunroof; ADM Race CAI; Zoomers CB; Viper Alarm; Pdaft F&R sways, Adj Endlinks, Rtrailing arms, Camber kit, strut brace, Front Trailing Arm Bushing; SLP Skip-Shift Elim; Tinted lights/windows; Hurst Short-throw; LoJack; Door & Dash ABL Mods; Subthump; JBA Shorty headers; AACStyle LEDs; Stillen DS rotors, Hawk Ceramic pads; Havoc Blk Chrome wheels: 20x9s; Lingenfelter Blk Al Pedals; RevXtreme Catch Can; Goodridge SS lines; Ported TB; RK Sport hood; Hotchkis chassis brace; KW V3 coilovers;
Michael_Js is offline   Reply With Quote
Old 10-06-2009, 01:34 PM   #3
a_Username


 
a_Username's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Jul 2009
Location: Murfreesboro, TN
Posts: 3,893
Quote:
Originally Posted by Michael_Js View Post
What are the symptoms to look for? SOunds?
For the compressor, there wasn't any noise. It just stopped blowing cold air. But for the coolant line, it was a hissing/air leaking noise coming from behind the passenger dash. It really started hissing above 3 RPMs.
a_Username is offline   Reply With Quote
Old 10-06-2009, 02:34 PM   #4
a_Username


 
a_Username's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Jul 2009
Location: Murfreesboro, TN
Posts: 3,893
I guess this might fall under the Camaro Issues section too?
a_Username is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Color and Model Numbers from spasticsquirrel TAP101 5th Gen Camaro SS LS LT General Discussions 87 10-07-2009 10:31 PM
Odor from A/C vents anyone? OBSSEST Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 1 10-02-2009 09:39 AM
A/C ISSUE!! whiplash Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 2 09-23-2009 01:02 PM
Vararam Test Units Shipping!!!! sales@vararam.com Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 13 08-21-2009 11:49 PM
GM keeping good numbers? bballr4567 5th Gen Camaro SS LS LT General Discussions 10 05-10-2009 10:38 AM


All times are GMT -5. The time now is 09:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.