Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JDP Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Tuning / Diagnostics -- engine and transmission

Tuning / Diagnostics -- engine and transmission Tune and diagnostics for engines and auto transmission.

Reply
 
Thread Tools
Old 06-19-2011, 07:25 PM   #1
Kinetic Kev HWSE 2013

 
Kinetic Kev HWSE 2013's Avatar
 
Drives: 2013 Hot Wheels Special Edition
Join Date: May 2009
Location: Auburn,Mass
Posts: 1,338
engine code

Today while I was crusing around my check engine light came on today so I had OnStar do a vehicle diagnostics and I was told that the code was P0157 oxygen Sensor Circuit Low Voltage (bank 2 sensor 2). Has anyone ever gotten this code and if so what can be done to fix this?
Kinetic Kev HWSE 2013 is offline   Reply With Quote
Old 06-19-2011, 07:33 PM   #2
Slowhawk
LSX specialty shop

 
Drives: 1999 Trans Am
Join Date: Jul 2009
Location: Bridgewater,Ma
Posts: 1,642
It's ussually a cat problem. Does the car have headers?
__________________


Bridgewater, Ma
(508)659-4454
Slowhawk is offline   Reply With Quote
Old 06-19-2011, 07:34 PM   #3
Kinetic Kev HWSE 2013

 
Kinetic Kev HWSE 2013's Avatar
 
Drives: 2013 Hot Wheels Special Edition
Join Date: May 2009
Location: Auburn,Mass
Posts: 1,338
Yes Kooks Lt'S with HF Cats also Kooks
Kinetic Kev HWSE 2013 is offline   Reply With Quote
Old 06-19-2011, 07:37 PM   #4
Tampa Tuning
Like us on Facebook!

 
Tampa Tuning's Avatar
 
Drives: C5 Corvette/ 2010 Camaro
Join Date: Oct 2010
Location: Tampa, Fl
Posts: 2,553
you'll need a tune or sims to neutralize your rear O2 sensors
__________________

Read this :
http://www.camaro5.com/forums/showth...20#post7838320

www.TampaTuning.com
Camaro Corvette CTS GTO Tuner Tampa Orlando Bradenton
Tampa Tuning is offline   Reply With Quote
Old 06-19-2011, 07:49 PM   #5
Kinetic Kev HWSE 2013

 
Kinetic Kev HWSE 2013's Avatar
 
Drives: 2013 Hot Wheels Special Edition
Join Date: May 2009
Location: Auburn,Mass
Posts: 1,338
The car is tuned, first time in a year I have gotten a check engine light
Kinetic Kev HWSE 2013 is offline   Reply With Quote
Old 06-19-2011, 09:29 PM   #6
MARINE1991


 
MARINE1991's Avatar
 
Drives: COTW 8/29/11 2010 CAMARO
Join Date: Jul 2009
Location: hickville NC USA
Posts: 9,929
Quote:
Originally Posted by Slowhawk View Post
It's ussually a cat problem. Does the car have headers?
its not a cat problem, its an O2 sensor issue, they go bad and need to be replaced.. After 2 weeks, I had my bank 1 go bad, replaced it and hold up well so far.
MARINE1991 is offline   Reply With Quote
Old 06-19-2011, 09:30 PM   #7
MARINE1991


 
MARINE1991's Avatar
 
Drives: COTW 8/29/11 2010 CAMARO
Join Date: Jul 2009
Location: hickville NC USA
Posts: 9,929
Quote:
Originally Posted by 2010CamaroSS/RS View Post
The car is tuned, first time in a year I have gotten a check engine light
Yea mine went bad after installing kooks, the performance guy told me they go bad often...
MARINE1991 is offline   Reply With Quote
Old 06-19-2011, 10:50 PM   #8
Kinetic Kev HWSE 2013

 
Kinetic Kev HWSE 2013's Avatar
 
Drives: 2013 Hot Wheels Special Edition
Join Date: May 2009
Location: Auburn,Mass
Posts: 1,338
Guess I'll bring up to the dealer and have them check it out for me
Kinetic Kev HWSE 2013 is offline   Reply With Quote
Old 06-19-2011, 11:05 PM   #9
13 ZL1
 
13 ZL1's Avatar
 
Drives: 2013 IOM ZL1
Join Date: Nov 2009
Location: Manteca CA
Posts: 689
You might want to check to see if it is loose before going to the dealer.
13 ZL1 is offline   Reply With Quote
Old 06-20-2011, 06:40 PM   #10
Kinetic Kev HWSE 2013

 
Kinetic Kev HWSE 2013's Avatar
 
Drives: 2013 Hot Wheels Special Edition
Join Date: May 2009
Location: Auburn,Mass
Posts: 1,338
I don't have access to do that, no ramps or a jack. If its still under warranty I'll just let them take care of it.
Kinetic Kev HWSE 2013 is offline   Reply With Quote
Old 06-20-2011, 07:02 PM   #11
camaro1

 
camaro1's Avatar
 
Drives: 550+RWHP 2010 camaro
Join Date: Sep 2007
Location: wisconsin
Posts: 1,588
car is tuned and has headers and aftermarket cats, the dealer isnt going to help you on this issue

its just a code for the rear o2,, just have your tuner fix up the tune
__________________
415ci stroker, TVS 2300 Magnacharger, cnc heads, cam, yank ss3200 converter, Kooks long tubes, Bwoody true cold air kit, ZL1 Pump, magnaflow 3" cat-back, lowering springs,BMR control arms and tie rod bars, 3.73 gears, diff mounts, RX can, ADM fuel controller
camaro1 is offline   Reply With Quote
Old 06-20-2011, 08:01 PM   #12
Slowhawk
LSX specialty shop

 
Drives: 1999 Trans Am
Join Date: Jul 2009
Location: Bridgewater,Ma
Posts: 1,642
Quote:
Originally Posted by camaro1 View Post
car is tuned and has headers and aftermarket cats, the dealer isnt going to help you on this issue

its just a code for the rear o2,, just have your tuner fix up the tune
Exactly....

02's just don't go bad. Yes a few will but it's not a common problem.

Having codes with the rear 02's can happen anytime with longtube headers installed. It can code right away or happen a few thousand miles later.

Best is to bring it to the tuner and have them scan the car to see the problem. We just delete the rear 02's when headers are installed since they are useless and the cars still pass emissions.
__________________


Bridgewater, Ma
(508)659-4454
Slowhawk is offline   Reply With Quote
Old 06-21-2011, 05:15 PM   #13
Kinetic Kev HWSE 2013

 
Kinetic Kev HWSE 2013's Avatar
 
Drives: 2013 Hot Wheels Special Edition
Join Date: May 2009
Location: Auburn,Mass
Posts: 1,338
Ok so I took my car to the dealer and they checked the O2 sensor, I know I know its not going to help but they changed it out and the one in there was pretty dark and full of carbon I guess. Then I took it up to the shop where I got the tune and I will be getting the o2's in the back turned off hopefully this saturday or next.
Kinetic Kev HWSE 2013 is offline   Reply With Quote
Old 06-23-2011, 09:21 PM   #14
cdn2usa
 
cdn2usa's Avatar
 
Drives: 2010 2SS
Join Date: Jan 2010
Location: Midlothian, Va
Posts: 257
Your "dark and full of carbon" statement would worry me, signs of possibly running rich. What mpg are you getting after your tune? If you can remove a few plugs and check the color, should be beige with no build up.
__________________
Aqua Blue 2SS c/w factory white strips, MT.
Installed options;Tinted Windows, De-badged,
Hurst Shifter,CAI,Vmax throttle body, Kooks LT Headers, High Flow Cats,Borla Touring Axle Back, ADM Scoop, Washwater relocation,Diablo Predator(c/w Ted's Magic), Custom start defeat switch, painted engine cover, shark fin & bow ties, ABL lighting, Rear Camera.
cdn2usa is offline   Reply With Quote
Old 06-23-2011, 10:50 PM   #15
DSX
Account Suspended
 
Drives: 2006 Z06
Join Date: Oct 2010
Location: St. Louis, MO
Posts: 145
Quote:
Originally Posted by cdn2usa View Post
Your "dark and full of carbon" statement would worry me, signs of possibly running rich. What mpg are you getting after your tune? If you can remove a few plugs and check the color, should be beige with no build up.
That's what they all start to look like.
DSX is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Roto-Fab | Cold Air Intakes | Engine Covers | Washer Reservoir Relocation Kit | Fuse+ AutoAgenda V8 Bolt-Ons & Tunes 7 07-11-2011 06:50 PM
LS3 engine specifications Tran Wiki 3 10-06-2010 10:56 PM


All times are GMT -5. The time now is 04:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.