Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Detroit Speed
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions

5th Gen Camaro SS LS LT General Discussions General 5th generation Camaro topics not covered by other subforums.

Reply
 
Thread Tools
Old 10-25-2009, 09:56 PM   #1
butterfingers
 
butterfingers's Avatar
 
Drives: Rally Yellow Camaro 2LT/RS
Join Date: Sep 2009
Location: Frisco
Posts: 588
Smells from the engine???

Okay, I have only 100 miles on my new camaro and I pulled into the garage after a fast run and when I closed the door and it was just me and my ride, I noticed a melting plastic like smell .. I was like WTF?!?! I am hoping its the engine just breaking in.

Has anybody else smelled this???
butterfingers is offline   Reply With Quote
Old 10-25-2009, 10:00 PM   #2
tradosaurus
Account Suspended
 
Drives: 2010 F150 Lariat, Candy Red
Join Date: Aug 2009
Location: Texas
Posts: 1,288
Quote:
Originally Posted by butterfingers View Post
Okay, I have only 100 miles on my new camaro and I pulled into the garage after a fast run and when I closed the door and it was just me and my ride, I noticed a melting plastic like smell .. I was like WTF?!?! I am hoping its the engine just breaking in.

Has anybody else smelled this???
Well the first order of the day would be to lift up the hood and look in your engine bay.

tradosaurus is offline   Reply With Quote
Old 10-25-2009, 10:01 PM   #3
ss.yes!
 
Drives: '98 Camaro V6, '10 Camaro SS
Join Date: Jul 2009
Location: Arlington, TX
Posts: 49
Yes, I smelled something like that too. Now at about 400 miles and this has greatly diminished after each trip, almost nonexistent now. No actual performance problems, engine code, or any other issues with the car. So I am guessing that it is nothing to worry about, just a break-in thing. Though it would be nice to have a resident expert reassure us.

Edit to add:

I have looked under the hood several times since then and nothing seems to be amiss. For me the smell was only really apparent on the first two trips or so. After that it decreased rapidly. I've been known to have a very sensitive nose, so... probably nothing.
ss.yes! is offline   Reply With Quote
Old 10-25-2009, 10:01 PM   #4
guydon
 
guydon's Avatar
 
Drives: 2010 Black SS
Join Date: Oct 2009
Location: Lacey, WA
Posts: 103
Did you burn the clutch a little maybe? Some might tell you differant but you should probably wait until around 500 miles to do a "fast run". I have noticed too that the engine cover keeps in a lot of heat.
guydon is offline   Reply With Quote
Old 10-25-2009, 10:04 PM   #5
RedJewelrsss32
 
RedJewelrsss32's Avatar
 
Drives: 2010 2SS/RS Red Jewel Camaro
Join Date: Sep 2009
Location: Helena Mt
Posts: 424
Your cats and headers have a coating on them from the factory takes awhile to burn off it is normal though
__________________
WHAT IS CAMARO? A small viscious animal that EATS mustangs!!! Delivered 9/17/09
RedJewelrsss32 is offline   Reply With Quote
Old 10-25-2009, 10:08 PM   #6
ss.yes!
 
Drives: '98 Camaro V6, '10 Camaro SS
Join Date: Jul 2009
Location: Arlington, TX
Posts: 49
Cool.. thanks for the info, figured it was something like that.
ss.yes! is offline   Reply With Quote
Old 10-26-2009, 12:00 AM   #7
Gunsmoke
wat?
 
Gunsmoke's Avatar
 
Drives: 2010 Chevy Camaro SS RS
Join Date: Oct 2009
Location: Las Vegas
Posts: 177
Quote:
Originally Posted by butterfingers View Post
Okay, I have only 100 miles on my new camaro and I pulled into the garage after a fast run and when I closed the door and it was just me and my ride, I noticed a melting plastic like smell .. I was like WTF?!?! I am hoping its the engine just breaking in.

Has anybody else smelled this???

perfectly normal.
Gunsmoke is offline   Reply With Quote
Old 10-26-2009, 12:44 AM   #8
LadyGreyMyst
ABM & 69 HO RS/SS
 
LadyGreyMyst's Avatar
 
Drives: 2001 Z24 Cavalier, ABM 2LT/RS
Join Date: Mar 2009
Location: West Kootenays, BC
Posts: 141
Mine actually was smoking. Scared me a little but I had to drive it up quite a long steep hill from the dealer and when I stopped I noticed smoke coming from the rear of the car after I turned off the ignition.
__________________

Who ever said it is just a car never drove a Camaro! Bought at Champion Chevrolet, Trail, BC July 11/09!
LadyGreyMyst is offline   Reply With Quote
Old 10-26-2009, 10:57 AM   #9
Dentyneice
 
Drives: 2010 Camaro 2ss
Join Date: Apr 2009
Location: new Jersey
Posts: 252
Only thing i usually smell is my clutch burning
__________________
2010 CGM/Black 2SS M6
20% Tint -:- Hurst 44% Short Throw Shifter -:- Viper 5901 Alarm/Remote start -:- High Gloss Black Painted Calipers + White Brembo Decal
Dentyneice is offline   Reply With Quote
Old 10-26-2009, 11:03 AM   #10
MrGood

 
MrGood's Avatar
 
Drives: Broken palmghetto test car
Join Date: Oct 2009
Location: Balm, FL
Posts: 1,034
Send a message via Yahoo to MrGood
Quote:
Originally Posted by RedJewelrsss32 View Post
Your cats and headers have a coating on them from the factory takes awhile to burn off it is normal though
I test drove one at the dealership the other day and when i brought it back it was smoking and i thought for sure he was gonna be pissed.. But he said it wasnt anything to worry about and that it had to burn that coating off that redjewel mentioned.. Phew..

Last edited by MrGood; 10-26-2009 at 12:07 PM. Reason: cant spell..
MrGood is offline   Reply With Quote
Old 10-26-2009, 11:32 AM   #11
attymf
 
attymf's Avatar
 
Drives: 2010 SS/RS 6M
Join Date: Nov 2008
Location: LI, NY
Posts: 676
My car made all sorts of weird smells for about 500 miles. After that nothing. Smelled like brakes, clutch and a mix of other stuff. Now with 3500 miles just smell new leather.
attymf is offline   Reply With Quote
Old 10-26-2009, 12:06 PM   #12
butterfingers
 
butterfingers's Avatar
 
Drives: Rally Yellow Camaro 2LT/RS
Join Date: Sep 2009
Location: Frisco
Posts: 588
Very cool guys .. THANKS!!!!
butterfingers is offline   Reply With Quote
Old 10-26-2009, 01:16 PM   #13
gt2serious
Dan Hall / SS-IN-TX
 
gt2serious's Avatar
 
Drives: SW/2SS/RS/11-11-09 It's all mine!!
Join Date: Jul 2009
Location: San Antonio, TX
Posts: 285
Drove a customer's Camaro down to the gas station (mile 1/2) to fill it with premium and when I got back I had 3 people come running up to the car so I said "what gives?" and about the same time noticed a large cloud of smoke coming out from under the car! I freaked:( and took it straight back to service! Found out that during the PDI (Pre-Delivery Inspection) they are supposed to remove the factory paper stickers from the exhaust pipes and mufflers and on this car they did'nt get it all off. I left the car running for a little while and by the time my customer got there it was all burned away. Could you imagine driving up to see your brand new Camaro looking like it was burning to the ground! Glad everything was fixed by the time he drove up!
__________________
Going fast is only a state of mind....until you release the brake!
gt2serious is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LS3 engine specifications Tran Wiki 3 10-06-2010 10:56 PM
Texas Speed & Performance Fall Engine Sale Trevor @ Texas Speed V8 Bolt-Ons & Tunes 2 12-08-2009 10:19 AM
L99 engine specifications Tran Wiki 0 10-19-2008 11:40 AM
Turbocharge your way to efficiency.....and power! Mr. Wyndham Forced Induction - V8 20 07-06-2008 12:46 PM


All times are GMT -5. The time now is 02:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.