Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 06-17-2010, 01:49 PM   #171
chevyridinghigh
The Bowtie Is Back
 
chevyridinghigh's Avatar
 
Drives: 2010 Silver Camaro SS/RS -Blk Int.
Join Date: May 2009
Location: Westchester County, NY
Posts: 655
FINALLY. I thought I was going crazy. Same issue here. I have 8900 miles on her. I am going to bring it in to New Rochelle Chevy when I have a chance. It's not something that happens all the time. But when I turn into my drive way (which is on an incline), it does it. Or the occasional slow speed pot hole/speed bump. Real annoying, makes the car sound cheap.
__________________
2SS RS SIM M6 with Polish Silver wheels
chevyridinghigh is offline   Reply With Quote
Old 06-18-2010, 01:53 PM   #172
Mikamaro
Mike
 
Mikamaro's Avatar
 
Drives: a 2010 CAMARO SS LS3 1LE Track Pack
Join Date: Sep 2009
Location: In the birth land of the Gen4 Camaros & Firebirds.
Posts: 2,035
I'm adding my name to this problem.
My car has 3000miles on it and I just heard this "POP" sound coming from the front driver suspension for the second time, both case in similar circumstance: Hard right turn under breaking over uneven road. It's a scary sound you don't want to hear at all...never ever...feel like the suspension just broke or something.
__________________

Track Day Videos: http://www.youtube.com/user/mrgoodman2000/videos
Built #83817, Born January 18th, Christened June 11th 2010.
Mikamaro is offline   Reply With Quote
Old 06-18-2010, 03:00 PM   #173
camarorick

 
camarorick's Avatar
 
Drives: .
Join Date: Jan 2008
Location: .
Posts: 2,166
The more I look at the suspension, the more it looks like the noise is caused by the whole strut assembly not really being fixed to the strut tower. I commented in a thread about Pfadt's new Camber Plate Kit, that it might actually be the solution. Is there anybody with this noise willing to try out the front camber plate kit from Pfadt, and report ? Maybe Pfadt could do a trial with one of the members to see I know that if it does solve the problem, it could mean a lot of business for Pfadt

http://www.camaro5.com/forums/showthread.php?t=79167
camarorick is offline   Reply With Quote
Old 06-20-2010, 10:38 PM   #174
chuck2010
 
Drives: 2010 1SS RS Cyber Grey Metallic
Join Date: Jun 2010
Location: Rhode Isand
Posts: 1
I am adding my car to the list. It has had the same noise over sharp, low speed bumps since about 400 miles. The current mileage is 2500.
ALSO:
Does anyone else have a vibration in 4th & 5th under high load & high speed 80+?
The rear view mirror vibrates with same frequency as it does with high volume & high bass setting on the radio.
chuck2010 is offline   Reply With Quote
Old 06-23-2010, 05:38 PM   #175
jeffb100
 
Drives: 2010 Victory Red 2LT RS Auto
Join Date: Dec 2009
Location: Atlanta
Posts: 2
Angry

My car has 4000 miles (2LT/RS), and the noise started about a month ago. The other day I hit a pot-hole (didn't know it at the time), but the noise was so loud it sounded like I hit something laying in the road, very hard. It scared the hell out of me. I knew I was on the road when it happened, so I turned around to see what I hit and what kind of damage was done to the passenger side. When I got back to the spot, I found no damage to the body, and nothing laying around that I could have hit. I did see a fairly good sized pot-hole, which is what I had hit. It wasn't big enough to do any damage, but that sound it made, I will never forget it. Now the car is getting scary to drive, bumps make it wallow all over, I can feel looseness in the front suspension, and the noises are getting very frequent. I am not driving it and am taking it to the dealer tomorrow, to get it fixed. Luckily my dealer is one of the best dealers in Atlanta, so they WILL take care of whatever the noise is.

Also, I noticed that every once in a while, the car will hesitate when I give it a sudden push on the accelerator. It is almost like the computer is running slow, while trying to figure out what gear to shift into.
jeffb100 is offline   Reply With Quote
Old 06-24-2010, 03:08 AM   #176
ex-SS-ve
 

Join Date: Feb 2010
Posts: 574
had the same rf strut "pop", however it didnt come in till i had the eibach springs installed. i just delt with it. finally i pulled a wheel off and checked everything and found it to be a incorrectly clocked spring. yes if the spring is installed on the strut assembly incorrectly it will rub and hit the inner spring retainer causing a pop that obvoiusly sounds like crap. reclocked the spring and the "pop" is gone!
ex-SS-ve is offline   Reply With Quote
Old 07-04-2010, 04:39 PM   #177
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,547
Fourth of July Bump!

-Funk
pnyklr is offline   Reply With Quote
Old 07-04-2010, 05:06 PM   #178
Michael_Js
SoCal C5 Family Member
 
Michael_Js's Avatar
 
Drives: 2010 Camaro SS/RS - Black w/IOM; 6M
Join Date: Jul 2009
Location: San Diego, CA, USA
Posts: 5,306
Send a message via AIM to Michael_Js Send a message via MSN to Michael_Js
I HAVE the Pfadt camber plate and my car pops on all bumps...I have Pfadt endlinks and sways also. Also, I have KW V3 coilovers and STILL it pops and makes noise over bumps. I am also fairly certain my sways and endlinks are on properly, but I will verify that tomorrow.
__________________
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~
2010 Black 2SS/RS; 6M; IOM, GFX, sunroof; ADM Race CAI; Zoomers CB; Viper Alarm; Pdaft F&R sways, Adj Endlinks, Rtrailing arms, Camber kit, strut brace, Front Trailing Arm Bushing; SLP Skip-Shift Elim; Tinted lights/windows; Hurst Short-throw; LoJack; Door & Dash ABL Mods; ********; JBA Shorty headers; AACStyle LEDs; Stillen DS rotors, Hawk Ceramic pads; Havoc Blk Chrome wheels: 20x9s; Lingenfelter Blk Al Pedals; RevXtreme Catch Can; Goodridge SS lines; Ported TB; RK Sport hood; Hotchkis chassis brace; KW V3 coilovers;
Michael_Js is offline   Reply With Quote
Old 07-04-2010, 07:21 PM   #179
ZAP 1401
 
Drives: 2SS/RS/Blk-Blk/L99,
Join Date: Aug 2009
Location: Bowling Green, Ky
Posts: 20
The service bulletin for this suspension noise, clunk, popping, rattle is
#PIE0054A:EI10035 Document ID : 2426027
ZAP 1401 is offline   Reply With Quote
Old 07-12-2010, 02:06 PM   #180
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,547
Quote:
Originally Posted by ZAP 1401 View Post
The service bulletin for this suspension noise, clunk, popping, rattle is
#PIE0054A:EI10035 Document ID : 2426027

Anyone have a copy they can post up?

-Funk
pnyklr is offline   Reply With Quote
Old 07-12-2010, 02:19 PM   #181
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by pnyklr View Post
Anyone have a copy they can post up?

-Funk
this is an old bulletin. I believe it describes a process of contacting engineering when they have one of these complaints, since they are investigating it.

Do a search on this forum and it is there.

mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 07-12-2010, 02:48 PM   #182
OUTATIME
 
OUTATIME's Avatar
 
Drives: 2010 IOM 2SS/RS
Join Date: Oct 2008
Location: NJ
Posts: 625
Is this supposed to be a noise that comes after some age? I'm at 500 miles and I don't have this.
OUTATIME is offline   Reply With Quote
Old 07-12-2010, 09:31 PM   #183
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by OUTATIME View Post
Is this supposed to be a noise that comes after some age? I'm at 500 miles and I don't have this.
As far as I know, GM is still investigating the noise.

I can tell you that we are seeing the upper strut to spring grommet tearing on OE struts on a regular basis. But all the ones that I have seen do not have a noise complaint. In fact, I have not driven a Camaro with any front end noise issues. Guess I have been lucky.

But GM is working on it. Has been a while and I do not think they have updated it as of yet.

mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 07-12-2010, 09:47 PM   #184
edog


 
edog's Avatar
 
Drives: 2010 2SS/RS IOM
Join Date: Oct 2008
Location: F'BURG VA
Posts: 3,641
This noise is not supposed to be there. My dealership resolved my issue after three attempts.

I had the sound turning left from a stop. after numerous attempts to fix it, the GM engineers told the dealership the struts, and the whole strut assembly needed to be replaced. Afterwards, I have been clunk free for three months.

See if they will do this for you.
edog is offline   Reply With Quote
Old 07-12-2010, 10:06 PM   #185
Michael_Js
SoCal C5 Family Member
 
Michael_Js's Avatar
 
Drives: 2010 Camaro SS/RS - Black w/IOM; 6M
Join Date: Jul 2009
Location: San Diego, CA, USA
Posts: 5,306
Send a message via AIM to Michael_Js Send a message via MSN to Michael_Js
Mine's not stock, but I eliminated a bit of the noise. I found the Pfadt rear end links on the lower frame were only hand tight!! They sure did loosen up from when I installed them! The upper rear end links were a bit loose, but not that much. Front were good and tight, but one side of the Pfadt sway bolts were loose. I guess I missed that one the last time I tightened it all up. Also, the passenger side end link was kind of twisted, so I straightened it out and that stopped a lot of the popping on the front right side

Next time I will be removing all the end link bolts and loctite them :( Didn't have the time this past weekend. i can't bring mine in for any suspension TSBs or otherwise since there isn't much left that's stock!
__________________
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~
2010 Black 2SS/RS; 6M; IOM, GFX, sunroof; ADM Race CAI; Zoomers CB; Viper Alarm; Pdaft F&R sways, Adj Endlinks, Rtrailing arms, Camber kit, strut brace, Front Trailing Arm Bushing; SLP Skip-Shift Elim; Tinted lights/windows; Hurst Short-throw; LoJack; Door & Dash ABL Mods; ********; JBA Shorty headers; AACStyle LEDs; Stillen DS rotors, Hawk Ceramic pads; Havoc Blk Chrome wheels: 20x9s; Lingenfelter Blk Al Pedals; RevXtreme Catch Can; Goodridge SS lines; Ported TB; RK Sport hood; Hotchkis chassis brace; KW V3 coilovers;
Michael_Js is offline   Reply With Quote
Old 07-16-2010, 12:12 PM   #186
CesOne
 
CesOne's Avatar
 
Drives: 2010 Camaro White 2LT RS
Join Date: Jun 2010
Location: FL and NY
Posts: 48
mine is in for the same front end noise that only happens when I'm going over a road that's bumpy. Something rattles like it's loose.... single bumps don't hear anything. I drove the car with the service guy in it and he heard it. Let see what happens
__________________
CesOne is offline   Reply With Quote
Old 07-16-2010, 12:24 PM   #187
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by Michael_Js View Post
Mine's not stock, but I eliminated a bit of the noise. I found the Pfadt rear end links on the lower frame were only hand tight!! They sure did loosen up from when I installed them! The upper rear end links were a bit loose, but not that much. Front were good and tight, but one side of the Pfadt sway bolts were loose. I guess I missed that one the last time I tightened it all up. Also, the passenger side end link was kind of twisted, so I straightened it out and that stopped a lot of the popping on the front right side

Next time I will be removing all the end link bolts and loctite them :( Didn't have the time this past weekend. i can't bring mine in for any suspension TSBs or otherwise since there isn't much left that's stock!
Can you look at your invoice and list the p/n of the replacement pieces for us.

tjhanks
mike
Info@PeddersUSA.com is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CAMARO WIKI Tran Wiki 54 02-06-2016 12:33 PM
FOUND PETITION TO GET RID OF FRONT PLATES The_Beast_ USA - California 90 03-29-2012 01:54 AM
New Camaro photoshop with beefier front end, drop and smoked wheels Tran Camaro Photoshops / Renderings Forum 60 10-25-2010 07:02 PM
2010 Camaro SS -- New closeup of front end: Photos only. Tran Camaro Photos | Spyshots | Video | Media Gallery 1 07-17-2008 11:09 PM
2 more 2009 Camaro spy pics - fuel door location shown! (+ front headlights closeup) HooliganZ Camaro Photos | Spyshots | Video | Media Gallery 369 07-02-2008 10:09 PM


All times are GMT -5. The time now is 01:11 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.