Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Rick@Livernois
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 08-21-2010, 12:34 AM   #205
Speed74SS

 
Speed74SS's Avatar
 
Drives: 2010 LPE 650+ CTS-V
Join Date: Oct 2008
Location: Sioux Falls, SD
Posts: 1,640
Quote:
Originally Posted by Big Brunsy View Post
I took my car in for the popping/snapping noise when turning. Showed them the TSB for the strut mounts, they ordered the parts and I took it in for repair today. They installed the new mounts, and it still made the noise, but only when the car was on the ground. He had my car apart and back together 3 times.

The tech said he was ordering a lower control arm for the drivers side as the passenger one was replaced after I hit the curb. After my car was repaired from the curb incident I had no noises coming from the car. They started about a month after the repairs were completed. I don't know if this will solve the problem or not, and I don't think the tech does either. All I know is I don't like the PT cruiser that they gave me for a loaner; good thing I still got my truck.
That sucks about the noises - hopefully there will be some sort of fix soon - I wouldn't have driven the PT Cruiser either
__________________
'10 CTS-V : LPE 650+ Package 587hp / 582tq

2.55 Upper / 8.6 Lower / ID850's / Kooks Longtubes / New Era CAI
Speed74SS is offline   Reply With Quote
Old 08-21-2010, 01:36 AM   #206
Big Brunsy

 
Drives: 2010 supercharged LS3
Join Date: Jan 2010
Location: Le Mars, Iowa
Posts: 2,229
Quote:
Originally Posted by Speed74SS View Post
That sucks about the noises - hopefully there will be some sort of fix soon - I wouldn't have driven the PT Cruiser either
tell me about it, the thing is a pile. It took me like 3 min to find the lights in the damned thing tonight. It should be standard on ALL vehicles to have automatic lights.
__________________
Big Brunsy is offline   Reply With Quote
Old 08-21-2010, 08:15 PM   #207
xpanda305x
Banned
 
Drives: Dark Knight
Join Date: Nov 2009
Location: Gunshine State
Posts: 3,152
mine does a wierd thump when going over speedbumps or holes. but it does it at random. any clue? maybe my struts? only does it with the front wheels i think.
xpanda305x is offline   Reply With Quote
Old 08-25-2010, 02:40 PM   #208
Big Brunsy

 
Drives: 2010 supercharged LS3
Join Date: Jan 2010
Location: Le Mars, Iowa
Posts: 2,229
Just got a call from the dealer, They found what was making the noise. It was a cracked knuckle....guy didn't really know how to explain exaclty where it was as he wasn't the guy doing the repair. They said it was from when I hit the curb, but who knows maybe other people who can't get it solved could check that too.
__________________
Big Brunsy is offline   Reply With Quote
Old 08-26-2010, 01:06 PM   #209
Draak
 
Draak's Avatar
 
Drives: 2010 RJT 2LT-RS
Join Date: Nov 2009
Location: Tampa, Florida
Posts: 12
It's sad that the official response for a customer's concern from GM about this rattling sound is; (and I'm paraphrasing).

'We built that noise into other Camaros, so it is a normal sound'.

Were this the case, why was my car wonderfully silent all the way from Tennessee to Florida when we drove it home from the dealer, then it started making noises after about 750 miles which it had not beforehand? Had the car made this sound at the time of delivery, I would have had the dealer put it up in the air and look for something loose in the front-end before making such a lengthy initial drive. And even were I to accept the statement that all Camaros make this rumbly-clunky noise from the moment they are rolled off of the delivery truck, the issue is this; actually, some do and some don't.

I'm sorry, but as a consumer whom has made a significant effort in order to acquire one of GM's finer designs, 'that's the way it is' seems to say that a front end which makes these sounds which are quite audible from within the passenger cabin, is a normal design and is ok with them. That's not a good position to hold, from the public's viewpoint.

Perhaps I am being punished for spending the extra money in order to have the 'Handling Package'...
Draak is offline   Reply With Quote
Old 08-27-2010, 04:06 PM   #210
johnc847
 
johnc847's Avatar
 
Drives: 2010 Camaro V6
Join Date: May 2010
Location: Little Rock AR
Posts: 28
I put mine in the shop for this. I took a shop guy on a ride on the freeway that runs in front of the dealer. There is a bump on the freeway that when I hit it it sounds like the front tire is going into the fender. He said thats not right when he was riding with me and I hit it. It also does it on speed bumps and small bumps in the road. They just called me and said its something with the rack and pinion. They told me they ordered the part and it will be in next wednesday and for safety reasons they advise me to stay in the rental car they provided me.
johnc847 is offline   Reply With Quote
Old 08-31-2010, 12:56 PM   #211
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,547
Dead on description of the problem. Post up when you get the car back.

-Funk
pnyklr is offline   Reply With Quote
Old 09-01-2010, 12:54 AM   #212
angelicsowner
 
angelicsowner's Avatar
 
Drives: 2010 IBM 2SS/RS
Join Date: Jul 2009
Location: Denver
Posts: 233
I took mine in today and he told me my front passenger control arm was loose. Good thing it didnt fall off when driving "spiritedly" up the mountain...

After tightening it up and a re-alignment, no more kerchunk-a-chunk when I go over a manhole or bumpy road!
__________________
Camaro Club of the Rockies
http://www.ccotr.org
angelicsowner is offline   Reply With Quote
Old 09-01-2010, 01:06 AM   #213
Sevn86


 
Sevn86's Avatar
 
Drives: 2010 Camaro 2LT/RS ABM
Join Date: Sep 2009
Location: Sugar Land, TX
Posts: 13,085
do yalls cars vibrate and shake also? my car does this...
__________________
2LT, RS, AT6 ABM, Gray Leather
Quote:
Originally Posted by baclarsen View Post
Dude, you go through cars faster than I go through underware!!
1000 Initial Order 9/14/2009 - Classic Chevy Sugar Land
1100 Order accepted at dealer: 9/15/2009 - NPGV41.
2000 Order accepted by GM: 9/29/2009
3000 Accepted By Production Control: 9/30/2009 - TPW 10/26/09
3100 Sequenced:10/12/09
3300 Scheduled For Production:10/13/09
3400 Broadcast:10/22/09
3800 Produced:10/27/09
4000 Available To Ship:10/28/09
4200 Shipped:10/29/09
5000 Delivered To The Dealer:11/09/09
6000 Delivered To Customer:11/12/09
Sevn86 is offline   Reply With Quote
Old 09-01-2010, 01:23 AM   #214
20Camaro11
 
20Camaro11's Avatar
 
Drives: SS
Join Date: Aug 2010
Location: not here
Posts: 655
I have not experienced what everyone is describing in my Camaro...yet, but sounds awfully familiar to a common complaint across many different GM products from a few years back. The intermediate shaft (something to do with the steering linkage?) is fouled up. I had heard GM had found a fix for it. My 2005 Monte Carlo did it for 40K miles before I got rid of it. My brothers 2008 Impala does it as well, I don't want to speak ill of GM, but I kind of expect this kind of quality...its a pattern I have experienced...I still love my Camaro. When I had the Monte Carlo, they basically just kept packing grease into this part to make the problem go away for short periods, then it would slowly start again untl I would schedule another trip to Mr. Goodwrench. I won't say this is the problem, but sounds familiar.
20Camaro11 is offline   Reply With Quote
Old 09-05-2010, 08:59 PM   #215
wally572
 
Drives: 2010 Camaro
Join Date: Nov 2009
Location: USA
Posts: 4
Guys im telling you, Ive posted before I have a G8 on the same platform as the camaro.....mine started as the thumping noise....by the time I had 25000 miles on the car or so, the dealer parked it as unsafe to drive the front end was about to fall out according to the tech. Had to have all 4 front control arms and related hardware replaced. Whats even worse is that Ive had a constant fear that the issue would come back, and low and behold my steering wheel is beginning to shake again. Going to take it and have rotors checked first since I do drive the heck out of it......but Id say Im in for a very expensive repair this time. Ill post again if shes falling apart again.:(
wally572 is offline   Reply With Quote
Old 09-08-2010, 01:18 AM   #216
F13body
 
F13body's Avatar
 
Drives: 2SS
Join Date: Aug 2010
Location: So CaL
Posts: 19
ive got the same problem since day one. let me know were to sign or write and e-mail. i love my car and i want it fixed. i wanna drive one that has drop springs and aftrmrkt shocks if it will still be a problem.
F13body is offline   Reply With Quote
Old 09-08-2010, 07:25 PM   #217
Bonanza7
Account Suspended
 
Drives: 2010, Rally Yellow, Black stripes
Join Date: Jul 2010
Location: Phoenix
Posts: 2,363
Mine does the same thing. Customer service CAN help. My dealer failed to pay-off my trade in. I was being charged interest while the car sat on his used car lot. He was using me to floor plan part of his inventory! I called Cust Service, and the next day, the dealer called me back, and fed ex'd the payment. Customer service kept track, got the check number and verified with me that it had finally been paid. Can't ask for more than that.
Bonanza7 is offline   Reply With Quote
Old 09-10-2010, 02:06 PM   #218
f5journal
Senior Camaro Fanatic
 
f5journal's Avatar
 
Drives: 2011 SS/RS manual - White
Join Date: Aug 2010
Location: aiken, sc
Posts: 2,021
I think I have the same thing on my brand new one. When I back out of the driveway, the passenger front makes a noise sortof like a brief rub of the fenderwell or slight dull pop as the suspension flexes across the curb dip at the road
f5journal is offline   Reply With Quote
Old 09-17-2010, 11:57 AM   #219
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,547
Seven Day Bump

-Funk
pnyklr is offline   Reply With Quote
Old 09-21-2010, 12:05 PM   #220
ponbigi
 
ponbigi's Avatar
 
Drives: 2011 CAMARO LS
Join Date: Sep 2010
Location: Chandler, AZ
Posts: 326
Quote:
Originally Posted by xpanda305x View Post
mine does a wierd thump when going over speedbumps or holes. but it does it at random. any clue? maybe my struts? only does it with the front wheels i think.

I have the same issue and notice it mostly when I hit the passenger side on the speed bump and the driver side goes through the "break" in between the speed bumps. that is the noly Time I have noticed the noise. But its pretty loud when it happens.
ponbigi is offline   Reply With Quote
Old 09-22-2010, 01:44 PM   #221
pedrero
 
pedrero's Avatar
 
Drives: 2010 Camaro 2SS/RS Black
Join Date: Jul 2009
Location: Fanwood, NJ
Posts: 31
ACCETPTABLE?????

I just got back from the dealer who told me the same thing. "all of the Camaros have the same noise and GM is calling it "Acceptable" I hate it! It only happens when I first take off from park and when I hit the brakes hard but it is very annoying!!! I hope the put a fix together to get rid of this. I can't believe that there is NOTHING wrong.
pedrero is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CAMARO WIKI Tran Wiki 53 10-24-2015 04:48 PM
FOUND PETITION TO GET RID OF FRONT PLATES The_Beast_ USA - California 90 03-29-2012 01:54 AM
New Camaro photoshop with beefier front end, drop and smoked wheels Tran Camaro Photoshops / Renderings Forum 60 10-25-2010 07:02 PM
2010 Camaro SS -- New closeup of front end: Photos only. Tran Camaro Photos | Spyshots | Video | Media Gallery 1 07-17-2008 11:09 PM
2 more 2009 Camaro spy pics - fuel door location shown! (+ front headlights closeup) HooliganZ Camaro Photos | Spyshots | Video | Media Gallery 369 07-02-2008 10:09 PM


All times are GMT -5. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.