Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
PFYC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 04-20-2010, 08:46 PM   #126
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by kencarguy View Post
Awhile back they replaced my strut mounts based on a front end noise TSB, but dudn't fix the problem. GM told me they have no answer so no more parts will be replaced until something is identified as the cause.

Thanks for the encouraging words / explanation Mike! I will continue to wait and bug my local dealer for answers till that strut-type noise goes away....

Ken
I have worked with GM engineers for a very long time and will tell you they are first class. If they are working on a problem, and it is blatantly obvious they have now officially started investigating this issue, there will be a fix. So lest give them some time to figure it out.

thanks
mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 04-21-2010, 07:34 AM   #127
qbert48

 
qbert48's Avatar
 
Drives: 2SS SIM
Join Date: Apr 2009
Location: texas panhandle BFE
Posts: 1,143
Quote:
Originally Posted by Jeanius View Post
Have you guys experienced clunking when backing out out of the driveway? its happened to me about 5 times now, Ill start backing out, turn the wheel and CLUNK
thats when i hear it too
__________________
2SS RS SIM gray leather stick shift ground FX
thank you gary richards @ classic chevy in sugarland

welcome home
1100 4-27-09
6000 6-27-09


yes i got to the dance late don't hate me
qbert48 is offline   Reply With Quote
Old 04-21-2010, 05:01 PM   #128
Jeanius


 
Jeanius's Avatar
 
Drives: Blk/Blk LS3 SS
Join Date: Dec 2006
Location: Golden State
Posts: 2,460
Hmm, I have plans to lower my car within the next few weeks, do you guys think that will affect the warranty status on whatever needs to be replaced?
__________________
2SS LS3 M6 - MGW - Dynatech LT's HF Cats - Magnaflow Street CB - ADM Race CAI - Pedders Xa Coilovers - Pfadt Sways
Jeanius is offline   Reply With Quote
Old 04-21-2010, 06:13 PM   #129
kencarguy
kencarguy
 
kencarguy's Avatar
 
Drives: 2010 2LT/RS- Inferno Orange w/Black
Join Date: Nov 2009
Location: Haddon Heights, NJ
Posts: 26
I can now add a Transmission problem to the front end noise in my car! Over the past week or so, shifting has gotten very stiff and difficulot... to the point that it seemed like the clutch was not disengagind from the flywheel when I pushed on the pedal. I limped into my dealer today to find out there IS a TSB on this problem, and it involves pulling the trans and looking to see if the bolts are backing out of the clutch.....

I drove back to work since they encouraged me to bring the car in at the beginning of next week. When it took me five minutes to get the thing into reverse after work, I called and immediately drove it over to the dealer for them to resolve. ALl the way there, it was a struggle to get the car in gear whewn I stopped, and to shift up /down. This is a new problem......... I hope the fix recommended in the TSB takes care of it.

Thanks!
Ken
kencarguy is offline   Reply With Quote
Old 04-21-2010, 11:08 PM   #130
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by Jeanius View Post
Hmm, I have plans to lower my car within the next few weeks, do you guys think that will affect the warranty status on whatever needs to be replaced?
Depends on what they ultimately find or do. You should get it documented with your dealer before anything is done

mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 04-22-2010, 10:17 AM   #131
spoone123
Next is SS camaro.....
 
spoone123's Avatar
 
Drives: 2010 Camaro LS, Rally yellow
Join Date: Feb 2010
Location: NC, Goldsboro
Posts: 622
Oh boy now i have to go see if my car does it. This happen only when you're going over speed bump?
__________________
Airraid CAI, Havoc Rims, Perreli tires, Remote start
spoone123 is offline   Reply With Quote
Old 04-25-2010, 04:02 PM   #132
qbert48

 
qbert48's Avatar
 
Drives: 2SS SIM
Join Date: Apr 2009
Location: texas panhandle BFE
Posts: 1,143
Quote:
Originally Posted by spoone123 View Post
Oh boy now i have to go see if my car does it. This happen only when you're going over speed bump?
mine does it when i back out of the driveway turning the wheel to the right
__________________
2SS RS SIM gray leather stick shift ground FX
thank you gary richards @ classic chevy in sugarland

welcome home
1100 4-27-09
6000 6-27-09


yes i got to the dance late don't hate me
qbert48 is offline   Reply With Quote
Old 04-25-2010, 05:56 PM   #133
bluedevil02

 
bluedevil02's Avatar
 
Drives: 2LT/RS
Join Date: Jul 2009
Location: San Antonio
Posts: 845
i also have the same damn noise...but mine started when i dropped it on an eibach pro-kit...make creaks and weird noise....esp on the passenger side while turning or with a passenger in the car..i even have them uninstalled and reinstalled on the fronts...and still no luck everything is on right and tight...
bluedevil02 is offline   Reply With Quote
Old 04-25-2010, 09:05 PM   #134
Draak
 
Draak's Avatar
 
Drives: 2010 RJT 2LT-RS
Join Date: Nov 2009
Location: Tampa, Florida
Posts: 11
So, I have noticed that we're having the same problem too. I heard a light rattle as we were bringing the car home and it was mostly on the left, but now it's on both sides and equally as noisy. The sound is a hollow, down-low clunking rattle that is definitely coming from the front end.

This rattle really is annoying, and when I took a buddy of mine for a ride in the car, he even asked about it, telling me I should take it in and get it looked at. The interesting thing about this is that I might be more sensative to this noise because the Dodge Magnum we traded in for this Camaro was making exactly the same sound in loudness and audio-frequency while going over small bumps.

When I took the Magnum in, they found that both of the main rubber bushings on the lower strut-arms were cracked and torn, but they only saw it after they put it on their alignment rack and there was pressure on the wheels, instead of hanging down like on a normal lift.

I'm not saying that this is the same problem with our Camaro, but perhaps more than just the upper strut bushing needs to be looked at. A car of this caliber with such few miles shouldn't be rattling over small bumps, sounding like my dad's 1972 Ford Torino wagon with clapped-out bushings...

2LT/RS with 2800 miles. 99% of them, highway miles.
Draak is offline   Reply With Quote
Old 04-26-2010, 09:17 PM   #135
kencarguy
kencarguy
 
kencarguy's Avatar
 
Drives: 2010 2LT/RS- Inferno Orange w/Black
Join Date: Nov 2009
Location: Haddon Heights, NJ
Posts: 26
My car makes the sound equally on both sides on any bump or dip ( Like pot holes).

ALso note- If you have a 3.6 6-sp manual trans... and it is hard to get into gear there is a TSB on that- released last week. I had it get really bad last week, and took it in. I had all the symptoms. Today they called to tell me they were replacing the clutch and pressure plate along with the bolts ( which had been working their way out...).

Thanks for sharing your experiences. I guess now we just have to wait for GMto come up with a "fix" for the froont end noise problem.

Ken
kencarguy is offline   Reply With Quote
Old 04-26-2010, 10:17 PM   #136
jnm2003
 
jnm2003's Avatar
 
Drives: O2 GMC & 2010 camaro SS IBM 6M
Join Date: Sep 2009
Location: US
Posts: 254
my SS is in the shop right now for new clutch and pressure plate
__________________

2010 camaro SS/RS Manual IBM.
Ran 12.82 @ 110 MPH 1.92 60ft ALMOST Bone Stock ONLY MOD IS Borla mufflers.
NEW TIME 12.24 @ 114 mph. - Nitto nt05 street tires, Hurst short throw, Halltech yellow jacket intake, AR long tube 1 7/8 headers, and a tune.
jnm2003 is offline   Reply With Quote
Old 04-26-2010, 11:41 PM   #137
bluedevil02

 
bluedevil02's Avatar
 
Drives: 2LT/RS
Join Date: Jul 2009
Location: San Antonio
Posts: 845
found this quite interesting....when pfadt posted this...but i may even consider changing this part out as a solution unless GM puts out a TSB?


Quote:
Originally Posted by PfadtRacing View Post
Hello all!

It has surfaced recently that there has been an upper spring isolator change for the Camaro, by General Motors. Quite frankly, we didn't see this as a big deal when we heard about it, hence why we never addressed it on the forums like other manufacturers have. We thought everyone had done enough engineering development to have this not be an issue. We just want to let everyone know, that our Pfadt Drop Springs, Coilovers, whatever...has no problem fitting with this recent spring isolator change from GM. Other companies are scampering to get some product revision to the market that accommodates this new part from GM. This means you will need to let them know what year car you have, take off your wheel and see what color isolator you have...makes NO difference to us at all! We just want to know if you have a Camaro!

Bottom line: Pfadt Racing has you covered. All of our springs/coilovers are unaffected by this change. Take a look at the pics below.

New isolator on left, old one on the right


Our Existing Drop Springs Fit Just fine with the new GM part




And, obviously since we discard any isolator in our coilover installation procedure, our coilovers still will work just fine. Our upper spring mount fits on the OEM strut top, which does not change.


bluedevil02 is offline   Reply With Quote
Old 04-27-2010, 01:22 PM   #138
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,531
pnyklr is offline   Reply With Quote
Old 04-27-2010, 02:44 PM   #139
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,531
From the guys at Pfadt:

"Thats an excellent question. Thank you for pointing me to that thread. This could very well be the reason for the change! I can't confirm for sure, as we can't verify any noise difference between the old and new parts on a stock setup anymore due to our car being heavily modified with our own products on it. If you are looking for a solution to clunking on your front end, it may be a good idea to call your local dealer and get the new parts. The part number that was sent to us 20859337. Not sure as to the cost. BUT with that said, the dealer also informed us that the spring changed, presumably to the OEM Buick Lacrosse spring (just a hunch). So, depending on what springs you have, they may/may not fit to begin with. If you have our springs, they WILL fit for sure. "

http://www.camaro5.com/forums/showthread.php?t=79323

-Funk
pnyklr is offline   Reply With Quote
Old 04-27-2010, 03:14 PM   #140
Jeanius


 
Jeanius's Avatar
 
Drives: Blk/Blk LS3 SS
Join Date: Dec 2006
Location: Golden State
Posts: 2,460
Any new info?

My car is at the dealer right now and we could not reproduce the noise, theyre going to lift it and make sure everything is in order, I told them that there are others having this problem and referred to the forum but, it seems like it was taken with a grain of salt
__________________
2SS LS3 M6 - MGW - Dynatech LT's HF Cats - Magnaflow Street CB - ADM Race CAI - Pedders Xa Coilovers - Pfadt Sways
Jeanius is offline   Reply With Quote
Old 04-27-2010, 09:28 PM   #141
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by Jeanius View Post
Any new info?

My car is at the dealer right now and we could not reproduce the noise, theyre going to lift it and make sure everything is in order, I told them that there are others having this problem and referred to the forum but, it seems like it was taken with a grain of salt
Have them check out PIE0054A. This should show them that at least GM is interested in finding the fix

thanks
mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 04-27-2010, 11:36 PM   #142
Jeanius


 
Jeanius's Avatar
 
Drives: Blk/Blk LS3 SS
Join Date: Dec 2006
Location: Golden State
Posts: 2,460
Quote:
Originally Posted by dms View Post
Have them check out PIE0054A. This should show them that at least GM is interested in finding the fix

thanks
mike
dms
Thanks Mike, unfortunately a little too late, If the problem continues and I take it in again I will be sure to have them check that out

Mike told me you stopped by to say hello, too bad I wasnt there, would have been great to meet you!
__________________
2SS LS3 M6 - MGW - Dynatech LT's HF Cats - Magnaflow Street CB - ADM Race CAI - Pedders Xa Coilovers - Pfadt Sways
Jeanius is offline   Reply With Quote
Old 04-28-2010, 01:21 AM   #143
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by Jeanius View Post
Thanks Mike, unfortunately a little too late, If the problem continues and I take it in again I will be sure to have them check that out

Mike told me you stopped by to say hello, too bad I wasnt there, would have been great to meet you!
It rained a lot today. that seems to shut down a lot of noise issues. There is a absolutely Class AAA tech there named Dave Wiggens. Dave worked for me a number of years, and I supported him in being one of the best trained GM techs in California. Keep his name in mind.

thanks
mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 04-28-2010, 10:10 AM   #144
bluedevil02

 
bluedevil02's Avatar
 
Drives: 2LT/RS
Join Date: Jul 2009
Location: San Antonio
Posts: 845
well went and ordered to new foam insulators....4-5 biz day turnaround...so hopefully install next went end...
bluedevil02 is offline   Reply With Quote
Old 04-28-2010, 10:53 AM   #145
Moorepheus

 
Drives: 2013 Dodge Charge R/T Plus AWD
Join Date: Jul 2009
Location: Niagara Falls, NY
Posts: 1,306
1600 miles on my Camaro and no noise like you guys talk about on mine from the front end. My rattling noise was fixed (an extra nut from the left rear knuckle was in the left rear lower control arm...weird). My car seems quiet now when going over bumps, etc.
Moorepheus is offline   Reply With Quote
Old 04-28-2010, 04:55 PM   #146
skippyss
 
Drives: 2010 camaro ls
Join Date: Mar 2010
Location: michigan
Posts: 1
same popping noise in front end come to find out both stabilizer links are broke off and have to wait a month for parts cause gm gets them from daewon america a korean company.
skippyss is offline   Reply With Quote
Old 04-28-2010, 09:30 PM   #147
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Quote:
Originally Posted by bluedevil02 View Post
well went and ordered to new foam insulators....4-5 biz day turnaround...so hopefully install next went end...
I do not think y ou can get them any more. Could be wrong. But I think you will get the new design, which I do not think are compatible with our OE coils

mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 04-30-2010, 01:18 PM   #148
Don O
Camaro and Vettehead
 
Don O's Avatar
 
Drives: 2SS/RS IOM L99 69 427/400 Vette
Join Date: Aug 2009
Location: 12 miles East of Disneyland - Anaheim Hills
Posts: 547
I have the same issue in the passenger side front. 5000 miles with Eibachs.

Gonna look at all the bolts and tie-rod ends tomorrow up on the lift and then it might be a trip to the dealer. For those that had it fixed, I assume the dealer did that under warranty ?

Don O
__________________
Nothing sucks more than that moment during an argument when you realize you're wrong.

Don O is offline   Reply With Quote
Old 05-04-2010, 09:25 PM   #149
JSC81
 
JSC81's Avatar
 
Drives: 2010 1SS/RS M6
Join Date: Apr 2010
Location: FT BENNING, GA
Posts: 396
My car did that a few times when I first got it. Always while backing out and cutting the wheels left or right out of the driveway. I havent heard it in a while though.
__________________
JSC81 is offline   Reply With Quote
Old 05-04-2010, 09:52 PM   #150
bluedevil02

 
bluedevil02's Avatar
 
Drives: 2LT/RS
Join Date: Jul 2009
Location: San Antonio
Posts: 845
Quote:
Originally Posted by dms View Post
I do not think y ou can get them any more. Could be wrong. But I think you will get the new design, which I do not think are compatible with our OE coils

mike
dms
i'm actually running eibachs...and yea they sold me the new foam insulators...do u think theyll fit the 2010 models?
bluedevil02 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CAMARO WIKI Tran Wiki 49 09-09-2014 05:46 AM
FOUND PETITION TO GET RID OF FRONT PLATES The_Beast_ USA - California 90 03-29-2012 12:54 AM
New Camaro photoshop with beefier front end, drop and smoked wheels Tran Camaro Photoshops / Renderings Forum 60 10-25-2010 06:02 PM
2010 Camaro SS -- New closeup of front end: Photos only. Tran Camaro Photos | Spyshots | Video | Media Gallery 1 07-17-2008 10:09 PM
2 more 2009 Camaro spy pics - fuel door location shown! (+ front headlights closeup) HooliganZ Camaro Photos | Spyshots | Video | Media Gallery 369 07-02-2008 09:09 PM


All times are GMT -5. The time now is 07:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.